nant-vl.spec 3.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104
  1. %define git 20130131
  2. Summary: A .NET based build tool
  3. Summary(ja): .NET ベースのビルドツール
  4. Name: nant
  5. Version: 0.92
  6. Release: 1%{?git:.git%{git}}%{?_dist_release}
  7. License: GPLv2+ and LGPLv2+
  8. Group: Development/Tools
  9. URL: http://nant.sourceforge.net/
  10. #Source0: http://downloads.sourceforge.net/nant/%{name}-%{version}-src.tar.gz
  11. # git clone //github.com/letiemble/nant.git
  12. Source0: %{name}.tar.xz
  13. BuildArch: noarch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: dos2unix
  16. BuildRequires: mono-core
  17. BuildRequires: mono-devel
  18. BuildRequires: pkgconfig
  19. Autoreq: no
  20. Requires: mono-core
  21. Requires: mono-data
  22. Requires: mono-web
  23. Requires: mono-winforms
  24. #Requires: mono(System)
  25. #Requires: mono(System.Data)
  26. #Requires: mono(System.Drawing)
  27. #Requires: mono(System.Web)
  28. #Requires: mono(System.Windows.Forms)
  29. #Requires: mono(System.Xml)
  30. #Requires: mono(mscorlib)
  31. # ignore some bundled dlls
  32. %define _use_internal_dependency_generator 0
  33. %define __find_provides env sh -c 'filelist=($(grep -v log4net.dll | grep -v scvs.exe | grep -v nunit | grep -v NDoc | grep -v neutral)) && { printf "%s\\n" "${filelist[@]}" | /usr/lib/rpm/find-provides && printf "%s\\n" "${filelist[@]}" | /usr/lib/rpm/mono-find-provides ; } | sort | uniq'
  34. %define __find_requires env sh -c 'filelist=($(cat)) && { printf "%s\\n" "${filelist[@]}" | /usr/lib/rpm/mono-find-requires ; } | sort | uniq'
  35. Vendor: Project Vine
  36. Distribution: Vine Linux
  37. %description
  38. NAnt is a .NET based build tool. In theory it is kind of like make
  39. without make's wrinkles. In practice it's a lot like Ant.
  40. %package devel
  41. Summary: NAnt pkgconfig files
  42. License: LGPLv2
  43. Group: Development/Libraries
  44. Requires: nant = %{version}-%{release}
  45. %description devel
  46. This package contains the pkgconfig files for NAnt.
  47. %prep
  48. %setup -q -n %{name}
  49. %build
  50. make TARGET=mono-4.5 MCS="gmcs -sdk:4"
  51. %install
  52. rm -rf $RPM_BUILD_ROOT
  53. make install prefix=%{_prefix} DESTDIR=$RPM_BUILD_ROOT TARGET=mono-4.5 MCS="gmcs -sdk:4" docdir=%{_docdir}
  54. mkdir -p $RPM_BUILD_ROOT%{_datadir}/pkgconfig
  55. mv $RPM_BUILD_ROOT%{_prefix}/lib/pkgconfig/%{name}.pc $RPM_BUILD_ROOT%{_datadir}/pkgconfig
  56. chmod -x $RPM_BUILD_ROOT%{_datadir}/NAnt/bin/lib/common/2.0/nunit-console.exe.config
  57. dos2unix $RPM_BUILD_ROOT%{_datadir}/NAnt/bin/lib/common/2.0/nunit-console.exe.config
  58. rm -rf _docs
  59. mkdir -p _docs
  60. mv $RPM_BUILD_ROOT%{_docdir}/NAnt/* _docs
  61. %clean
  62. rm -rf $RPM_BUILD_ROOT
  63. %files
  64. %defattr(-,root,root)
  65. %doc COPYING.txt README.txt _docs/*
  66. %{_bindir}/nant
  67. %dir %{_datadir}/NAnt
  68. %{_datadir}/NAnt/*
  69. %files devel
  70. %defattr(-,root,root)
  71. %{_datadir}/pkgconfig/%{name}.pc
  72. %changelog
  73. * Sat Mar 28 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.92-1.git20140131
  74. - updated to 0.92+git based on OpenSUSE
  75. - built with mono 3.12.1
  76. * Mon Apr 25 2011 Shu KONNO <owa@bg.wakwak.com> 0.90-3
  77. - rebuilt with mono-2.10.1-3
  78. * Sun Apr 03 2011 Shu KONNO <owa@bg.wakwak.com> 0.90-2
  79. - rebuilt with mono-2.10.1
  80. * Tue Oct 12 2010 Shu KONNO <owa@bg.wakwak.com> 0.90-1
  81. - initial build for VineSeed