jd-vl.spec 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228
  1. ### for Vine Linux 4.x / 5.x ###
  2. %define pkg_version 2.6.0
  3. %define strtag 100208
  4. %define repoid 40140
  5. %define vendor_rel 2
  6. %define pre_release 0
  7. %if %{pre_release}
  8. %define pkg_release %{vendor_rel}.%{strtag}%{?_dist_release}
  9. %else
  10. %define pkg_release %{vendor_rel}%{?_dist_release}
  11. %endif
  12. ## icon install dist dir
  13. %define icondir %{_datadir}/icons/hicolor
  14. ## enable/disable sound (0:disable 1:enable)
  15. %define sound 1
  16. Summary: A 2ch browser
  17. Summary(ja): 2ちゃんねる用ブラウザ
  18. Name: jd
  19. Version: %{pkg_version}
  20. Release: %{pkg_release}
  21. Source0: http://prdownloads.sourceforge.jp/jd4linux/%{repoid}/%{name}-%{version}-%{strtag}.tgz
  22. Source1: jd-vl.desktop
  23. # upstream svn patches
  24. # Patch100: jd-2.5.0_http_201.patch
  25. # Patch100: jd-2.4.0_close_err_image.patch
  26. # Patch110: jd-2.4.0_tag_drawing_fix.patch
  27. Patch100: jd-2.6.0_gtkmm28.patch
  28. License: GPL
  29. Group: Applications/Internet
  30. URL: http://jd4linux.sourceforge.jp/
  31. Requires: gtkmm2 >= 2.8
  32. Requires: glibmm
  33. Requires: zlib >= 1.2
  34. Requires: pango
  35. Requires: gnutls >= 1.2
  36. Prereq: desktop-file-utils
  37. BuildRequires: libtool, automake, autoconf
  38. BuildRequires: gtkmm2-devel >= 2.8
  39. BuildRequires: glibmm-devel
  40. BuildRequires: zlib-devel >= 1.2
  41. BuildRequires: XOrg-devel
  42. BuildRequires: pango-devel
  43. BuildRequires: gnutls-devel >= 1.2
  44. %if %{sound}
  45. BuildRequires: alsa-lib-devel
  46. %endif
  47. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  48. Packager: tomcat, iwamoto
  49. Vendor: Project Vine
  50. Distribution: Vine Linux
  51. %description
  52. JD is a 2ch browser based on gtkmm2.
  53. %description -l ja
  54. JD gtkmm2 ベースの2ちゃんねる用ブラウザです。
  55. %prep
  56. %setup -q -n %{name}-%{version}-%{strtag}
  57. # find . -name .svn | sort -r | xargs %{__rm} -rf
  58. # Patch 100 - 200 are upstream patches
  59. # %patch100 -p2 -b .close_err_image
  60. %patch100 -p2 -b .gtkmm28
  61. %build
  62. autoreconf -i
  63. ## set TZ for __TIME__
  64. export TZ='Asia/Tokyo'
  65. %if %{sound}
  66. %configure --with-alsa
  67. %else
  68. %configure
  69. %endif
  70. %{__make} %{?_smp_mflags}
  71. %install
  72. %{__rm} -rf ${RPM_BUILD_ROOT}
  73. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  74. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/applications
  75. %{__install} -p -m644 %{SOURCE1} ${RPM_BUILD_ROOT}%{_datadir}/applications/jd.desktop
  76. for i in 16 32 48 96;do \
  77. %{__mkdir_p} ${RPM_BUILD_ROOT}%{icondir}/$i"x"$i/apps; \
  78. %{__install} -p -m644 src/icons/%{name}$i.png ${RPM_BUILD_ROOT}%{icondir}/$i"x"$i/apps/%{name}.png; \
  79. done
  80. %clean
  81. %{__rm} -rf ${RPM_BUILD_ROOT}
  82. %post
  83. update-desktop-database %{_datadir}/applications
  84. %postun
  85. update-desktop-database %{_datadir}/applications
  86. %files
  87. %defattr(-,root,root)
  88. %doc COPYING ChangeLog README
  89. %{_bindir}/%{name}
  90. %{_datadir}/applications/%{name}.desktop
  91. %{_datadir}/pixmaps/%{name}.png
  92. %{icondir}/*/apps/%{name}.png
  93. %changelog
  94. * Mon Mar 22 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.0-2
  95. - add Patch100 to build fix with <= gtkmm28 (Vine 4.x env)
  96. * Mon Feb 8 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.0-1
  97. - new upstream release
  98. * Sat Feb 6 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.0-0.100130
  99. - 2.6.0 rc1 (not for release)
  100. * Tue Dec 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-1
  101. - new upstream release
  102. * Mon Dec 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-0.091225
  103. - 2.5.5 rc1 (not for release)
  104. * Wed Dec 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-0.091220
  105. - 2.5.5 beta (not for release)
  106. - drop patch100 (included in new release)
  107. * Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.0-1
  108. - new upstream release
  109. * Mon Sep 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.2-1
  110. - new upstream release
  111. * Tue Sep 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  112. - 2.4.2-rc090921-0
  113. - for test
  114. * Mon Jul 13 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.1-1
  115. - new upstream release
  116. * Sat Jul 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  117. - 2.4.1-rc090705-1
  118. - new upstream rc release for testing
  119. - drop patch100, 110 (included in new release)
  120. * Sat May 30 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.0-2
  121. - Merge spec file for vl4 and for vl5
  122. - add patch100, 110 from upstream svn
  123. * Sat May 23 2009 tomcat <webmaster2@tomcat.nyanta.jp> 2.4.0-1vl4
  124. - new upstream release
  125. * Fri Mar 06 2009 tomcat <webmaster2@tomcat.nyanta.jp> 2.3.0-1vl4
  126. - new upstream release
  127. * Fri Jan 16 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.1.0-2vl4
  128. - fix icon file install method
  129. * Sun Dec 28 2008 tomcat <webmaster2@tomcat.nyanta.jp> 2.1.0-1vl4
  130. - new upstream release
  131. * Mon Nov 24 2008 tomcat <webmaster2@tomcat.nyanta.jp> 2.0.3-1vl4
  132. - new upstream release
  133. * Wed Oct 01 2008 tomcat <webmaster2@tomcat.nyanta.jp> 2.0.2-1vl4
  134. - rebuild for official
  135. * Sun Sep 21 2008 tomcat <webmaster2@tomcat.nyanta.jp> 2.0.2-1tomvl4
  136. - update to 2.0.2
  137. * Sun Feb 03 2008 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.8-1tom3
  138. - build with gnutls-1.4.1(official package)
  139. * Sun Dec 30 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.8-1tom2
  140. - build with gnutls-1.6.3(unofficial package)
  141. * Sat Dec 29 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.8-1tom1
  142. - new upstream release
  143. - drop Patch0 (jd-1.9.5-desktop-vi.patch)
  144. - add Source1 (jd-vi.desktop)
  145. * Fri Nov 23 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.7-1tom1
  146. - new upstream release
  147. * Sat Oct 06 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.6-1tom1
  148. - new upstream release
  149. * Wed Jul 04 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.5-1tom2
  150. - modified jd-vi.spec
  151. - add patch0
  152. * Sun Jul 01 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.5-1
  153. - new upstream release
  154. * Wed May 23 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.8.8-2
  155. - fix the Help file is not installed
  156. * Wed Apr 04 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.8.8-1
  157. - new upstream release
  158. * Sat Feb 03 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.8.5-1
  159. - new upstream release
  160. * Mon Dec 18 2006 tomcat <webmaster2@tomcat.nyanta.jp> 1.8.1-1
  161. - new upstream release
  162. * Thu Nov 30 2006 tomcat <webmaster2@tomcat.nyanta.jp> 1.8.0-1
  163. - initial build for Vine Linux
  164. * Sun Mar 9 2006 Houritsuchu <houritsuchu@hotmail.com>
  165. - Version up.
  166. - add icon
  167. * Sat Feb 25 2006 Houritsuchu <houritsuchu@hotmail.com>
  168. - first