ode-vl.spec 6.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191
  1. Name: ode
  2. Version: 0.11.1
  3. Release: 1%{?_dist_release}
  4. Summary: High performance library for simulating rigid body dynamics
  5. Group: System Environment/Libraries
  6. License: BSD or LGPLv2+
  7. URL: http://www.ode.org
  8. Source0: http://downloads.sourceforge.net/opende/ode-%{version}.tar.bz2
  9. # This works around a bug in rpmbuild, where with localbuilds it will pass
  10. # the machine being build on as host param to configure instead of the machine
  11. # on which the code will run
  12. Patch0: ode-0.10.0-no-pentium-on-i386.patch
  13. Patch1: ode-0.11.1-multilib.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  15. BuildRequires: libGL-devel libGLU-devel
  16. %description
  17. ODE is an open source, high performance library for simulating rigid body
  18. dynamics. It is fully featured, stable, mature and platform independent with
  19. an easy to use C/C++ API. It has advanced joint types and integrated collision
  20. detection with friction. ODE is useful for simulating vehicles, objects in
  21. virtual reality environments and virtual creatures. It is currently used in
  22. many computer games, 3D authoring tools and simulation tools.
  23. %package double
  24. Summary: Ode physics library compiled with double precision
  25. Group: Development/Libraries
  26. %description double
  27. The %{name}-double package contains a version of the ODE library for simulating
  28. rigid body dynamics compiled with double precision.
  29. %package devel
  30. Summary: Development files for %{name}
  31. Group: Development/Libraries
  32. Requires: %{name} = %{version}-%{release}
  33. Requires: %{name}-double = %{version}-%{release}
  34. %description devel
  35. The %{name}-devel package contains libraries and header files for
  36. developing applications that use %{name} or %{name}-double.
  37. %prep
  38. %setup -q
  39. %patch0 -p1
  40. %patch1 -p1
  41. # to stop autoxxx from getting regenerated because of our configure patch
  42. touch -r CHANGELOG.txt configure.in
  43. # stop rpmlint from complaining about executable files in the debug package
  44. chmod -x ode/src/stepfast.cpp include/ode/collision_trimesh.h \
  45. include/ode/odeconfig.h
  46. %build
  47. %configure --enable-shared --disable-static --enable-double-precision
  48. make %{?_smp_mflags} X_LIBS=-lX11 \
  49. libode_la_LDFLAGS="-release double -version-info 2:1:1"
  50. sed -i 's|-lode|-lode-double|g' ode-config ode.pc
  51. mv ode-config ode-double-config
  52. mv ode.pc ode-double.pc
  53. mv ode/src/.libs/libode-double.so.1.1.1 .
  54. make distclean
  55. CFLAGS="%{optflags} -ffast-math"
  56. CXXFLAGS="%{optflags} -ffast-math"
  57. %configure --enable-shared --disable-static
  58. make %{?_smp_mflags} X_LIBS=-lX11
  59. %install
  60. rm -rf $RPM_BUILD_ROOT
  61. make install DESTDIR=$RPM_BUILD_ROOT
  62. rm $RPM_BUILD_ROOT%{_libdir}/libode.la
  63. # DIY libode-double install
  64. install -m 755 ode-double-config $RPM_BUILD_ROOT%{_bindir}
  65. install -m 755 libode-double.so.1.1.1 $RPM_BUILD_ROOT%{_libdir}
  66. ln -s libode-double.so.1.1.1 $RPM_BUILD_ROOT%{_libdir}/libode-double.so.1
  67. ln -s libode-double.so.1.1.1 $RPM_BUILD_ROOT%{_libdir}/libode-double.so
  68. install -m 644 ode-double.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig
  69. %clean
  70. rm -rf $RPM_BUILD_ROOT
  71. %post -p /sbin/ldconfig
  72. %postun -p /sbin/ldconfig
  73. %post double -p /sbin/ldconfig
  74. %postun double -p /sbin/ldconfig
  75. %files
  76. %defattr(-,root,root,-)
  77. %doc CHANGELOG.txt LICENSE*.TXT README.txt
  78. %{_libdir}/libode.so.1*
  79. %files double
  80. %defattr(-,root,root,-)
  81. %doc CHANGELOG.txt LICENSE*.TXT README.txt
  82. %{_libdir}/libode-double.so.1*
  83. %files devel
  84. %defattr(-,root,root,-)
  85. %{_bindir}/%{name}-config
  86. %{_bindir}/%{name}-double-config
  87. %{_includedir}/%{name}
  88. %{_libdir}/libode.so
  89. %{_libdir}/libode-double.so
  90. %{_libdir}/pkgconfig/%{name}.pc
  91. %{_libdir}/pkgconfig/%{name}-double.pc
  92. %changelog
  93. * Fri Jan 07 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 0.11.1-1
  94. - initial build for Vine Linux based on fedora development
  95. * Mon Nov 8 2010 Hans de Goede <hdegoede@redhat.com> 0.11.1-5
  96. - Add a -double subpackage providing a version of ode compiled with
  97. double precision (#574034)
  98. * Tue Feb 16 2010 Hans de Goede <hdegoede@redhat.com> 0.11.1-4
  99. - Fix FTBFS (#564642)
  100. * Thu Nov 12 2009 Hans de Goede <hdegoede@redhat.com> 0.11.1-3
  101. - Fix multilib conflict in -devel sub package (#507981)
  102. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11.1-2
  103. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  104. * Mon May 25 2009 Hans de Goede <hdegoede@redhat.com> 0.11.1-1
  105. - New upstream release 0.11.1
  106. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11-2
  107. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  108. * Fri Jan 30 2009 Hans de Goede <hdegoede@redhat.com> 0.11-1
  109. - New upstream release 0.11
  110. * Mon Sep 15 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.1-1
  111. - New upstream release 0.10.1 (bz 460033)
  112. * Thu Apr 3 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.9-4
  113. - Force proper use of RPM_OPT_FLAGS during build
  114. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.9-3
  115. - Autorebuild for GCC 4.3
  116. * Thu Oct 18 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.9-2
  117. - Drop workaround for stormbaancoureur crash, it is now fixed in
  118. stormbaancoureur
  119. * Fri Oct 12 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.9-1
  120. - New upstream release 0.9 (final)
  121. * Fri Sep 28 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.9-0.1.rc1
  122. - New upstream release 0.9-rc1
  123. * Tue Sep 11 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.8.1-0.1.rc1
  124. - New upstream release 0.8.1-rc1
  125. * Wed Aug 15 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.8-2
  126. - Update License tag for new Licensing Guidelines compliance
  127. * Wed Feb 14 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.8-1
  128. - New upstream release 0.8
  129. * Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.7-2
  130. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  131. * Fri Sep 22 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 0.7-1
  132. - New upstream release 0.7
  133. * Mon Aug 28 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 0.6-3
  134. - FE6 Rebuild
  135. * Wed Jul 5 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 0.6-2
  136. - Change name from libode to ode
  137. - Fix soname & /usr/lib64 usage
  138. - Patch configure to accept our CFLAGS instead of always using its own
  139. - Patch configure to never activate the generation of asm-code which is then
  140. used unconditionally, the build CPU may be very different from the CPU on
  141. which the package gets run.
  142. * Sun Jun 18 2006 Hugo Cisneiros <hugo@devin.com.br> 0.6-1
  143. - Initial RPM release