acl-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: acl
  3. Summary: Access control list utilities
  4. Version: 2.2.53
  5. Release: 2%{?_dist_release}
  6. Group: system
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: GPLv2+
  10. URL: http://oss.sgi.com/projects/xfs/
  11. Source: http://download.savannah.nongnu.org/releases/acl/acl-%{version}.tar.gz
  12. # avoid permission denied problem with LD_PRELOAD in the test-suite
  13. Patch1: 0001-acl-2.2.53-test-runwrapper.patch
  14. # make __acl_create_entry_obj() work with LTO enabled (#1873975)
  15. Patch2: 0002-acl-2.2.53-setattr-segv.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: gawk
  18. BuildRequires: gettext
  19. BuildRequires: libattr-devel >= 2.4.1
  20. BuildRequires: libtool
  21. Requires: libacl = %{version}-%{release}
  22. %description
  23. This package contains the getfacl and setfacl utilities needed for
  24. manipulating access control lists.
  25. %package -n libacl
  26. Summary: Dynamic library for access control list support
  27. License: LGPLv2+
  28. Group: system
  29. Requires(post): /sbin/ldconfig
  30. Requires(postun): /sbin/ldconfig
  31. %description -n libacl
  32. This package contains the libacl.so dynamic library which contains
  33. the POSIX 1003.1e draft standard 17 functions for manipulating access
  34. control lists.
  35. %package -n libacl-devel
  36. Summary: Access control list static libraries and headers.
  37. License: LGPLv2+
  38. Group: programming
  39. Requires: libacl = %{version}-%{release}
  40. Requires: libattr-devel
  41. %description -n libacl-devel
  42. This package contains static libraries and header files needed to develop
  43. programs which make use of the access control list programming interface
  44. defined in POSIX 1003.1e draft standard 17.
  45. %if %build_compat32
  46. %package -n compat32-libacl
  47. Summary: Dynamic library for access control list support
  48. License: LGPLv2+
  49. Group: system,legacy
  50. Requires(post): /sbin/ldconfig
  51. Requires(postun): /sbin/ldconfig
  52. %description -n compat32-libacl
  53. This package contains the libacl.so dynamic library which contains
  54. the POSIX 1003.1e draft standard 17 functions for manipulating access
  55. control lists.
  56. %endif
  57. %debug_package
  58. %prep
  59. %setup -q
  60. %autopatch -p1
  61. %build
  62. touch .census
  63. # acl abuses libexecdir
  64. %configure --libdir=/%{_lib} --libexecdir=%{_libdir}
  65. %make_build
  66. %install
  67. rm -rf %{buildroot}
  68. %make_install
  69. mv -f %{buildroot}%{_datadir}/doc/acl ./doc-nover
  70. # get rid of libacl.a and libacl.la
  71. rm -f %{buildroot}/%{_lib}/libacl.{a,la}
  72. rm -f %{buildroot}%{_libdir}/libacl.{a,la}
  73. # fix links to shared libs and permissions
  74. rm -f %{buildroot}%{_libdir}/libacl.so
  75. mkdir -p %{buildroot}%{_libdir}
  76. ln -sf ../../%{_lib}/libacl.so %{buildroot}%{_libdir}/libacl.so
  77. chmod 0755 %{buildroot}/%{_lib}/libacl.so.*.*.*
  78. mv -f %{buildroot}/%{_lib}/pkgconfig %{buildroot}%{_libdir}/
  79. %find_lang %{name}
  80. %check
  81. if ./setfacl/setfacl -m u:`id -u`:rwx .; then
  82. make tests || exit $?
  83. if test 0 = `id -u`; then
  84. make root-tests || exit $?
  85. fi
  86. else
  87. echo '*** ACLs are probably not supported by the file system,' \
  88. 'the test-suite will NOT run ***'
  89. fi
  90. %clean
  91. rm -rf %{buildroot}
  92. %files -f %{name}.lang
  93. %defattr(-,root,root)
  94. %doc doc-nover/*
  95. %{_bindir}/chacl
  96. %{_bindir}/getfacl
  97. %{_bindir}/setfacl
  98. %{_mandir}/man1/chacl.1*
  99. %{_mandir}/man1/getfacl.1*
  100. %{_mandir}/man1/setfacl.1*
  101. %{_mandir}/man5/acl.5*
  102. %files -n libacl-devel
  103. %defattr(-,root,root)
  104. /%{_lib}/libacl.so
  105. %{_includedir}/acl
  106. %{_includedir}/sys/acl.h
  107. %{_libdir}/libacl.*
  108. %{_libdir}/pkgconfig/*.pc
  109. %{_mandir}/man3/acl_*
  110. %files -n libacl
  111. %defattr(-,root,root)
  112. /%{_lib}/libacl.so.*
  113. %if %build_compat32
  114. %files -n compat32-libacl
  115. %defattr(-,root,root,-)
  116. /%{_lib}/libacl.so.*
  117. %endif
  118. %changelog
  119. * Wed Mar 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.53-2
  120. - dropped scriptlets.
  121. * Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.53-1
  122. - new upstream release.
  123. - dropped all patches: fixed in upstream.
  124. * Thu Apr 16 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.52-2
  125. - added compat32 package.
  126. * Fri Jul 4 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.52-1
  127. - new upstream release.
  128. - replaced patches to the newest rawhide's.
  129. * Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.49-1
  130. - updated to 2.2.49
  131. - added Patch2-7 from Fedora
  132. * Wed Apr 06 2011 Kamil Dudka <kdudka@redhat.com> 2.2.49-11
  133. - add function acl_extended_file_nofollow() (#692982)
  134. * Tue Mar 29 2011 Kamil Dudka <kdudka@redhat.com> 2.2.49-10
  135. - fix typos in setfacl(1) man page (#675451)
  136. * Thu Jul 08 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-8
  137. - remove dependency of libacl-devel on nfs-utils-lib and openldap
  138. * Tue May 25 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-7
  139. - let acl depend on the same version of libacl (#595674)
  140. * Wed Mar 24 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-6
  141. - prevent setfacl --restore from SIGSEGV on malformed restore file (#576550)
  142. * Mon Jun 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.47-2
  143. - initial build for Vine Linux
  144. * Tue Feb 12 2008 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.47-1
  145. - new upstream version
  146. * Mon Jan 28 2008 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.45-3
  147. - Fixed segfault when using only "--" as parameter
  148. - Resolves: #430458
  149. * Wed Nov 7 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.45-2
  150. - Fixed setfacl exitcodes
  151. - Resolves: #368451
  152. * Wed Oct 31 2007 Jiri Moskovcak <jmoskovc@redhat.com> - 2.2.45-1
  153. - New version
  154. - dropped walk patch
  155. * Thu Sep 20 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-10
  156. - Rewriten path_max patch to support long UTF8 names
  157. - Resolves #287701, #183181
  158. * Fri Aug 31 2007 Steve Dickson <steved@redhat.com> - 2.2.39-9
  159. - Removed NFS4 ACL patch since it was rejected by upstream.
  160. * Thu Aug 30 2007 Jeremy Katz <katzj@redhat.com> - 2.2.39-8
  161. - disable nfs patch; linking libacl against libs in /usr will lead to breakage
  162. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.2.39-7
  163. - Build Require gawk
  164. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.2.39-6
  165. - Rebuild for selinux ppc32 issue.
  166. * Mon Aug 27 2007 Steve Dickson <steved@redhat.com> 2.2.39-5
  167. - Added NFS v4 ACL support
  168. * Thu Jul 26 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-4.1
  169. - Updated man page for getfacl
  170. * Wed Jul 25 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-4
  171. - Added support fort short params to getfacl
  172. - Resolves: #204087
  173. * Wed Mar 21 2007 Thomas Woerner <twoerner@redhat.com> 2.2.39-3.1
  174. - new improved walk patch with fixed getfacl exit code (rhbz#232884)
  175. * Fri Feb 23 2007 Karsten Hopp <karsten@redhat.com> 2.2.39-3
  176. - fix buildroot
  177. - remove trailing dot from summary
  178. - -devel requires same version of libacl
  179. - escape macro in changelog
  180. - make .so symlink relative
  181. * Thu Feb 22 2007 Steve Grubb <sgrubb@redhat.com> 2.2.39-2
  182. - Apply patch to make order consistent.
  183. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.2.39-1.1
  184. - rebuild
  185. * Wed Jul 5 2006 Thomas Woerner <twoerner@redhat.com> 2.2.39-1
  186. - new version 2.2.39
  187. - fixed usage of long UTF-8 filenames (#183181)
  188. Thanks to Andrey for the initial patch.
  189. * Wed Jun 7 2006 Jeremy Katz <katzj@redhat.com> - 2.2.34-2
  190. - rebuild for -devel deps
  191. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.2.34-1.2
  192. - bump again for double-long bug on ppc(64)
  193. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.2.34-1.1
  194. - rebuilt for new gcc4.1 snapshot and glibc changes
  195. * Fri Feb 3 2006 Thomas Woerner <twoerner@redhat.com> 2.2.34-1
  196. - new version 2.2.34
  197. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  198. - rebuilt
  199. * Tue Dec 6 2005 Thomas Woerner <twoerner@redhat.com> 2.2.32-2.1
  200. - fixed permissions of libacl
  201. * Tue Dec 6 2005 Thomas Woerner <twoerner@redhat.com> 2.2.32-2
  202. - spec file cleanup
  203. - mark po files as lang specific
  204. * Sun Nov 06 2005 Florian La Roche <laroche@redhat.com>
  205. - 2.2.32
  206. * Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.2.31-1
  207. - update to 2.2.31
  208. * Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.2.23-9
  209. - get rid of *.la files
  210. - remove duplicate doc files
  211. * Wed Feb 9 2005 Stephen C. Tweedie <sct@redhat.com> 2.2.23-6
  212. - Rebuild
  213. * Thu Sep 16 2004 Jeremy Katz <katzj@redhat.com> - 2.2.23-5
  214. - make the libs executable so that we find their dependencies (#132696)
  215. * Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.23-4
  216. - libacl-devel Requires: libattr-devel for libattr.la
  217. * Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.23-3
  218. - Requires libtool >= 1.5 for building
  219. * Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.2.23-2
  220. - Make libacl.so.* executable.
  221. * Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.2.23-1
  222. - Update to latest upstream version.
  223. * Sun Aug 8 2004 Alan Cox <alan@redhat.com> 2.2.7-7
  224. - Close bug #125300 (Steve Grubb: build requires libtool,gettext)
  225. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  226. - rebuilt
  227. * Wed Mar 31 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.7-5
  228. - Add missing %%defattr
  229. * Tue Mar 30 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.7-3
  230. - Add /usr/include/acl to files manifest
  231. - Fix location of doc files, add main doc dir to files manifest
  232. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  233. - rebuilt
  234. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  235. - rebuilt
  236. * Tue Aug 5 2003 Elliot Lee <sopwith@redhat.com> 2.2.7-2
  237. - Fix libtool invocation
  238. * Tue Jun 3 2003 Stephen C. Tweedie <sct@redhat.com> 2.2.7-1
  239. - Update to acl-2.2.7
  240. * Wed Mar 26 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.3-2
  241. - include patch from Jay Berkenbilt to print better error messages
  242. * Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.3-1
  243. - udpate/rebuild
  244. * Sat Jan 4 2003 Jeff Johnson <jbj@redhat.com> 2.0.11-7
  245. - set execute bits on library so that requires are generated.
  246. * Tue Nov 19 2002 Elliot Lee <sopwith@redhat.com> 2.0.11-5
  247. - Correct patch in previous fix so that shared libraries go in /lib*
  248. instead of /usr/lib*
  249. * Tue Nov 19 2002 Elliot Lee <sopwith@redhat.com> 2.0.11-4
  250. - Fix multilibbing
  251. * Wed Sep 11 2002 Than Ngo <than@redhat.com> 2.0.11-3
  252. - Added fix to install libs in correct directory on 64bit machine
  253. * Thu Aug 08 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.11-2
  254. - Made the package only own the one directory that is unique to it:
  255. /usr/include/acl
  256. * Mon Jun 24 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.11-1
  257. - Initial Red Hat package
  258. Made as few changes as possible relative to upstream packaging to
  259. make it easier to maintain long-term. This means that some of
  260. the techniques used here are definitely not standard Red Hat
  261. techniques. If you are looking for an example package to fit
  262. into Red Hat Linux transparently, this would not be the one to
  263. pick.
  264. - acl-devel -> libacl-devel