gnome-python-desktop-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. %define glib_version 2.24.0
  3. %define gtk_version 2.20.0
  4. %define pygtk_version 2.14.0
  5. %define gnome_python_version 2.28.0
  6. %define libgnome_keyring_version 2.30.0
  7. %define gnome_panel_version 2.30.0
  8. %define gnome_desktop_version 2.30.0
  9. %define gtksourceview_version 1.1.90
  10. %define libgtop_version 2.28.0
  11. %define gnome_media_version 2.30.0
  12. %define metacity_version 2.30.0
  13. %define librsvg2_version 2.26.0
  14. %define totem_version 2.30.0
  15. %define libwnck_version 2.30.0
  16. %define bug_buddy_version 2.30.0
  17. %define evolution_data_server_version 2.30.0
  18. ### Abstract ###
  19. Name: gnome-python-desktop
  20. Version: 2.30.0
  21. Release: 1%{?_dist_release}
  22. License: GPL/LGPL
  23. Group: Development/Libraries
  24. Summary: The sources for additional PyGNOME Python extension modules
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  26. Source: gnome-python-desktop-%{version}.tar.bz2
  27. ### Dependencies ###
  28. Requires: gnome-python >= %{gnome_python_version}
  29. ### Build Dependencies ###
  30. BuildRequires: glib2-devel >= %{glib_version}
  31. BuildRequires: gtk2-devel >= %{gtk_version}
  32. BuildRequires: python >= 2.6
  33. BuildRequires: pygtk2-devel >= %{pygtk_version}
  34. BuildRequires: gnome-python-devel >= %{gnome_python_version}
  35. BuildRequires: libgnome-keyring-devel >= %{libgnome_keyring_version}
  36. BuildRequires: gnome-panel >= %{gnome_panel_version}
  37. BuildRequires: gnome-desktop-devel >= %{gnome_desktop_version}
  38. BuildRequires: libgnomeprint-devel
  39. BuildRequires: libgnomeprintui-devel
  40. BuildRequires: evince-devel
  41. BuildRequires: evolution-data-server >= %{evolution_data_server_version}
  42. BuildRequires: gtksourceview-devel >= %{gtksourceview_version}
  43. BuildRequires: libgtop2-devel >= %{libgtop_version}
  44. BuildRequires: gnome-media >= %{gnome_media_version}
  45. BuildRequires: metacity-devel >= %{metacity_version}
  46. BuildRequires: brasero-devel
  47. BuildRequires: librsvg2-devel >= %{librsvg2_version}
  48. BuildRequires: pycairo-devel
  49. BuildRequires: totem-pl-parser-devel >= %{totem_version}
  50. BuildRequires: totem >= %{totem_version}
  51. BuildRequires: libwnck-devel >= %{libwnck_version}
  52. BuildRequires: bug-buddy >= %{bug_buddy_version}
  53. %description
  54. The gnome-python-desktop package contains the source packages for additional
  55. Python bindings for GNOME. It should be used together with gnome-python.
  56. %package -n gnome-python-applet
  57. Summary: Python bindings for GNOME Panel applets.
  58. Group: Development/Libraries
  59. Requires: %{name} = %{version}-%{release}
  60. # applets from GNOME 1.4 are no longer supported - we only have 1 panel
  61. Obsoletes: pygnome-applet
  62. %description -n gnome-python-applet
  63. This module contains a wrapper that allows GNOME Panel applets to be
  64. written in Python.
  65. %package -n gnome-python-bugbuddy
  66. Summary: Python bindings for interacting with bug-buddy
  67. Group: Development/Libraries
  68. Requires: %{name} = %{version}-%{release}
  69. Requires: bug-buddy >= %{bug_buddy_version}
  70. %description -n gnome-python-bugbuddy
  71. This module contains a wrapper that allows the use of bug-buddy via
  72. Python.
  73. %package -n gnome-python-evolution
  74. Summary: Python bindings for interacting with evolution
  75. Group: Development/Libraries
  76. Requires: %{name} = %{version}-%{release}
  77. Requires: evolution-data-server >= %{evolution_data_server_version}
  78. %description -n gnome-python-evolution
  79. This module contains a wrapper that allows the use of evolution via
  80. Python.
  81. %package -n gnome-python-gnomeprint
  82. Summary: Python bindings for interacting with libgnomeprint
  83. Group: Development/Libraries
  84. Requires: %{name} = %{version}-%{release}
  85. Requires: libgnomeprint
  86. Requires: libgnomeprintui
  87. %description -n gnome-python-gnomeprint
  88. This module contains a wrapper that allows the use of libgnomeprint via
  89. Python.
  90. %package -n gnome-python-gtksourceview
  91. Summary: Python bindings for interacting with the gtksourceview library
  92. Group: Development/Libraries
  93. Requires: %{name} = %{version}-%{release}
  94. Requires: gtksourceview >= %{gtksourceview_version}
  95. Requires: gnome-python-gnomeprint
  96. %description -n gnome-python-gtksourceview
  97. This module contains a wrapper that allows the use of gtksourceview via
  98. Python.
  99. %package -n gnome-python-libwnck
  100. Summary: Python bindings for interacting with libwnck
  101. Group: Development/Libraries
  102. Requires: libwnck >= %{libwnck_version}
  103. %description -n gnome-python-libwnck
  104. This module contains a wrapper that allows the use of libwnck via
  105. Python.
  106. %package -n gnome-python-libgtop2
  107. Summary: Python bindings for interacting with libgtop
  108. Group: Development/Libraries
  109. Requires: %{name} = %{version}-%{release}
  110. Requires: libgtop2 >= %{libgtop_version}
  111. %description -n gnome-python-libgtop2
  112. This module contains a wrapper that allows the use of libgtop via
  113. Python.
  114. %package -n gnome-python-brasero
  115. Summary: Python bindings for interacting with brasero
  116. Group: Development/Libraries
  117. Requires: %{name} = %{version}-%{release}
  118. Requires: brasero-libs
  119. %description -n gnome-python-brasero
  120. This module contains a wrapper that allows the use of brasero
  121. via Python.
  122. %package -n gnome-python-metacity
  123. Summary: Python bindings for interacting with metacity
  124. Group: Development/Libraries
  125. Requires: %{name} = %{version}-%{release}
  126. Requires: metacity >= %{metacity_version}
  127. %description -n gnome-python-metacity
  128. This module contains a wrapper that allows the use of metacity
  129. via Python.
  130. %package -n gnome-python-totem
  131. Summary: Python bindings for interacting with totem
  132. Group: Development/Libraries
  133. Requires: %{name} = %{version}-%{release}
  134. Requires: totem >= %{totem_version}
  135. %description -n gnome-python-totem
  136. This module contains a wrapper that allows the use of totem
  137. via Python.
  138. %package -n gnome-python-rsvg
  139. Summary: Python bindings for interacting with librsvg
  140. Group: Development/Libraries
  141. Requires: librsvg2 >= %{librsvg2_version}
  142. Requires: pycairo
  143. %description -n gnome-python-rsvg
  144. This module contains a wrapper that allows the use of librsvg
  145. via Python.
  146. %package -n gnome-python-gnomedesktop
  147. Summary: Python bindings for interacting with gnome-desktop
  148. Group: Development/Libraries
  149. Requires: %{name} = %{version}-%{release}
  150. Requires: gnome-desktop >= %{gnome_desktop_version}
  151. %description -n gnome-python-gnomedesktop
  152. This module contains a wrapper that allows the use of gnome-desktop
  153. via Python.
  154. %package -n gnome-python-gnomekeyring
  155. Summary: Python bindings for interacting with gnome-keyring
  156. Group: Development/Libraries
  157. Requires: %{name} = %{version}-%{release}
  158. Requires: libgnome-keyring >= %{libgnome_keyring_version}
  159. %description -n gnome-python-gnomekeyring
  160. This module contains a wrapper that allows the use of gnome-keyring
  161. via Python.
  162. %package -n gnome-python-evince
  163. Summary: Python bindings for interacting with evince
  164. Group: Development/Libraries
  165. Requires: %{name} = %{version}-%{release}
  166. Requires: evince
  167. %description -n gnome-python-evince
  168. This module contains a wrapper that allows the use of evince
  169. via Python.
  170. %prep
  171. %setup -q -n gnome-python-desktop-%{version}
  172. %build
  173. ./waf configure --prefix=%{_prefix} --libdir=%{_libdir} --enable-metacity
  174. ./waf build %{?_smp_mflags}
  175. %install
  176. rm -rf $RPM_BUILD_ROOT
  177. ./waf install --destdir=$RPM_BUILD_ROOT
  178. find $RPM_BUILD_ROOT -name '*.la' -exec rm {} \;
  179. rm -rf $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/gtk-2.0/gksu
  180. %clean
  181. rm -rf $RPM_BUILD_ROOT
  182. %files
  183. %defattr(-,root,root,-)
  184. %doc AUTHORS ChangeLog NEWS
  185. %{_libdir}/pkgconfig/gnome-python-desktop-2.0.pc
  186. %{_datadir}/pygtk
  187. %files -n gnome-python-applet
  188. %defattr(-,root,root,-)
  189. %{python_sitearch}/gtk-2.0/gnomeapplet.so
  190. %defattr(644,root,root,755)
  191. %doc ../gnome-python-desktop-%{version}/examples/applet/*
  192. %files -n gnome-python-bugbuddy
  193. %defattr(-,root,root,-)
  194. %{python_sitearch}/gtk-2.0/bugbuddy.py*
  195. %files -n gnome-python-evolution
  196. %defattr(-,root,root,-)
  197. %dir %{python_sitearch}/gtk-2.0/evolution/
  198. %{python_sitearch}/gtk-2.0/evolution/*
  199. %files -n gnome-python-gnomeprint
  200. %defattr(-,root,root,-)
  201. %{python_sitearch}/gtk-2.0/gnomeprint/
  202. %{_datadir}/gtk-doc/html/pygnomeprint
  203. %{_datadir}/gtk-doc/html/pygnomeprintui
  204. %defattr(644,root,root,755)
  205. %doc ../gnome-python-desktop-%{version}/examples/gnomeprint/*
  206. %files -n gnome-python-gtksourceview
  207. %defattr(-,root,root,-)
  208. %{python_sitearch}/gtk-2.0/gtksourceview.so
  209. %{_datadir}/gtk-doc/html/pygtksourceview
  210. %defattr(644,root,root,755)
  211. %doc ../gnome-python-desktop-%{version}/examples/gtksourceview/*
  212. %files -n gnome-python-libwnck
  213. %defattr(-,root,root,-)
  214. %{python_sitearch}/gtk-2.0/wnck.so
  215. %defattr(644,root,root,755)
  216. %doc ../gnome-python-desktop-%{version}/examples/wnck_example.py
  217. %files -n gnome-python-libgtop2
  218. %defattr(-,root,root,-)
  219. %{python_sitearch}/gtk-2.0/gtop.so
  220. %files -n gnome-python-brasero
  221. %defattr(-,root,root,-)
  222. %{python_sitearch}/gtk-2.0/braseroburn.so
  223. %{python_sitearch}/gtk-2.0/braseromedia.so
  224. %defattr(644,root,root,755)
  225. %doc ../gnome-python-desktop-%{version}/examples/braseroburn/*
  226. %doc ../gnome-python-desktop-%{version}/examples/braseromedia/*
  227. %files -n gnome-python-metacity
  228. %defattr(-,root,root,-)
  229. %{python_sitearch}/gtk-2.0/metacity.so
  230. %files -n gnome-python-totem
  231. %defattr(-,root,root,-)
  232. %{python_sitearch}/gtk-2.0/mediaprofiles.so
  233. %{python_sitearch}/gtk-2.0/totem
  234. %files -n gnome-python-rsvg
  235. %{python_sitearch}/gtk-2.0/rsvg.so
  236. %defattr(644,root,root,755)
  237. %doc ../gnome-python-desktop-%{version}/examples/rsvg/*
  238. %files -n gnome-python-gnomedesktop
  239. %{python_sitearch}/gtk-2.0/gnomedesktop
  240. %files -n gnome-python-gnomekeyring
  241. %{python_sitearch}/gtk-2.0/gnomekeyring.so
  242. %defattr(644,root,root,755)
  243. %doc ../gnome-python-desktop-%{version}/examples/keyring*.py
  244. %files -n gnome-python-evince
  245. %{python_sitearch}/gtk-2.0/evince.so
  246. %changelog
  247. * Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  248. - new upstream release
  249. - add BuildRequires: totem
  250. - change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
  251. * Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
  252. - rebuild for python-2.6
  253. * Sat Nov 7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
  254. - new upstream release
  255. - added gnome-python-brasero, gnome-python-evince package
  256. - remove gnome-python-nautilus-cd-burner package
  257. - used waf instead of configure script
  258. * Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  259. - new upstream release
  260. * Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.24.0-1
  261. - new upstream release
  262. - added BuildRequires: pycairo-devel
  263. * Wed Jul 23 2008 Shu KONNO <owa@bg.wakwak.com> - 2.20.0-3
  264. - rebuilt with python-2.5.2
  265. * Wed Apr 16 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.20.0-2
  266. - re-enable BuildRequires: gnome-python-devel
  267. * Mon Apr 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.22.0-1vl5
  268. - new upstream release
  269. - added gnome-python-evolution subpackage
  270. * Wed Jan 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.20.0-0vl1
  271. - new upstream release
  272. * Sun Jul 08 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.18.0-1vl2
  273. - add BuildRequires: gnome-media
  274. * Sat Jul 7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.18.0-1vl1
  275. - initial build for Vine Linux
  276. * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 2.18.0-1.fc7
  277. - Update to 2.18.0
  278. * Wed Feb 28 2007 Matthias Clasen <mclasen@redhat.com> - 2.17.93-1
  279. - Update to 2.17.93
  280. * Sun Feb 25 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.92-1.fc7
  281. - Update to 2.17.92
  282. - Remove patch for GNOME bug #401760 (fixed upstream).
  283. * Mon Feb 05 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.3-3.fc7
  284. - Add patch for GNOME bug #401760 (plparser fails to build).
  285. * Mon Feb 05 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.3-2.fc7
  286. - Rename spec file to gnome-python2-desktop.spec (RH bug #225832).
  287. * Mon Jan 08 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.3-1
  288. - Update to 2.17.3
  289. * Sun Jan 07 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.2-1
  290. - Update to 2.17.2
  291. - New gnome-python2-bugbuddy subpackage.
  292. - Update version requirements to match configure.ac.
  293. - Use python_sitearch macro for installing libraries.
  294. * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 2.17.1-2
  295. - rebuild for python 2.5
  296. - BR gnome-python2-devel
  297. * Sat Oct 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.17.1-1
  298. - Update to 2.17.1
  299. * Tue Sep 5 2006 Matthias Clasen <mclasen@redhat.com> - 2.16.0-1.fc6
  300. - Update to 2.16.0
  301. * Tue Aug 22 2006 Dan Williams <dcbw@redhat.com> - 2.15.90-2.fc6
  302. - Remove unecessary dependencies on gnome-python2-desktop from
  303. -libwnck and -rsvg subpackages (OLPC)
  304. * Fri Aug 4 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.90-1.fc6
  305. - Update to 2.15.90
  306. * Thu Jul 20 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.4-2
  307. - Rebuild against dbus
  308. * Thu Jul 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.4-1
  309. - Update to 2.15.4
  310. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.15.3-4.1
  311. - rebuild
  312. * Thu Jun 15 2006 Jesse Keating <jkeating@redhat.com> - 2.15.3-4
  313. - Create gnomekeyring subpackage
  314. - block out the nautilus-cd stuff
  315. * Thu Jun 15 2006 Jesse Keating <jkeating@redhat.com> - 2.15.3-2
  316. - Bump for new nautilus-cd-burner
  317. * Tue Jun 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.3-1
  318. - Update to 2.15.3
  319. * Tue May 30 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.2-1
  320. - Update to 2.15.2
  321. - Add subpackages gnome-python2-rsvg and gnome-python2-gnomedesktop
  322. * Wed May 24 2006 John (J5) Palmieri <johnp@redhat.com> - 2.14.0-2
  323. - Add pygtk2 BR
  324. * Mon Mar 13 2006 Ray Strode <rstrode@redhat.de> 2.14.0-1
  325. - Update to 2.14.0
  326. * Tue Feb 28 2006 Karsten Hopp <karsten@redhat.de> 2.13.3-2
  327. - Buildrequires: python-devel
  328. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.13.3-1.1
  329. - bump again for double-long bug on ppc(64)
  330. * Mon Feb 6 2006 John (J5) Palmieri <johnp@redhat.com> - 2.13.3-1
  331. - Initial build.