python-requests-vl.spec 1.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687
  1. %define ver 2.20.1
  2. %define rel 1
  3. Summary: Python HTTP for Humans
  4. Name: python-requests
  5. Version: %{ver}
  6. Release: %{rel}%{?_dist_release}
  7. License: ASLv2
  8. Group: Development/Languages
  9. URL: https://pypi.python.org/pypi/requests
  10. Source0: https://pypi.python.org/packages/source/r/requests/requests-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  12. Requires: python
  13. BuildRequires: python-devel
  14. BuildRequires: python-rpm-macros
  15. BuildRequires: python-setuptools
  16. BuildRequires: python3-devel
  17. BuildRequires: python3-rpm-macros
  18. BuildRequires: python3-setuptools
  19. BuildArch: noarch
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. Packager: iwaim
  23. %description
  24. Requests is an Apache2 Licensed HTTP library, written in Python, for human beings.
  25. %package -n python3-requests
  26. Summary: Python HTTP for Humans
  27. Group: Development/Languages
  28. Requires: python3
  29. %description -n python3-requests
  30. Requests is an Apache2 Licensed HTTP library, written in Python, for human beings.
  31. %prep
  32. %setup -qc -n requests-%{ver}
  33. mv requests-%{ver} python2
  34. cp -a python2 python3
  35. %build
  36. pushd python2
  37. %py_build
  38. popd
  39. pushd python3
  40. %py3_build
  41. popd
  42. %install
  43. rm -rf $RPM_BUILD_ROOT
  44. pushd python2
  45. %py_install
  46. cp -f LICENSE README* HISTORY* ../
  47. popd
  48. pushd python3
  49. %py3_install
  50. popd
  51. %clean
  52. rm -rf $RPM_BUILD_ROOT
  53. %files
  54. %defattr(-,root,root,-)
  55. %license LICENSE
  56. %doc README* HISTORY*
  57. %{python_sitelib}/requests
  58. %{python_sitelib}/requests-%{version}-py*.egg-info
  59. %files -n python3-requests
  60. %defattr(-,root,root,-)
  61. %license LICENSE
  62. %doc README* HISTORY*
  63. %{python3_sitelib}/requests
  64. %{python3_sitelib}/requests-%{version}-py*.egg-info
  65. %changelog
  66. * Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.20.1-1
  67. - new upstream release.
  68. - add python2 support.
  69. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5.1-2
  70. - rebuild with python3-3.5.2
  71. * Sun Mar 22 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 2.5.1-1
  72. - Initial build.