self-build-mikutter-vl.spec 4.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130
  1. %define pkgname mikutter
  2. %define sourceurl http://mikutter.hachune.net/bin/%{pkgname}.%{version}.tar.gz
  3. Summary: Package to automatically build %{pkgname} rpm package
  4. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  5. Name: self-build-%{pkgname}
  6. Version: 3.0.5
  7. Release: 1%{?_dist_release}
  8. Source0: %{pkgname}-vl.spec
  9. License: GPLv3
  10. Group: Restricted Software
  11. Requires(post): self-build-setup >= 0.9.9
  12. # (build)requies of target package.
  13. Requires(post): alsa-utils
  14. Requires(post): ruby >= 1.9.3
  15. Requires(post): ruby-gtk2 >= 1.5.0
  16. Requires(post): rcairo >= 1.10.0
  17. Requires(post): desktop-file-utils
  18. BuildArch: noarch
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. Packager: Takemikaduchi
  21. %description
  22. mikutter is simple, powerful and moeful twitter client.
  23. If you install this package, it automaticaly downloads source
  24. code, compile it, and create rpm packages of
  25. %{pkgname}-%{version}.
  26. And the created rpm packages are automatically installed
  27. if installation is executed by apt-get command or synaptic
  28. package manager.
  29. [Note]
  30. This package requires many other packages to compile
  31. targetsoftware. So it consume more disk space than usual.
  32. Also installation takes logner time because of compilation.
  33. (This will take a few minutes to quarter or half of an hour,
  34. depends on building environment)
  35. [About self-build package]
  36. For some kind of software, distributing of binary package
  37. may viorate the patent or law. Therefore we chose self-build
  38. packge, create binary package on your machine, for such kind
  39. of softwares instead of distributing binary package.
  40. Please obey the national law when you use the created binary
  41. packages. And if you want to use the softwares using patented
  42. thechnology, it may be required to get a permission, make an
  43. agreement or purchas a license. Please consider it with your
  44. purpose or way of use and take appropriate action.
  45. %description -l ja
  46. 全てのミク廃、そして Twitter 中毒者へ贈る、至高の Twitter
  47. Client を目指す Twitter Client。
  48. このパッケージをインストールすると、自動的にソースコードを
  49. ダウンロードしてコンパイルし、%{pkgname}-%{version}
  50. の rpm パッケージを作成します。
  51. また apt-get コマンドや synaptic パッケージマネージャから実行
  52. した場合は、作成された rpm パッケージのインストールも自動的に
  53. 行います。
  54. [注意]
  55. コンパイルに必要な多くの関連パッケージを要求するので通常より
  56. ディスクの領域を多く消費します。
  57. またインストール時にコンパイルを行うため、通常より時間がかか
  58. る場合があります。(環境にもよりますが数分から数十分程度)
  59. [self-build パッケージについて]
  60. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  61. 違反する可能性があるものがあります。その為、このような問題が
  62. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  63. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  64. ジという方法を採っています。
  65. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  66. アのライセンス、および利用する国の各種法令に従ってください。
  67. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  68. センスの購入などが必要となる場合がありますので、利用する目的
  69. や形態に応じて各自で判断し適切な対応を取ってください。
  70. %prep
  71. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  72. %install
  73. %{__rm} -rf ${RPM_BUILD_ROOT}
  74. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  75. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  76. %clean
  77. %{__rm} -rf ${RPM_BUILD_ROOT}
  78. %posttrans
  79. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 5000
  80. %files
  81. %{_datadir}/%{name}
  82. %changelog
  83. * Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.5-1
  84. - new upstream release
  85. * Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.3-1
  86. - new upstream release
  87. * Sun Jun 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.0-1
  88. - new upstream release
  89. * Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.2.1537-1
  90. - new upstream release
  91. * Wed Jan 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.2.1476-1
  92. - new upstream release
  93. * Tue Dec 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.2.1430-1
  94. - new upstream release
  95. * Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.2.1410-1
  96. - initial build