jemalloc-vl.spec 8.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257
  1. Name: jemalloc
  2. Version: 4.1.1
  3. Release: 1%{?_dist_release}
  4. Summary: General-purpose scalable concurrent malloc implementation
  5. Summary(ja): 汎用・スケーラブル・並行 malloc 実装
  6. Group: System Environment/Libraries
  7. License: BSD
  8. URL: http://www.canonware.com/jemalloc/
  9. Source0: https://github.com/jemalloc/%{name}/releases/download/%{version}/%{name}-%{version}.tar.bz2
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  11. # ARMv5tel has no atomic operations
  12. Patch2: jemalloc-armv5-force-atomic.patch
  13. # RHEL5/POWER has no atomic operations
  14. Patch3: jemalloc-3.0.0.atomic_h_ppc_32bit_operations.patch
  15. Patch4: jemalloc-3.6.0.no_explicit_altivec.patch
  16. BuildRequires: /usr/bin/xsltproc
  17. %ifnarch s390
  18. BuildRequires: valgrind-devel
  19. %endif
  20. %description
  21. General-purpose scalable concurrent malloc(3) implementation.
  22. This distribution is the stand-alone "portable" implementation of %{name}.
  23. %package devel
  24. Summary: Development files for %{name}
  25. Requires: %{name} = %{version}-%{release}
  26. Group: Development/Libraries
  27. %description devel
  28. The %{name}-devel package contains libraries and header files for
  29. developing applications that use %{name}.
  30. %prep
  31. %setup -q
  32. #% patch2 -p1 -b .armv5tel
  33. %ifarch ppc ppc64
  34. %if 0%{?rhel} == 5
  35. %patch3 -b .ppc
  36. %patch4 -b .ppc
  37. %endif
  38. %endif
  39. %build
  40. %ifarch i686
  41. %if 0%{?fedora} >= 21
  42. CFLAGS="%{optflags} -msse2"
  43. %endif
  44. %endif
  45. %if 0%{?rhel} && 0%{?rhel} < 7
  46. export LDFLAGS="%{?__global_ldflags} -lrt"
  47. %endif
  48. %configure
  49. make %{?_smp_mflags}
  50. %check
  51. make check
  52. %install
  53. rm -rf %{buildroot}
  54. make install DESTDIR=%{buildroot}
  55. # Install this with doc macro instead
  56. rm %{buildroot}%{_datadir}/doc/%{name}/jemalloc.html
  57. # None of these in fedora
  58. find %{buildroot}%{_libdir}/ -name '*.a' -exec rm -vf {} ';'
  59. %clean
  60. rm -rf %{buildroot}
  61. %files
  62. %defattr(-,root,root,-)
  63. %{_libdir}/libjemalloc.so.*
  64. %{_bindir}/jemalloc.sh
  65. %{_bindir}/jemalloc-config
  66. %{_bindir}/jeprof
  67. %{_libdir}/pkgconfig/jemalloc.pc
  68. %doc COPYING README VERSION
  69. %doc doc/jemalloc.html
  70. %ifarch ppc ppc64
  71. %if 0%{?rhel} == 5
  72. %doc COPYING.epel5-ppc
  73. %endif
  74. %endif
  75. %files devel
  76. %defattr(-,root,root,-)
  77. %{_includedir}/jemalloc
  78. %{_libdir}/libjemalloc.so
  79. %{_mandir}/man3/jemalloc.3*
  80. %post -p /sbin/ldconfig
  81. %postun -p /sbin/ldconfig
  82. %changelog
  83. * Wed May 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.1.1-1
  84. - new upstream release.
  85. * Fri Oct 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.0.4-2
  86. - initial build for Vine Linux.
  87. * Sat Oct 24 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.4-1
  88. - New upstream release
  89. * Fri Sep 25 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.3-1
  90. - New upstream release
  91. - Removed oom test patch, it has been fixed upstream
  92. * Thu Sep 24 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.2-2
  93. - oom test also fails on 32bit ppc, so patch it out there as well
  94. * Tue Sep 22 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.2-1
  95. - New upstream release
  96. - Added a patch removing a non-critical test that fails on i386
  97. - Removed now included negative bitshift patch.
  98. * Wed Aug 19 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.0-1
  99. - New upstream release
  100. - Removed the no-pprof patch, as jemalloc now comes with its own prof variant
  101. - Removed atomic.h patch for armv5tel. jemalloc now provides a specific
  102. variant for armv5tel
  103. - Added a patch from upstream for errnous bitshift by negative amounts on pagesize >8KiB
  104. - Added -lrt to LDFLAGS for rhel<7
  105. * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.6.0-9
  106. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  107. * Mon Aug 18 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-8
  108. - valgrind-devel is not available on s390, closes #1131014
  109. * Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.6.0-7
  110. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  111. * Fri Aug 15 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-6
  112. - bz #1106933 fix only for fedora 21 and above
  113. * Fri Aug 15 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-5
  114. - Added valgrind-devel to BuildRequires, fixing bz #974270
  115. * Fri Aug 15 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-4
  116. - Added an i686 build fixing bz #1106933
  117. * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.6.0-3
  118. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  119. * Tue Apr 01 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-2
  120. - Patch that removes explicit altivec on el5/ppc
  121. * Mon Mar 31 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-1
  122. - New upstream release. This release fixes a critical regression
  123. * Fri Mar 28 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.5.1-1
  124. - New upstream release
  125. - Updated nopprof patch to match new release
  126. - Fixed a few bogus changelog entries
  127. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.4.0-2
  128. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  129. * Fri Jun 07 2013 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.4.0-1
  130. - New upstream release
  131. * Mon Mar 11 2013 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.3.1-1
  132. - New upstream release
  133. - Dropped s390 patch, it's in upstream now.
  134. * Fri Jan 25 2013 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.3.0-1
  135. - New upstream release
  136. * Mon Nov 19 2012 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.2.0-1
  137. - New upstream release
  138. * Tue Oct 23 2012 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.1.0-1
  139. - New upstream release
  140. - Removed ptmalloc_lock_all patch, it is merged upstream
  141. * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.0-3
  142. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  143. * Thu May 24 2012 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.0.0-2
  144. - Added a patch from upstream, fixing a crash in ptmalloc_lock_all,
  145. closing #824646
  146. * Mon May 14 2012 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.0.0-1
  147. - New upstream release
  148. - Updated no_pprof patch to match new release
  149. - Updated s390 patch to match new relase
  150. - Added make check
  151. - Added new script jemalloc.sh
  152. - Added a patch for atomic operations on epel5/ppc
  153. * Sat Apr 21 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 2.2.5-5
  154. - Improve ARM patch
  155. * Fri Apr 20 2012 Dennis Gilmore <dennis@ausil.us> - 2.2.5-4
  156. - no attomics on armv5tel
  157. * Wed Feb 08 2012 Dan Horák <dan[at]danny.cz> - 2.2.5-3
  158. - substitute version information in the header (#788517)
  159. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.5-2
  160. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  161. * Sun Nov 06 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.5-1
  162. - New upstream release, closes #75618
  163. * Sun Nov 06 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.4-1
  164. - New upstream release
  165. * Thu Oct 13 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.3-1
  166. - New upstream release, closes #735057
  167. * Mon Aug 01 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.2-1
  168. - New upstream release, closes #727103
  169. - Updated no_pprof patch for 2.2.2
  170. * Thu Mar 31 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.1-1
  171. - New upstream release
  172. * Sun Mar 27 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.0-1
  173. - New upstream release
  174. - Updated no_pprof patch for 2.2.0
  175. * Tue Mar 15 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.1.3-2
  176. - New upstream release
  177. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.1-2
  178. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  179. * Tue Feb 01 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.1.1-1
  180. - New upstream release
  181. * Wed Jan 05 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.1.0-1
  182. - New upstream release
  183. - Updated patch to remove pprof
  184. - Added html doc and xsltproc as a requirement to build it
  185. * Sat Dec 11 2010 Dan Horák <dan[at]danny.cz> - 2.0.1-3
  186. - fix build on s390
  187. * Thu Nov 18 2010 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.0.1-2
  188. - Added a patch that removes pprof, as it already exists in the
  189. google-perftools package
  190. - Cosmetic fixes as requested in the package review (rhbz#653682)
  191. * Mon Nov 15 2010 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.0.1-1
  192. - First cut of an rpm distribution of jemalloc