rhythmbox-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634
  1. # -*- coding: utf-8-unix -*-
  2. %define desktop_file_utils_version 0.9
  3. %define enable_DLNA_UPnP 0
  4. Summary: Music Management Application
  5. Summary(ja): 音楽管理アプリケーション
  6. Name: rhythmbox
  7. Version: 2.97
  8. Release: 1%{?_dist_release}
  9. License: GPL2+ with exceptions and GFDL
  10. Group: Applications/Multimedia
  11. URL: http://projects.gnome.org/rhythmbox/
  12. Source0: http://download.gnome.org/sources/rhythmbox/2.96/%{name}-%{version}.tar.xz
  13. Source101: rhythmbox-png.tar.bz2
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: gtk3-devel
  16. BuildRequires: avahi-glib-devel >= 0.6
  17. BuildRequires: brasero-devel >= 2.32.0
  18. BuildRequires: dbus-glib-devel
  19. BuildRequires: gstreamer-plugins-base-devel >= 0.10
  20. BuildRequires: json-glib-devel
  21. BuildRequires: libSM-devel
  22. BuildRequires: libgnome-keyring-devel >= 2.30.0
  23. BuildRequires: libgpod-devel
  24. BuildRequires: libgudev1-devel
  25. BuildRequires: libmusicbrainz3-devel >= 3.0.2
  26. BuildRequires: libnotify-devel
  27. BuildRequires: libsoup-devel
  28. BuildRequires: pygobject3-devel
  29. BuildRequires: totem-pl-parser-devel
  30. BuildRequires: WebKit3-gtk-devel
  31. BuildRequires: libpeas-devel
  32. BuildRequires: clutter-gtk-devel
  33. BuildRequires: clutter-gst-devel
  34. BuildRequires: libmx-devel
  35. BuildRequires: check-devel
  36. BuildRequires: libmtp-devel
  37. BuildRequires: libtdb-devel
  38. BuildRequires: lirc
  39. BuildRequires: gnome-doc-utils >= 0.3.2
  40. Requires: libgpod
  41. Requires: libnotify
  42. Requires: lirc
  43. Requires: libmtp
  44. Requires: brasero
  45. Requires: gnome-themes
  46. Requires: libgnome-keyring
  47. %if %{enable_DLNA_UPnP}
  48. Requires: python-Coherence
  49. %endif
  50. Requires: desktop-file-utils >= %{desktop_file_utils_version}
  51. Requires: scrollkeeper
  52. # # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
  53. # # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
  54. # # respectively.
  55. # Requires: self-build-gstreamer-plugins-ffmpeg
  56. # Requires: self-build-gstreamer-plugins-ugly
  57. Vendor: Project Vine
  58. Distribution: Vine Linux
  59. %description
  60. Rhythmbox is an integrated music management application based on the powerful
  61. GStreamer media framework. It has a number of features, including an easy to
  62. use music browser, searching and sorting, comprehensive audio format support
  63. through GStreamer, Internet Radio support, playlists and more.
  64. Rhythmbox is extensible through a plugin system.
  65. %description -l ja
  66. Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
  67. 統合音楽管理アプリケーションです。
  68. 見やすいユーザインターフェースを備え、検索や整列ができ、
  69. GStreamer により数多くの音声フォーマットをサポート、
  70. インターネットラジオをサポート、プレイリスト管理などの
  71. 数多くの特徴を持ちます。
  72. %package devel
  73. Summary: Development tools for rhythmbox applications.
  74. Summary(ja): rhythmbox アプリケーションの開発用ファイル
  75. Group: Development/Libraries
  76. Requires: %{name} = %{version}-%{release}
  77. Requires: pkgconfig
  78. Requires: libxml2-devel
  79. Requires: glib2-devel
  80. Requires: gtk3-devel
  81. Requires: libsoup-devel
  82. Requires: totem-pl-parser-devel
  83. Requires: gstreamer-devel
  84. %description devel
  85. Header files and libraries for building a extension library for the rhythmbox.
  86. %description devel -l ja
  87. %prep
  88. %setup -q
  89. tar xjf %{SOURCE101}
  90. %build
  91. # work around a gstreamer bug
  92. /usr/bin/gst-inspect-0.10 --print-all >& /dev/null || :
  93. libtoolize --force --copy
  94. autoreconf
  95. %configure --with-ipod \
  96. --with-mtp \
  97. --with-mdns=avahi \
  98. --enable-lirc \
  99. --enable-python \
  100. --disable-vala \
  101. --disable-browser-plugin \
  102. --disable-static \
  103. --disable-scrollkeeper \
  104. --disable-schemas-install \
  105. --enable-browser-plugin \
  106. --without-hal
  107. %__make %{?_smp_mflags}
  108. %install
  109. %__rm -rf $RPM_BUILD_ROOT
  110. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  111. %__make install DESTDIR=$RPM_BUILD_ROOT
  112. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  113. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
  114. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
  115. %__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  116. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
  117. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
  118. %__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
  119. %__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
  120. ## Don't package DLNA/UPnP plugin
  121. %if !%{enable_DLNA_UPnP}
  122. %__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
  123. %endif
  124. %find_lang %{name}
  125. # Don't package api docs
  126. %__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
  127. # Don't package scrollkeeper catalogs
  128. %__rm -rf $RPM_BUILD_ROOT%{_localstatedir}
  129. # And don't package vala
  130. %__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
  131. %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
  132. # save space by linking identical images in translated docs
  133. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  134. for f in $helpdir/C/figures/*.png; do
  135. b="$(basename $f)"
  136. for d in $helpdir/*; do
  137. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  138. g="$d/figures/$b"
  139. if [ -f "$g" ]; then
  140. if cmp -s $f $g; then
  141. %__rm "$g"; ln -s "../../C/figures/$b" "$g"
  142. fi
  143. fi
  144. fi
  145. done
  146. done
  147. %clean
  148. %__rm -rf $RPM_BUILD_ROOT
  149. %post
  150. /sbin/ldconfig
  151. update-desktop-database -q
  152. scrollkeeper-update -q
  153. touch --no-create %{_datadir}/icons/hicolor
  154. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  155. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  156. fi
  157. %postun
  158. /sbin/ldconfig
  159. update-desktop-database -q
  160. scrollkeeper-update -q
  161. touch --no-create %{_datadir}/icons/hicolor
  162. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  163. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  164. fi
  165. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  166. %posttrans
  167. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  168. %files -f %{name}.lang
  169. %defattr(-, root, root)
  170. %doc AUTHORS COPYING ChangeLog README NEWS
  171. %{_bindir}/*
  172. %{_libdir}/girepository-1.0/*.typelib
  173. %{_libdir}/lib*.so.*
  174. %{_libdir}/mozilla/plugins/librhythmbox-itms-detection-plugin.so
  175. %{_libdir}/rhythmbox/plugins
  176. %{_datadir}/applications/rhythmbox.desktop
  177. %{_datadir}/applications/rhythmbox-device.desktop
  178. %{_datadir}/dbus-1/services/org.gnome.Rhythmbox3.service
  179. %{_datadir}/glib-2.0/schemas/org.gnome.rhythmbox.gschema.xml
  180. %{_datadir}/gnome/help/rhythmbox
  181. %{_datadir}/icons/*
  182. %{_datadir}/omf/rhythmbox
  183. %{_datadir}/rhythmbox
  184. %{_mandir}/man1/*
  185. %{_libexecdir}/rhythmbox-metadata
  186. %files devel
  187. %defattr(-, root, root)
  188. %{_includedir}/%{name}/*
  189. %{_libdir}/*.so
  190. %{_libdir}/pkgconfig/*.pc
  191. %{_datadir}/gir-1.0/*.gir
  192. %changelog
  193. * Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.97-1
  194. - new upstream release
  195. * Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.96-1
  196. - new upstream release
  197. * Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-1
  198. - new upstream release
  199. - add BuildRequires: gtk3-devel, libtdb-devel, pygobject3-devel
  200. - remove BuildRequires: gnome-vfs2-devel, gstreamer-python-devel, libffi-devel, libgnome-media-profiles-devel, libgnomeui-devel, libsexy-devel, popt-devel, python-devel, pygtk2-devel, sqlite3-devel
  201. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-4
  202. - rebuild with cogl-0.8.0
  203. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-3
  204. - rebuild with libnotify-0.7
  205. - change BuildRequires: libmusicbrainz3-devel instead of libmusicbrainz-devel
  206. - change BuildRequires: libgnome-media-profiles-devel instead of gnome-media-devel
  207. - add BuildRequires: WebKit3-gtk-devel, libpeas-devel, clutter-gtk-devel, clutter-gst-devel, libmx-devel
  208. - add Patch0 (rhythmbox-0.13.3-git20110809.patch)
  209. - add Source101 (rhythmbox-png.tar.bz2)
  210. * Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-2
  211. - add BuildRequires: json-glib-devel
  212. - remove unrecognized configure option (--with-dbus, --with-cd-burning, --with-metadata-helper)
  213. * Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-1
  214. - new upstream release
  215. - change BuildRequires: gstreamer-python-devel instead of gstreamer-python
  216. * Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.2-1
  217. - new upstream release
  218. * Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-3
  219. - rebuild with brasero-2.32.0
  220. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
  221. - rebuild with rpm-4.8.1 for pkg-config file
  222. * Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
  223. - new upstream release
  224. - fix %files (add rhythmbox-device.desktop)
  225. * Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
  226. - new upstream release
  227. - change BuildRequires: gnome-media-devel instead of gnome-media
  228. - add devel package
  229. - drop Patch0
  230. * Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
  231. - new upstream release
  232. - drop Patch1, Patch2, Patch3
  233. - change BuildRequires: nautilus-cd-burner -> brasero-devel
  234. - change Requires: nautilus-cd-burner -> brasero
  235. - change BuildRequires: hal-devel -> libgudev1-devel
  236. - change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
  237. - change Requires: gnome-keyring -> libgnome-keyring
  238. - add configure option (--without-hal)
  239. * Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
  240. - rebuilt with new environment
  241. * Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
  242. - new upstream release
  243. - dropped upstreamed/obsolete patches
  244. - added patches applied Fedora development
  245. * Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
  246. - new upstream release
  247. - added configure options:
  248. --disable-vala
  249. --disable-browser-plugin
  250. * Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
  251. - added Japanese description
  252. * Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
  253. - new upstream release
  254. - dropped rb-disable-power-plugin-by-default.patch
  255. - added BuildRequires:
  256. - libSM-devel
  257. - gnome-media
  258. * Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
  259. - rebuild with libgpod-0.7.2
  260. * Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
  261. - new upstream release
  262. - corrected License tag
  263. - dropped rhythmbox-0.11.6-libmtp.patch
  264. - added BuildRequires:
  265. - sqlite3-devel
  266. - libffi-devel
  267. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
  268. - defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
  269. - applied rhythmbox-0.11.6-libmtp.patch
  270. - added Requires:
  271. - libgpod
  272. - libnotify
  273. - libsexy
  274. - lirc
  275. - libmtp
  276. - libgnomeui
  277. - nautilus-cd-burner
  278. - gstreamer-python
  279. - gnome-vfs2
  280. - gnome-themes
  281. - gnome-keyring
  282. - python-Coherence, if enable_DLNA_UPnP = 1
  283. - added BuildRequires:
  284. - libnotify-devel
  285. - libsexy-devel
  286. - lirc
  287. - libmtp-devel
  288. - gnome-vfs2-devel, instead of gnome-vfs2
  289. - gnome-keyring-devel
  290. - dropped --with-internal-libsexy in configure options
  291. - added in configure options:
  292. --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
  293. - added %%preun to remove the schema
  294. * Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
  295. - new upstream release
  296. - changed to --with-metadata-helper in configure options
  297. - added BuildRequires:
  298. - gstreamer-python
  299. - intltool >= 0.35.0
  300. - popt-devel
  301. * Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
  302. - added BuildRequires: totem-pl-parser-devel, instead of totem-devel
  303. - rebuilt with python-2.5.2
  304. - applied new versioning policy
  305. - spec in utf-8
  306. * Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
  307. - rebuilt with libgpod-0.6.0
  308. * Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
  309. - new upstream release
  310. * Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
  311. - new upstream release
  312. * Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
  313. - rebuilt with new toolchain and libgpod-0.4.2
  314. - add BuildRequires: dbus-glib-devel
  315. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
  316. - new upstream release
  317. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
  318. - rebuilt for VineSeed
  319. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
  320. - new upstream release
  321. - added --enable-python option to %%configure
  322. - added Requires: gnome-python
  323. * Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
  324. - new upstream release
  325. - built with libsoup 2.2.99
  326. * Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
  327. - added --with-cd-burner to configure
  328. - added BuildRequires: libsexy-devel hal-devel libsoup-devel
  329. * Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
  330. - add BuildRequires:
  331. - gnome-doc-utils >= 0.3.2
  332. - python-devel
  333. - pygtk2-devel
  334. - check >= 0.8.2
  335. * Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
  336. - rebuild with gnutls-1.4.1
  337. * Sun Oct 1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
  338. - new upstream release
  339. * Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
  340. - new upstream release
  341. - run scrollkeeper-update at %post and %postun
  342. - added BuildRequires: libnotify-devel
  343. * Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
  344. - new upstream release (dropped patch0)
  345. - added --without-metadata-helper at configure
  346. * Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
  347. - Initial build for Vine Linux based on FC pacakge
  348. * Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
  349. - add patch from James "Doc" Livingston to stop a hang
  350. for new users (bug 183883)
  351. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
  352. - bump again for double-long bug on ppc(64)
  353. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
  354. - rebuilt for new gcc4.1 snapshot and glibc changes
  355. * Sat Feb 4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
  356. - Update to 0.9.3.1
  357. - Use gstreamer (0.10)
  358. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
  359. - Remove hack for 173869, as its no longer needed.
  360. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
  361. - 0.9.3
  362. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
  363. - Newer CVS snapshot
  364. * Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
  365. - Update to latest CVS
  366. - Add hack to workaround bug #173869
  367. * Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
  368. - Rebuild, now that gstreamer08-plugins has been fixed
  369. * Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
  370. - bonobo multilib issue (bug 156982)
  371. * Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
  372. - rebuild with ipod support
  373. * Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
  374. - rebuilt again
  375. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  376. - rebuilt
  377. * Mon Dec 5 2005 Matthias Clasen <mclasen@redhat.com>
  378. - rebuild
  379. * Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
  380. - rebuild for new dbus
  381. * Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
  382. - Update to 0.9.2
  383. * Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
  384. - Update to 0.9.1
  385. * Fri Sep 02 2005 Colin Walters <walters@redhat.com>
  386. - Add configure flags --with-bonobo --with-dbus
  387. - BR nautilus-cd-burner-devel
  388. - New upstream CVS snapshot for testing
  389. - Drop IDL file and ui .xml
  390. - Add dbus service file
  391. - Drop upstreamed rhythmbox-bluecurve.tar.gz
  392. - Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
  393. * Fri Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
  394. - Add Bluecurve-ized icons from Jeff Schroeder (157716)
  395. - Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
  396. cell renderer for playback icon (no longer necessary) and
  397. changes the rating renderer to work with non-b&w icons
  398. * Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
  399. - Rebuild for GCC4
  400. * Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
  401. - New upstream version
  402. - Remove librb-nautilus-context-menu.so, killed upstream
  403. * Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
  404. - PreReq desktop-file-utils >= 0.9
  405. * Sat Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
  406. - New upstream version
  407. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
  408. - Fix postun to use correct syntax, thanks Nils Philippsen
  409. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
  410. - New upstream version
  411. - Call update-desktop-database in post and postun
  412. * Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
  413. - New upstream version
  414. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  415. - rebuilt
  416. * Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
  417. - New upstream version
  418. - Remove backported patches
  419. - Gratuitiously bump various BuildRequires versions
  420. * Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
  421. - Remove code to unregister GConf schema for now (Closes: #122532)
  422. * Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
  423. - Apply tiny patch from 0.8 arch to fix GConf key used
  424. for initial sorting
  425. * Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
  426. - Apply patch from 0.8 arch tree to fix a number of memleaks
  427. * Thu May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
  428. - Update to 0.8.3: fixes showstopper bug with internet radio
  429. * Thu Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
  430. - Update to 0.8.2
  431. - Fix Source url
  432. - Add smp_mflags
  433. - Bump BuildRequires on gstreamer to 0.8.1
  434. * Tue Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
  435. - Uninstall GConf schemas on removal
  436. * Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
  437. - Update to 0.8.1
  438. * Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
  439. - Update to 0.8.0
  440. * Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
  441. - Update to 0.7.2
  442. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
  443. - Remove BuildRequires on autoconf and libvorbis-devel
  444. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
  445. - New major version - I know we are past major version slush, but
  446. this should have been done two weeks ago along with the GNOME 2.6
  447. upload. As upstream author as well, I believe this version is
  448. good enough for FC2.
  449. - Remove --disable-mp3
  450. - Remove id3, flac variables
  451. - Remove GStreamer major version patch
  452. - Fix typo in description
  453. * Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
  454. - rebuild for new gstreamer
  455. * Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
  456. - update to 0.6.8
  457. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  458. - rebuilt
  459. * Mon Mar 1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
  460. - update to 0.6.7
  461. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  462. - rebuilt
  463. * Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
  464. - New upstream version
  465. - Don't re-run the autotools; upstream incorporates newer versions.
  466. * Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
  467. - new version
  468. - remove smp_flags
  469. * Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
  470. - remove the initial iradio channels as they all are mp3 based.
  471. * Wed Oct 8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
  472. - Fix category from Development/Libraries to Applications/Multimedia.
  473. - Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
  474. - Fix SCHEMES vs. SCHEMAS in the post scriplet.
  475. - Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
  476. - Removed unnecessary date expansion define.
  477. - Updated description, including mp3 reference removal.
  478. - Added libid3tag and flac optional support for convenient rebuild.
  479. - Removed obsolete omf.make and xmldocs.make (included ones are the same now).
  480. * Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
  481. - new version
  482. - use %{_sysconfdir} instead of /etc
  483. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  484. - rebuilt
  485. * Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
  486. - gave up on other archs for the Beta
  487. - new version
  488. - remove werror and add missing files
  489. * Thu Nov 7 2002 Jeremy Katz <katzj@redhat.com>
  490. - update to newer cvs snap
  491. * Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
  492. - update to cvs snap
  493. * Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
  494. - use %%(lang)
  495. * Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
  496. - fix post to actually install the schema
  497. * Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  498. - Added gconf file
  499. - Added i18n directory
  500. * Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  501. - Updated for new rewrite of rhythmbox, thanks to Jeroen
  502. * Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
  503. - removed bonobo dependency
  504. * Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
  505. - created new spec file