flim-vl.spec 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %define emacsen_pkgdir /usr/lib/emacsen-common/packages
  4. %define origver 1.14.9
  5. %define origname flim
  6. Summary: Library to provide basic features about message for Emacsen
  7. Summary(ja): Emacsen 用の message に関する表現形式や符号化のためのライブラリです。
  8. Name: %{origname}
  9. Version: %{origver}
  10. Release: 2%{?_dist_release}
  11. Source0: http://www.kanji.zinbun.kyoto-u.ac.jp/~tomo/comp/emacsen/lisp/flim/flim-1.14/flim-%{origver}.tar.gz
  12. Source1: %{origname}-install.sh
  13. Source2: %{origname}-remove.sh
  14. Source3: %{origname}-init.el
  15. Patch0: FLIM-CFG.emacs.patch
  16. License: 1993-1999 Free Software Foundation, Inc., Dan Rich, Morioka Tomohiko, Kobayashi Shuhei
  17. Group: Applications/Editors/Emacs
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildArch: noarch
  20. PreReq: emacsen
  21. %prereq_ge emacsen-common
  22. %prereq_ge apel
  23. Obsoletes: flim-el
  24. Conflicts: semi <= 1.14.5-0vl2
  25. Vendor: Project Vine
  26. Distribution: Vine Linux
  27. Packager: shaolin
  28. %description
  29. FLIM is a library to provide basic features about message
  30. representation or encoding.
  31. Note: in order to rebuild this SRPM package, you need
  32. emacsen, emacsen-common and apel installed.
  33. %description -l ja
  34. FLIM は Internet message に関する様々な表現形式や符号化に関する
  35. 基礎的な機能を提供するための汎用部品です.
  36. 注意:この SRPM パッケージを rebuild するには、emacsen と emacsen-common
  37. 及び apel がインストールされている必要があります.
  38. %prep
  39. rm -rf ${RPM_BUILD_DIR}/%{origname}-%{origver}
  40. %setup -n %{origname}-%{origver}
  41. %patch0 -p1
  42. %install
  43. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  44. [ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
  45. mkdir -p $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/%{origname}
  46. mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/install
  47. mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/remove
  48. #
  49. # remove unnecessary file
  50. #
  51. ## upstream is dropped in FLIM-ELS: see ChangeLog file 2002-11-15
  52. %{__rm} -f mailcap.el
  53. #
  54. # install el files
  55. #
  56. cp Makefile FLIM-* *.el %{SOURCE3} \
  57. ${RPM_BUILD_ROOT}/usr/share/emacs/site-lisp/%{origname}
  58. #
  59. # install script( bytecompile el and install elc , remove )
  60. #
  61. %_installemacsenscript %{origname} %{SOURCE1}
  62. %_removeemacsenscript %{origname} %{SOURCE2}
  63. #
  64. # install info file
  65. #
  66. mkdir -p ${RPM_BUILD_ROOT}/usr/info
  67. %post
  68. #
  69. # bytecompile and install
  70. #
  71. if [ "$1" = 2 ]; then
  72. %_emacsenPackageRemove %{origname}
  73. fi
  74. %_addemacsenlist %{origname}
  75. %_emacsenPackageInstall %{origname}
  76. %preun
  77. if [ "$1" = 0 ]; then
  78. %_emacsenPackageRemove %{origname}
  79. %_removeemacsenlist %{origname}
  80. fi
  81. %triggerpostun -- flim-el
  82. %_emacsenPackageInstall %{origname}
  83. %clean
  84. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  85. rm -rf ${RPM_BUILD_DIR}/apel-%{apelver}
  86. %files
  87. %defattr(-,root,root)
  88. %doc ChangeLog NEWS README* VERSION
  89. /usr/share/emacs/site-lisp/%{origname}/
  90. %{emacsen_pkgdir}/install/%{origname}
  91. %{emacsen_pkgdir}/remove/%{origname}
  92. %changelog
  93. * Thu Mar 4 2010 IWAI, Masaharu <iwai@alib.jp> 1.14.9-2
  94. - remove mailcap.el: <BTS:VineLinux:935>
  95. - update Packager's syntax
  96. - update description-{en,ja}
  97. * Tue Sep 09 2008 Shu KONNO <owa@bg.wakwak.com> 1.14.9-1vl5
  98. - applied new versioning policy, spec in utf-8
  99. - added %%emacsen_pkgdir macro
  100. * Fri Dec 7 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.9-0vl1
  101. - updated to 1.14.9
  102. * Wed Jan 10 2007 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.14.8-0vl1
  103. - updated in sync with 1.14.8 release
  104. * Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.14.7-0vl2
  105. - changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  106. - s/Copyright/License/
  107. * Mon Dec 13 2004 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.14.7-0vl1
  108. - updated in sync with 1.14.7 release
  109. * Wed Dec 24 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.6-0vl1
  110. - updated in sync with 1.14.6 release
  111. * Mon Jun 09 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.5-0vl2
  112. - increased release number for the new apel release
  113. * Wed May 21 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.14.5-0vl1
  114. - updated in sync with 1.14.5 release
  115. * Mon Jun 03 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.4-0vl1
  116. - updated in sync with 1.14.4 release
  117. * Fri Jan 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.3-0vl9
  118. - Obsoletes: flim-el now, instead of Conflicts:
  119. - added %%triggerpostun -- flim-el
  120. * Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.3-0vl8
  121. - package name changed flim-el -> flim again
  122. - added Source3 for forthcoming site-start mechanism
  123. * Sun Dec 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.3-0vl7
  124. - modified Source1 to remove mel-b-ccl.el* if the flavor is xemacs-21.1.x
  125. (see http://lists.airs.net/wl/archive/200101/msg00077.html)
  126. * Fri Nov 9 2001 Kazuhisa TAKEI <takei@vinelinux.org>
  127. - change Patch0( fixed load-path)
  128. * Mon Jul 23 2001 Kazuhisa TAKEI <takei@vinelinux.org>
  129. - requires: emacsen-common -> prereq
  130. * Wed Jul 18 2001 Kazuhisa TAKEI <takei@vinelinux.org>
  131. - emacsenize
  132. * Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  133. - 1.14.3-0vl2
  134. - back to Requires: emacs = 20.7 -> emacs >= 20.7 (for emacs-beta)
  135. * Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  136. - 1.14.3-0vl1
  137. - updated to apel-10.3, flim-1.14.3, semi-1.14.3, emh-1.14.1
  138. * Fri Aug 25 2000 MATSUBAYASHI 'Shaolin' Kohji
  139. - 1.13.7-8
  140. - added %define _noVersionedDependencies 1
  141. * Fri Aug 25 2000 MATSUBAYASHI 'Shaolin' Kohji
  142. - 1.13.7-7
  143. - modified %files section to handle compressed man page(s)
  144. * Wed May 10 2000 MATSUBAYASHI 'Shaolin' Kohji
  145. - 1.13.7-6
  146. - apel updated to 10.2
  147. * Mon Jan 24 2000 MATSUBAYASHI 'Shaolin' Kohji
  148. - 1.13.7-5
  149. - added patch (see emacs-mime-ja: 00303) to format texinfo correctly
  150. * Thu Dec 24 1999 MATSUBAYASHI 'Shaolin' Kohji
  151. - 1.13.7-4
  152. - updated in sync with apel-10.0 / clime-1.13.6 release
  153. * Wed Dec 1 1999 MATSUBAYASHI 'Shaolin' Kohji
  154. - 1.13.7-3
  155. - change Group to Applications/Editors/EmacsLisp
  156. * Mon Nov 29 1999 MATSUBAYASHI 'Shaolin' Kohji
  157. - 1.13.7-2
  158. - added patches (see emacs-mime-ja:00183, emacs-mime-ja:00184)
  159. - now emh-1.10.1 and rmail-mime-1.13.0 are also included
  160. - documentation files are properly stored under /usr/doc directory
  161. * Wed Nov 3 1999 MATSUBAYASHI 'Shaolin' Kohji
  162. - 1.13.7-1
  163. - updated to apel-9.23 / clime-1.13.5 / semi-1.13.7 release
  164. - added Japanese / English info files to be installed