pcsc-perl-vl.spec 5.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160
  1. %define pcscver 1.3.0
  2. %define pcsclib libpcsclite.so.1
  3. %ifarch x86_64 ppc64 ia64 sparc64 s390x
  4. %define mark64 ()(64bit)
  5. %endif
  6. Name: pcsc-perl
  7. Version: 1.4.8
  8. Release: 1%{?_dist_release}
  9. Summary: Perl interface to the PC/SC smart card library
  10. Summary(ja): Perl interface to the PC/SC smart card library
  11. Group: Development/Libraries
  12. License: GPLv2+
  13. URL: http://ludovic.rousseau.free.fr/softwares/pcsc-perl/
  14. Source0: http://ludovic.rousseau.free.fr/softwares/pcsc-perl/%{name}-%{version}.tar.gz
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  16. BuildRequires: perl(ExtUtils::MakeMaker)
  17. BuildRequires: pcsc-lite-devel >= %{pcscver}
  18. Requires: %{pcsclib}%{?mark64}
  19. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  20. Provides: perl-pcsc = %{version}-%{release}
  21. %description
  22. This package contains a Perl interface to the PC/SC smart card
  23. library.
  24. %prep
  25. %setup -q
  26. chmod 644 examples/* # avoid dependencies
  27. f=Changelog ; iconv -f iso-8859-1 -t utf-8 $f > $f.utf8 ; mv $f.utf8 $f
  28. %build
  29. %{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS" DEFINE=-Wall
  30. make %{?_smp_mflags}
  31. %install
  32. rm -rf $RPM_BUILD_ROOT
  33. make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  34. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  35. find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
  36. find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null ';'
  37. chmod -R u+w $RPM_BUILD_ROOT/*
  38. %check
  39. # tests need configured readers etc
  40. if ! grep -qF 'dlopen("%{pcsclib}"' PCSCperl.h ; then # sanity check
  41. echo "ERROR: pcsc lib name mismatch in PCSCperl.h/dependencies" ; exit 1
  42. fi
  43. %clean
  44. rm -rf $RPM_BUILD_ROOT
  45. %files
  46. %defattr(-,root,root,-)
  47. %doc Changelog LICENCE README examples/
  48. %{perl_vendorarch}/auto/Chipcard/
  49. %{perl_vendorarch}/Chipcard/
  50. %{_mandir}/man3/Chipcard::PCSC*.3*
  51. %changelog
  52. * Sun Feb 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.8-1
  53. - update to 1.4.8
  54. * Mon Mar 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.7-1
  55. - initial build for Vine Linux
  56. * Thu Mar 27 2008 Ville Skyttä <ville.skytta at iki.fi> - 1.4.7-1
  57. - 1.4.7.
  58. * Thu Mar 06 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.4.6-4
  59. - Rebuild for new perl
  60. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.6-3
  61. - Autorebuild for GCC 4.3
  62. * Tue Aug 7 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.4.6-2
  63. - Apply #defines patch only when building with pcsc-lite < 1.4.0.
  64. - License: GPLv2+
  65. * Tue Apr 17 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.4.6-1
  66. - 1.4.6 + PCSCperl.h #defines fixes.
  67. - BuildRequire perl(ExtUtils::MakeMaker).
  68. * Sun Dec 24 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.4.4-3
  69. - Eliminate file based dependencies.
  70. * Thu Nov 2 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.4.4-2
  71. - Rebuild with pcsc-lite 1.3.2 for extended APDU support.
  72. * Tue Aug 15 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.4.4-1
  73. - 1.4.4.
  74. * Wed May 17 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.4.3-1
  75. - 1.4.3.
  76. * Mon Mar 6 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.4.1-1
  77. - 1.4.1.
  78. - Don't hardcode required pcsc-lite-libs version, use shared lib file instead.
  79. - Convert docs to UTF-8.
  80. * Wed Feb 15 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.3.1-8
  81. - Rebuild, cosmetics.
  82. * Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 1.3.1-7
  83. - rebuild on all arches
  84. * Thu May 19 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.3.1-6
  85. - Provide perl-pcsc, fixate required pcsc-lite version to 1.2.0.
  86. * Fri Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 1.3.1-5
  87. - rebuilt
  88. * Fri Jan 7 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.3.1-4
  89. - Honor $RPM_OPT_FLAGS, remove (some) extra include dirs from build (#1281).
  90. - Improve summary and description.
  91. * Wed May 12 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.3.1-0.fdr.3
  92. - BuildRequire perl >= 1:5.6.1 for vendor install dir support.
  93. - Use pure_install to avoid perllocal.pod workarounds.
  94. * Sun Apr 25 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.3.1-0.fdr.2
  95. - Require perl(:MODULE_COMPAT_*).
  96. * Fri Apr 2 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.3.1-0.fdr.1
  97. - Update to 1.3.1.
  98. * Sun Feb 8 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.3.0-0.fdr.2
  99. - Reduce directory ownership bloat.
  100. * Wed Dec 17 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.3.0-0.fdr.1
  101. - Update to 1.3.0.
  102. * Sun Sep 14 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.2-0.fdr.4
  103. - More spec cleanups.
  104. * Wed Aug 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.2-0.fdr.3
  105. - Spec cleanups, install into vendor dirs.
  106. * Fri Jul 4 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.2-0.fdr.2
  107. - Fix dir ownerships, non-root strip during build.
  108. * Thu May 29 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.2-0.fdr.1
  109. - Update to 1.2.2.
  110. - Drop patch and hacks, already applied/fixed upstream.
  111. * Sun May 25 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.1-0.fdr.1
  112. - Update to 1.2.1.
  113. - Fix build and runtime dependencies.
  114. * Thu May 22 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.1
  115. - First build.