rhpl-vl.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. Summary: Library of python code used by programs in Vine Linux
  3. Summary(ja): Vine Linux で利用する python コードライブラリ
  4. Name: rhpl
  5. Version: 0.216
  6. Release: 6%{?_dist_release}
  7. Source0: %{name}-%{version}.tar.bz2
  8. Patch0: %{name}-0.216-compat.patch
  9. Patch1: %{name}-0.216-pmac.patch
  10. License: GPL
  11. Group: System Environment/Libraries
  12. BuildRoot: %{_tmppath}/%{name}-root
  13. BuildRequires: python-devel, gettext
  14. BuildRequires: wireless-tools-devel
  15. Requires: python >= %(%{__python} -c "import sys; print sys.version[:3]")
  16. Requires: pyxf86config >= 0.3.2
  17. %description
  18. The rhpl package contains Python code used by programs in Vine Linux.
  19. %prep
  20. %setup -q
  21. %patch0 -p1 -b .compat
  22. %patch1 -p1 -b .pmac
  23. # this line is no more need?
  24. perl -pi -e 's/python2.3/python2.4/g' Makefile.inc src/*
  25. perl -pi -e 's/xgettext /xgettext --from-code=UTF-8 /g' po/Makefile
  26. %build
  27. %__make
  28. %install
  29. rm -rf $RPM_BUILD_ROOT
  30. make DESTDIR=${RPM_BUILD_ROOT} install
  31. %find_lang %name
  32. %clean
  33. rm -rf $RPM_BUILD_ROOT
  34. %files -f %{name}.lang
  35. %defattr(-,root,root)
  36. %doc README COPYING
  37. %{python_sitearch}/rhpl
  38. %changelog
  39. * Wed Mar 31 2010 Shu KONNO <owa@bg.wakwak.com> 0.216-6
  40. - updated release number
  41. - import Vine5.1 changes
  42. * Wed Jan 27 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.216-5
  43. - add BuildRequires: wireless-tools-devel
  44. * Wed Sep 9 2009 MATSUBAYSHI Kohji <shaolin@vinelinux.org> 0.216-4
  45. - add Patch1: implement getPPCMachineName()
  46. * Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.216-4
  47. - rebuild with python-2.6
  48. * Wed Mar 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.216-3
  49. - disable deprecate warning in log.py
  50. * Tue Feb 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.216-2
  51. - add comps.py from rhpl-0.146.3
  52. * Mon Aug 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.216-1
  53. - new upstream release
  54. * Tue May 22 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl17
  55. - add "--from-code" option to xgettext
  56. * Thu Nov 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl16
  57. - update vine patch
  58. - add some fontpath (<BTS:371>)
  59. - add nv panel size detection code.
  60. * Wed Nov 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl15
  61. - update vine patch
  62. - remove unsupported (larger) display from Modes list.
  63. * Tue Oct 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl14
  64. - update vine patch
  65. - set desired_resolution from LCD panel resolution.
  66. * Wed Oct 25 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl13
  67. - apply new compare_resolution algorism for all arch. (<BTS:301>)
  68. * Sun Oct 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl12
  69. - update vine patch
  70. - fix radeon panel size detection code.
  71. * Wed Sep 20 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.148.3-0vl11
  72. - don't apply Patch60 on ppc
  73. * Wed Sep 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl10
  74. - add more extra modelines
  75. * Wed Sep 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl9
  76. - add extra modeline to extramodes
  77. * Thu Sep 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl8
  78. - add Patch50 to guess unprobed mouse as generic mouse.
  79. * Fri Sep 08 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.148.3-0vl7
  80. - add Patch40 for ppc
  81. * Sat Sep 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl6
  82. - add Patch30 to modifiy keyboard_models
  83. * Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl5
  84. - update vine patch
  85. - detect i810 panel size
  86. * Tue Aug 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl4
  87. - update vine patch
  88. - add more display resolutions
  89. * Thu Aug 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl3
  90. - replace obsolete gtk.{TRUE,FALSE} with {True,False}
  91. * Tue Aug 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl2
  92. - fix default X settings
  93. - add VMWare monitor hacks
  94. * Wed Aug 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl1
  95. - initial build for Vine Linux
  96. * Fri Jul 8 2005 Jeremy Katz <katzj@redhat.com> - 0.148.3-1
  97. - fix indic keyboards (#158139)
  98. * Wed Nov 17 2004 Jeremy Katz <katzj@redhat.com> - 0.148.2-1
  99. - add patch from Jim Parsons to add executil.execWithCaptureErrorStatus as
  100. needed by system-config-lvm
  101. * Tue Nov 16 2004 Paul Nasrat <pnasrat@redhat.com> - 0.148.1-1
  102. - RHEL4 remove synaptics
  103. * Wed Oct 13 2004 Paul Nasrat <pnasrat@redhat.com> - 0.148-1
  104. - Indic keyboard fixups
  105. - Multi-input synaptics
  106. - require synaptics
  107. - Less verbose ddcprobe
  108. * Thu Sep 30 2004 Harald Hoyer <harald@redhat.com> - 0.147-1
  109. - let Conf.ConfModules use modprobe.conf name and format (bug 131952)
  110. - use network script resolv.conf merger/changer (bug 132485)
  111. * Fri Sep 24 2004 Jeremy Katz <katzj@redhat.com>
  112. - require python (#133462)
  113. * Wed Sep 22 2004 Jeremy Katz <katzj@redhat.com> - 0.146-1
  114. - add synaptics support (pnasrat)
  115. - add arabic and indic keyboards (pnasrat)
  116. * Fri Jun 18 2004 Jeremy Katz <katzj@redhat.com> - 0.145-1
  117. - improved lib64 detection, rebuild with gcc 3.4
  118. * Wed May 5 2004 Jeremy Katz <katzj@redhat.com> - 0.144-1
  119. - open cd device with O_NONBLOCK so eject ioctl works (#122524)
  120. * Tue Apr 20 2004 Brent Fox <bfox@redhat.com> 0.143-1
  121. - Do not write out XkbRules line to config file, as it is unnecessary to hard
  122. code the rules file, which has a built in default which should always
  123. work. (#120858)
  124. * Fri Apr 16 2004 Jeremy Katz <katzj@redhat.com> - 0.142-1
  125. - more XFree86->xorg
  126. * Thu Apr 15 2004 Jeremy Katz <katzj@redhat.com> - 0.141-1
  127. - xserver.py: workaround libxf86config not writing out the monitor stuff
  128. we tell it to (#120950)
  129. * Wed Apr 14 2004 Jeremy Katz <katzj@redhat.com> - 0.140-1
  130. - translate.py: one more try at string encoding madness (#119391)
  131. * Tue Apr 13 2004 Jeremy Katz <katzj@redhat.com> - 0.139-1
  132. - videocard.py: fixups for VESA handling on x86_64
  133. - videocard.py, xserver.py: XFree86 -> Xorg changes
  134. * Wed Mar 17 2004 Bill Nottingham <notting@redhat.com> 0.138-1
  135. - mouse.py cleanups
  136. * Tue Mar 16 2004 Bill Nottingham <notting@redhat.com> 0.135-1
  137. - remove old default keymap when writing config (#116852)
  138. * Tue Mar 9 2004 Brent Fox <bfox@redhat.com> 0.134-1
  139. - user fr-latin9 for the X keymap too (bug #113672)
  140. * Tue Mar 9 2004 Jeremy Katz <katzj@redhat.com> - 0.133-1
  141. - use vesa for unknown cards on x86_64
  142. * Fri Mar 5 2004 Brent Fox <bfox@redhat.com> 0.132-1
  143. - use fr-latin9 instead of fr-latin0 (bug #113672)
  144. * Thu Mar 4 2004 Jeremy Katz <katzj@redhat.com> - 0.131-1
  145. - switch some default keyboard layouts (#117007)
  146. * Thu Mar 4 2004 Brent Fox <bfox@redhat.com> 0.130-1
  147. - strip out refresh rate data (bug #117327)
  148. * Wed Mar 3 2004 Brent Fox <bfox@redhat.com> 0.129-1
  149. - enable DRI extentions for all i386, x86_64, and ia64 systems (bug #115672)
  150. - vmware doesn't do 24bpp (#117375)
  151. - fix for savage + lcds (#117079)
  152. * Thu Feb 26 2004 Brent Fox <bfox@redhat.com> 0.128-1
  153. - add some hooks to xhwstate.py to get PCI bus ID info
  154. * Fri Feb 20 2004 Brent Fox <bfox@redhat.com> 0.127-2
  155. - correct a typo
  156. * Fri Feb 20 2004 Brent Fox <bfox@redhat.com> 0.127-1
  157. - changes to mouse handling in xhwstate.py
  158. * Wed Feb 18 2004 Jeremy Katz <katzj@redhat.com> 0.126-1
  159. - minor tweak for mouse stuff
  160. * Fri Feb 13 2004 Brent Fox <bfox@redhat.com> 0.125.1-1
  161. - use hu_qwerty for Hungarian (101 key) (bug #114629)
  162. * Thu Jan 22 2004 Jeremy Katz <katzj@redhat.com> 0.124.1-1
  163. - translate.py: minor tweaks
  164. * Tue Jan 20 2004 Jeremy Katz <katzj@redhat.com> 0.124-1
  165. - translate.py: return UTF-8 encoded strings (#113202)
  166. * Thu Jan 8 2004 Brent Fox <bfox@redhat.com> 0.123.1-1
  167. - add an entry for Korean keyboards (bug #112024)
  168. * Tue Jan 6 2004 Jeremy Katz <katzj@redhat.com>
  169. - mark keyboard model names as keyboard|name to make them differ
  170. from language names (#84969)
  171. * Tue Dec 16 2003 Jeremy Katz <katzj@redhat.com>
  172. - use EISA if name doesn't exist in ddc data (#112281)
  173. * Fri Nov 14 2003 Jeremy Katz <katzj@redhat.com> 0.122.2-1
  174. - more python2.3
  175. * Sat Nov 8 2003 Jeremy Katz <katzj@redhat.com> 0.122.1-1
  176. - more python 2.3 fixups
  177. * Thu Nov 6 2003 Jeremy Katz <katzj@redhat.com> 0.122-1
  178. - python 2.3
  179. * Tue Oct 21 2003 Jeremy Katz <katzj@redhat.com> 0.121-1
  180. - don't try to use 24bpp on old hardware (#105713)
  181. * Thu Oct 16 2003 Brent Fox <bfox@redhat.com> 0.120-1
  182. - mouse.py - add two entries for optical mice
  183. * Thu Oct 16 2003 Jeremy Katz <katzj@redhat.com> 0.119-1
  184. - keyboard_models.py: fix greek keyboard layout (#100773)
  185. * Wed Oct 15 2003 Jeremy Katz <katzj@redhat.com> 0.118-1
  186. - translate.py: assume UTF-8 if we can't figure out the encoding of a mofile
  187. * Thu Oct 8 2003 Michael Fulbright <msf@redhat.com> 0.117-1
  188. - xhwstate.py - dont write out video ram option to XF86Config
  189. * Thu Oct 2 2003 Brent Fox <bfox@redhat.com> 0.116-1
  190. - videocard.py: added pci busID functions
  191. * Tue Sep 30 2003 Jeremy Katz <katzj@redhat.com> 0.115-1
  192. - mouse.py: add new API and make sane to use for translation
  193. * Thu Sep 25 2003 Harald Hoyer <harald@redhat.de> 0.114-1
  194. - preserve comments in modules.conf #76640
  195. * Tue Sep 23 2003 Michael Fulbright <msf@redhat.com>
  196. - fix bug dealing with determining video modes supported by a monitor
  197. * Mon Sep 8 2003 Jeremy Katz <katzj@redhat.com>
  198. - use RPM_OPT_FLAGS (#103970)
  199. * Thu Sep 04 2003 Harald Hoyer <harald@redhat.de> 0.112-1
  200. - fixed ConfPAP.getfields()
  201. * Thu Sep 04 2003 Michael Fulbright <msf@redhat.com> 0.111-1
  202. - fixes for bugzilla #103353
  203. * Tue Sep 02 2003 Michael Fulbright <msf@redhat.com> 0.111-1
  204. - fixes to X setup code
  205. * Fri Aug 29 2003 Harald Hoyer <harald@redhat.de> 0.110-1
  206. - removed memory leak
  207. * Wed Jul 16 2003 Jeremy Katz <katzj@redhat.com> 0.110-1
  208. - add an interface for adding packages to groups
  209. * Mon Jul 14 2003 Jeremy Katz <katzj@redhat.com> 0.109-1
  210. - multilib on ia64
  211. * Wed Jul 09 2003 Harald Hoyer <harald@redhat.de> 0.108-3
  212. - rebuilt with all files updated from cvs
  213. * Tue Jul 8 2003 Jeremy Katz <katzj@redhat.com> 0.108-1
  214. - comps.py: preserve xml doc/nodes
  215. - translate.py: make it so we can use translations from update disks in
  216. anaconda
  217. * Thu Jun 12 2003 Brent Fox <bfox@redhat.com> 0.107-1
  218. - add a get_xconfig() method to xhwstate.py
  219. * Tue Jun 10 2003 Harald Hoyer <harald@redhat.de> 0.106-1
  220. - better regexp in Conf.py
  221. - strip filename from subject
  222. * Fri Jun 6 2003 Jeremy Katz <katzj@redhat.com> 0.105-1
  223. - more biarch fun
  224. * Wed Jun 4 2003 Jeremy Katz <katzj@redhat.com> 0.104-1
  225. - add ppc64[ip]series
  226. * Wed Jun 4 2003 Jeremy Katz <katzj@redhat.com> 0.103.1-1
  227. - arch.py tweaks
  228. * Fri May 30 2003 Jeremy Katz <katzj@redhat.com> 0.103-1
  229. - comps.py extensions for biarch
  230. * Fri May 23 2003 Jeremy Katz <katzj@redhat.com> 0.102.1-1
  231. - fix tyop
  232. * Fri May 23 2003 Jeremy Katz <katzj@redhat.com> 0.102-1
  233. - add arch.py
  234. * Wed May 21 2003 Harald Hoyer <harald@redhat.de> 0.101.1-1
  235. - strip quotes from PAP/CHAP server also
  236. - Conf.py, cope with lines at the end of the file, that have no newline
  237. - speedup some things
  238. * Wed May 07 2003 Michael Fulbright <msf@redhat.com> 0.100.1-1
  239. - fixed simpleconfig.py and how it uppercases keys
  240. * Tue Apr 29 2003 Harald Hoyer <harald@redhat.com> 0.99.1-1
  241. - genClass and ethtool updates
  242. * Thu Apr 24 2003 Brent Fox <bfox@redhat.com> 0.98.1-2
  243. - strip an invalid char from monitor name (bug #87588)
  244. * Wed Apr 23 2003 Jeremy Katz <katzj@redhat.com> 0.98.1-1
  245. - revert broken part of pseries fb change
  246. * Mon Apr 21 2003 Jeremy Katz <katzj@redhat.com> 0.98-1
  247. - handle headless case better
  248. * Fri Apr 18 2003 Jeremy Katz <katzj@redhat.com> 0.97-1
  249. - fixes so that framebuffer can work for use on ppc machines
  250. * Thu Apr 3 2003 Brent Fox <bfox@redhat.com> 0.96-2
  251. - update the list of dri drivers from mharris
  252. * Thu Apr 3 2003 Brent Fox <bfox@redhat.com> 0.96-1
  253. - add ati and i810 to dri supported list in xhwstate.py
  254. * Wed Apr 2 2003 Brent Fox <bfox@redhat.com> 0.95-1
  255. - allow dialog size to be passed into firstboot_gui_window
  256. * Thu Feb 27 2003 Bill Nottingham <notting@redhat.com> 0.94-1
  257. - make py_bind_textdomain_codeset not segfault on ia64 (#85334)
  258. * Mon Feb 24 2003 Jeremy Katz <katzj@redhat.com> 0.93-1
  259. - mouse.py (mouseWindow): try to ensure we have a locale that
  260. we can do linedrawing chars for (#84908)
  261. * Wed Feb 12 2003 Brent Fox <bfox@redhat.com> 0.92-1
  262. - add grp_led:scroll to all lines with XkbOptions (bug #82096)
  263. * Tue Feb 11 2003 Brent Fox <bfox@redhat.com> 0.91-1
  264. - convert all toggles to grp:shift_toggle (bug #79287)
  265. * Fri Feb 7 2003 Brent Fox <bfox@redhat.com> 0.90-1
  266. - add grp_led:scroll to all Russian keyboards
  267. * Fri Feb 7 2003 Brent Fox <bfox@redhat.com> 0.89-1
  268. - add translate.textdomain('rhpl') to fix bug #69760
  269. * Thu Feb 6 2003 Matt Wilson <msw@redhat.com> 0.88-1
  270. - only reset the mouse if you have to
  271. * Thu Feb 6 2003 Brent Fox <bfox@redhat.com> 0.87-1
  272. - load additional us keymap for all ru keyboards in keyboard_models.py
  273. - make sure the kbd option gets set in keyboard.py
  274. * Thu Feb 6 2003 Brent Fox <bfox@redhat.com> 0.86-1
  275. - use sv-latin1 for swedish keyboards (bug #80508)
  276. * Wed Feb 5 2003 Matt Wilson <msw@redhat.com> 0.85-1
  277. - autodetect ps/2 wheel mice (#81902)
  278. * Wed Feb 5 2003 Brent Fox <bfox@redhat.com> 0.84-1
  279. - if there are no display Modes in the XF86Config file, create one and default to 800x600 (bug #83314)
  280. * Tue Feb 04 2003 Harald Hoyer <harald@redhat.de> 0.83-1
  281. - ConfPAP fix for quotation
  282. * Fri Jan 31 2003 Jeremy Katz <katzj@redhat.com> 0.81-2
  283. - fix typo
  284. * Fri Jan 31 2003 Adrian Likins <alikins@redhat.com>
  285. - added get_ipaddr, get_netmask, get_broadcast
  286. to ethtool module
  287. * Fri Jan 31 2003 Harald Hoyer <harald@redhat.de>
  288. - added some BuildRequires
  289. * Thu Jan 30 2003 Jeremy Katz <katzj@redhat.com> 0.80-1
  290. - default non-i386 arches to 8 megs of videoram
  291. * Wed Jan 22 2003 Brent Fox <bfox@redhat.com> 0.79-1
  292. - add us keymap and XkbOptions to non-latin keymaps in keyboard_models.py
  293. - change keyboard.py to handle the XkbOptions field
  294. * Mon Jan 20 2003 Michael Fulbright <msf@redhat.com> 0.78-1
  295. - improved code for LCD guessing
  296. * Fri Jan 17 2003 Michael Fulbright <msf@redhat.com> 0.77-1
  297. - added code to xserver.py to guess LCD size using guesslcd.py
  298. * Fri Jan 17 2003 Brent Fox <bfox@redhat.com> 0.76-1
  299. - changes to firstbootGuiWindow.py for new firstboot look
  300. * Tue Jan 14 2003 Michal Fulbright <msf@redhat.com> 0.75-1
  301. - fix xserver.py to include keyboard import
  302. * Fri Jan 10 2003 Brent Fox <bfox@redhat.com> 0.74-2
  303. - change se-latin1 kbd to se-fi-lat6 according to bug #80508
  304. * Fri Jan 3 2003 Brent Fox <bfox@redhat.com> 0.74-1
  305. - default to pc105 for most keyboards
  306. * Thu Jan 2 2003 Jeremy Katz <katzj@redhat.com> 0.73-3
  307. - make the translate.py change less noisy
  308. * Thu Jan 2 2003 Jeremy Katz <katzj@redhat.com> 0.73-2
  309. - typo fix
  310. * Wed Jan 1 2003 Jeremy Katz <katzj@redhat.com> 0.73-1
  311. - discid.py: add readFromBuffer
  312. * Sun Dec 29 2002 Jeremy Katz <katzj@redhat.com>
  313. - translate.py: if we fail, at least gracefully fall back instead of
  314. causing a traceback (#76104)
  315. * Thu Dec 19 2002 Harald Hoyer <harald@redhat.de> 0.72-1
  316. - added exception.py
  317. * Tue Dec 17 2002 Jeremy Katz <katzj@redhat.com> 0.71-2
  318. - fix silly typo
  319. * Tue Dec 17 2002 Jeremy Katz <katzj@redhat.com> 0.71-1
  320. - simpleconfig.py: gracefully handle non-existent config files
  321. * Mon Dec 16 2002 Harald Hoyer <harald@redhat.de> 0.70-1
  322. - _setParent() in GenClass::__setitem__
  323. * Fri Dec 13 2002 Jeremy Katz <katzj@redhat.com> 0.69-1
  324. - only probe for the mouse once to fix mouse probing problems
  325. - make keyboard names more consistent (#79354)
  326. * Thu Dec 12 2002 Harald Hoyer <harald@redhat.de> 0.68-1
  327. - genClass: slicing of anonymous lists
  328. - executil: dup2 more output redirectors
  329. * Tue Nov 26 2002 Michael Fulbright <msf@redhat.com> 0.67-1
  330. - Fixed issue related to not defaulting to sane monitor values if monitor
  331. was not probed.
  332. * Tue Nov 26 2002 Phil Knirsch <pknirsch@redhat.com> 0.66-1
  333. - Fixed -fpic handling for s390 and s390x.
  334. * Thu Nov 21 2002 Michael Fulbright <msf@redhat.com> 0.65-1
  335. - added some code to handle the no mouse setup better
  336. * Thu Nov 21 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  337. - do not require pyxf86config for mainframe
  338. * Tue Nov 19 2002 Michael Fulbright <msf@redhat.com> 0.64-1
  339. - Added new xserver.py which has code to help get X up and running from scratch
  340. * Tue Nov 19 2002 Jeremy Katz <katzj@redhat.com> 0.63-2
  341. - rebuild for all arches
  342. * Fri Nov 15 2002 Brent Fox <bfox@redhat.com> 0.63-1
  343. - Added Latin American (la-latin1) keyboard
  344. * Thu Nov 14 2002 Harald Hoyer <harald@redhat.de> 0.62-1
  345. - removed Alchemist dependency from genClass
  346. - executil extended
  347. * Tue Nov 12 2002 Michael Fulbright <msf@redhat.com> 0.61-1
  348. - big changes as we moved alot of code from redhat-config-xfree86 into xhwstate.py
  349. * Tue Nov 5 2002 Jeremy Katz <katzj@redhat.com> 0.59-1
  350. - access Cards database in /usr/share/hwdata instead of
  351. /usr/X11R6/lib/X11 (#73899)
  352. - excludearch x86_64 until python is fixed
  353. * Fri Nov 1 2002 Jeremy Katz <katzj@redhat.com> 0.58-1
  354. - add macedonian keyboard (#76902)
  355. - find loadkeys for anaconda (#75329)
  356. * Thu Oct 31 2002 Brent Fox <bfox@redhat.com> 0.57-1
  357. - Mark keyboard names for translations
  358. * Mon Oct 21 2002 Brent Fox <bfox@redhat.com> 0.56-1
  359. - Use cz_qwerty keymap for Czech qwerty keyboards
  360. * Thu Oct 10 2002 Jeremy Katz <katzj@redhat.com> 0.55-2
  361. - rebuild so that we actually get object files for the correct architectures
  362. * Wed Oct 9 2002 Dan Walsh <dwalsh@redhat.de> 0.55-1
  363. - removed chmod from ConfSMB.py file protection should remain the same
  364. * Tue Oct 8 2002 Harald Hoyer <harald@redhat.de> 0.54-1
  365. - removed fd/socket leaking
  366. * Tue Oct 08 2002 Phil Knirsch <pknirsch@redhat.com> 0.53-2
  367. - Integreated Karsten Hopp's 64bit bigendian patch for s390x.
  368. * Fri Oct 4 2002 Brent Fox <bfox@redhat.com> 0.53-1
  369. - Allow window icon to be passed into stand_alone in firstboot_gui_window.py
  370. * Thu Oct 3 2002 Jeremy Katz <katzj@redhat.com> 0.52-2
  371. - fixup installation into %%{_libdir}/python2.2/
  372. * Thu Oct 3 2002 Jeremy Katz <katzj@redhat.com> 0.52-1
  373. - iconvmodule.c: PyObject_asReadBuffer() expects *int while iconv()
  374. expects size_t.
  375. * Thu Aug 29 2002 Jeremy Katz <katzj@redhat.com> 0.51-1
  376. - src/keyboard_models.py: fix romanian console keymap (#72952)
  377. * Wed Aug 28 2002 Jeremy Katz <katzj@redhat.com> 0.50-1
  378. - diskutil.py: update /etc/mtab
  379. * Fri Aug 23 2002 Michael Fulbright <msf@redhat.com> 0.49-1
  380. - videocard.py: Use unsupported VGA compatible card entry if card unknown
  381. * Thu Aug 22 2002 Brent Fox <bfox@redhat.com> 0.48-1
  382. - translate.py: add ability to set codeset for textdomains not pulled in by us
  383. * Thu Aug 22 2002 Brent Fox <bfox@redhat.com> 0.47-1
  384. - fix another typo in translate.py
  385. * Thu Aug 22 2002 Jeremy Katz <katzj@redhat.com> 0.46-1
  386. - fix a typo in translate.py
  387. * Thu Aug 22 2002 Jeremy Katz <katzj@redhat.com> 0.45-1
  388. - minor mouse fixups (#70289, #71893)
  389. * Wed Aug 21 2002 Michael Fulbright <msf@redhat.com> 0.44-1
  390. - added sanity check to ddcprobe'd range values
  391. * Tue Aug 20 2002 Harald Hoyer <harald@redhat.de> 0.43-1
  392. - fixed genClass.py:toContext()
  393. - ValueError -> TypeError in checkType
  394. * Fri Aug 16 2002 Brent Fox <bfox@redhat.com> 0.42-1
  395. - Mark window title for translations in firstboot_gui_window
  396. * Fri Aug 16 2002 Jeremy Katz <katzj@redhat.com> 0.41-1
  397. - translate.py fixes
  398. - "None - None" is back, but as "No mouse"
  399. * Thu Aug 15 2002 Jeremy Katz <katzj@redhat.com> 0.40-1
  400. - comps.py: handle translated category names
  401. * Wed Aug 14 2002 Harald Hoyer <harald@redhat.de>
  402. - added iwconfig-support to ethtool
  403. * Wed Aug 14 2002 Brent Fox <bfox@redhat.com> 0.37-1
  404. - Call destroy() when a firstboot window exits
  405. * Mon Aug 12 2002 Jeremy Katz <katzj@redhat.com> 0.36-1
  406. - add generic wheel mouse types
  407. - add bad hack to handle packages which should only be installed
  408. if another package is installed
  409. * Sun Aug 11 2002 Brent Fox <bfox@redhat.com> 0.35-1
  410. - Create US International keymap line for bug 71105
  411. * Sun Aug 11 2002 Brent Fox <bfox@redhat.com> 0.34-2
  412. - Fix typo that I made with the last build
  413. * Sun Aug 11 2002 Brent Fox <bfox@redhat.com> 0.34-1
  414. - Fix Brazilian abnt2 keyboard map for bug 70351
  415. * Tue Aug 6 2002 Michael Fulbright <msf@redhat.com>
  416. - added sanity checks for sync rates
  417. * Fri Aug 2 2002 Jeremy Katz <katzj@redhat.com>
  418. - keyboard_models.py: be-latin2 isn't a valid keymap
  419. * Wed Jul 31 2002 Jeremy Katz <katzj@redhat.com> 0.32-1
  420. - add losetup, unlosetup, and getUnusedLoop to diskutil
  421. * Tue Jul 30 2002 Brent Fox <bfox@redhat.com> 0.31-1
  422. - remove some dead code
  423. - make the font big for firstboot_gui_window titles
  424. * Thu Jul 25 2002 Jeremy Katz <katzj@redhat.com> 0.30-1
  425. - mouse.py: don't enable emulate three buttons on the fly (#68129)
  426. * Thu Jul 25 2002 Jeremy Katz <katzj@redhat.com> 0.29-1
  427. - translate.py: set up default langs based on environment
  428. * Wed Jul 24 2002 Jonathan Blandford <jrb@redhat.com> 0.28-1
  429. * add GenericError.py
  430. * Wed Jul 24 2002 Jeremy Katz <katzj@redhat.com> 0.27-2
  431. - actually install _diskutil.so
  432. * Wed Jul 24 2002 Jeremy Katz <katzj@redhat.com> 0.27-1
  433. - diskutil.py, diskutil.c: add some simple disk utility methods (mount,
  434. umount, sync, ejectCdrom)
  435. * Mon Jul 22 2002 Jeremy Katz <katzj@redhat.com> 0.26-1
  436. - comps.py: add support for reading group hierarchy
  437. * Thu Jul 17 2002 Brent Fox <bfox@redhat.com> 0.25-1
  438. - Make firstboot windows use GtkDialog instead of GtkWindow
  439. * Wed Jul 17 2002 Brent Fox <bfox@redhat.com> 0.24-3
  440. - Change Poland keyboard to Polish. Bug #68520
  441. * Wed Jul 17 2002 Michael Fulbright <msf@redhat.com> 0.24-2
  442. - minor typo fix
  443. * Wed Jul 17 2002 Michael Fulbright <msf@redhat.com> 0.24-1
  444. - executil.py: add getfd() function
  445. * Tue Jul 16 2002 Jeremy Katz <katzj@redhat.com> 0.23-1
  446. - comps.py: add metapkg support
  447. * Tue Jul 16 2002 Brent Fox <bfox@redhat.com> 0.22-2
  448. - Call loadkeys if the binary exists when changing keymaps
  449. * Mon Jul 15 2002 Jeremy Katz <katzj@redhat.com> 0.21-1
  450. - fix jp106 entry in keyboard_models
  451. - add method to get list of supported keyboard maps
  452. * Sat Jul 13 2002 Brent Fox <bfox@redhat.com> 0.20-1
  453. - Small change in firstboot_gui_window.py to center popup windows
  454. * Wed Jul 10 2002 Brent Fox <bfox@redhat.com> 0.19-1
  455. - Added a Greek keyboard to keyboard_models.py
  456. * Wed Jul 10 2002 Alexander Larsson <alexl@redhat.com> 0.18-1
  457. - Fixed bug in monitor resoultion support code
  458. * Mon Jul 1 2002 Harald Hoyer <harald@redhat.de> 0.16-1
  459. - updated Conf*.py
  460. - updated genClass
  461. - added ethtool
  462. * Fri Jun 28 2002 Jeremy Katz <katzj@redhat.com> 0.15-1
  463. - comps.py: use libxml2 for xml parsing instead of expat
  464. * Fri Jun 28 2002 Jeremy Katz <katzj@redhat.com> 0.14-1
  465. - only setxkbmap if $DISPLAY is set
  466. * Thu Jun 27 2002 Jeremy Katz <katzj@redhat.com> 0.13-1
  467. - add parser for new comps file
  468. * Wed Jun 26 2002 Michael Fulbright <msf@redhat.com> 0.12-1
  469. - Fix bug of uninitialized data in Mouse class
  470. * Tue Jun 25 2002 Brent Fox <bfox@redhat.com> 0.11-3
  471. - Allow a window title to be passed in
  472. * Wed Jun 19 2002 Brent Fox <bfox@redhat.com> 0.9-4
  473. - Fixed line for German keyboards in keyboard_models.py
  474. * Tue Jun 18 2002 Brent Fox <bfox@redhat.com> 0.9-3
  475. - Remove cancel button from firstboot_gui_window
  476. * Tue Jun 18 2002 Brent Fox <bfox@redhat.com> 0.9-2
  477. - Provide a way to pass keymap name back to firstboot
  478. - Fix error in Slovakian keymap line in keyboard_models.py
  479. * Wed Jun 12 2002 Jeremy Katz <katzj@redhat.com>
  480. - use cz-lat2 for Czechoslovakian keybaord map (#66354)
  481. * Tue Jun 04 2002 Michael Fulbright <msf@redhat.com>
  482. - fixed bug referencing ddcDevice and videoram in card.
  483. * Tue May 28 2002 Jeremy Katz <katzj@redhat.com>
  484. - removed kbd.py, added keyboard.py
  485. * Fri May 24 2002 Michael Fulbright <msf@redhat.com>
  486. - Added kbd.py
  487. * Thu May 23 2002 Alex Larsson <alexl@redhat.com>
  488. - Added /usr/share/rhpl to files list
  489. * Thu May 23 2002 Michael Fulbright <msf@redhat.com>
  490. - added log.py, videocard.py, mouse.py, monitor.py, simpleconfig.py
  491. * Wed May 22 2002 Jeremy Katz <katzj@redhat.com>
  492. - Initial build.