texlive-collection-texinfo-vl.spec 6.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204
  1. ## -*- coding: utf-8-unix -*-
  2. ## NOTE: This spec file is generated by tlpdb2rpmspec 2009-3:
  3. ## tlpdb2rpmspec collection-texinfo
  4. %bcond_with firstbuild
  5. %define tex_destdir %{_datadir}
  6. %define texmf %{tex_destdir}/texmf
  7. %define texlive_src %{tex_destdir}/texlive-sources
  8. %define build_tex_destdir %{buildroot}%{tex_destdir}
  9. %define build_texmf %{buildroot}%{texmf}
  10. %define exec_mktexlsr [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
  11. %define exec_texhash [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
  12. %define exec_updmap [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
  13. %define exec_fmtutil [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
  14. %define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
  15. %define vartexfonts %{_var}/lib/texmf
  16. %define __find_provides %{nil}
  17. %define __find_requires %{nil}
  18. %define __perl_provides %{nil}
  19. %define __perl_requires %{nil}
  20. Autoreq: 0
  21. Summary: TeX Live: GNU Texinfo
  22. Summary(ja): TeX Live: GNU Texinfo
  23. Name: texlive-collection-texinfo
  24. Version: 2009
  25. Release: 3%{?_dist_release}
  26. License: GPL+
  27. Group: Applications/Publishing
  28. URL:http://www.tug.org/texlive/
  29. Requires: texlive = %{version}
  30. Requires: texlive-collection-basic = %{version}
  31. Requires(post): texlive = %{version}
  32. Requires(postun): texlive = %{version}
  33. BuildRequires: texlive-sources = %{version}
  34. BuildArch: noarch
  35. Buildroot: %{_tmppath}/%{name}-%{version}-root
  36. Vendor: Project Vine
  37. Distribution: Vine Linux
  38. Packager: munepi
  39. %description
  40. The TeX Live software distribution offers a complete TeX system for a
  41. variety of Unix, Macintosh, Windows and other platforms. It
  42. encompasses programs for editing, typesetting, previewing and printing
  43. of TeX documents in many different languages, and a large collection
  44. of TeX macros and font libraries.
  45. The distribution includes extensive general documentation about TeX,
  46. as well as the documentation for the included software packages.
  47. This package is a collection of GNU Texinfo:
  48. TeX macros for the GNU Texinfo documentation system. The
  49. programs and documentation are no longer distributed with TeX
  50. Live; get the original Texinfo package for your system.
  51. This package contains the following CTAN packages:
  52. texinfo: Texinfo documentation system.
  53. %description -l ja
  54. TeX Live ソフトウェアディストリビューションは、
  55. さまざまな Unix, Macintosh, Windows、および
  56. 他のプラットホームに対して完全な TeX システムを提供します。
  57. 多くの異なった言語を含む TeX ドキュメントの
  58. 編集、組版、閲覧、印刷するためのプログラム、
  59. そして、TeX マクロやフォントライブラリの大きなコレクションを
  60. 同梱しています。
  61. このディストリビューションは
  62. 同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
  63. TeX に関するたくさんの一般的なドキュメントを含んでいます。
  64. このパッケージは以下のようなパッケージ集です。
  65. GNU Texinfo:
  66. TeX macros for the GNU Texinfo documentation system. The
  67. programs and documentation are no longer distributed with TeX
  68. Live; get the original Texinfo package for your system.
  69. このパッケージは以下の CTAN パッケージを含んでいます:
  70. texinfo: Texinfo documentation system.
  71. %prep
  72. %build
  73. %install
  74. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  75. PREF=%{buildroot}%{tex_destdir}
  76. manifest=(
  77. texmf-dist/tex/texinfo/texinfo.ini
  78. texmf-dist/tex/texinfo/texinfo.tex
  79. texmf-dist/tex/texinfo/txi-cs.tex
  80. texmf-dist/tex/texinfo/txi-de.tex
  81. texmf-dist/tex/texinfo/txi-en.tex
  82. texmf-dist/tex/texinfo/txi-es.tex
  83. texmf-dist/tex/texinfo/txi-fr.tex
  84. texmf-dist/tex/texinfo/txi-it.tex
  85. texmf-dist/tex/texinfo/txi-nb.tex
  86. texmf-dist/tex/texinfo/txi-nl.tex
  87. texmf-dist/tex/texinfo/txi-nn.tex
  88. texmf-dist/tex/texinfo/txi-pl.tex
  89. texmf-dist/tex/texinfo/txi-pt.tex
  90. texmf-dist/tex/texinfo/txi-ru.tex
  91. texmf-dist/tex/texinfo/txi-sr.tex
  92. texmf-dist/tex/texinfo/txi-tr.tex
  93. texmf-dist/tex/texinfo/txi-uk.tex
  94. )
  95. %__mkdir_p ${PREF}/texmf-dist
  96. for i in "${manifest[@]}"; do
  97. %__install -D %{texlive_src}/$i ${PREF}/$i
  98. done
  99. ## info
  100. %__rm -f %{buildroot}%{_infodir}/dir
  101. %__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
  102. ## man
  103. ## man t1* files are provided by t1utils
  104. for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
  105. %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
  106. done
  107. ## man some files are provided by psutils
  108. for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
  109. %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
  110. done
  111. ## fix perl path
  112. for i in source/metapost/expressg/expressg.dtx \
  113. doc/metapost/expressg/n2mpsprl.prl \
  114. doc/latex/songbook/contrib/crd2sb/crd2sb; do
  115. [ -f %{build_texmf}-dist/${i} ] && \
  116. %__sed -i -e "s|^#!/usr/local/bin/perl|#!%{__perl}|" %{build_texmf}-dist/${i}
  117. done
  118. ## remove asymptote directries, which provides asymptote package
  119. find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
  120. # find %{buildroot} -name "Makefile" | xargs %__rm -f
  121. # ## remove xindy
  122. # find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
  123. # ## remove tex4ht
  124. # find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
  125. ## remove arch dependent binaries
  126. %__rm -f %{build_texmf}-dist/source/latex/splitindex/splitindex-{OpenBSD,Linux}-i386
  127. ## remove unpackaging files
  128. find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
  129. find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
  130. ## Files list
  131. find %{buildroot} -type f -or -type l | \
  132. %__sed -e "s|%{buildroot}||g" > filelist.full
  133. find %{buildroot}%{texmf}-dist -type d | \
  134. %__sed -e "s|^%{buildroot}|%dir |" \
  135. -e "s|$|/|" >> filelist.full
  136. %clean
  137. %__rm -rf %{buildroot}
  138. %post
  139. %{exec_texhash}
  140. exit 0
  141. %postun
  142. if [ "$1" = 0 ]; then
  143. %{exec_texhash}
  144. fi
  145. exit 0
  146. %files -f filelist.full
  147. %defattr(-,root,root)
  148. %changelog
  149. * Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
  150. - generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-texinfo
  151. - improved %%post
  152. * Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  153. - generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-texinfo
  154. - removed arch dependent binaries (texlive-collection-latexextra)
  155. - fixed perl path
  156. - improved updmap process in %%post and %%postun
  157. * Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  158. - generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-texinfo