php-ext-mailparse-vl.spec 4.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185
  1. %bcond_without php80
  2. %bcond_without php74
  3. %define extname mailparse
  4. Summary: Email message manipulation for PHP
  5. Summary(ja): PHP用e-mailメッセージ操作拡張
  6. Name: php-ext-%{extname}
  7. Version: 3.1.2
  8. Release: 1%{_dist_release}
  9. Group: programming
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Packager: tomop
  13. License: The PHP License
  14. URL: https://pecl.php.net/package/mailparse
  15. Source: https://pecl.php.net/get/%{extname}-%{version}.tgz
  16. %description
  17. Mailparse is an extension for parsing and working with email messages.
  18. It can deal with rfc822 and rfc2045 (MIME) compliant messages.
  19. %description -l ja
  20.  Mailparseモジュールは、e-mailメッセージの解析・操作を行うPHP拡張です。
  21. rfc822やrfc2045 (MIME)に準拠したメッセージを取り扱うことが可能です。
  22. %if %{with php74}
  23. %package -n php74-ext-mailparse
  24. Summary: Email message manipulation for PHP-7.4
  25. Summary(ja): PHP-7.4用e-mailメッセージ操作拡張
  26. Group: programming
  27. BuildRequires: php74-devel
  28. %if "%{?req_php74_api}" != ""
  29. Requires: %{req_php74_api}
  30. %endif
  31. %description -n php74-ext-mailparse
  32. Mailparse is an extension for parsing and working with email messages.
  33. It can deal with rfc822 and rfc2045 (MIME) compliant messages.
  34. %description -n php74-ext-mailparse -l ja
  35.  Mailparseモジュールは、e-mailメッセージの解析・操作を行うPHP拡張です。
  36. rfc822やrfc2045 (MIME)に準拠したメッセージを取り扱うことが可能です。
  37. %endif
  38. %if %{with php80}
  39. %package -n php80-ext-mailparse
  40. Summary: Email message manipulation for PHP-8.0
  41. Summary(ja): PHP-8.0用e-mailメッセージ操作拡張
  42. Group: programming
  43. BuildRequires: php80-devel
  44. %if "%{?req_php80_api}" != ""
  45. Requires: %{req_php80_api}
  46. %endif
  47. %description -n php80-ext-mailparse
  48. Mailparse is an extension for parsing and working with email messages.
  49. It can deal with rfc822 and rfc2045 (MIME) compliant messages.
  50. %description -n php80-ext-mailparse -l ja
  51.  Mailparseモジュールは、e-mailメッセージの解析・操作を行うPHP拡張です。
  52. rfc822やrfc2045 (MIME)に準拠したメッセージを取り扱うことが可能です。
  53. %endif
  54. %debug_package
  55. %prep
  56. %setup -q -c -n %{extname}-%{version}
  57. cp %{extname}-%{version}/{LICENSE,README.md,CREDITS} ./
  58. %if %{with php74}
  59. cp -a %{extname}-%{version} php74
  60. pushd php74
  61. phpize74
  62. popd
  63. %endif
  64. %if %{with php80}
  65. cp -a %{extname}-%{version} php80
  66. pushd php80
  67. phpize80
  68. popd
  69. %endif
  70. %build
  71. %if %{with php74}
  72. pushd php74
  73. %configure --with-php-config=%{_bindir}/php-config74
  74. %__make %{?_smp_mflags}
  75. popd
  76. %endif
  77. %if %{with php80}
  78. pushd php80
  79. %configure --with-php-config=%{_bindir}/php-config80
  80. %__make %{?_smp_mflags}
  81. popd
  82. %endif
  83. %install
  84. rm -rf %{buildroot}
  85. %if %{with php74}
  86. mkdir -p %{buildroot}%{_libdir}/php74/
  87. mkdir -p %{buildroot}%{_sysconfdir}/php74/php.d
  88. pushd php74
  89. %makeinstall INSTALL_ROOT=%{buildroot}
  90. popd
  91. cat > %{buildroot}%{_sysconfdir}/php74/php.d/%{extname}.ini <<EOF
  92. ; Enable %{extname} extension module
  93. extension=%{extname}.so
  94. EOF
  95. %endif
  96. %if %{with php80}
  97. mkdir -p %{buildroot}%{_libdir}/php80/
  98. mkdir -p %{buildroot}%{_sysconfdir}/php80/php.d
  99. pushd php80
  100. %makeinstall INSTALL_ROOT=%{buildroot}
  101. popd
  102. cat > %{buildroot}%{_sysconfdir}/php80/php.d/%{extname}.ini <<EOF
  103. ; Enable %{extname} extension module
  104. extension=%{extname}.so
  105. EOF
  106. %endif
  107. %clean
  108. rm -rf %{buildroot}
  109. %if %{with php74}
  110. %files -n php74-ext-mailparse
  111. %defattr(-,root,root)
  112. %license LICENSE
  113. %doc README CREDITS
  114. %{_libdir}/php74/*
  115. %config(noreplace) %{_sysconfdir}/php74/php.d/*
  116. %endif
  117. %if %{with php80}
  118. %files -n php80-ext-mailparse
  119. %defattr(-,root,root)
  120. %license LICENSE
  121. %doc README CREDITS
  122. %{_libdir}/php80/*
  123. %config(noreplace) %{_sysconfdir}/php80/php.d/*
  124. %endif
  125. %changelog
  126. * Mon Nov 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.2-1
  127. - new upstream release.
  128. * Sat Dec 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.1-1
  129. - new upstream release.
  130. - added php80 support.
  131. - dropped php73 support.
  132. * Thu Dec 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.3-1
  133. - dropped Patch0: fixed in upstream.
  134. - added php74 support.
  135. - dropped php72 support.
  136. * Sat Dec 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.2-2
  137. - added php73 support.
  138. * Wed Dec 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.2-1
  139. - new upstream release.
  140. - built with php72.
  141. * Fri Apr 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.6-2
  142. - rebuilt with php5-5.6.7.
  143. * Fri Dec 13 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.6-1
  144. - initial build.