glib2-vl.spec 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A library of handy utility functions.
  3. Name: glib2
  4. Version: 2.46.2
  5. Release: 1%{?_dist_release}
  6. License: LGPLv2+
  7. Group: System Environment/Libraries
  8. Source: http://ftp.gnome.org/pub/GNOME/sources/glib/2.46/glib-%{version}.tar.xz
  9. Source2: glib2.sh
  10. Source3: glib2.csh
  11. Patch0: glib-2.32.1-dconf-path.patch
  12. BuildRoot: %{_tmppath}/glib-%{version}-root
  13. BuildRequires: pkgconfig >= 0.14
  14. BuildRequires: dbus-devel
  15. BuildRequires: gamin-devel
  16. BuildRequires: libffi-devel
  17. BuildRequires: zlib-devel
  18. BuildRequires: python-devel
  19. BuildRequires: gtk-doc
  20. Obsoletes: glib-gtkbeta
  21. URL: http://www.gtk.org
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. Packager: Daisuke SUZUKI <daisuke@linux.or.jp>, Takemikaduchi
  25. %description
  26. GLib is the low-level core library that forms the basis
  27. for projects such as GTK+ and GNOME. It provides data structure
  28. handling for C, portability wrappers, and interfaces for such runtime
  29. functionality as an event loop, threads, dynamic loading, and an
  30. object system.
  31. This package provides version 2.46 of GLib.
  32. %package devel
  33. Summary: Development files for the GLib library
  34. Group: Development/Libraries
  35. Requires: %{name} = %{version}
  36. Requires: pkgconfig >= 0.14
  37. Requires: libffi-devel
  38. Requires: zlib-devel
  39. Obsoletes: glib-gtkbeta-devel
  40. Conflicts: glib-devel <= 1.2.8
  41. %description devel
  42. The glib-devel package includes the header files for
  43. version 2.46 of the GLib library.
  44. ## to build compat32 for x86_64 architecture support
  45. %package -n compat32-%{name}
  46. Summary: A library of handy utility functions.
  47. Group: System Environment/Libraries
  48. %description -n compat32-%{name}
  49. GLib is the low-level core library that forms the basis
  50. for projects such as GTK+ and GNOME. It provides data structure
  51. handling for C, portability wrappers, and interfaces for such runtime
  52. functionality as an event loop, threads, dynamic loading, and an
  53. object system.
  54. This package provides version 2.46 of GLib.
  55. %package -n compat32-%{name}-devel
  56. Summary: Development files for the GLib library
  57. Group: Development/Libraries
  58. Requires: pkgconfig >= 0.14
  59. Requires: compat32-%{name} = %{version}
  60. Conflicts: glib-devel <= 1.2.8
  61. %description -n compat32-%{name}-devel
  62. The glib-devel package includes the header files for
  63. version 2.46 of the GLib library.
  64. %prep
  65. %setup -q -n glib-%{version}
  66. %patch0 -p1
  67. %build
  68. NOCONFIGURE=1 ./autogen.sh
  69. %configure --disable-selinux --enable-static --enable-systemtap
  70. make %{?_smp_mflags}
  71. %install
  72. rm -rf $RPM_BUILD_ROOT
  73. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  74. make install DESTDIR=$RPM_BUILD_ROOT
  75. ## glib2.sh and glib2.csh
  76. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
  77. install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
  78. install -m 755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
  79. #mkdir -p $RPM_BUILD_ROOT%{python_sitearch}
  80. #ln -sf %{_libdir}/gdbus-2.0/codegen $RPM_BUILD_ROOT%{python_sitearch}/codegen
  81. touch $RPM_BUILD_ROOT%{_libdir}/gio/modules/giomodule.cache
  82. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  83. rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/lib*.{a,la}
  84. rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/*.cache
  85. %find_lang glib20
  86. %clean
  87. rm -rf $RPM_BUILD_ROOT
  88. %post
  89. /sbin/ldconfig
  90. gio-querymodules %{_libdir}/gio/modules
  91. %postun
  92. /sbin/ldconfig
  93. gio-querymodules %{_libdir}/gio/modules
  94. %post -n compat32-%{name} -p /sbin/ldconfig
  95. %postun -n compat32-%{name} -p /sbin/ldconfig
  96. %files -f glib20.lang
  97. %defattr(-, root, root)
  98. %doc AUTHORS COPYING ChangeLog NEWS README
  99. %{_bindir}/gapplication
  100. %{_bindir}/gdbus
  101. %{_bindir}/gio-querymodules
  102. %{_bindir}/glib-compile-schemas
  103. %{_bindir}/gsettings
  104. %{_libdir}/libglib-2.0.so.*
  105. %{_libdir}/libgthread-2.0.so.*
  106. %{_libdir}/libgmodule-2.0.so.*
  107. %{_libdir}/libgobject-2.0.so.*
  108. %{_libdir}/libgio-2.0.so.*
  109. %{_libdir}/gio/modules/lib*.so
  110. %{_sysconfdir}/profile.d/*
  111. %{_datadir}/bash-completion/completions/gapplication
  112. %{_datadir}/bash-completion/completions/gdbus
  113. %{_datadir}/bash-completion/completions/gsettings
  114. %files devel
  115. %defattr(-, root, root)
  116. %{_bindir}/gdbus-codegen
  117. %{_bindir}/glib-compile-resources
  118. %{_bindir}/glib-genmarshal
  119. %{_bindir}/glib-gettextize
  120. %{_bindir}/glib-mkenums
  121. %{_bindir}/gobject-query
  122. %{_bindir}/gresource
  123. %{_bindir}/gtester
  124. %{_bindir}/gtester-report
  125. %{_libdir}/lib*.so
  126. %{_libdir}/lib*.a
  127. #%{_libdir}/gdbus-2.0/codegen/*
  128. %{_libdir}/glib-2.0
  129. %{_libdir}/pkgconfig/*
  130. #%{python_sitearch}/codegen
  131. %{_includedir}/*
  132. %{_datadir}/aclocal/*
  133. %{_datadir}/glib-2.0
  134. %doc %{_datadir}/gtk-doc/html/*
  135. %doc %{_mandir}/man1/*
  136. %{_datadir}/gdb/auto-load%{_libdir}/libglib-2.0.so.*-gdb.py*
  137. %{_datadir}/gdb/auto-load%{_libdir}/libgobject-2.0.so.*-gdb.py*
  138. %{_datadir}/bash-completion/completions/gresource
  139. %if %{build_compat32}
  140. %files -n compat32-%{name}
  141. %defattr(-, root, root)
  142. %{_libdir}/libglib-2.0.so.*
  143. %{_libdir}/libgthread-2.0.so.*
  144. %{_libdir}/libgmodule-2.0.so.*
  145. %{_libdir}/libgobject-2.0.so.*
  146. %{_libdir}/libgio-2.0.so.*
  147. %{_libdir}/gio/modules/lib*.so
  148. %files -n compat32-%{name}-devel
  149. %defattr(-, root, root)
  150. %{_libdir}/lib*.so
  151. %{_libdir}/lib*.a
  152. %{_libdir}/glib-2.0
  153. %endif
  154. %changelog
  155. * Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.46.2-1
  156. - new upstream release
  157. * Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.46.1-1
  158. - new upstream release
  159. * Thu May 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.44.1-1
  160. - new upstream release
  161. * Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.44.0-1
  162. - new upstream release
  163. * Sun Mar 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.2-1
  164. - new upstream release
  165. * Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.1-1
  166. - new upstream release
  167. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.0-1
  168. - new upstream release
  169. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.0-2
  170. - rebuild with libffi-3.0.13
  171. * Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.0-1
  172. - new upstream release
  173. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.2-1
  174. - new upstream release
  175. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.1-1
  176. - new upstream release
  177. * Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-1
  178. - new upstream release
  179. - remove Patch1 (glib-2.36.3-revert-g_file_set_contents.patch) from upstream
  180. * Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.3-1
  181. - new upstream release
  182. - add Patch1 (glib-2.36.3-revert-g_file_set_contents.patch) from upstream
  183. * Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.2-1
  184. - new upstream release
  185. * Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.1-1
  186. - new upstream release
  187. * Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.3-1
  188. - new upstream release
  189. * Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.2-1
  190. - new upstream release
  191. * Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.1-1
  192. - new upstream release
  193. * Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
  194. - new upstream release
  195. * Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.4-1
  196. - new upstream release
  197. * Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.3-1
  198. - new upstream release
  199. * Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
  200. - new upstream release
  201. * Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
  202. - new upstream release
  203. - add BuildRequires: python-devel
  204. - add Patch0 (glib-2.32.1-dconf-path.patch)
  205. * Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  206. - new upstream release
  207. * Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  208. - new upstream release
  209. * Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  210. - new upstream release
  211. - add Requires: libffi-devel, zlib-devel (-devel sub package)
  212. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.92-1
  213. - new upstream release
  214. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.18-1
  215. - new upstream release
  216. - remove Patch0,1
  217. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.16-1
  218. - new upstream release
  219. - Patch0: glib-2.29.16-fixes-bug-656387.patch
  220. - Patch1: glib-2.29.16-fixes-bug-656675.patch
  221. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.14-1
  222. - new upstream release
  223. - add BuildRequires: libffi-devel, dbus-devel
  224. * Sat Jun 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.8-1
  225. - new upstream release
  226. * Fri Apr 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
  227. - new upstream release
  228. * Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.5-1
  229. - new upstream release
  230. * Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
  231. - new upstream release
  232. * Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
  233. - new upstream release
  234. * Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
  235. - new upstream release
  236. * Sat Feb 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
  237. - new upstream release
  238. * Sat Feb 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  239. - new upstream release
  240. * Fri Dec 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-2
  241. - move the following files from glib2-devel to glib2 package
  242. (gdbus, gio-querymodules, glib-compile-schemas, gsettings)
  243. * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-1
  244. - new upstream release
  245. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.0-1
  246. - new upstream release
  247. - fix Source (add URL)
  248. - fix %files to add /etc/bash_completion.d files
  249. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.2-2
  250. - build with rpm-4.8.1-1 for pkg-config file
  251. * Sat Aug 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.2-1
  252. - new upstream release
  253. * Tue May 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-1
  254. - new upstream release
  255. * Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
  256. - new upstream release
  257. - add BuildRequires: zlib-devel
  258. * Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.5-1
  259. - new upstream release
  260. * Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.4-1
  261. - new upstream release
  262. * Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.3-1
  263. - new upstream release
  264. * Sun Oct 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
  265. - new upstream release
  266. * Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.0-1
  267. - new upstream release
  268. * Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.4-1
  269. - new upstream release
  270. * Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-1
  271. - new upstream release
  272. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-1
  273. - new upstream release
  274. * Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-1
  275. - new upstream release
  276. * Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-1
  277. - new upstream release
  278. * Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1
  279. - new upstream release
  280. * Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.3-1
  281. - new upstream release
  282. * Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-1
  283. - new upstream release
  284. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-1
  285. - new upstream release
  286. * Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
  287. - new upstream release
  288. * Mon Jul 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.4-1
  289. - new upstream release
  290. * Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.16.3-2
  291. - updated %%if %%{build_compat32} case related statements
  292. * Wed Apr 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.3-1vl5
  293. - new upstream release
  294. - removed lib*.la files from devel package
  295. * Sun Apr 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.2-1vl5
  296. - new upstream release
  297. * Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-1vl5
  298. - added %%{?_dist_release}
  299. - BuildRequires: gamin-devel
  300. * Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-0vl1
  301. - new upstream release
  302. * Thu Feb 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.6-0vl1
  303. - new upstream release
  304. * Wed Jan 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.5-0vl1
  305. - new upstream release
  306. * Wed Nov 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
  307. - new upstream release
  308. * Thu Oct 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
  309. - new upstream release
  310. - removed BuildRequires: automake17
  311. * Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
  312. - new upstream release
  313. * Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
  314. - new upstream release
  315. * Wed Jul 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.13-0vl1
  316. - new upstream release
  317. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl2
  318. - rebuild with new environment
  319. * Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl1
  320. - new upstream release
  321. * Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.11-0vl1
  322. - new upstream release
  323. * Mon Jan 08 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.7-0vl1
  324. - new upstream release
  325. * Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
  326. - new upstream release
  327. * Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
  328. - new upstream release
  329. * Wed Aug 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
  330. - new upstream release
  331. * Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
  332. - new upstream release
  333. * Mon Jun 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.3-0vl3
  334. - rebuild
  335. * Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl2
  336. - update glib2.{sh,csh}
  337. - add EUC-JP,CP932,UTF-8 to G_FILENAME_ENCODING
  338. * Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
  339. - new upstream release
  340. * Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
  341. - new upstream release
  342. * Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
  343. - new upstream release
  344. * Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
  345. - new upstream release
  346. * Mon Feb 27 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl2
  347. - added compat32-* packages for x86_64 architecture support
  348. - chaged G_ATOMIC_X86_64 to I486 in config.h before making compat32
  349. * Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.6-0vl1
  350. - new upstream release
  351. * Thu Jan 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-0vl1
  352. - new upstream release
  353. * Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.4-0vl1
  354. - new upstream release
  355. * Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
  356. - new upstream release
  357. * Tue Sep 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl3
  358. - fixed typo in glib2.csh
  359. * Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
  360. - update glib2.{sh,csh} to use G_FILENAME_ENCODING instead of
  361. G_BROKEN_FILENAMES.
  362. * Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
  363. - new upstream release
  364. * Sat Aug 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
  365. - new upstream release
  366. * Sat Aug 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.7-0vl1
  367. - new upstream release
  368. * Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.6-0vl1
  369. - new upstream release
  370. * Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-0vl1
  371. - new upstream release
  372. * Sun Jul 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-0vl1
  373. - new upstream release
  374. - add *.la to build arts (should be fixed in arts?)
  375. * Sat Apr 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
  376. - new upstream release
  377. * Fri Mar 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
  378. - new upstream release
  379. * Sat Feb 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
  380. - new upstream release
  381. * Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
  382. - new upstream release
  383. * Sat Dec 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl1
  384. - new upstream release
  385. * Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl2
  386. - rebuilt
  387. * Mon Oct 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl1
  388. - new upstream release
  389. * Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.6-0vl1
  390. - new upstream release
  391. * Sun Aug 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-0vl1
  392. - new upstream release
  393. * Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-0vl1
  394. - new upstream release
  395. * Sat Jun 5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
  396. - new upstream release
  397. * Sat May 1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
  398. - new upstream release
  399. * Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
  400. - new upstream release
  401. * Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.3-0vl2
  402. - rebuild with new toolchain
  403. * Sat Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
  404. - new upstream release
  405. * Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
  406. - new upstream release
  407. * Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
  408. - new upstream release
  409. * Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  410. - new upstream release
  411. * Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
  412. - new upstream release
  413. - build for Vine Linux
  414. * Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
  415. - install glib2.sh and glib2.csh to set G_BROKEN_FILENAMES
  416. - blow away unpackaged files in install
  417. * Thu Aug 8 2002 Owen Taylor <otaylor@redhat.com>
  418. - Version 2.0.6
  419. - Remove fixed-ltmain.sh; shouldn't be needed any more.
  420. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  421. - automated rebuild
  422. * Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
  423. - 2.0.4
  424. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  425. - automated rebuild
  426. * Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
  427. - rebuild in different environment
  428. * Mon Apr 15 2002 Owen Taylor <otaylor@redhat.com>
  429. - Fix missing .po files (#63336)
  430. * Wed Apr 3 2002 Alex Larsson <alexl@redhat.com>
  431. - Update to version 2.0.1
  432. * Fri Mar 8 2002 Owen Taylor <otaylor@redhat.com>
  433. - Version 2.0.0
  434. * Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
  435. - Update to 1.3.15
  436. * Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
  437. - Bump for rebuild
  438. * Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
  439. - Update to 1.3.14
  440. * Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
  441. - add horrible buildrequires hack
  442. * Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
  443. - 1.3.13.91 cvs snap
  444. * Mon Feb 11 2002 Matt Wilson <msw@redhat.com>
  445. - rebuild from CVS snapshot
  446. - use setup -q
  447. * Thu Jan 31 2002 Jeremy Katz <katzj@redhat.com>
  448. - rebuild
  449. * Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
  450. - 1.3.13
  451. * Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
  452. - attempting rebuild in rawhide
  453. * Wed Jan 2 2002 Havoc Pennington <hp@redhat.com>
  454. - remove 64-bit patch now upstream, 1.3.12.90
  455. * Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
  456. - add some missing files to file list, langify
  457. * Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
  458. - add temporary patch to fix GTypeFundamentals on 64-bit
  459. * Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
  460. - Version 1.3.11
  461. * Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
  462. - Version 1.3.10
  463. * Tue Sep 25 2001 Owen Taylor <otaylor@redhat.com>
  464. - Version 1.3.9
  465. * Wed Sep 19 2001 Owen Taylor <otaylor@redhat.com>
  466. - Version 1.3.8
  467. * Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
  468. - Make -devel package require main package (#45388)
  469. - Fix description and summary
  470. - Configure with --disable-gtk-doc
  471. * Wed Jun 20 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  472. - add some portability fixes needed at least on s390
  473. - copy config.{guess,sub} instead of calling libtoolize
  474. * Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
  475. - try a new glib tarball with Makefile changes to work around
  476. libtool linking to installed .la files
  477. - make -devel require pkgconfig
  478. * Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
  479. - either libtool or the bad libtool hacks caused link
  480. against glib-gobject 1.3.2, rebuild
  481. * Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
  482. - 1.3.6
  483. - bad libtool workarounds
  484. * Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
  485. - 1.3.5, rename to glib2
  486. * Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
  487. - Final 1.3.2
  488. * Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
  489. - Version 1.3.2pre1
  490. - Remove pkgconfig
  491. * Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
  492. - Call 1.3.1b instead of snap... the snap* naming doesn't
  493. order correctly.
  494. * Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
  495. - new snapshot with fixed .pc files
  496. * Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
  497. - include .pc files in file list
  498. * Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
  499. - Include pkg-config
  500. - Upgrade to a glib CVS snapshot
  501. * Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
  502. - rebuild to cope with glibc locale binary incompatibility
  503. * Fri Jul 14 2000 Owen Taylor <otaylor@redhat.com>
  504. - Remove glib-config.1 manpage from build since
  505. it conflicts with glib-devel. When we go to
  506. glib glib1.2 setup, we should add it back
  507. * Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
  508. - Version 1.3.1
  509. - Move back to standard %{prefix}
  510. * Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
  511. - Rebuild in /opt/gtk-beta
  512. * Tue May 30 2000 Owen Taylor <otaylor@redhat.com>
  513. - New version (adds gobject)
  514. * Tue Apr 25 2000 Owen Taylor <otaylor@redhat.com>
  515. - Don't blow away /etc/ld.so.conf (sorry!)
  516. * Mon Apr 24 2000 Owen Taylor <otaylor@redhat.com>
  517. - Snapshot RPM for Pango testing
  518. * Fri Feb 04 2000 Owen Taylor <otaylor@redhat.com>
  519. - Added fixes from stable branch of CVS
  520. * Thu Oct 7 1999 Owen Taylor <otaylor@redhat.com>
  521. - version 1.2.6
  522. * Fri Sep 24 1999 Owen Taylor <otaylor@redhat.com>
  523. - version 1.2.5
  524. * Fri Sep 17 1999 Owen Taylor <otaylor@redhat.com>
  525. - version 1.2.4
  526. * Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
  527. - version 1.2.3
  528. * Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
  529. - version 1.2.1
  530. * Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
  531. - Version 1.2
  532. * Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
  533. - version 1.2.0pre1
  534. * Tue Feb 23 1999 Cristian Gafton <gafton@redhat.com>
  535. - new description tags
  536. * Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
  537. - removed libtoolize from %build
  538. * Thu Feb 11 1999 Michael Fulbright <drmike@redhat.com>
  539. - added libgthread to file list
  540. * Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
  541. - version 1.1.15
  542. * Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
  543. - version 1.1.14
  544. * Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
  545. - version 1.1.13
  546. * Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
  547. - version 1.1.12
  548. * Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
  549. - updated in preparation for the GNOME freeze
  550. * Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
  551. - Split out glib package