gnome-shell-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346
  1. %define pkg_version 3.18.2
  2. %define pkg_release 1%{?_dist_release}
  3. Summary: Window management and application launching for GNOME
  4. Summary(ja): GNOME 上でウィンドウの管理及びアプリケーションの起動を行うインターフェース
  5. Name: gnome-shell
  6. Version: %{pkg_version}
  7. Release: %{pkg_release}
  8. Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.18/%{name}-%{version}.tar.xz
  9. # settings for Vine
  10. Patch101: gnome-shell-3.14.1-vine-settings.patch
  11. Patch102: gnome-shell-3.16.0-revert-loginManager.patch
  12. Patch103: gnome-shell-3.16.2-disable-packagekit.patch
  13. Patch104: gnome-shell-3.18.1-vine-themes.patch
  14. License: GPLv2+
  15. Group: User Interface/Desktops
  16. URL: http://live.gnome.org/GnomeShell
  17. Requires: mutter
  18. Requires: caribou
  19. Requires: ca-certificates
  20. Requires: at-spi2-atk
  21. Requires: telepathy-logger
  22. Requires: network-manager-applet
  23. Requires: gnome-tweak-tool
  24. BuildRequires: gnome-common
  25. BuildRequires: libtool
  26. BuildRequires: automake
  27. BuildRequires: autoconf
  28. BuildRequires: pkgconfig
  29. BuildRequires: gtk2-devel
  30. BuildRequires: clutter-devel
  31. BuildRequires: mutter-devel
  32. BuildRequires: gjs-devel
  33. BuildRequires: gnome-desktop3-devel
  34. BuildRequires: gnome-menus-devel
  35. BuildRequires: libSM-devel
  36. BuildRequires: libffi-devel
  37. BuildRequires: startup-notification-devel
  38. BuildRequires: gnome-doc-utils
  39. BuildRequires: desktop-file-utils
  40. BuildRequires: libcroco-devel
  41. BuildRequires: librsvg2-devel
  42. BuildRequires: gobject-introspection-devel
  43. BuildRequires: control-center-devel
  44. BuildRequires: gcr-devel
  45. BuildRequires: gstreamer-devel
  46. BuildRequires: dbus-glib-devel
  47. BuildRequires: telepathy-logger-devel
  48. BuildRequires: polkit-devel
  49. BuildRequires: pulseaudio-libs-devel
  50. BuildRequires: evolution-data-server-devel
  51. BuildRequires: folks-devel
  52. BuildRequires: NetworkManager-glib-devel
  53. BuildRequires: libnm-gtk-devel
  54. BuildRequires: libgudev1-devel
  55. BuildRequires: libcanberra-gtk3-devel
  56. BuildRequires: caribou-devel
  57. BuildRequires: ca-certificates
  58. BuildRequires: python3-devel
  59. BuildRequires: intltool
  60. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  61. Vendor: Project Vine
  62. Distribution: Vine Linux
  63. Packager: Takemikaduchi
  64. %description
  65. GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
  66. It provides core interface functions like switching to windows and launching
  67. applications. GNOME Shell takes advantage of the capabilities of modern graphics
  68. hardware and introduces innovative user interface concepts to provide a delightful
  69. and easy to use experience.
  70. %package docs
  71. Summary: Documentation for %{name}
  72. Summary(ja): %{name} 用のドキュメント
  73. Group: Documentation
  74. Requires: %{name} = %{version}-%{release}
  75. BuildArch: noarch
  76. %description docs
  77. This package contains documentation for %{name}.
  78. %prep
  79. %setup -q
  80. %patch101 -p1 -b .vine
  81. %patch102 -p1 -b .vine
  82. %patch103 -p1 -b .vine
  83. %patch104 -p1 -b .vine
  84. %build
  85. %configure \
  86. --disable-static \
  87. --disable-systemd
  88. %{__make} %{?_smp_mflags} V=1
  89. %install
  90. %{__rm} -rf ${RPM_BUILD_ROOT}
  91. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  92. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  93. rm $RPM_BUILD_ROOT%{_datadir}/applications/gnome-shell-wayland.desktop
  94. %find_lang %{name}
  95. %clean
  96. %{__rm} -rf ${RPM_BUILD_ROOT}
  97. %post
  98. /sbin/ldconfig
  99. touch --no-create %{_datadir}/icons/hicolor
  100. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  101. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  102. fi
  103. %postun
  104. /sbin/ldconfig
  105. touch --no-create %{_datadir}/icons/hicolor
  106. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  107. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  108. fi
  109. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  110. %posttrans
  111. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  112. %files -f %{name}.lang
  113. %defattr(-,root,root,-)
  114. %doc COPYING NEWS README
  115. %{_bindir}/gnome-shell
  116. %{_bindir}/gnome-shell-extension-tool
  117. %{_bindir}/gnome-shell-extension-prefs
  118. %{_bindir}/gnome-shell-perf-tool
  119. %{_libdir}/%{name}/*
  120. %{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
  121. %{_libexecdir}/gnome-shell-calendar-server
  122. %{_libexecdir}/gnome-shell-hotplug-sniffer
  123. %{_libexecdir}/gnome-shell-perf-helper
  124. %{_libexecdir}/gnome-shell-portal-helper
  125. %{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
  126. %{_datadir}/applications/gnome-shell.desktop
  127. %{_datadir}/applications/gnome-shell-extension-prefs.desktop
  128. %{_datadir}/applications/evolution-calendar.desktop
  129. %{_datadir}/applications/org.gnome.Shell.PortalHelper.desktop
  130. %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
  131. %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
  132. %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
  133. %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
  134. %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
  135. %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
  136. %{_datadir}/dbus-1/services/org.gnome.Shell.PortalHelper.service
  137. %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
  138. %{_datadir}/%{name}/*
  139. %{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
  140. %{_mandir}/man1/%{name}.1.gz
  141. %files docs
  142. %defattr(-,root,root,-)
  143. %{_datadir}/gtk-doc/html/shell
  144. %{_datadir}/gtk-doc/html/st
  145. %changelog
  146. * Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-1
  147. - new upstream release
  148. * Thu Nov 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
  149. - new upstream release
  150. - update Patch104 (gnome-shell-3.18.1-vine-themes.patch)
  151. * Sun Jul 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.3-1
  152. - new upstream release
  153. * Sun Jun 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-3
  154. - add Patch104 (gnome-shell-3.16.2-vine-themes.patch)
  155. * Sun May 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-2
  156. - add Patch103 (gnome-shell-3.16.2-disable-packagekit.patch)
  157. * Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
  158. - new upstream release
  159. * Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
  160. - new upstream release
  161. * Thu Apr 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
  162. - new upstream release
  163. - add BuildRequires: python3-devel
  164. - update Patch102 (gnome-shell-3.16.0-revert-loginManager.patch)
  165. * Tue Feb 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.14.3-2
  166. - rebuilt with libical 1.0.1
  167. * Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.3-1
  168. - new upstream release
  169. * Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
  170. - new upstream release
  171. * Sat Nov 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1.5-1
  172. - new upstream release
  173. - update Patch101 (gnome-shell-3.14.1-vine-settings.patch)
  174. - add Patch102 (gnome-shell-3.14.1.5-revert-loginManager.patch)
  175. * Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
  176. - new upstream release
  177. * Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
  178. - new upstream release
  179. * Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
  180. - new upstream release
  181. * Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
  182. - new upstream release
  183. * Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2.1-1
  184. - new upstream release
  185. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
  186. - new upstream release
  187. * Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4-1
  188. - new upstream release
  189. * Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
  190. - new upstream release
  191. * Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
  192. - new upstream release
  193. * Mon Apr 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
  194. - new upstream release
  195. - update Patch101 (gnome-shell-vine-settings.patch)
  196. - add BuildRequires: control-center-devel, libnm-gtk-devel, caribou-devel
  197. - add Requires: telepathy-logger, network-manager-applet, gnome-tweak-tool
  198. - create %%{name}-docs subpackage
  199. * Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3.1-1
  200. - new upstream release
  201. - remove Source102 (gnome-shell.gnome-3-6.ja.po)
  202. * Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
  203. - new upstream release
  204. - add Source102 (gnome-shell.gnome-3-6.ja.po)
  205. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
  206. - new upstream release
  207. - remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
  208. * Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
  209. - rebuild with telepathy-logger-0.6.0
  210. - add Patch0 (gnome-shell-3.4.1-git20121031.patch)
  211. * Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
  212. - new upstream release
  213. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  214. - new upstream release
  215. - add Patch0 (gnome-shell-3.5.92-git20120921.patch)
  216. - update Patch101 (gnome-shell-vine-settings.patch)
  217. - change BuildRequires: ca-certificates instead of openssl
  218. - add BuildRequires: libcanberra-gtl3-devel
  219. * Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  220. - new upstream release
  221. - remove Patch103 (gnome-shell-ja.po-date.patch)
  222. * Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  223. - new upstream release
  224. - update Patch101,103
  225. - remove Patch0,102
  226. - add BuildRequires: gcr-devel
  227. - remove BuildRequires: GConf2-devel
  228. - add Requires: at-spi2-atk
  229. * Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
  230. - new upstream release
  231. - remove Patch1
  232. * Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
  233. - add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
  234. - add Patch1 (gnome-shell-3.2.1-ja.po.patch)
  235. - rename Patch103 (gnome-shell-ja.po-date.patch)
  236. - drop Patch102
  237. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  238. - new upstream release
  239. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  240. - new upstream release
  241. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  242. - new upstream release
  243. - update Patch101
  244. - update Patch102
  245. - update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
  246. - add BuildRequires: libgudev1-devel, openssl
  247. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
  248. - new upstream release
  249. - add BuildRequires: folks-devel, NetworkManager-glib-devel
  250. - add Requires: caribou
  251. - remove Patch0
  252. - update Patch101
  253. - update Patch102
  254. - update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
  255. * Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
  256. - rebuild with gnome-menus-3.1.5
  257. - add Patch0 (gnome-shell-git20110821.patch)
  258. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  259. - new upstream release
  260. - add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
  261. - change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
  262. - remove BuildRequires: xulrunner-devel
  263. - add Patch101 (gnome-shell-vine-settings.patch)
  264. - add Patch102 (gnome-shell-vine-customize.patch)
  265. - add Patch103 (gnome-shell-3.1.4-ja.po.patch)
  266. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
  267. - add Requires: mutter
  268. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
  269. - new upstream release
  270. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  271. - initial build for Vine Linux