gtk3-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491
  1. # Note that this is NOT a relocatable package
  2. %define glib2_base_version 2.46.0
  3. %define glib2_version %{glib2_base_version}-1
  4. %define pango_base_version 1.38.0
  5. %define pango_version %{pango_base_version}-1
  6. %define atk_base_version 2.18.0
  7. %define atk_version %{atk_base_version}-1
  8. %define cairo_base_version 1.14.4
  9. %define cairo_version %{cairo_base_version}-1
  10. %define gdkpixbuf2_base_version 2.32.0
  11. %define gdkpixbuf2_version %{gdkpixbuf2_base_version}-1
  12. %define gobject_introspection_version 1.46.0
  13. %define base_version 3.18.4
  14. %define bin_version 3.0.0
  15. # biarch support
  16. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  17. %define _query_suffix %{nil}
  18. %if %{build_compat32}
  19. %define _query_suffix -32
  20. %endif
  21. Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
  22. Summary(ja): X 用 GUI 作成ライブラリ: GIMP ツールキット(GTK+)
  23. Name: gtk3
  24. Version: %{base_version}
  25. Release: 1%{?_dist_release}
  26. License: LGPL
  27. Group: System Environment/Libraries
  28. Source: http://ftp.gnome.org/pub/GNOME/sources/gtk+/3.18/gtk+-%{version}.tar.xz
  29. Patch0: gtk3-3.10.0-gtk-widget-size-allocate.patch
  30. # for Vine
  31. Patch100: gtk+-3.14.0-vine-default-theme.patch
  32. BuildRequires: atk-devel >= %{atk_version}
  33. BuildRequires: at-spi2-atk-devel
  34. BuildRequires: pango-devel >= %{pango_version}
  35. BuildRequires: glib2-devel >= %{glib2_version}
  36. BuildRequires: cairo-devel >= %{cairo_version}
  37. BuildRequires: gdk-pixbuf2-devel >= %{gdkpixbuf2_version}
  38. BuildRequires: gtk2-devel
  39. BuildRequires: gobject-introspection-devel >= %{gobject_introspection_version}
  40. BuildRequires: libtiff-devel >= 3.7
  41. BuildRequires: libjpeg-turbo-devel
  42. BuildRequires: libpng-devel
  43. BuildRequires: jasper-devel
  44. BuildRequires: colord-devel
  45. BuildRequires: gtk-doc >= 1.20
  46. BuildRequires: gamin-devel
  47. BuildRequires: cups-devel
  48. BuildRequires: rest-devel
  49. BuildRequires: json-glib-devel
  50. BuildRequires: libepoxy-devel
  51. BuildRequires: libICE-devel
  52. BuildRequires: libXext-devel
  53. BuildRequires: libXi-devel
  54. BuildRequires: libXrandr-devel >= 1.3.0
  55. BuildRequires: libXrender-devel
  56. BuildRequires: libXcursor-devel
  57. BuildRequires: libXfixes-devel
  58. BuildRequires: libXinerama-devel
  59. BuildRequires: libXcomposite-devel
  60. BuildRequires: libXdamage-devel
  61. BuildRoot: %{_tmppath}/gtk-%{version}-root
  62. URL: http://www.gtk.org
  63. # required for icon themes apis to work
  64. Requires: hicolor-icon-theme
  65. # We need to prereq these so we can run gtk-query-immodules-2.0
  66. Requires(post): glib2 >= %{glib2_version}
  67. Requires(post): atk >= %{atk_version}
  68. Requires(post): pango >= %{pango_version}
  69. Requires(post): libSM >= 1.1.0
  70. # We need to prereq libtiff >= 3.7 to run gdk-pixbuf-query-loaders
  71. Requires(post): libtiff >= 3.7
  72. Requires: libXrandr >= 1.3.0
  73. Vendor: Project Vine
  74. Distribution: Vine Linux
  75. Packager: Takemikaduchi
  76. %description
  77. GTK+ is a multi-platform toolkit for creating graphical user
  78. interfaces. Offering a complete set of widgets, GTK+ is suitable for
  79. projects ranging from small one-off tools to complete application
  80. suites.
  81. %package devel
  82. Summary: Development tools for GTK+ applications.
  83. Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
  84. Group: Development/Libraries
  85. Requires: %{name} = %{version}-%{release}
  86. Requires: pango-devel >= %{pango_version}
  87. Requires: atk-devel >= %{atk_version}
  88. Requires: glib2-devel >= %{glib2_version}
  89. Requires: gdk-pixbuf2-devel >= %{gdkpixbuf2_version}
  90. Requires: libX11-devel, libXcursor-devel, libXinerama-devel
  91. Requires: libXext-devel, libXi-devel, libXrandr-devel
  92. Requires: libXfixes-devel, libXcomposite-devel
  93. Requires: libpng-devel
  94. %description devel
  95. The gtk+-devel package contains the header files and developer
  96. docs for the GTK+ widget toolkit.
  97. #######################################################################
  98. # compat32
  99. %package -n compat32-%{name}
  100. Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
  101. Summary(ja): X 用 GUI 作成ライブラリ: GIMP ツールキット(GTK+)
  102. Group: System Environment/Libraries
  103. Requires(post): compat32-glib2 >= %{glib2_version}
  104. Requires(post): compat32-atk >= %{atk_version}
  105. Requires(post): compat32-pango >= %{pango_version}
  106. Requires(post): compat32-libSM >= 1.1.0
  107. Requires(post): compat32-libtiff >= 3.7
  108. Requires: compat32-libXrandr >= 1.3.0
  109. %description -n compat32-%{name}
  110. GTK+ is a multi-platform toolkit for creating graphical user
  111. interfaces. Offering a complete set of widgets, GTK+ is suitable for
  112. projects ranging from small one-off tools to complete application
  113. suites.
  114. %package -n compat32-%{name}-devel
  115. Summary: Development tools for GTK+ applications.
  116. Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
  117. Group: Development/Libraries
  118. Requires: compat32-%{name} = %{version}-%{release}
  119. Requires: %{name}-devel = %{version}
  120. Requires: compat32-libX11-devel, compat32-libXcursor-devel, compat32-libXinerama-devel
  121. Requires: compat32-libXext-devel, compat32-libXi-devel, compat32-libXrandr-devel
  122. Requires: compat32-libXfixes-devel, compat32-libXcomposite-devel
  123. Requires: compat32-libpng-devel
  124. %description -n compat32-%{name}-devel
  125. The gtk+-devel package contains the header files and developer
  126. docs for the GTK+ widget toolkit.
  127. %prep
  128. %setup -q -n gtk+-%{version}
  129. %patch0 -p1 -b .allocate
  130. %patch100 -p1 -b .vine-default-theme
  131. #for i in config.guess config.sub ; do
  132. # test -f %{_datadir}/libtool/$i && cp %{_datadir}/libtool/$i .
  133. #done
  134. %build
  135. # if ! pkg-config --exists pangoxft ; then
  136. # echo "No pangoxft.pc!"
  137. # exit 1
  138. # fi
  139. #libtoolize --force --copy
  140. #autoreconf -i
  141. %configure \
  142. --enable-gtk2-dependency \
  143. --enable-man \
  144. --enable-gtk-doc \
  145. --enable-debug=minimum \
  146. --disable-rebuilds \
  147. --disable-glibtest \
  148. --enable-introspection=yes \
  149. --enable-xkb=yes \
  150. --enable-xinerama=yes \
  151. --enable-xrandr=yes \
  152. --enable-xfixes=yes \
  153. --enable-xcomposite=yes \
  154. --enable-xdamage=yes \
  155. --enable-x11-backend \
  156. --disable-packagekit \
  157. --enable-colord=yes
  158. # fight unused direct deps
  159. sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
  160. make %{?_smp_mflags}
  161. %install
  162. rm -rf $RPM_BUILD_ROOT
  163. make install DESTDIR=$RPM_BUILD_ROOT RUN_QUERY_IMMODULES_TEST=false RUN_QUERY_LOADER_TEST=false
  164. %find_lang gtk30
  165. %find_lang gtk30-properties
  166. cat gtk30.lang gtk30-properties.lang > all.lang
  167. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gtk-3.0
  168. # We need to have separate 32-bit and 64-bit binaries
  169. # for places where we have two copies of the GTK+ package installed.
  170. # (we might have x86_64 and i686 packages on the same system, for example.)
  171. %if %{build_compat32}
  172. cp $RPM_BUILD_ROOT%{_bindir}/gtk-query-immodules-3.0 \
  173. $RPM_BUILD_ROOT%{_bindir}/gtk-query-immodules-3.0%{_query_suffix}
  174. %endif
  175. touch $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/%{bin_version}/immodules.cache
  176. mkdir -p $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/modules
  177. mkdir -p $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/immodules
  178. # Remove unpackaged files
  179. find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
  180. rm -rf $RPM_BUILD_ROOT%{_datadir}/themes/Raleigh
  181. %clean
  182. rm -rf $RPM_BUILD_ROOT
  183. %post
  184. /sbin/ldconfig
  185. %{_bindir}/gtk-query-immodules-3.0 --update-cache || : > /dev/null 2>&1
  186. %postun
  187. /sbin/ldconfig
  188. if [ $1 -gt 0 ]; then
  189. %{_bindir}/gtk-query-immodules-3.0 --update-cache || : > /dev/null 2>&1
  190. fi
  191. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  192. %posttrans
  193. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  194. %if %{build_compat32}
  195. %post -n compat32-%{name}
  196. /sbin/ldconfig
  197. %{_bindir}/gtk-query-immodules-3.0%{_query_suffix} --update-cache || : > /dev/null 2>&1
  198. %postun -n compat32-%{name}
  199. /sbin/ldconfig
  200. if [ $1 = 0 ]; then
  201. %{_bindir}/gtk-query-immodules-3.0%{_query_suffix} --update-cache || : > /dev/null 2>&1
  202. fi
  203. %endif
  204. %files -f all.lang
  205. %defattr(-, root, root)
  206. %doc AUTHORS COPYING ChangeLog NEWS README
  207. %{_bindir}/gtk3-demo
  208. %{_bindir}/gtk3-demo-application
  209. %{_bindir}/gtk3-widget-factory
  210. %{_bindir}/gtk-encode-symbolic-svg
  211. %{_bindir}/gtk3-icon-browser
  212. %{_bindir}/gtk-launch
  213. %{_bindir}/gtk-builder-tool
  214. %exclude %{_bindir}/gtk-update-icon-cache
  215. %{_bindir}/gtk-query-immodules-3.0
  216. %{_libdir}/libgtk-3.so.*
  217. %{_libdir}/libgdk-3.so.*
  218. %{_libdir}/libgailutil-3.so.*
  219. %dir %{_libdir}/gtk-3.0
  220. %{_libdir}/gtk-3.0/%{bin_version}
  221. %dir %{_libdir}/gtk-3.0/modules
  222. %{_libdir}/girepository-1.0/*.typelib
  223. %{_datadir}/applications/gtk3-demo.desktop
  224. %{_datadir}/applications/gtk3-icon-browser.desktop
  225. %{_datadir}/applications/gtk3-widget-factory.desktop
  226. %{_datadir}/gtk-3.0
  227. %{_datadir}/icons/hicolor/*/apps/*
  228. %{_datadir}/themes/Default
  229. %{_datadir}/themes/Emacs
  230. %dir %{_sysconfdir}/gtk-3.0
  231. %{_sysconfdir}/gtk-3.0/im-multipress.conf
  232. %{_datadir}/glib-2.0/schemas/*.xml
  233. %files devel
  234. %defattr(-, root, root)
  235. %{_libdir}/lib*.so
  236. %dir %{_libdir}/gtk-3.0
  237. %{_datadir}/gtk-doc/
  238. %{_datadir}/gir-1.0/*.gir
  239. %{_mandir}/man1/*
  240. %exclude %{_mandir}/man1/gtk-update-icon-cache.1.gz
  241. %{_includedir}/*
  242. %{_datadir}/aclocal/*
  243. %{_libdir}/pkgconfig/*
  244. # compat32
  245. %if %{build_compat32}
  246. %files -n compat32-%{name}
  247. %defattr(-, root, root)
  248. %{_bindir}/gtk-query-immodules-3.0%{_query_suffix}
  249. %{_libdir}/libgtk-3.so.*
  250. %{_libdir}/libgdk-3.so.*
  251. %{_libdir}/libgailutil-3.so.*
  252. %dir %{_libdir}/gtk-3.0
  253. %{_libdir}/gtk-3.0/%{bin_version}
  254. %dir %{_libdir}/gtk-3.0/modules
  255. %dir %{_sysconfdir}/gtk-3.0
  256. %files -n compat32-%{name}-devel
  257. %defattr(-, root, root)
  258. %{_libdir}/lib*.so
  259. %dir %{_libdir}/gtk-3.0
  260. %endif
  261. %changelog
  262. * Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.4-1
  263. - new upstream release
  264. * Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-1
  265. - new upstream release
  266. * Sat Oct 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.7-1
  267. - new upstream release
  268. * Sun Jul 26 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.6-1
  269. - new upstream release
  270. * Fri Jul 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.5-1
  271. - new upstream release
  272. * Thu Jun 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.4-1
  273. - new upstream release
  274. * Thu May 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.3-1
  275. - new upstream release
  276. * Wed Apr 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
  277. - new upstream release
  278. * Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
  279. - new upstream release
  280. - add BuildRequires: libepoxy-devel
  281. * Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.9-1
  282. - new upstream release
  283. * Sun Feb 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.8-1
  284. - new upstream release
  285. * Mon Jan 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.7-1
  286. - new upstream release
  287. * Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.6-1
  288. - new upstream release
  289. * Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.5-1
  290. - new upstream release
  291. - add BuildRequires: gtk2-devel, rest-devel, json-glib-devel
  292. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.4-1
  293. - new upstream release
  294. - update Patch100 (gtk+-3.14.0-vine-default-theme.patch)
  295. * Wed May 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
  296. - new upstream release
  297. * Sun Apr 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
  298. - new upstream release
  299. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
  300. - new upstream release
  301. - update Patch100 (gtk+-3.12.0-vine-default-theme.patch)
  302. * Sat Feb 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.7-1
  303. - new upstream release
  304. * Sat Dec 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.6-1
  305. - new upstream release
  306. * Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.5-1
  307. - new upstream release
  308. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
  309. - new upstream release
  310. - update Patch0 (gtk3-3.10.0-gtk-widget-size-allocate.patch)
  311. - remove Patch1 (gtk3-3.8.2-immodule.patch)
  312. * Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4-1
  313. - new upstream release
  314. * Tue Aug 13 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-2
  315. - add Patch1 (gtk3-3.8.2-immodule.patch)
  316. * Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
  317. - new upstream release
  318. * Fri Apr 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
  319. - new upstream release
  320. * Tue Jan 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.4-1
  321. - new upstream release
  322. * Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
  323. - new upstream release
  324. * Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
  325. - new upstream release
  326. * Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
  327. - new upstream release
  328. * Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  329. - new upstream release
  330. - add BuildRequires: at-spi2-atk-devel
  331. * Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
  332. - new upstream release
  333. * Sat May 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
  334. - new upstream release
  335. * Sun May 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  336. - new upstream release
  337. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  338. - new upstream release
  339. - update Patch100 (gtk+-3.4.0-vine-default-theme.patch)
  340. * Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.4-1
  341. - new upstream release
  342. * Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
  343. - new upstream release
  344. * Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
  345. - new upstream release
  346. - remove Patch1
  347. * Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  348. - new upstream release
  349. - add Patch1 (gtk3-3.2.1-bug658772.patch)
  350. * Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  351. - new upstream release
  352. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  353. - new upstream release
  354. * Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.18-1
  355. - new upstream release
  356. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.16-1
  357. - new upstream release
  358. * Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.12-1
  359. - new upstream release
  360. - add Patch0 (gtk3-3.1.12-gtk-widget-size-allocate.patch)
  361. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10-2
  362. - fix %%files
  363. * Sat Jul 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10-1
  364. - new upstream release
  365. - add BuildRequires: colord-devel
  366. * Sun Jun 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.11-1
  367. - new upstream release
  368. * Sun Apr 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.9-1
  369. - new upstream release
  370. * Sat Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.8-1
  371. - new upstream release
  372. * Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.7-1
  373. - new upstream release
  374. * Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.6-1
  375. - new upstream release
  376. * Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.4-1
  377. - new upstream release
  378. * Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.3-1
  379. - new upstream release
  380. * Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
  381. - new upstream release
  382. * Tue Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-1
  383. - new upstream release
  384. * Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.0-1
  385. - initial build for Vine Linux