nsd-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310
  1. Summary: Fast and lean authoritative DNS Name Server
  2. Summary(ja): 高速で最小限のAuthoritative専用DNSネームサーバ
  3. Name: nsd
  4. Version: 4.1.6
  5. Release: 1%{?_dist_release}
  6. License: BSD
  7. Url: http://www.nlnetlabs.nl/%{name}/
  8. Source: http://www.nlnetlabs.nl/downloads/%{name}/%{name}-%{version}.tar.gz
  9. Source1: nsd.init
  10. Source3: nsd.sysconfig
  11. Group: System Environment/Daemons
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  13. BuildRequires: flex, libevent-devel, openssl-devel
  14. Requires(pre): shadow-utils
  15. %description
  16. NSD is a complete implementation of an authoritative DNS name server.
  17. For further information about what NSD is and what NSD is not please
  18. consult the REQUIREMENTS document which is a part of this distribution
  19. %description -l ja
  20. NSD は Authoritative DNSネームサーバの完全な実装です。
  21. NSD に関する詳しい情報は REQUIREMENTS ドキュメントを参照してください。
  22. %prep
  23. %setup -q
  24. %build
  25. %configure \
  26. --with-configdir=%{_sysconfdir}/nsd \
  27. --with-nsd_conf_file=%{_sysconfdir}/nsd/nsd.conf \
  28. --with-zonesdir=%{_sysconfdir}/nsd \
  29. --with-pidfile=%{_localstatedir}/run/%{name}/%{name}.pid \
  30. --with-dbfile=%{_localstatedir}/lib/%{name}/nsd.db \
  31. --with-difffile=%{_localstatedir}/lib/%{name}/ixfr.db \
  32. --with-xfrdfile=%{_localstatedir}/lib/%{name}/ixfr.state \
  33. --with-max-ips=1024 \
  34. --with-ssl \
  35. --with-user=nsd \
  36. --enable-bind8-stats \
  37. --enable-checking \
  38. --enable-mmap \
  39. --enable-nsec3 \
  40. --enable-ratelimit
  41. %{__make} %{?_smp_mflags}
  42. #convert to utf8
  43. iconv -f iso8859-1 -t utf-8 doc/RELNOTES > doc/RELNOTES.utf8
  44. iconv -f iso8859-1 -t utf-8 doc/CREDITS > doc/CREDITS.utf8
  45. mv -f doc/RELNOTES.utf8 doc/RELNOTES
  46. mv -f doc/CREDITS.utf8 doc/CREDITS
  47. %install
  48. rm -rf %{buildroot}
  49. %{__make} DESTDIR=%{buildroot} install
  50. install -d -m 0755 %{buildroot}%{_initrddir}
  51. install -m 0755 %{SOURCE1} %{buildroot}/%{_initrddir}/nsd
  52. install -d -m 0700 %{buildroot}%{_localstatedir}/run/%{name}
  53. install -d -m 0700 %{buildroot}%{_localstatedir}/lib/%{name}
  54. install -d -m 0755 %{buildroot}%{_sysconfdir}/sysconfig
  55. install -m 0755 %{SOURCE3} %{buildroot}/%{_sysconfdir}/sysconfig/%{name}
  56. # change .sample to normal config files
  57. head -150 %{buildroot}%{_sysconfdir}/nsd/nsd.conf.sample > %{buildroot}%{_sysconfdir}/nsd/nsd.conf
  58. echo "database: /var/lib/nsd/nsd.db" >> %{buildroot}%{_sysconfdir}/nsd/nsd.conf
  59. head -175 %{buildroot}%{_sysconfdir}/nsd/nsd.conf.sample | tail -26 >> %{buildroot}%{_sysconfdir}/nsd/nsd.conf
  60. echo "# include: \"/some/path/file\"" >> %{buildroot}%{_sysconfdir}/nsd/nsd.conf
  61. rm %{buildroot}%{_sysconfdir}/nsd/nsd.conf.sample
  62. %clean
  63. rm -rf ${RPM_BUILD_ROOT}
  64. %files
  65. %defattr(-,root,root,-)
  66. %doc doc/*
  67. %doc contrib/nsd.zones2nsd.conf
  68. %dir %{_sysconfdir}/nsd/
  69. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/nsd/nsd.conf
  70. #%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/nsd/nsd.zones
  71. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/nsd
  72. %attr(0755,root,root) %{_initrddir}/%{name}
  73. %ghost %attr(0755,%{name},%{name}) %dir %{_localstatedir}/run/%{name}
  74. %attr(0755,%{name},%{name}) %dir %{_localstatedir}/lib/%{name}
  75. %{_sbindir}/*
  76. %{_mandir}/*/*
  77. %pre
  78. getent group nsd >/dev/null || groupadd -r nsd
  79. getent passwd nsd >/dev/null || \
  80. useradd -r -g nsd -d /etc/nsd -s /sbin/nologin \
  81. -c "nsd daemon account" nsd
  82. exit 0
  83. %post
  84. /sbin/chkconfig --add %{name}
  85. chown -R nsd.nsd %{_localstatedir}/lib/nsd 2>/dev/null ||:
  86. chown -R nsd.nsd %{_localstatedir}/run/nsd 2>/dev/null ||:
  87. if [ ! -f %{_sysconfdir}/nsd/nsd_control.pem ]; then
  88. /usr/sbin/nsd-control-setup
  89. fi
  90. %preun
  91. if [ $1 -eq 0 ]; then
  92. /sbin/service %{name} stop
  93. /sbin/chkconfig --del %{name}
  94. fi
  95. %postun
  96. if [ "$1" -ge "1" ]; then
  97. /sbin/service %{name} condrestart
  98. fi
  99. %changelog
  100. * Tue Nov 3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.6-1
  101. - new upstream release.
  102. * Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.3-1
  103. - new upstream release.
  104. - dropped Source2 (no longer needed).
  105. * Sat Feb 23 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.15-1
  106. - new upstream release
  107. * Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.12-1
  108. - new upstream release
  109. * Wed Feb 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.10-1
  110. - new upstream release
  111. * Fri Mar 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.8-1
  112. - new upstream release
  113. * Sat May 29 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.4-1
  114. - initial build for Vine Linux
  115. * Wed Jan 06 2010 Paul Wouters <paul@xelerance.com> - 3.2.4-1
  116. - Updated to nsd 3.2.4
  117. * Tue Jan 05 2010 Paul Wouters <paul@xelerance.com> - 3.2.3-4
  118. - Incorporated Ville Mattila's fixes to nsd.cron
  119. - Support for NSD_AUTOREBUILD in /etc/sysconfig/nsd [Ville]
  120. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 3.2.3-3
  121. - rebuilt with new openssl
  122. * Thu Aug 20 2009 Ville Mattila <vmattila@csc.fi> - 3.2.3-2
  123. - The 'nsdc patch' and 'nsdc rebuild' commands wrote a %%1 file by mistake
  124. * Mon Aug 17 2009 Paul Wouters <paul@xelerance.com> - 3.2.3-1
  125. -Updated to version 3.2.3
  126. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.2-4
  127. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  128. * Sat Jun 06 2009 Paul Wouters <paul@xelerance.com> - 3.2.2-3
  129. - Fixed /dev/nul which cause a file \%%1 to be written by cron
  130. - Bump for EVR.
  131. * Mon May 18 2009 Paul Wouters <paul@xelerance.com> - 3.2.2-1
  132. - Upgraded to 3.2.2 security release
  133. http://www.nlnetlabs.nl/publications/NSD_vulnerability_announcement.html
  134. * Thu Apr 09 2009 Ville Mattila <vmattila@csc.fi> - 3.2.1-6
  135. - Make various file paths used by the nsd.init script configurable
  136. from /etc/sysconfig/nsd.
  137. - Add template /etc/sysconfig/nsd.
  138. * Sun Mar 08 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-5
  139. - nsd used the 'named' subsystem in one call in the init script
  140. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-4
  141. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  142. * Mon Jan 26 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-3
  143. - Fix init script 'unary operator' error.
  144. * Mon Jan 26 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-1
  145. - Updated to new version 3.2.1
  146. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 3.2.0-4
  147. - rebuild with new openssl
  148. * Mon Nov 24 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-3
  149. - Updates summary as per Richard Hughes guidelines
  150. * Mon Nov 10 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-2
  151. - Bump version after pre-release version correction.
  152. * Mon Nov 10 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-1
  153. - 3.2.0-1
  154. * Thu Oct 9 2008 Paul Wouters <paul@xelerance.com> - 3.1.1-1
  155. - updated to 3.1.1
  156. * Mon Aug 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 3.1.0-2
  157. - fix license tag
  158. - fix static user creation
  159. * Mon Jun 30 2008 Paul Wouters <paul@xelerance.com> - 3.1.0-1
  160. - Updated to 3.1.0
  161. * Tue May 6 2008 Paul Wouters <paul@xelerance.com> - 3.0.8-2
  162. - Fix /dev/null redirection [Venkatesh Krishnamurthi]
  163. * Tue May 6 2008 Paul Wouters <paul@xelerance.com> - 3.0.8-1
  164. - Updated to 3.0.8
  165. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.0.7-3
  166. - Autorebuild for GCC 4.3
  167. * Wed Dec 5 2007 Paul Wouters <paul@xelerance.com> - 3.0.7-2
  168. - Rebuild for new libcrypto
  169. * Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 3.0.7-1
  170. - Updated to new version
  171. - fix RELNOTES/README to be utf8
  172. - Fix path to nsd.db in cron job.
  173. * Thu Nov 8 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-7
  174. - Modified cron to only rebuild/reload when zone updates
  175. have been received
  176. * Wed Nov 7 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-6
  177. - Added hourly cron job to do various maintenance tasks
  178. - Added nsd rebuild to create the proper nsd.db file on startup
  179. - Added nsd patch on shutdown to ensure zonefiles are up to date
  180. * Tue Oct 2 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-5
  181. - nsdc update and nsdc notify are no longer needed in initscript.
  182. * Mon Sep 24 2007 Jesse Keating <jkeating@redhat.com> - 3.0.6-4
  183. - Bump release for upgrade path.
  184. * Fri Sep 14 2007 Paul Wouters <paul@xelerance.com> 3.0.6-3
  185. - Do not include examples from nsd.conf.sample that causes
  186. bogus network traffic.
  187. * Fri Sep 14 2007 Paul Wouters <paul@xelerance.com> 3.0.6-2
  188. - Change locations of ixfr.db and xfrd.state to /var/lib/nsd
  189. - Enable NSEC3
  190. - Delay running nsdc update until after nsd has started
  191. - Delete xfrd.state on nsd stop
  192. - Run nsdc notify in the background, since it can take
  193. a very long time when remote servers are unavailable.
  194. * Tue Sep 11 2007 Paul Wouters <paul@xelerance.com> 3.0.6-1
  195. - Upgraded to 3.0.6
  196. - Do not include bind2nsd, since it didn't compile for me
  197. * Fri Jul 13 2007 Paul Wouters <paul@xelerance.com> 3.0.5-2
  198. - Fix init script, bug #245546
  199. * Fri Mar 23 2007 Paul Wouters <paul@xelerance.com> 3.0.5-1
  200. - Upgraded to 3.0.5
  201. * Thu Dec 7 2006 Paul Wouters <paul@xelerance.com> 3.0.3-1
  202. - Upgraded to 3.0.3
  203. * Mon Nov 27 2006 Paul Wouters <paul@xelerance.com> 3.0.2-1
  204. - Upgraded to 3.0.2.
  205. - Use new configuration file nsd.conf. Still needs migration script.
  206. patch from Farkas Levente <lfarkas@bppiac.hu>
  207. * Mon Oct 16 2006 Paul Wouters <paul@xelerance.com> 2.3.6-2
  208. - Bump version for upgrade path
  209. * Thu Oct 12 2006 Paul Wouters <paul@xelerance.com> 2.3.6-1
  210. - Upgraded to 2.3.6
  211. - Removed obsolete workaround in nsd.init
  212. - Fixed spec file so daemon gets properly restarted on upgrade
  213. * Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 2.3.5-4
  214. - Rebuild requested for PT_GNU_HASH support from gcc
  215. - Removed dbaccess.c from doc section
  216. * Mon Jun 26 2006 Paul Wouters <paul@xelerance.com> - 2.3.5-3
  217. - Bump version for FC-x upgrade path
  218. * Mon Jun 26 2006 Paul Wouters <paul@xelerance.com> - 2.3.5-1
  219. - Upgraded to nsd-2.3.5
  220. * Sun May 7 2006 Paul Wouters <paul@xelerance.com> - 2.3.4-3
  221. - Upgraded to nsd-2.3.4.
  222. - Removed manual install targets because DESTDIR is now supported
  223. - Re-enabled --checking, checking patch no longer needed and removed.
  224. - Work around in nsd.init for nsd failing to start when there is no ipv6
  225. * Thu Dec 15 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-7
  226. - chkconfig and attribute changes as proposed by Dmitry Butskoy
  227. * Thu Dec 15 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-6
  228. - Moved pid file to /var/run/nsd/nsd.pid.
  229. - Use _localstatedir instead of "/var"
  230. * Tue Dec 13 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-5
  231. - Added BuildRequires for openssl-devel, removed Requires for openssl.
  232. * Mon Dec 12 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-4
  233. - upgraded to nsd-2.3.3
  234. * Wed Dec 7 2005 Tom "spot" Callaway <tcallawa@redhat.com> - 2.3.2-2
  235. - minor cleanups
  236. * Mon Dec 5 2005 Paul Wouters <paul@xelerance.com> - 2.3.2-1
  237. - Upgraded to 2.3.2. Changed post scripts to comply to Fedora
  238. Extras policies (eg do not start daemon on fresh install)
  239. * Tue Oct 4 2005 Paul Wouters <paul@xelerance.com> - 2.3.1-1
  240. - Initial version