gnome-python-vl.spec 8.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269
  1. %define pyver %(python -c 'import sys;print(sys.version[0:3])')
  2. # libzvt is in Extras but not Core
  3. %define buildzvt 0
  4. Summary: The sources for the PyGNOME Python extension module.
  5. Name: gnome-python
  6. Version: 2.28.1
  7. Release: 1%{?_dist_release}
  8. Source: ftp://ftp.gnome.org/pub/GNOME/sources/gnome-python/2.28/gnome-python-%{version}.tar.bz2
  9. License: LGPL
  10. Group: Development/Libraries
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: pygtk2-devel >= 2.14.0
  13. BuildRequires: python-devel >= 2.5
  14. BuildRequires: pyorbit-devel >= 2.24.0
  15. BuildRequires: pygobject-devel >= 2.17.0
  16. BuildRequires: libbonobo-devel >= 2.24.1
  17. BuildRequires: libbonoboui-devel >= 2.24.1
  18. BuildRequires: libgnome-devel >= 2.26.0
  19. BuildRequires: gnome-vfs2-devel >= 2.24.0
  20. BuildRequires: GConf2-devel >= 2.26.0
  21. %if %{buildzvt}
  22. BuildRequires: libzvt-devel >= 2.0.2
  23. %endif
  24. ## needed for automake/autoconf to work right with multilib python
  25. #BuildRequires: automake >= 1.9.6, libtool, autoconf
  26. #Obsoletes: gnome-python-applet
  27. Obsoletes: gnome-python-bonobo
  28. Obsoletes: gnome-python-canvas
  29. Obsoletes: gnome-python-gconf
  30. #Obsoletes: gnome-python-gnomeprint
  31. Obsoletes: gnome-python-gnomevfs
  32. #Obsoletes: gnome-python-gtkhtml2
  33. Obsoletes: gnome-python-nautilus
  34. %if %{buildzvt}
  35. Obsoletes: gnome-python-zvt
  36. %endif
  37. Requires: pyorbit >= 2.24.0
  38. Requires: pygtk2 >= 2.14.1
  39. %description
  40. The gnome-python package contains the source packages for the Python
  41. bindings for GNOME called PyGNOME.
  42. PyGNOME is an extension module for Python that provides access to the
  43. base GNOME libraries, so you have access to more widgets, a simple
  44. configuration interface, and metadata support.
  45. %package devel
  46. Summary: Development files for building add-on libraries
  47. Group: Development/Libraries
  48. Requires: %{name} = %{version}-%{release}
  49. Requires: gnome-vfs2-devel >= 2.24.0
  50. Requires: pkgconfig
  51. Requires: python-devel >= %{pyver}
  52. %description devel
  53. This package contains files required to build wrappers for GNOME add-on
  54. libraries so that they interoperate with gnome-python.
  55. %prep
  56. %setup -q -n gnome-python-%{version}
  57. %build
  58. # libtoolize --force
  59. # aclocal && automake && autoconf
  60. #export PYTHON=/usr/bin/python%{pyver}
  61. #CFLAGS="$RPM_OPT_FLAGS -L/usr/lib/python%{pyver}/config" \
  62. # ./configure --prefix=%{_prefix}
  63. %configure
  64. make
  65. %install
  66. rm -rf $RPM_BUILD_ROOT
  67. make install DESTDIR=$RPM_BUILD_ROOT
  68. find $RPM_BUILD_ROOT -name '*.la' -exec rm {} \;
  69. %clean
  70. rm -rf $RPM_BUILD_ROOT
  71. %files
  72. %defattr(-,root,root,-)
  73. %doc AUTHORS COPYING ChangeLog INSTALL NEWS README examples
  74. %{_libdir}/gnome-vfs-2.0/modules/libpythonmethod.so
  75. %{_libdir}/python?.?/site-packages/gtk-2.0/bonobo
  76. %{_libdir}/python?.?/site-packages/gtk-2.0/gconf.so
  77. %{_libdir}/python?.?/site-packages/gtk-2.0/gnome
  78. %{_libdir}/python?.?/site-packages/gtk-2.0/gnomecanvas.so
  79. %{_libdir}/python?.?/site-packages/gtk-2.0/gnomevfs
  80. %if %{buildzvt}
  81. %{_libdir}/python?.?/site-packages/gtk-2.0/zvt.so
  82. %endif
  83. %{_datadir}/pygtk/*
  84. %files devel
  85. %defattr(-,root,root,-)
  86. %{_includedir}/gnome-python-2.0
  87. %{_libdir}/pkgconfig/gnome-python-2.0.pc
  88. %{_datadir}/gtk-doc/html/pygnomevfs
  89. ## old versions did not have .pyc and .pyo files in their file list
  90. ## remove them now, or bad things will now happen because of the new
  91. ## paths. This trigger must remain until upgrading from RHL 8.0 is no
  92. ## longer supported.
  93. #%triggerun bonobo -- gnome-python-bonobo < 1.99.14-5
  94. #rm -f /usr/lib/python%{pyver}/site-packages/bonobo/__init__.{pyc,pyo}
  95. %changelog
  96. * Fri Apr 09 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-1
  97. - new upstream release
  98. - dropt "Obsoletes: gnome-python-gtkhtml2" (provided by gnome-python-extras)
  99. * Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
  100. - rebuild for python-2.6
  101. * Sun Nov 1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
  102. - new upstream release
  103. * Sun Apr 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
  104. - new upstream release
  105. - add Requires: pygtk2, pyorbit
  106. * Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  107. - new upstream release
  108. * Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
  109. - new upstream release
  110. * Sat Jul 19 2008 Shu KONNO <owa@bg.wakwak.com> 2.22.0-2vl5
  111. - rebuilt with python-2.5
  112. * Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
  113. - new upstream release
  114. - split devel package
  115. * Wed Jan 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
  116. - new upstream release
  117. * Sat Jul 7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
  118. - new upstream release
  119. * Mon May 8 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.4-0vl1
  120. - new upstream release 2.12.4
  121. * Thu Oct 13 2005 Shu KONNO <owa@bg.wakwak.com> 2.12.1-0vl1
  122. - new upstream release 2.12.1
  123. - obsolete all sub-packages
  124. * Sat Jun 11 2005 Shu KONNO <owa@bg.wakwak.com> 2.10.0-0vl2
  125. - dropped "Obsoletes: gnome-python-applet, -capplet, -nautilus,
  126. -gtkhtml2, -gnomeprint" because they moved to gnome-python-extras srpm
  127. * Mon Apr 04 2005 Shu KONNO <owa@bg.wakwak.com> 2.10.0-0vl1
  128. - new upstream release 2.10.0
  129. - rebuilt with python 2.4.1
  130. - dropped gnome-python-applet
  131. - dropped gnome-python-capplet
  132. - dropped gnome-python-nautilus
  133. - dropped gnome-python-gtkhtml2
  134. - dropped gnome-python-gnomeprint
  135. see also ftp://ftp.gnome.org/pub/GNOME/sources/gnome-python-extras
  136. * Mon Dec 27 2004 Kazuhisa TAKEI <takei@vinelinux.org> 2.6.2-0vl3
  137. - fixed BuildRequires/Requires for pyorbit's version
  138. * Mon Dec 27 2004 Kazuhisa TAKEI <takei@vinelinux.org> 2.6.2-0vl1
  139. - new upstream release
  140. * Thu Jun 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.2-0vl1
  141. - new upstream release
  142. * Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-2vl2
  143. - rebuild with python-2.3.3-0vl1
  144. * Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-2vl1.1
  145. - rebuild with python-2.3.3-0vl0.3 (for TestPkg)
  146. * Sat Jan 17 2004 Tomoya TAKA <taka@vinelinux.org> 2.0.0-2vl1
  147. - sync with Fedora 2.0.0-2
  148. * Thu Oct 2 2003 Matt Wilson <msw@redhat.com> 2.0.0-2
  149. - fix segv in gnome.ui.About() (#104396)
  150. - rebuild with new toolchain and pyorbit
  151. - s/Copyright/License/
  152. * Fri Sep 12 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.0-1vl1
  153. - build for Vine Linux
  154. * Thu Sep 4 2003 Jeremy Katz <katzj@redhat.com> 2.0.0-1
  155. - 2.0.0
  156. * Wed Aug 20 2003 Jeremy Katz <katzj@redhat.com> 1.99.16-1
  157. - update to 1.99.16
  158. - add gnomeprint subpackage
  159. - don't double include the gnome-vfs module (#102074)
  160. * Tue Aug 5 2003 Elliot Lee <sopwith@redhat.com> 1.99.14-7
  161. - Fix libtool
  162. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  163. - rebuilt
  164. * Thu Feb 6 2003 Matt Wilson <msw@redhat.com> 1.99.14-5
  165. - added a trigger to remove left-over bonobo .pyc and .pyo files (#79652)
  166. * Thu Feb 6 2003 Mihai Ibanescu <misa@redhat.com> 1.99.14-4
  167. - rebuilt against new python
  168. * Tue Jan 28 2003 Jeremy Katz <katzj@redhat.com> 1.99.14-3
  169. - libdir-ify
  170. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  171. - rebuilt
  172. * Fri Dec 27 2002 Jeremy Katz <katzj@redhat.com> 1.99.14-1
  173. - update to 1.99.14
  174. * Fri Dec 13 2002 Jeremy Katz <katzj@redhat.com>
  175. - update to 1.99.13
  176. - add gnomevfs subpackage
  177. * Thu Oct 31 2002 Matt Wilson <msw@redhat.com>
  178. - use %%configure
  179. * Wed Oct 30 2002 Matt Wilson <msw@redhat.com>
  180. - add gnome-python-2.0.pc to file list
  181. * Wed Aug 28 2002 Matt Wilson <msw@redhat.com>
  182. - bind gnome_client_set_*_command
  183. * Wed Aug 28 2002 Tim Powers <timp@redhat.com>
  184. - rebuilt
  185. * Tue Aug 20 2002 Matt Wilson <msw@redhat.com>
  186. - obsolete pygtk-applet (#69830)
  187. * Thu Aug 1 2002 Jonathan Blandford <jrb@redhat.com>
  188. - make the GnomeDruid's fields accessible from python
  189. * Tue Jul 30 2002 Matt Wilson <msw@redhat.com>
  190. - official 1.99.11 release
  191. * Thu May 30 2002 Matt Wilson <msw@redhat.com>
  192. - s/Gconf/GConf/
  193. * Thu May 30 2002 Jeremy Katz <katzj@redhat.com>
  194. - add gtkhtml2 and gconf subpackages
  195. * Wed May 29 2002 Bill Nottingham <notting@redhat.com>
  196. - add some defattrs
  197. * Fri May 24 2002 Matt Wilson <msw@redhat.com>
  198. - added bonobo, nautilus subpackages. re-enabled applet subpackage
  199. * Mon Nov 26 2001 Matt Wilson <msw@redhat.com>
  200. - subpackages will need __init__ included in them
  201. * Thu Oct 18 2001 Matt Wilson <msw@redhat.com>
  202. - doesn't obsolete pygnome - it can be installed side-by-side
  203. - added _gnomemodule.so to base package filelist
  204. * Mon Oct 15 2001 Matt Wilson <msw@redhat.com>
  205. - added __init__ files to gnome-python main package
  206. * Mon Oct 8 2001 Matt Wilson <msw@redhat.com>
  207. - new gnome-python package based on old pygtk package.