openssl-vl.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define soversion 10
  3. %define version 1.0.0d
  4. %define release 2%{_dist_release}
  5. Summary: Secure Sockets Layer Toolkit
  6. Name: openssl
  7. Version: %{version}
  8. Release: %{release}
  9. Source: openssl-%{version}.tar.gz
  10. Source2: Makefile.certificate
  11. Source3: ca-bundle.crt
  12. Source5: make-dummy-cert
  13. # Source6: openssl-%{version}.pc
  14. Patch0: openssl-1.0.0-soversion.patch
  15. Patch2: openssl-1.0.0-rpm_opt.patch
  16. Patch4: openssl-1.0.0-enginesdir.patch
  17. # security fix
  18. # nothing ;-)
  19. License: BSDish
  20. Group: System Environment/Libraries
  21. URL: http://www.openssl.org/
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. BuildRequires: perl, sed
  24. BuildRequires: zlib-devel, krb5-devel
  25. Requires: mktemp
  26. Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
  27. Vendor: Project Vine
  28. Distribution: Vine Linux
  29. %define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
  30. %description
  31. The OpenSSL certificate management tool and the shared libraries that
  32. provide various cryptographic algorithms and protocols.
  33. %package devel
  34. Summary: OpenSSL libraries and development headers.
  35. Group: Development/Libraries
  36. Requires: %{name} = %{version}-%{release}
  37. Requires: krb5-devel
  38. %description devel
  39. The static libraries and include files needed to compile apps
  40. with support for various the cryptographic algorithms and protocols
  41. supported by OpenSSL.
  42. Patches for many networking apps can be found at:
  43. ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
  44. %package static
  45. Summary: Libraries for static linking of applications which will use OpenSSL
  46. Group: Development/Libraries
  47. Requires: %{name}-devel = %{version}-%{release}
  48. %description static
  49. OpenSSL is a toolkit for supporting cryptography. The openssl-static
  50. package contains static libraries needed for static linking of
  51. applications which support various cryptographic algorithms and
  52. protocols.
  53. %package perl
  54. Summary: OpenSSL scripts which require Perl.
  55. Group: Applications/Internet
  56. Requires: perl
  57. Requires: %{name} = %{version}-%{release}
  58. %description perl
  59. Perl scripts provided with OpenSSL for converting certificates and keys
  60. from other formats to those used by OpenSSL.
  61. ## to build compat32 for x86_64 architecture support
  62. %package -n compat32-%{name}
  63. Summary: Secure Sockets Layer Toolkit
  64. Group: System Environment/Libraries
  65. Requires: %{name} = %{version}-%{release}
  66. %description -n compat32-%{name}
  67. The OpenSSL certificate management tool and the shared libraries that
  68. provide various cryptographic algorithms and protocols.
  69. %package -n compat32-%{name}-devel
  70. Summary: OpenSSL libraries and development headers.
  71. Group: Development/Libraries
  72. Requires: compat32-%{name} = %{version}-%{release}
  73. Requires: compat32-krb5-devel
  74. %description -n compat32-%{name}-devel
  75. The static libraries and include files needed to compile apps
  76. with support for various the cryptographic algorithms and protocols
  77. supported by OpenSSL.
  78. %prep
  79. %setup -q -n openssl-%{version}
  80. %patch0 -p1 -b .soversion
  81. %patch2 -p1 -b .rpm_opt
  82. %patch4 -p1 -b .enginesdir
  83. # security fix
  84. # nothing ;-)
  85. chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
  86. chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
  87. chmod 644 doc/openssl_button.html doc/openssl_button.gif
  88. chmod 644 doc/ssleay.txt
  89. # Link the configuration header to the one we're going to make.
  90. ln -sf ../../crypto/opensslconf.h include/openssl/
  91. %build
  92. PATH=${PATH}:${PWD}/bin
  93. TOPDIR=${PWD}
  94. LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
  95. # Figure out which flags we want to use. Can't use assembler because it's
  96. # not lowest-common-denominator in most cases.
  97. perl util/perlpath.pl `dirname %{__perl}`
  98. %ifarch %ix86
  99. sslarch=linux-elf
  100. sslflags="no-asm 386"
  101. %endif
  102. %ifarch ppc
  103. sslarch=linux-ppc
  104. sslflags=no-asm
  105. %endif
  106. %ifarch sparc
  107. sslarch=linux-sparcv9
  108. sslflags=no-asm
  109. %endif
  110. %ifarch ia64
  111. sslarch=linux-ia64
  112. sslflags=no-asm
  113. %endif
  114. %ifarch alpha
  115. sslarch=linux-alpha-gcc
  116. sslflags=no-asm
  117. %endif
  118. %ifarch s390
  119. sslarch=linux-s390
  120. %endif
  121. %ifarch s390x
  122. sslarch=linux-s390x
  123. %endif
  124. %ifarch mipsel
  125. sslarch=linux-mips
  126. sslflags=no-asm
  127. %endif
  128. ## to build for x86_64 architecture support
  129. %ifarch x86_64
  130. sslarch=linux-x86_64
  131. sslflags=no-asm
  132. %endif
  133. # Configure the build tree. Override OpenSSL defaults with known-good defaults
  134. # usable on all platforms. The Configure script already knows to use -fPIC and
  135. # RPM_OPT_FLAGS, so we can skip specifiying them here.
  136. ./Configure \
  137. --prefix=%{_prefix} --openssldir=%{_datadir}/ssl ${sslflags} \
  138. zlib-dynamic enable-rfc3779 \
  139. --enginesdir=%{_libdir}/openssl/engines \
  140. --with-krb5-flavor=MIT --with-krb5-dir=/usr \
  141. shared ${sslarch}
  142. # Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
  143. # marked as not requiring an executable stack.
  144. RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
  145. make depend
  146. make all build-shared
  147. # Generate hashes for the included certs.
  148. LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
  149. export LD_LIBRARY_PATH
  150. make rehash build-shared
  151. # Verify that what was compiled actually works.
  152. make -C test apps tests
  153. # Relink the main binary to get it dynamically linked.
  154. rm apps/openssl
  155. make all build-shared
  156. %install
  157. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  158. # Install OpenSSL.
  159. install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
  160. make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
  161. install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
  162. # added for lib64
  163. # mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
  164. mv $RPM_BUILD_ROOT%{_libdir}/engines $RPM_BUILD_ROOT%{_libdir}/openssl
  165. # mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
  166. mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
  167. mv $RPM_BUILD_ROOT%{_datadir}/ssl/man/* $RPM_BUILD_ROOT%{_mandir}
  168. rmdir $RPM_BUILD_ROOT%{_datadir}/ssl/man
  169. rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
  170. for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
  171. chmod 755 ${lib}
  172. ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
  173. ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
  174. done
  175. # install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
  176. # Install a makefile for generating keys and self-signed certs, and a script
  177. # for generating them on the fly.
  178. mkdir -p $RPM_BUILD_ROOT%{_datadir}/ssl/certs
  179. install -m644 $RPM_SOURCE_DIR/Makefile.certificate $RPM_BUILD_ROOT%{_datadir}/ssl/certs/Makefile
  180. install -m644 $RPM_SOURCE_DIR/make-dummy-cert $RPM_BUILD_ROOT%{_datadir}/ssl/certs/make-dummy-cert
  181. # Make sure we actually include the headers we built against.
  182. for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
  183. if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
  184. install -m644 include/openssl/`basename ${header}` ${header}
  185. fi
  186. done
  187. # Rename man pages so that they don't conflict with system man pages. We used
  188. # to change the file extensions, but that only prevents file conflicts. The
  189. # man viewer still can't select either of the two unless we physically change
  190. # the directory.
  191. for section in 1 2 3 4 5 6 7 8 ; do
  192. if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
  193. mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
  194. $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
  195. fi
  196. done
  197. # Pick a CA script.
  198. pushd $RPM_BUILD_ROOT%{_datadir}/ssl/misc
  199. mv CA.sh CA
  200. popd
  201. # Install root CA stuffs.
  202. cat %{SOURCE3} > ca-bundle.crt
  203. install -m644 ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/certs/
  204. ln -s certs/ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/cert.pem
  205. # Fix libdir.
  206. #sed 's,^libdir=${exec_prefix}/lib,libdir=${exec_prefix}/%{_lib},g' \
  207. # sed 's,^libdir=/usr/lib,libdir=%{_libdir},g' \
  208. # $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc > \
  209. # $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp && \
  210. # cat $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp > \
  211. # $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc && \
  212. # rm -f $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp
  213. %clean
  214. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  215. %files
  216. %defattr(-,root,root)
  217. %doc FAQ LICENSE CHANGES NEWS INSTALL README
  218. %doc doc/README doc/c-indentation.el doc/openssl.txt
  219. %doc doc/openssl_button.html doc/openssl_button.gif
  220. %doc doc/ssleay.txt
  221. %dir %{_datadir}/ssl
  222. %{_datadir}/ssl/certs
  223. %{_datadir}/ssl/cert.pem
  224. %{_datadir}/ssl/misc/CA
  225. %{_datadir}/ssl/misc/c_*
  226. %{_datadir}/ssl/private
  227. %config(noreplace) %{_datadir}/ssl/openssl.cnf
  228. %attr(0755,root,root) %{_bindir}/openssl
  229. %attr(0755,root,root) /%{_lib}/*.so.*
  230. %attr(0755,root,root) %{_libdir}/openssl/engines/*.so
  231. %attr(0755,root,root) %dir %{_mandir}/man1*
  232. %attr(0644,root,root) %{_mandir}/man1*/*
  233. %attr(0755,root,root) %dir %{_mandir}/man5*
  234. %attr(0644,root,root) %{_mandir}/man5*/*
  235. %attr(0755,root,root) %dir %{_mandir}/man7*
  236. %attr(0644,root,root) %{_mandir}/man7*/*
  237. %files devel
  238. %defattr(-,root,root)
  239. %{_prefix}/include/openssl
  240. %exclude %{_libdir}/lib*.a
  241. %attr(0755,root,root) %{_libdir}/*.so
  242. %attr(0755,root,root) %dir %{_mandir}/man3*
  243. %attr(0644,root,root) %{_mandir}/man3*/*
  244. %attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
  245. %files static
  246. %defattr(-,root,root)
  247. %attr(0644,root,root) %{_libdir}/*.a
  248. %files perl
  249. %defattr(-,root,root)
  250. %attr(0755,root,root) %{_bindir}/c_rehash
  251. %attr(0755,root,root) %dir %{_mandir}/man1*
  252. %attr(0644,root,root) %{_mandir}/man1*/*.pl*
  253. %{_datadir}/ssl/misc/*.pl
  254. # %{_datadir}/ssl/misc/tsget
  255. %doc apps/tsget
  256. ## to build compat32 for x86_64 architecture support
  257. %if %{build_compat32}
  258. %files -n compat32-%{name}
  259. %defattr(-,root,root)
  260. %attr(0755,root,root) /%{_lib}/*.so.*
  261. %files -n compat32-%{name}-devel
  262. %defattr(-,root,root)
  263. %exclude %{_libdir}/lib*.a
  264. %attr(0755,root,root) %{_libdir}/*.so
  265. %attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
  266. %endif
  267. %post -p /sbin/ldconfig
  268. %postun -p /sbin/ldconfig
  269. %post -n compat32-%{name} -p /sbin/ldconfig
  270. %postun -n compat32-%{name} -p /sbin/ldconfig
  271. %changelog
  272. * Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
  273. - rebuild with krb5-libs 1.8
  274. * Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
  275. - new upstream release with security fix
  276. * Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
  277. - use upstream openssl.pc instead of vine original one (SOURCE6)
  278. * Sun Jan 9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
  279. - move tsget to docs to delete dependency perl(WWW::Curl::Easy)
  280. * Sat Jan 1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
  281. - add R: krb5-devel into devel pkg
  282. - add R: compat32-krb5-devel into compat32-devel pkg
  283. * Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
  284. - new upstream release 1.0.0x
  285. - separate static libs into static package
  286. - change configure options
  287. - change so version 10
  288. - add tsget into perl package
  289. - update all patches
  290. * Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
  291. - fix changelog typo...
  292. * Tue Dec 7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
  293. - new upstream release with security fix (CVE-2010-4180)
  294. * Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
  295. - new upstream release with security fix (CVE-2010-3864)
  296. - drop patches included in new release
  297. - update patch4
  298. * Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
  299. - add patch12 for fix CVE-2009-3555 (renegotiation)
  300. * Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
  301. - add patch11 for fix CVE-2009-4355 (memory leak)
  302. * Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
  303. - add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
  304. * Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
  305. - removed unnecessary %%if %{build_compat32} statements
  306. - removed lib*.a from devel package
  307. * Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
  308. - new upstream release with security fix (CVE-2000-0590,0591,0789)
  309. * Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
  310. - new upstream release with security fix (CVE-2008-5077)
  311. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
  312. - new upstream release
  313. * Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
  314. - new upstream release
  315. - new versioning policy
  316. * Fri Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
  317. - new upstream release
  318. - drop patch10,20 which is merged in upstream
  319. * Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
  320. - add security patch in advance for CVE-2007-5135
  321. http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
  322. http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
  323. * Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
  324. - add security patch for CVE-2007-3108
  325. (http://openssl.org/news/patch-CVE-2007-3108.txt)
  326. * Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
  327. - new upstream release
  328. * Sat Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
  329. - update (fix) openssl.pc <BTS:437>
  330. * Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
  331. - new upstream release (with security fix)
  332. * Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
  333. - new upstream release
  334. - add patch2 to use RPM_OPT macro
  335. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
  336. - moved macros _lib to /usr/lib/rpm/rpmrc or macros files
  337. * Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
  338. - added compat32-* packages for x86_64 architecture support
  339. - added openssl-0.9.7i.Configure-compat32.patch
  340. - changed '/lib' to '/%{_lib}'
  341. * Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
  342. - new upstream release
  343. * Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
  344. - rebuild on VineSeed
  345. * Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
  346. - added a security patch from Gentoo.
  347. - Patch1: openssl-0.9.7c-tempfile.patch
  348. * Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
  349. - sslarch for ppc was missing... added.
  350. * Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
  351. - use sslarch=linux-alpha-gcc instead of alpha-gcc
  352. * Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
  353. - new upstream version
  354. - clean up of spec file
  355. -- removed old patches
  356. * Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
  357. - new upstream release
  358. - SECURITY fix.
  359. - http://www.openssl.org/news/secadv_20040317.txt
  360. * Wed Oct 1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
  361. - new upstream release
  362. - [Security fix]
  363. - Vulnerabilities in ASN.1 parsing
  364. http://www.openssl.org/news/secadv_20030930.txt
  365. - see %{_docdir}/%{name}-%{version}/CHANGES for other changes
  366. * Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
  367. - add openssl.pc for pkgconfig
  368. * Fri Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
  369. - New upstream version
  370. - dropped patch10, 11
  371. -- merged upstream version
  372. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
  373. - rebuild for VineSeed
  374. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
  375. - [Security Fix]
  376. - Timing-based attacks on RSA keys
  377. http://www.openssl.org/news/secadv_20030317.txt
  378. - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
  379. http://www.openssl.org/news/secadv_20030317.txt
  380. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
  381. - new upstream release 0.9.6i
  382. - [Security Fix]
  383. - build for Vine Linux 2.6 errata
  384. * Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
  385. - new upstream release 0.9.6h
  386. * Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
  387. - new upstream release 0.9.6g
  388. * Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
  389. - SECURITY: CAN-2002-0659 fixed
  390. - added Patch101 from RedHat 7.2 updates 0.9.6b-28
  391. * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
  392. - update asn patch to fix accidental reversal of a logic check
  393. * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
  394. - update asn patch to reduce chance that compiler optimization will remove
  395. one of the added tests
  396. * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
  397. - rebuild
  398. * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
  399. - add patch to fix ASN.1 vulnerabilities
  400. * Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
  401. - rename spec file name
  402. - SECURITY: CA-2002-23 fixed
  403. - added Patch100 from RedHat 7.2 updates 0.9.6b-24
  404. * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
  405. - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
  406. * Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
  407. - added ${PATH} in LD_LIBRARY_PATH
  408. - added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
  409. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
  410. - remove --no-<cipher>
  411. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
  412. - add Patch10 for mipsel shared ( Configure )
  413. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
  414. - build for Vine Linux
  415. - use openssl-engine-0.9.6b.tar.gz
  416. * Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
  417. - update to 0.9.6b
  418. * Thu Jul 5 2001 Nalin Dahyabhai <nalin@redhat.com>
  419. - move .so symlinks back to %%{_libdir}
  420. * Tue Jul 3 2001 Nalin Dahyabhai <nalin@redhat.com>
  421. - move shared libraries to /lib (#38410)
  422. * Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
  423. - switch to engine code base
  424. * Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
  425. - add a script for creating dummy certificates
  426. - move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
  427. * Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  428. - add s390x support
  429. * Fri Jun 1 2001 Nalin Dahyabhai <nalin@redhat.com>
  430. - change two memcpy() calls to memmove()
  431. - don't define L_ENDIAN on alpha
  432. * Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
  433. - make subpackages depend on the main package
  434. * Tue May 1 2001 Nalin Dahyabhai <nalin@redhat.com>
  435. - adjust the hobble script to not disturb symlinks in include/ (fix from
  436. Joe Orton)
  437. * Fri Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
  438. - drop the m2crypo patch we weren't using
  439. * Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
  440. - configure using "shared" as well
  441. * Sun Apr 8 2001 Nalin Dahyabhai <nalin@redhat.com>
  442. - update to 0.9.6a
  443. - use the build-shared target to build shared libraries
  444. - bump the soversion to 2 because we're no longer compatible with
  445. our 0.9.5a packages or our 0.9.6 packages
  446. - drop the patch for making rsatest a no-op when rsa null support is used
  447. - put all man pages into <section>ssl instead of <section>
  448. - break the m2crypto modules into a separate package
  449. * Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
  450. - use BN_LLONG on s390
  451. * Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
  452. - fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
  453. * Sat Mar 3 2001 Nalin Dahyabhai <nalin@redhat.com>
  454. - move c_rehash to the perl subpackage, because it's a perl script now
  455. * Fri Mar 2 2001 Nalin Dahyabhai <nalin@redhat.com>
  456. - update to 0.9.6
  457. - enable MD2
  458. - use the libcrypto.so and libssl.so targets to build shared libs with
  459. - bump the soversion to 1 because we're no longer compatible with any of
  460. the various 0.9.5a packages circulating around, which provide lib*.so.0
  461. * Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  462. - change hobble-openssl for disabling MD2 again
  463. * Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
  464. - re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
  465. bytes or so, causing EVP_DigestInit() to zero out stack variables in
  466. apps built against a version of the library without it
  467. * Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
  468. - disable some inline assembly, which on x86 is Pentium-specific
  469. - re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
  470. * Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  471. - fix s390 patch
  472. * Fri Dec 8 2000 Than Ngo <than@redhat.com>
  473. - added support s390
  474. * Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  475. - remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
  476. - add the CA.pl man page to the perl subpackage
  477. * Thu Nov 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  478. - always build with -mcpu=ev5 on alpha
  479. * Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
  480. - add a symlink from cert.pem to ca-bundle.crt
  481. * Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
  482. - add a ca-bundle file for packages like Samba to reference for CA certificates
  483. * Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
  484. - remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
  485. * Mon Oct 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  486. - add unzip as a buildprereq (#17662)
  487. - update m2crypto to 0.05-snap4
  488. * Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
  489. - fix some issues in building when it's not installed
  490. * Wed Sep 6 2000 Nalin Dahyabhai <nalin@redhat.com>
  491. - make sure the headers we include are the ones we built with (aaaaarrgh!)
  492. * Fri Sep 1 2000 Nalin Dahyabhai <nalin@redhat.com>
  493. - add Richard Henderson's patch for BN on ia64
  494. - clean up the changelog
  495. * Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  496. - fix the building of python modules without openssl-devel already installed
  497. * Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
  498. - byte-compile python extensions without the build-root
  499. - adjust the makefile to not remove temporary files (like .key files when
  500. building .csr files) by marking them as .PRECIOUS
  501. * Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  502. - break out python extensions into a subpackage
  503. * Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
  504. - tweak the makefile some more
  505. * Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
  506. - disable MD2 support
  507. * Thu Jul 6 2000 Nalin Dahyabhai <nalin@redhat.com>
  508. - disable MDC2 support
  509. * Sun Jul 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  510. - tweak the disabling of RC5, IDEA support
  511. - tweak the makefile
  512. * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  513. - strip binaries and libraries
  514. - rework certificate makefile to have the right parts for Apache
  515. * Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  516. - use %%{_perl} instead of /usr/bin/perl
  517. - disable alpha until it passes its own test suite
  518. * Fri Jun 9 2000 Nalin Dahyabhai <nalin@redhat.com>
  519. - move the passwd.1 man page out of the passwd package's way
  520. * Fri Jun 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  521. - update to 0.9.5a, modified for U.S.
  522. - add perl as a build-time requirement
  523. - move certificate makefile to another package
  524. - disable RC5, IDEA, RSA support
  525. - remove optimizations for now
  526. * Wed Mar 1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  527. - Bero told me to move the Makefile into this package
  528. * Wed Mar 1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  529. - add lib*.so symlinks to link dynamically against shared libs
  530. * Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  531. - update to 0.9.5
  532. - run ldconfig directly in post/postun
  533. - add FAQ
  534. * Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  535. - Fix build on non-x86 platforms
  536. * Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  537. - move /usr/share/ssl/* from -devel to main package
  538. * Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  539. - inital packaging
  540. - changes from base:
  541. - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
  542. - handle RPM_OPT_FLAGS