self-build-chromium-ffmpeg-vl.spec 4.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111
  1. %define pkgname chromium-ffmpeg
  2. %define name self-build-%{pkgname}
  3. %define version 17.0.963.54
  4. %define release 1%{?_dist_release}
  5. %define sourceurl0 http://gsdview.appspot.com/chromium-browser-official/chromium-%{version}.tar.bz2
  6. Summary: Package to automatically build %{pkgname} rpm package
  7. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  8. Name: %{name}
  9. Version: %{version}
  10. Release: %{release}
  11. Source0: %{pkgname}-vl.spec
  12. License: BSD
  13. Group: Restricted Software
  14. Requires(post): self-build-setup >= 0.9.9
  15. # (build)requies of target package.
  16. Requires: chromium
  17. Requires(post): zlib-devel
  18. BuildArch: noarch
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. Packager: munepi
  21. %description
  22. FFMPEG library built from the chromium sources.
  23. If you install this package, it automaticaly downloads source
  24. code, compile it, and create rpm packages of
  25. %{pkgname}-%{version}.
  26. And the created rpm packages are automatically installed
  27. if installation is executed by apt-get command or synaptic
  28. package manager.
  29. [Note]
  30. This package requires many other packages to compile
  31. targetsoftware. So it consume more disk space than usual.
  32. Also installation takes logner time because of compilation.
  33. (This will take a few minutes to quarter or half of an hour,
  34. depends on building environment)
  35. [About self-build package]
  36. For some kind of software, distributing of binary package
  37. may viorate the patent or law. Therefore we chose self-build
  38. packge, create binary package on your machine, for such kind
  39. of softwares instead of distributing binary package.
  40. Please obey the national law when you use the created binary
  41. packages. And if you want to use the softwares using patented
  42. thechnology, it may be required to get a permission, make an
  43. agreement or purchas a license. Please consider it with your
  44. purpose or way of use and take appropriate action.
  45. %description -l ja
  46. chromium のソースから FFMPEG ライブラリをビルドします。
  47. このパッケージをインストールすると、自動的にソースコードをダ
  48. ウンロードしてコンパイルし、%{pkgname}-%{version}
  49. の rpm パッケージを作成します。
  50. また apt-get コマンドや synaptic パッケージマネージャから実行
  51. した場合は、作成された rpm パッケージのインストールも自動的に
  52. 行います。
  53. [注意]
  54. コンパイルに必要な多くの関連パッケージを要求するので通常より
  55. ディスクの領域を多く消費します。
  56. またインストール時にコンパイルを行うため、通常より時間がかか
  57. る場合があります。(環境にもよりますが数分から数十分程度)
  58. [self-build パッケージについて]
  59. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  60. 違反する可能性があるものがあります。その為、このような問題が
  61. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  62. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  63. ジという方法を採っています。
  64. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  65. アのライセンス、および利用する国の各種法令に従ってください。
  66. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  67. センスの購入などが必要となる場合がありますので、利用する目的
  68. や形態に応じて各自で判断し適切な対応を取ってください。
  69. %prep
  70. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  71. %install
  72. %{__rm} -rf ${RPM_BUILD_ROOT}
  73. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  74. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  75. %clean
  76. %{__rm} -rf ${RPM_BUILD_ROOT}
  77. %posttrans
  78. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 358000
  79. %files
  80. %defattr(-,root,root)
  81. %{_datadir}/%{name}/*
  82. %changelog
  83. * Sun Feb 12 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.54-1
  84. - initial build