texlive-collection-binextra-vl.spec 28 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578
  1. ## -*- coding: utf-8-unix -*-
  2. ## NOTE: This spec file is generated by tlpdb2rpmspec 2011-2:
  3. ## tlpdb2rpmspec collection-binextra
  4. %global _use_internal_dependency_generator 0
  5. %global __find_provides %{nil}
  6. %global __find_requires %{nil}
  7. %bcond_with firstbuild
  8. %define tex_destdir %{_datadir}
  9. %define texmf %{tex_destdir}/texmf
  10. %define texlive_src %{tex_destdir}/texlive-sources
  11. %define build_tex_destdir %{buildroot}%{tex_destdir}
  12. %define build_texmf %{buildroot}%{texmf}
  13. %define exec_mktexlsr [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
  14. %define exec_texhash [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
  15. %define exec_updmap [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys
  16. %define exec_fmtutil [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
  17. %define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
  18. %define vartexfonts %{_var}/lib/texmf/fonts
  19. Summary: TeX Live: TeX auxiliary programs
  20. Summary(ja): TeX Live: TeX auxiliary programs
  21. Name: texlive-collection-binextra
  22. Version: 2011
  23. Release: 2%{?_dist_release}
  24. License: GPL+, LGPLv2+, LPPL, Knuth, Freely redistributable without restriction, Public Domain, Artistic, GPLv3+
  25. Group: Applications/Publishing
  26. URL:http://www.tug.org/texlive/
  27. Requires: texlive = %{version}
  28. Requires: texlive-collection-basic = %{version}
  29. Requires: asymptote
  30. Requires: detex
  31. Requires: dvipng
  32. Requires: latexmk
  33. Requires(post): texlive = %{version}
  34. Requires(postun): texlive = %{version}
  35. BuildRequires: texlive-sources = %{version}
  36. BuildArch: noarch
  37. Buildroot: %{_tmppath}/%{name}-%{version}-root
  38. Vendor: Project Vine
  39. Distribution: Vine Linux
  40. Packager: munepi
  41. %description
  42. The TeX Live software distribution offers a complete TeX system for a
  43. variety of Unix, Macintosh, Windows and other platforms. It
  44. encompasses programs for editing, typesetting, previewing and printing
  45. of TeX documents in many different languages, and a large collection
  46. of TeX macros and font libraries.
  47. The distribution includes extensive general documentation about TeX,
  48. as well as the documentation for the included software packages.
  49. This package is a collection of TeX auxiliary programs:
  50. Various useful, but non-essential, support programs. Includes
  51. programs and macros for DVI file manipulation, literate
  52. programming, patgen, and the TeX Works Editor.
  53. This package contains the following CTAN packages:
  54. a2ping: Advanced PS, PDF, EPS converter.
  55. asymptote: 2D and 3D TeX-Aware Vector Graphics Language.
  56. bibtex8: A fully 8-bit adaptation of BibTeX 0.99.
  57. bibtexu:
  58. bundledoc: Bundle together all the files needed to build a LaTeX document.
  59. chktex: Check for errors in LaTeX documents.
  60. ctie: C version of tie (merging Web change files).
  61. cweb: A Web system in C.
  62. de-macro: Expand private macros in a document.
  63. detex: Strip TeX from a source file.
  64. dtl: Tools to dis-assemble and re-assemble DVI files.
  65. dvi2tty: Produce ASCII from DVI.
  66. dviasm: A utility for editing DVI files.
  67. dvicopy: Copy DVI files, flattening VFs.
  68. dvidvi: Convert one DVI file into another.
  69. dviljk: DVI to Laserjet output.
  70. dvipng: A fast DVI to PNG/GIF converter.
  71. dvipos:
  72. dvisvgm: Converts DVI files to Scalable Vector Graphics format (SVG).
  73. findhyph: Find hyphenated words in a document.
  74. fragmaster: Using psfrag with PDFLaTeX.
  75. hyphenex: Generate a hyphenation exceptions file.
  76. installfont: A bash script for installing a LaTeX font family.
  77. lacheck: LaTeX checker.
  78. latex2man: Translate LaTeX-based manual pages into Unix man format.
  79. latexdiff: Determine and mark up significant differences between latex files.
  80. latexmk: Fully automated LaTeX document generation routine.
  81. listings-ext: Automated input of source.
  82. mkjobtexmf: Generate a texmf tree for a particular job.
  83. patgen:
  84. pdfcrop: Crop PDF graphics.
  85. pdfjam: Shell scripts interfacing to pdfpages.
  86. pdftools: PDF-related utilities, including PostScript-to-PDF conversion
  87. pkfix: Replace pk fonts in PostScript with Type 1 fonts.
  88. pkfix-helper: Make PostScript files accessible to pkfix.
  89. purifyeps: Make EPS work with both LaTeX/dvips and pdfLaTeX.
  90. seetexk: Utilities for manipulating DVI files.
  91. sty2dtx: Create a .dtx file from a .sty file.
  92. synctex:
  93. texcount: Count words in a LaTeX document.
  94. texdef: Display the definitions of TeX commands.
  95. texdiff: Compare documents and produce tagged merge.
  96. texdirflatten: Collect files related to a LaTeX job in a single directory.
  97. texdoc: Documentation access for TeX distributions.
  98. texloganalyser: Analyse TeX logs.
  99. texware: Utility programs for use with TeX.
  100. tie: Allow multiple web change files.
  101. tpic2pdftex: Use tpic commands in PDFTeX.
  102. web: original web programs tangle and weave
  103. xindy: A general-purpose index processor.
  104. %description -l ja
  105. TeX Live ソフトウェアディストリビューションは、
  106. さまざまな Unix, Macintosh, Windows、および
  107. 他のプラットホームに対して完全な TeX システムを提供します。
  108. 多くの異なった言語を含む TeX ドキュメントの
  109. 編集、組版、閲覧、印刷するためのプログラム、
  110. そして、TeX マクロやフォントライブラリの大きなコレクションを
  111. 同梱しています。
  112. このディストリビューションは
  113. 同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
  114. TeX に関するたくさんの一般的なドキュメントを含んでいます。
  115. このパッケージは以下のようなパッケージ集です。
  116. TeX auxiliary programs:
  117. Various useful, but non-essential, support programs. Includes
  118. programs and macros for DVI file manipulation, literate
  119. programming, patgen, and the TeX Works Editor.
  120. このパッケージは以下の CTAN パッケージを含んでいます:
  121. a2ping: Advanced PS, PDF, EPS converter.
  122. asymptote: 2D and 3D TeX-Aware Vector Graphics Language.
  123. bibtex8: A fully 8-bit adaptation of BibTeX 0.99.
  124. bibtexu:
  125. bundledoc: Bundle together all the files needed to build a LaTeX document.
  126. chktex: Check for errors in LaTeX documents.
  127. ctie: C version of tie (merging Web change files).
  128. cweb: A Web system in C.
  129. de-macro: Expand private macros in a document.
  130. detex: Strip TeX from a source file.
  131. dtl: Tools to dis-assemble and re-assemble DVI files.
  132. dvi2tty: Produce ASCII from DVI.
  133. dviasm: A utility for editing DVI files.
  134. dvicopy: Copy DVI files, flattening VFs.
  135. dvidvi: Convert one DVI file into another.
  136. dviljk: DVI to Laserjet output.
  137. dvipng: A fast DVI to PNG/GIF converter.
  138. dvipos:
  139. dvisvgm: Converts DVI files to Scalable Vector Graphics format (SVG).
  140. findhyph: Find hyphenated words in a document.
  141. fragmaster: Using psfrag with PDFLaTeX.
  142. hyphenex: Generate a hyphenation exceptions file.
  143. installfont: A bash script for installing a LaTeX font family.
  144. lacheck: LaTeX checker.
  145. latex2man: Translate LaTeX-based manual pages into Unix man format.
  146. latexdiff: Determine and mark up significant differences between latex files.
  147. latexmk: Fully automated LaTeX document generation routine.
  148. listings-ext: Automated input of source.
  149. mkjobtexmf: Generate a texmf tree for a particular job.
  150. patgen:
  151. pdfcrop: Crop PDF graphics.
  152. pdfjam: Shell scripts interfacing to pdfpages.
  153. pdftools: PDF-related utilities, including PostScript-to-PDF conversion
  154. pkfix: Replace pk fonts in PostScript with Type 1 fonts.
  155. pkfix-helper: Make PostScript files accessible to pkfix.
  156. purifyeps: Make EPS work with both LaTeX/dvips and pdfLaTeX.
  157. seetexk: Utilities for manipulating DVI files.
  158. sty2dtx: Create a .dtx file from a .sty file.
  159. synctex:
  160. texcount: Count words in a LaTeX document.
  161. texdef: Display the definitions of TeX commands.
  162. texdiff: Compare documents and produce tagged merge.
  163. texdirflatten: Collect files related to a LaTeX job in a single directory.
  164. texdoc: Documentation access for TeX distributions.
  165. texloganalyser: Analyse TeX logs.
  166. texware: Utility programs for use with TeX.
  167. tie: Allow multiple web change files.
  168. tpic2pdftex: Use tpic commands in PDFTeX.
  169. web: original web programs tangle and weave
  170. xindy: A general-purpose index processor.
  171. %package doc
  172. Summary: TeX Live: Documentation files of %{name}
  173. Group: Applications/Publishing
  174. Requires: %{name} = %{version}-%{release}
  175. %description doc
  176. This package contains documentation files of %{name}.
  177. %prep
  178. %build
  179. %install
  180. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  181. PREF=%{buildroot}%{tex_destdir}
  182. manifest=(
  183. texmf-dist/bibtex/csf/base/88591lat.csf
  184. texmf-dist/bibtex/csf/base/88591sca.csf
  185. texmf-dist/bibtex/csf/base/README.TEXLIVE
  186. texmf-dist/bibtex/csf/base/ascii.csf
  187. texmf-dist/bibtex/csf/base/cp437lat.csf
  188. texmf-dist/bibtex/csf/base/cp850lat.csf
  189. texmf-dist/bibtex/csf/base/cp850sca.csf
  190. texmf-dist/bibtex/csf/base/cp866rus.csf
  191. texmf-dist/bibtex/csf/base/csfile.txt
  192. texmf-dist/bibtex/csf/polish-csf/88592pl.csf
  193. texmf-dist/bibtex/csf/polish-csf/cp1250pl.csf
  194. texmf-dist/bibtex/csf/polish-csf/cp852pl.csf
  195. texmf-dist/bibtex/csf/polish-csf/iso8859-7.csf
  196. texmf-dist/doc/support/bundledoc/README
  197. texmf-dist/scripts/bundledoc/arlatex
  198. texmf-dist/scripts/bundledoc/bundledoc
  199. texmf-dist/tex/latex/bundledoc/miktex.cfg
  200. texmf-dist/tex/latex/bundledoc/texlive-unix.cfg
  201. texmf-dist/doc/plain/cweb/cwebman.dvi
  202. texmf-dist/tex/plain/cweb/cwebmac.tex
  203. texmf-dist/tex/plain/cweb/pdfXcwebmac.tex
  204. texmf-dist/tex/plain/cweb/pdfcwebmac.tex
  205. texmf-dist/tex/plain/cweb/pdfdcwebmac.tex
  206. texmf-dist/tex/plain/cweb/pdffcwebmac.tex
  207. texmf-dist/tex/plain/cweb/pdficwebmac.tex
  208. texmf-dist/tex/plain/cweb/pdfwebmac.tex
  209. texmf-dist/doc/support/de-macro/README
  210. texmf-dist/doc/support/de-macro/user-guide.pdf
  211. texmf-dist/doc/support/de-macro/user-guide.tex
  212. texmf-dist/scripts/de-macro/de-macro
  213. texmf-dist/scripts/dviasm/dviasm.py
  214. texmf-dist/doc/support/findhyph/Makefile
  215. texmf-dist/doc/support/findhyph/README
  216. texmf-dist/doc/support/findhyph/findhyph.bat
  217. texmf-dist/doc/support/findhyph/findhyph.txt
  218. texmf-dist/scripts/findhyph/findhyph
  219. texmf-dist/doc/support/fragmaster/AUTHORS
  220. texmf-dist/doc/support/fragmaster/COPYING
  221. texmf-dist/doc/support/fragmaster/CREDITS
  222. texmf-dist/doc/support/fragmaster/Changes
  223. texmf-dist/doc/support/fragmaster/README
  224. texmf-dist/doc/support/fragmaster/README.de
  225. texmf-dist/doc/support/fragmaster/example/document.pdf
  226. texmf-dist/doc/support/fragmaster/example/document.ps
  227. texmf-dist/doc/support/fragmaster/example/document.tex
  228. texmf-dist/doc/support/fragmaster/example/parabel.eps
  229. texmf-dist/doc/support/fragmaster/example/parabel.pdf
  230. texmf-dist/doc/support/fragmaster/example/parabel_fm
  231. texmf-dist/doc/support/fragmaster/example/parabel_fm.eps
  232. texmf-dist/doc/support/fragmaster/example/parabel_fm.gp
  233. texmf-dist/doc/support/fragmaster/example/parabel_fm.pdf
  234. texmf-dist/doc/support/fragmaster/fragmaster.pdf
  235. texmf-dist/scripts/fragmaster/fragmaster.pl
  236. texmf-dist/source/generic/hyphenex/GNUmakefile
  237. texmf-dist/source/generic/hyphenex/README
  238. texmf-dist/source/generic/hyphenex/hyphenex.pl
  239. texmf-dist/source/generic/hyphenex/hyphenex.sh
  240. texmf-dist/source/generic/hyphenex/tb0hyf.pdf
  241. texmf-dist/source/generic/hyphenex/tb0hyf.tex
  242. texmf-dist/source/generic/hyphenex/test.tex
  243. texmf-dist/tex/generic/hyphenex/ushyphex.tex
  244. texmf-dist/doc/support/installfont/LICENSE
  245. texmf-dist/doc/support/installfont/README
  246. texmf-dist/doc/support/installfont/installfont
  247. texmf-dist/doc/support/installfont/installfont.pdf
  248. texmf-dist/doc/support/installfont/installfont.tex
  249. texmf-dist/doc/support/installfont/manifest.txt
  250. texmf-dist/scripts/installfont/installfont-tl
  251. texmf-dist/doc/support/latex2man/CHANGES
  252. texmf-dist/doc/support/latex2man/INSTALL
  253. texmf-dist/doc/support/latex2man/Makefile
  254. texmf-dist/doc/support/latex2man/README
  255. texmf-dist/doc/support/latex2man/THIS-IS-VERSION-1.24
  256. texmf-dist/doc/support/latex2man/latex2man-CHANGES.html
  257. texmf-dist/doc/support/latex2man/latex2man.1
  258. texmf-dist/doc/support/latex2man/latex2man.css
  259. texmf-dist/doc/support/latex2man/latex2man.html
  260. texmf-dist/doc/support/latex2man/latex2man.pdf
  261. texmf-dist/doc/support/latex2man/latex2man.tex
  262. texmf-dist/doc/support/latex2man/latex2man.texi
  263. texmf-dist/doc/support/latex2man/latex2man.trans
  264. texmf-dist/doc/support/latex2man/latex2man.txt
  265. texmf-dist/scripts/latex2man/latex2man
  266. texmf-dist/tex/latex/latex2man/latex2man.cfg
  267. texmf-dist/tex/latex/latex2man/latex2man.sty
  268. texmf-dist/doc/latex/latexdiff/CHANGES
  269. texmf-dist/doc/latex/latexdiff/LICENSE
  270. texmf-dist/doc/latex/latexdiff/Makefile
  271. texmf-dist/doc/latex/latexdiff/README
  272. texmf-dist/doc/latex/latexdiff/contrib/latexdiff-wrap
  273. texmf-dist/doc/latex/latexdiff/contrib/latexdiff.spec
  274. texmf-dist/doc/latex/latexdiff/example/example-draft.tex
  275. texmf-dist/doc/latex/latexdiff/example/example-rev.tex
  276. texmf-dist/doc/latex/latexdiff/latexdiff
  277. texmf-dist/doc/latex/latexdiff/latexdiff-fast
  278. texmf-dist/doc/latex/latexdiff/latexdiff-man.pdf
  279. texmf-dist/scripts/latexdiff/latexdiff-vc.pl
  280. texmf-dist/scripts/latexdiff/latexdiff.pl
  281. texmf-dist/scripts/latexdiff/latexrevise.pl
  282. texmf-dist/doc/support/latexmk/CHANGES
  283. texmf-dist/doc/support/latexmk/COPYING
  284. texmf-dist/doc/support/latexmk/INSTALL
  285. texmf-dist/doc/support/latexmk/README
  286. texmf-dist/doc/support/latexmk/example_rcfiles/README
  287. texmf-dist/doc/support/latexmk/example_rcfiles/asymptote_latexmkrc
  288. texmf-dist/doc/support/latexmk/example_rcfiles/glossary_latexmkrc
  289. texmf-dist/doc/support/latexmk/example_rcfiles/pdflatexmkrc
  290. texmf-dist/doc/support/latexmk/example_rcfiles/sagetex_latexmkrc
  291. texmf-dist/doc/support/latexmk/extra-scripts/README1
  292. texmf-dist/doc/support/latexmk/extra-scripts/dvipdfm_call
  293. texmf-dist/doc/support/latexmk/extra-scripts/dvipdfm_call.bat
  294. texmf-dist/doc/support/latexmk/extra-scripts/dvipdfmx_call
  295. texmf-dist/doc/support/latexmk/extra-scripts/dvipdfmx_call.bat
  296. texmf-dist/doc/support/latexmk/extra-scripts/kickxdvi
  297. texmf-dist/doc/support/latexmk/extra-scripts/l1
  298. texmf-dist/doc/support/latexmk/extra-scripts/l2
  299. texmf-dist/doc/support/latexmk/extra-scripts/pst2pdf_for_latexmk
  300. texmf-dist/doc/support/latexmk/extra-scripts/pst2pdf_for_latexmk_README.txt
  301. texmf-dist/doc/support/latexmk/extra-scripts/startacroread
  302. texmf-dist/doc/support/latexmk/latexmk.bat
  303. texmf-dist/doc/support/latexmk/latexmk.pdf
  304. texmf-dist/doc/support/latexmk/latexmk.txt
  305. texmf-dist/scripts/latexmk/latexmk.pl
  306. texmf-dist/doc/latex/listings-ext/README
  307. texmf-dist/doc/latex/listings-ext/THIS_IS_VERSION_v67
  308. texmf-dist/doc/latex/listings-ext/getversion.tex
  309. texmf-dist/doc/latex/listings-ext/hyperref.cfg
  310. texmf-dist/doc/latex/listings-ext/listings-ext.bib
  311. texmf-dist/doc/latex/listings-ext/listings-ext.el
  312. texmf-dist/doc/latex/listings-ext/listings-ext.makemake
  313. texmf-dist/doc/latex/listings-ext/listings-ext.mk
  314. texmf-dist/doc/latex/listings-ext/listings-ext.pdf
  315. texmf-dist/doc/latex/listings-ext/listings-ext_exmpl_a.java
  316. texmf-dist/doc/latex/listings-ext/listings-ext_exmpl_b.java
  317. texmf-dist/doc/latex/listings-ext/listings-ext_exmpl_c.java
  318. texmf-dist/doc/latex/listings-ext/listings-ext_exmpl_d.java
  319. texmf-dist/doc/latex/listings-ext/listings-ext_exmpl_e.java
  320. texmf-dist/doc/latex/listings-ext/listings-ext_test_a.tex
  321. texmf-dist/doc/latex/listings-ext/listings-ext_test_d.tex
  322. texmf-dist/doc/latex/listings-ext/listings.cfg
  323. texmf-dist/source/latex/listings-ext/listings-ext.dtx
  324. texmf-dist/source/latex/listings-ext/listings-ext.ins
  325. texmf-dist/scripts/listings-ext/listings-ext.sh
  326. texmf-dist/tex/latex/listings-ext/listings-ext.sty
  327. texmf-dist/doc/generic/mkjobtexmf/README
  328. texmf-dist/doc/generic/mkjobtexmf/mkjobtexmf.html
  329. texmf-dist/doc/generic/mkjobtexmf/mkjobtexmf.ltx
  330. texmf-dist/doc/generic/mkjobtexmf/mkjobtexmf.pdf
  331. texmf-dist/doc/generic/mkjobtexmf/mkjobtexmf.txt
  332. texmf-dist/source/generic/mkjobtexmf/Makefile.in
  333. texmf-dist/source/generic/mkjobtexmf/configure
  334. texmf-dist/source/generic/mkjobtexmf/configure.ac
  335. texmf-dist/source/generic/mkjobtexmf/install-sh
  336. texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
  337. texmf-dist/doc/support/pdfcrop/README
  338. texmf-dist/scripts/pdfcrop/pdfcrop.pl
  339. texmf-dist/doc/support/pdfjam/COPYING
  340. texmf-dist/doc/support/pdfjam/PDFjam-README.html
  341. texmf-dist/doc/support/pdfjam/VERSION
  342. texmf-dist/doc/support/pdfjam/pdfdroplets.png
  343. texmf-dist/doc/support/pdfjam/pdfjam.conf
  344. texmf-dist/doc/support/pdfjam/tests.zip
  345. texmf-dist/scripts/pdfjam/pdf180
  346. texmf-dist/scripts/pdfjam/pdf270
  347. texmf-dist/scripts/pdfjam/pdf90
  348. texmf-dist/scripts/pdfjam/pdfbook
  349. texmf-dist/scripts/pdfjam/pdfflip
  350. texmf-dist/scripts/pdfjam/pdfjam
  351. texmf-dist/scripts/pdfjam/pdfjam-pocketmod
  352. texmf-dist/scripts/pdfjam/pdfjam-slides3up
  353. texmf-dist/scripts/pdfjam/pdfjam-slides6up
  354. texmf-dist/scripts/pdfjam/pdfjoin
  355. texmf-dist/scripts/pdfjam/pdfnup
  356. texmf-dist/scripts/pdfjam/pdfpun
  357. texmf-dist/doc/support/pkfix/README
  358. texmf-dist/scripts/pkfix/pkfix.pl
  359. texmf-dist/doc/support/pkfix-helper/README
  360. texmf-dist/doc/support/pkfix-helper/encoding-samples.pdf
  361. texmf-dist/doc/support/pkfix-helper/encoding-samples.tex
  362. texmf-dist/scripts/pkfix-helper/pkfix-helper
  363. texmf-dist/doc/support/purifyeps/README
  364. texmf-dist/scripts/purifyeps/purifyeps
  365. texmf-dist/doc/support/sty2dtx/README
  366. texmf-dist/scripts/sty2dtx/sty2dtx.pl
  367. texmf-dist/doc/support/texcount/QuickReference.pdf
  368. texmf-dist/doc/support/texcount/QuickReference.tex
  369. texmf-dist/doc/support/texcount/README
  370. texmf-dist/doc/support/texcount/TeXcount.pdf
  371. texmf-dist/doc/support/texcount/TeXcount.tex
  372. texmf-dist/doc/support/texcount/macros.tex
  373. texmf-dist/scripts/texcount/texcount.pl
  374. texmf-dist/doc/support/texdef/INSTALL
  375. texmf-dist/doc/support/texdef/README
  376. texmf-dist/scripts/texdef/texdef.pl
  377. texmf-dist/doc/support/texdiff/README
  378. texmf-dist/scripts/texdiff/texdiff
  379. texmf-dist/scripts/texdirflatten/texdirflatten
  380. texmf-dist/texdoc/texdoc.cnf
  381. texmf-dist/doc/support/texloganalyser/README
  382. texmf-dist/scripts/texloganalyser/texloganalyser
  383. )
  384. %__mkdir_p ${PREF}/texmf-dist
  385. for i in "${manifest[@]}"; do
  386. %__install -m $(stat -c %a %{texlive_src}/$i) -p -D %{texlive_src}/$i ${PREF}/$i
  387. done
  388. ## make symlinks of core script utils
  389. mk_symlinks=(
  390. texlive-collection-bibtexextra,/usr/bin/bibexport,/usr/share/texmf-dist/scripts/bibexport/bibexport.sh
  391. texlive-collection-binextra,/usr/bin/arlatex,/usr/share/texmf-dist/scripts/bundledoc/arlatex
  392. texlive-collection-binextra,/usr/bin/bundledoc,/usr/share/texmf-dist/scripts/bundledoc/bundledoc
  393. texlive-collection-binextra,/usr/bin/de-macro,/usr/share/texmf-dist/scripts/de-macro/de-macro
  394. texlive-collection-binextra,/usr/bin/dviasm,/usr/share/texmf-dist/scripts/dviasm/dviasm.py
  395. texlive-collection-binextra,/usr/bin/findhyph,/usr/share/texmf-dist/scripts/findhyph/findhyph
  396. texlive-collection-binextra,/usr/bin/fragmaster,/usr/share/texmf-dist/scripts/fragmaster/fragmaster.pl
  397. texlive-collection-binextra,/usr/bin/installfont-tl,/usr/share/texmf-dist/scripts/installfont/installfont-tl
  398. texlive-collection-binextra,/usr/bin/latex2man,/usr/share/texmf-dist/scripts/latex2man/latex2man
  399. texlive-collection-binextra,/usr/bin/latexdiff,/usr/share/texmf-dist/scripts/latexdiff/latexdiff.pl
  400. texlive-collection-binextra,/usr/bin/latexdiff-vc,/usr/share/texmf-dist/scripts/latexdiff/latexdiff-vc.pl
  401. texlive-collection-binextra,/usr/bin/latexmk,/usr/share/texmf-dist/scripts/latexmk/latexmk.pl
  402. texlive-collection-binextra,/usr/bin/latexrevise,/usr/share/texmf-dist/scripts/latexdiff/latexrevise.pl
  403. texlive-collection-binextra,/usr/bin/listings-ext.sh,/usr/share/texmf-dist/scripts/listings-ext/listings-ext.sh
  404. texlive-collection-binextra,/usr/bin/mkjobtexmf,/usr/share/texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
  405. texlive-collection-binextra,/usr/bin/pdf180,/usr/share/texmf-dist/scripts/pdfjam/pdf180
  406. texlive-collection-binextra,/usr/bin/pdf270,/usr/share/texmf-dist/scripts/pdfjam/pdf270
  407. texlive-collection-binextra,/usr/bin/pdf90,/usr/share/texmf-dist/scripts/pdfjam/pdf90
  408. texlive-collection-binextra,/usr/bin/pdfbook,/usr/share/texmf-dist/scripts/pdfjam/pdfbook
  409. texlive-collection-binextra,/usr/bin/pdfcrop,/usr/share/texmf-dist/scripts/pdfcrop/pdfcrop.pl
  410. texlive-collection-binextra,/usr/bin/pdfflip,/usr/share/texmf-dist/scripts/pdfjam/pdfflip
  411. texlive-collection-binextra,/usr/bin/pdfjam,/usr/share/texmf-dist/scripts/pdfjam/pdfjam
  412. texlive-collection-binextra,/usr/bin/pdfjam-pocketmod,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-pocketmod
  413. texlive-collection-binextra,/usr/bin/pdfjam-slides3up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides3up
  414. texlive-collection-binextra,/usr/bin/pdfjam-slides6up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides6up
  415. texlive-collection-binextra,/usr/bin/pdfjoin,/usr/share/texmf-dist/scripts/pdfjam/pdfjoin
  416. texlive-collection-binextra,/usr/bin/pdfnup,/usr/share/texmf-dist/scripts/pdfjam/pdfnup
  417. texlive-collection-binextra,/usr/bin/pdfpun,/usr/share/texmf-dist/scripts/pdfjam/pdfpun
  418. texlive-collection-binextra,/usr/bin/pkfix,/usr/share/texmf-dist/scripts/pkfix/pkfix.pl
  419. texlive-collection-binextra,/usr/bin/pkfix-helper,/usr/share/texmf-dist/scripts/pkfix-helper/pkfix-helper
  420. texlive-collection-binextra,/usr/bin/purifyeps,/usr/share/texmf-dist/scripts/purifyeps/purifyeps
  421. texlive-collection-binextra,/usr/bin/sty2dtx,/usr/share/texmf-dist/scripts/sty2dtx/sty2dtx.pl
  422. texlive-collection-binextra,/usr/bin/texcount,/usr/share/texmf-dist/scripts/texcount/texcount.pl
  423. texlive-collection-binextra,/usr/bin/texdef,/usr/share/texmf-dist/scripts/texdef/texdef.pl
  424. texlive-collection-binextra,/usr/bin/texdiff,/usr/share/texmf-dist/scripts/texdiff/texdiff
  425. texlive-collection-binextra,/usr/bin/texdirflatten,/usr/share/texmf-dist/scripts/texdirflatten/texdirflatten
  426. texlive-collection-binextra,/usr/bin/texloganalyser,/usr/share/texmf-dist/scripts/texloganalyser/texloganalyser
  427. texlive-collection-fontutils,/usr/bin/afm2afm,/usr/share/texmf-dist/scripts/fontools/afm2afm
  428. texlive-collection-fontutils,/usr/bin/autoinst,/usr/share/texmf-dist/scripts/fontools/autoinst
  429. texlive-collection-fontutils,/usr/bin/cmap2enc,/usr/share/texmf-dist/scripts/fontools/cmap2enc
  430. texlive-collection-fontutils,/usr/bin/epstopdf,/usr/share/texmf-dist/scripts/epstopdf/epstopdf.pl
  431. texlive-collection-fontutils,/usr/bin/font2afm,/usr/share/texmf-dist/scripts/fontools/font2afm
  432. texlive-collection-fontutils,/usr/bin/mkt1font,/usr/share/texmf-dist/scripts/accfonts/mkt1font
  433. texlive-collection-fontutils,/usr/bin/ot2kpx,/usr/share/texmf-dist/scripts/fontools/ot2kpx
  434. texlive-collection-fontutils,/usr/bin/pfm2kpx,/usr/share/texmf-dist/scripts/fontools/pfm2kpx
  435. texlive-collection-fontutils,/usr/bin/showglyphs,/usr/share/texmf-dist/scripts/fontools/showglyphs
  436. texlive-collection-fontutils,/usr/bin/vpl2ovp,/usr/share/texmf-dist/scripts/accfonts/vpl2ovp
  437. texlive-collection-fontutils,/usr/bin/vpl2vpl,/usr/share/texmf-dist/scripts/accfonts/vpl2vpl
  438. texlive-collection-htmlxml,/usr/bin/ht,/usr/share/texmf-dist/scripts/tex4ht/ht.sh
  439. texlive-collection-htmlxml,/usr/bin/htcontext,/usr/share/texmf-dist/scripts/tex4ht/htcontext.sh
  440. texlive-collection-htmlxml,/usr/bin/htlatex,/usr/share/texmf-dist/scripts/tex4ht/htlatex.sh
  441. texlive-collection-htmlxml,/usr/bin/htmex,/usr/share/texmf-dist/scripts/tex4ht/htmex.sh
  442. texlive-collection-htmlxml,/usr/bin/httex,/usr/share/texmf-dist/scripts/tex4ht/httex.sh
  443. texlive-collection-htmlxml,/usr/bin/httexi,/usr/share/texmf-dist/scripts/tex4ht/httexi.sh
  444. texlive-collection-htmlxml,/usr/bin/htxelatex,/usr/share/texmf-dist/scripts/tex4ht/htxelatex.sh
  445. texlive-collection-htmlxml,/usr/bin/htxetex,/usr/share/texmf-dist/scripts/tex4ht/htxetex.sh
  446. texlive-collection-htmlxml,/usr/bin/mk4ht,/usr/share/texmf-dist/scripts/tex4ht/mk4ht.pl
  447. texlive-collection-langgreek,/usr/bin/mkgrkindex,/usr/share/texmf-dist/scripts/mkgrkindex/mkgrkindex
  448. texlive-collection-langindic,/usr/bin/ebong,/usr/share/texmf-dist/scripts/ebong/ebong.py
  449. texlive-collection-latex,/usr/bin/mptopdf,/usr/share/texmf-dist/scripts/context/perl/mptopdf.pl
  450. texlive-collection-latex,/usr/bin/pdfatfi,/usr/share/texmf-dist/scripts/oberdiek/pdfatfi.pl
  451. texlive-collection-latexextra,/usr/bin/authorindex,/usr/share/texmf-dist/scripts/authorindex/authorindex
  452. texlive-collection-latexextra,/usr/bin/makeglossaries,/usr/share/texmf-dist/scripts/glossaries/makeglossaries
  453. texlive-collection-latexextra,/usr/bin/pdfannotextractor,/usr/share/texmf-dist/scripts/pax/pdfannotextractor.pl
  454. texlive-collection-latexextra,/usr/bin/pdfthumb,/usr/share/texmf-dist/scripts/ppower4/pdfthumb.tlu
  455. texlive-collection-latexextra,/usr/bin/perltex,/usr/share/texmf-dist/scripts/perltex/perltex.pl
  456. texlive-collection-latexextra,/usr/bin/ppower4,/usr/share/texmf-dist/scripts/ppower4/ppower4.tlu
  457. texlive-collection-latexextra,/usr/bin/ps4pdf,/usr/share/texmf-dist/scripts/pst-pdf/ps4pdf
  458. texlive-collection-latexextra,/usr/bin/splitindex,/usr/share/texmf-dist/scripts/splitindex/perl/splitindex.pl
  459. texlive-collection-latexextra,/usr/bin/svn-multi,/usr/share/texmf-dist/scripts/svn-multi/svn-multi.pl
  460. texlive-collection-latexextra,/usr/bin/vpe,/usr/share/texmf-dist/scripts/vpe/vpe.pl
  461. texlive-collection-latexrecommended,/usr/bin/thumbpdf,/usr/share/texmf-dist/scripts/thumbpdf/thumbpdf.pl
  462. texlive-collection-luatex,/usr/bin/mkluatexfontdb,/usr/share/texmf-dist/scripts/luaotfload/mkluatexfontdb.lua
  463. texlive-collection-music,/usr/bin/musixflx,/usr/share/texmf-dist/scripts/musixtex/musixflx.lua
  464. texlive-collection-music,/usr/bin/musixtex,/usr/share/texmf-dist/scripts/musixtex/musixtex.lua
  465. texlive-collection-pictures,/usr/bin/cachepic,/usr/share/texmf-dist/scripts/cachepic/cachepic.tlu
  466. texlive-collection-pictures,/usr/bin/epspdf,/usr/share/texmf-dist/scripts/epspdf/epspdf.rb
  467. texlive-collection-pictures,/usr/bin/epspdftk,/usr/share/texmf-dist/scripts/epspdf/epspdftk.tcl
  468. texlive-collection-pictures,/usr/bin/fig4latex,/usr/share/texmf-dist/scripts/fig4latex/fig4latex
  469. texlive-collection-pictures,/usr/bin/mathspic,/usr/share/texmf-dist/scripts/mathspic/mathspic.pl
  470. texlive-collection-pstricks,/usr/bin/pst2pdf,/usr/share/texmf-dist/scripts/pst2pdf/pst2pdf
  471. texlive-collection-science,/usr/bin/ulqda,/usr/share/texmf-dist/scripts/ulqda/ulqda.pl
  472. )
  473. %__mkdir_p %{buildroot}%{_bindir}
  474. pushd %{buildroot}%{_bindir}
  475. for i in "${mk_symlinks[@]}"; do
  476. tlc=$(echo $i | cut -f 1 -d",")
  477. lnk=$(echo $i | cut -f 2 -d"," | %__sed -e "s|/usr/bin/||")
  478. rlnk=$(echo $i | cut -f 3 -d"," | %__sed -e "s|/usr/|../|")
  479. [ "%{name}" = "$tlc" ] || continue
  480. [ -f $rlnk ] || exit 1
  481. %__ln_s $rlnk $lnk || exit 1
  482. done
  483. popd
  484. ## use external packages
  485. %__rm %{buildroot}/usr/bin/latexmk || exit 1
  486. ## Files list
  487. find %{buildroot} -type f -or -type l | \
  488. %__sed -e "s|%{buildroot}||g" > filelist.full
  489. find %{buildroot}%{texmf}-dist -type d | \
  490. %__sed -e "s|^%{buildroot}|%dir |" \
  491. -e "s|$|/|" >> filelist.full
  492. ## subpackages
  493. grep "/texmf-dist/doc/" filelist.full > filelist.doc
  494. cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
  495. %__mv -f filelist.tmp filelist.full
  496. %clean
  497. %__rm -rf %{buildroot}
  498. %post
  499. %{exec_texhash}
  500. exit 0
  501. %postun
  502. if [ "$1" = 0 ]; then
  503. %{exec_texhash}
  504. fi
  505. exit 0
  506. %files -f filelist.full
  507. %defattr(-,root,root,-)
  508. %files -f filelist.doc doc
  509. %defattr(-,root,root,-)
  510. %changelog
  511. * Sat Dec 3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
  512. - generated by tlpdb2rpmspec 2011-2: tlpdb2rpmspec collection-binextra
  513. - set external dependencies (texlive-collection-binextra,
  514. texlive-collection-fontutils)
  515. * Sun Oct 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
  516. - generated by tlpdb2rpmspec 2011-1: tlpdb2rpmspec collection-binextra
  517. * Mon Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
  518. - generated by tlpdb2rpmspec 2009-4: tlpdb2rpmspec collection-binextra
  519. - make symlinks of core script utils (texlive-collection-binextra,
  520. texlive-collection-context, texlive-collection-fontutils,
  521. texlive-collection-langgreek, texlive-collection-langindic,
  522. texlive-collection-latex, texlive-collection-latexextra,
  523. texlive-collection-latexrecommended, texlive-collection-pictures,
  524. texlive-collection-pstricks, texlive-collection-science)
  525. * Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
  526. - generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-binextra
  527. - improved %%post
  528. * Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  529. - generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-binextra
  530. - removed arch dependent binaries (texlive-collection-latexextra)
  531. - fixed perl path
  532. - improved updmap process in %%post and %%postun
  533. * Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  534. - generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-binextra