notify-python-vl.spec 2.8 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. Summary: Python bindings for libnotify
  3. Summary(ja): libnotify の Python バインディング
  4. Name: notify-python
  5. Version: 0.1.1
  6. Release: 3%{?_dist_release}
  7. Group: Development/Languages
  8. # No version specified, just COPYING.
  9. License: LGPLv2+
  10. URL: http://www.galago-project.org/specs/notification
  11. Source0: http://www.galago-project.org/files/releases/source/notify-python/notify-python-%{version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  13. BuildRequires: python-devel, pkgconfig, libnotify-devel, pygtk2-devel
  14. BuildRequires: gtk2-devel, dbus-devel, dbus-glib-devel
  15. Requires: libnotify
  16. Requires: notification-daemon
  17. %define pypkgname pynotify
  18. %description
  19. Python bindings for libnotify
  20. %prep
  21. %setup -q
  22. # WARNING - we touch src/pynotify.override in build because upstream did not rebuild pynotify.c
  23. # from the input definitions, this forces pynotify.c to be regenerated, at some point this can be removed
  24. %build
  25. CFLAGS="$RPM_OPT_FLAGS"
  26. PYTHON=%{__python}
  27. %configure
  28. touch src/pynotify.override
  29. make
  30. %install
  31. rm -rf $RPM_BUILD_ROOT
  32. make DESTDIR=$RPM_BUILD_ROOT install
  33. # remove unnecessary la file
  34. rm $RPM_BUILD_ROOT/%{python_sitearch}/gtk-2.0/%{pypkgname}/_%{pypkgname}.la
  35. %clean
  36. rm -rf $RPM_BUILD_ROOT
  37. %files
  38. %defattr(-,root,root,-)
  39. %doc
  40. %{python_sitearch}/gtk-2.0/%{pypkgname}
  41. %{_datadir}/pygtk/2.0/defs/%{pypkgname}.defs
  42. %{_libdir}/pkgconfig/%{name}.pc
  43. %changelog
  44. * Sat Oct 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.1.1-3
  45. - rebuilt with rpm-4.8.1 for pkg-config
  46. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.1.1-2
  47. - rebuild with python-2.6
  48. * Mon Nov 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.1-1
  49. - initial build for Vine Linux
  50. * Mon Aug 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.1.1-4
  51. - fix license tag
  52. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.1.1-3
  53. - Autorebuild for GCC 4.3
  54. * Fri Jan 4 2008 <jdennis@redhat.com> - 0.1.1-2
  55. - Resolves bug# 427499: attach_to_status_icon not created
  56. force regeneration of pynotify.c
  57. * Wed Jan 2 2008 John Dennis <jdennis@redhat.com> - 0.1.1-1
  58. - upgrade to current upstream
  59. - no longer remove package config file (notify-python.pc), resolves bug #427001
  60. * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 0.1.0-4
  61. - rebuild for python 2.5
  62. * Tue Aug 15 2006 Luke Macken <lmacken@redhat.com> - 0.1.0-3
  63. - Add notify-python-0.1.0-attach_to_status_icon.patch to allow the attaching
  64. notifications to status icons.
  65. * Thu Jul 20 2006 John Dennis <jdennis@redhat.com> - 0.1.0-2
  66. - change use of python_sitelib to python_sitearch, add BuildRequires
  67. * Wed Jul 19 2006 John Dennis <jdennis@redhat.com> - 0.1.0-1
  68. - Initial build