libpcap-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460
  1. %define pcap_major 1
  2. %define pcap_minor 0
  3. %define pcap_subminor 0
  4. %define libpcap_ver %{pcap_major}.%{pcap_minor}.%{pcap_subminor}
  5. Summary: A system-independent interface for user-level packet capture.
  6. Summary(ja): ユーザレベルでパケットをキャプチャするインターフェイス
  7. Name: libpcap
  8. Version: %{libpcap_ver}
  9. Release: 2%{?_dist_release}
  10. Epoch: 1
  11. # XXX epoch is necessary to obsolete tcpdump-3.4a5
  12. License: BSD
  13. Group: System Environment/Libraries
  14. Source0: http://www.tcpdump.org/release/libpcap-%{libpcap_ver}.tar.gz
  15. Patch50: libpcap-1.0.0-shared.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: kernel-headers >= 2.2.0
  18. BuildRequires: flex >= 2.4
  19. BuildRequires: bison
  20. BuildRequires: openssl-devel
  21. Requires: kernel >= 2.2.0
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. %description
  25. Libpcap provides a portable framework for low-level network
  26. monitoring. Libpcap can provide network statistics collection,
  27. security monitoring and network debugging. Since almost every system
  28. vendor provides a different interface for packet capture, the libpcap
  29. authors created this system-independent API to ease in porting and to
  30. alleviate the need for several system-dependent packet capture modules
  31. in each application.
  32. Install libpcap if you need to do low-level network traffic monitoring
  33. on your network.
  34. %description -l ja
  35. Libpcap は低レベルでネットワークをモニタするためのポータブルなフレーム
  36. ワークを提供します。Libpcap はネットワークの統計を収集したり、セキュリ
  37. ティの為のモニタリングやネットワークのデバッグなどの用途に使用できます。
  38. ほぼ全てのシステムベンダがパケットのキャプチャに異なるインターフェイス
  39. を提供していたので、libpcap の作者は 移植性を良くして 各々のアプリケー
  40. ションにおける数々のシステムに依存したパケットキャプチャモジュールを
  41. 可能にするために、このシステムに依存しない API を作成しました。
  42. ネットワークの低レベルのトラフィックを監視する必要がある場合、libpcap
  43. をインストールして下さい。
  44. %package devel
  45. Summary: Development package for %{name}
  46. Group: Development/Libraries
  47. Requires: %{name} = %{epoch}:%{version}-%{release}
  48. %description devel
  49. The %{name}-devel package contains the files needed for development
  50. with %{name}.
  51. %prep
  52. %setup -q
  53. %patch50 -p1 -b .shared
  54. %build
  55. %configure --enable-ipv6
  56. DEFS="-g -D_U_=\"\" -fPIC -DHAVE_CONFIG_H"
  57. %ifarch alpha sparc sparc64
  58. DEFS="$DEFS -DHAVE_ETHER_HOSTTON=1 -DLBL_ALIGN=1"
  59. %endif
  60. make DEFS="$DEFS" \
  61. LIBMAJOR="%{pcap_major}" \
  62. LIBMINOR="%{pcap_minor}" \
  63. LIBSUBMINOR="%{pcap_subminor}"
  64. %install
  65. rm -rf $RPM_BUILD_ROOT
  66. mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
  67. mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
  68. make DESTDIR=${RPM_BUILD_ROOT} \
  69. includedir=%{_includedir}/pcap \
  70. LIBMAJOR="%{pcap_major}" \
  71. LIBMINOR="%{pcap_minor}" \
  72. LIBSUBMINOR="%{pcap_subminor}" \
  73. install
  74. #chmod +x ${RPM_BUILD_ROOT}%{_libdir}/libpcap.so.*
  75. %clean
  76. rm -rf ${RPM_BUILD_ROOT}
  77. %post -p /sbin/ldconfig
  78. %postun -p /sbin/ldconfig
  79. %files
  80. %defattr(-,root,root)
  81. %doc README CHANGES
  82. %{_libdir}/libpcap.so.*
  83. %files devel
  84. %defattr(-,root,root)
  85. %{_bindir}/pcap-config
  86. %{_includedir}/pcap
  87. %{_libdir}/libpcap.so
  88. %{_libdir}/libpcap.a
  89. %{_mandir}/man1/*
  90. %{_mandir}/man3/*
  91. %{_mandir}/man5/*
  92. %{_mandir}/man7/*
  93. %changelog
  94. * Fri Apr 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:1.0.0-2vl5
  95. - split devel package
  96. * Wed Oct 29 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1:1.0.0-1vl5
  97. - new upstream release
  98. - update Patch50 to fit 1.0.0
  99. * Mon Apr 14 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1:0.9.8-2vl5
  100. - add BuildRequires: flex >= 2.4, bison
  101. * Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.9.8-1vl5
  102. - new upstream release
  103. * Sat Sep 1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.9.7-0vl1
  104. - new upstream release
  105. * Sat Jul 7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.9.6-0vl1
  106. - new upstream release
  107. * Sun Aug 21 2005 Satoshi MACHINO <machino@vinelinux.org> 1:0.9.3-0vl1
  108. - new upstream release
  109. * Sun Jun 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.8.3-0vl1
  110. - new upstream release
  111. * Sat Oct 11 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.7.2-0vl1
  112. - updated to 0.7.2
  113. - dropped patch52
  114. - s/Copyright/License/
  115. * Fri Feb 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.7.1-0vl1
  116. - libpcap standalone package splitted from tcpdump
  117. * Fri Feb 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.7.1-0vl1
  118. - update to new upstream release tcpdump 3.7.1
  119. - drop unneeded patches
  120. - use autoconf213, automake14
  121. - split arpwatch
  122. * Fri Feb 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.6.2-13vl2
  123. - add patch16 to fix print_bgp security bug
  124. - errata 20030221-3
  125. * Wed Jun 12 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.6.2-13vl1
  126. - merged with 3.6.2-13
  127. - fix buffer overflow for errata
  128. * Thu May 16 2002 Harald Hoyer <harald@redhat.de> 12:3.6.2-13
  129. - added official 3.6.3 fix
  130. - fixed 6.2 compat #63113
  131. * Wed Jan 23 2002 Harald Hoyer <harald@redhat.de> 12:3.6.2-12
  132. - tcpdump-3.6.2-snaplen.patch added to fix #55145
  133. * Tue Dec 18 2001 Harald Hoyer <harald@redhat.de> 12:3.6.2-10
  134. - took old purge patch for filters
  135. - fixed #54225,#58346
  136. - drop root by default #49635
  137. - fixed #54593
  138. - fixed #57711
  139. * Thu Oct 25 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp>
  140. - 3.6.2-9vl1
  141. - used PRM macros
  142. - changed File Name to Package Name in Prereq tag
  143. - marged 3.6.2-9 (RedHat7.2)
  144. * Tue Jan 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  145. - 3.4-19vl2
  146. - use better macros
  147. * Thu Sep 21 2000 Yoshihiro Kajiki <kajiki@ylug.org>
  148. - add libpcap-0.4-guy-gerald.patch to fix the timeout problem (by Ethereal)
  149. - add Japanese summarys and descriptions
  150. - modify spec file to build as a normal user
  151. * Thu Feb 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  152. - Compile shared libpcap with -fPIC (Bug #6342)
  153. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  154. - fix descriptions
  155. - man pages are compressed
  156. * Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
  157. - remove sparc64 SIOCGIFNAME hack, not needed with (at least) kernel 2.2.12-40.
  158. - upgrade to ANK ss991030 snapshot with pcap magic fix (#6773).
  159. - add getprotobyname lookup (#6725).
  160. - getservbyname port lookup appears functional (#7569).
  161. - remove uid 2090 backdoor (sorry Dave) (#7116).
  162. * Thu Sep 09 1999 Cristian Gafton <gafton@redhat.com>
  163. - fox the pcap.h header
  164. * Fri Aug 20 1999 Jeff Johnson <jbj@redhat.com>
  165. - prevent segfault on obscure spoofed ip header (#4634).
  166. * Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
  167. - add defattr to arpwatch (#4591).
  168. * Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
  169. - initscript munging
  170. * Sun Aug 8 1999 Jeff Johnson <jbj@redhat.com>
  171. - add -DWORDS_BIGINDIAN to tcpdump compile on sparc sparc61.
  172. * Tue Aug 3 1999 Jeff Johnson <jbj@redhat.com>
  173. - include A. Kuznetsov's patches to libpcap/tcpdump.
  174. - added arpsnmp to package (#3258).
  175. - arp2ethers written for different of awk (#4326).
  176. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  177. - auto rebuild in the new build environment (release 10)
  178. * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
  179. - strip binaries.
  180. * Wed Jan 13 1999 Bill Nottingham <notting@redhat.com>
  181. - autoconf fixes for arm
  182. * Tue Sep 29 1998 Jeff Johnson <jbj@redhat.com>
  183. - libpcap description typo.
  184. * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
  185. - fix arpwatch summary line.
  186. * Mon Aug 17 1998 Jeff Johnson <jbj@redhat.com>
  187. - enable arpwatch
  188. * Mon Aug 3 1998 Jeff Johnson <jbj@redhat.com>
  189. - separate package for libpcap.
  190. - update tcpdump to 3.4, libpcap to 0.4.
  191. - added arpwatch (but disabled for now)
  192. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  193. - translations modified for de, fr, tr
  194. * Sat May 2 1998 Alan Cox <alan@rehat.com>
  195. - Added the SACK printing fix so you can dump Linux 2.1+.
  196. * Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
  197. - updated to release 3.4a5
  198. - uses a buildroot and %attr
  199. * Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
  200. - built against glibc
  201. * Fri Aug 31 2001 Harald Hoyer <harald@redhat.de> 12:3.6.2-9
  202. - took better fix for #52654 from tcpdump cvs
  203. * Thu Aug 30 2001 Harald Hoyer <harald@redhat.de> 11:3.6.2-8
  204. - fixed #52654
  205. * Thu Jul 19 2001 Harald Hoyer <harald@redhat.de> 10:3.6.2-7
  206. - added shared library to libpcap (#47174)
  207. - afs printing security patch (#49294)
  208. * Wed Jun 20 2001 Harald Hoyer <harald@redhat.de>
  209. - use initgroups, instead of setgroups
  210. * Mon Jun 18 2001 Harald Hoyer <harald@redhat.de>
  211. - added dropgroup patches (#44563)
  212. * Mon May 07 2001 Harald Hoyer <harald@redhat.de>
  213. - switched to Pekka's tcpdump-3.6.2 package
  214. - incremented epoch
  215. * Sat Apr 14 2001 Pekka Savola <pekkas@netcore.fi>
  216. - fix building of tcpslice on glibc 2.2.2 (time.h)
  217. - disable /etc/init.d requirement and fix %post scripts in arpwatch
  218. * Wed Feb 14 2001 Harald Hoyer <harald@redhat.de>
  219. - glibc sys/time -> time include patch
  220. * Wed Feb 7 2001 Trond Eivind Glomsr <teg@redhat.com>
  221. - Add space to this check
  222. * Wed Feb 07 2001 Harald Hoyer <harald@redhat.com>
  223. - added check for presence of /etc/sysconfig/arpwatch (#23172)
  224. * Wed Feb 7 2001 Pekka Savola <pekkas@netcore.fi>
  225. - update to 3.6.2, 0.6.2 and new CVS of tcpslice.
  226. - i18n'ize arpwatch init script
  227. * Fri Feb 2 2001 Trond Eivind Glomsr <teg@redhat.com>
  228. - i18nize initscript
  229. * Mon Jan 29 2001 Harald Hoyer <harald@redhat.com>
  230. - fixed EINTR stopping for e.g. SIGSTOP. (#22008)
  231. - added -u option for tcpdump (#20231)
  232. - new arpwatch version (#23172)
  233. - added "all" and "one" interface for -i (#20907)
  234. - added arpwatch sysconfig (#23172)
  235. * Mon Jan 22 2001 Harald Hoyer <harald@redhat.com>
  236. - more (potential) overflows in libpcap. #21373
  237. - documentation fix for #20906
  238. * Sun Jan 14 2001 Pekka Savola <pekkas@netcore.fi>
  239. - use --enable-ipv6
  240. - Add two patches from CVS to enhance 802.2 printing, and more importantly,
  241. to be able to specify 'no stp'
  242. * Sat Jan 13 2001 Pekka Savola <pekkas@netcore.fi>
  243. - Make SMB printing output a lot more quiet unless in verbose mode.
  244. - Make -n resolve port/protocol numbers but not hostnames, -nn for no
  245. resolving at all
  246. - Separate droproot patch from a more generic man/usage fix one
  247. - Add non-promiscuous mode -by default patch, but don't apply it by default
  248. * Thu Jan 11 2001 Pekka Savola <pekkas@netcore.fi>
  249. - Update to tcpdump 3.6.1 and libpcap 0.6.1 releases.
  250. * Mon Jan 8 2001 Pekka Savola <pekkas@netcore.fi>
  251. - Update to 20010108 CVS, disable some upstreamed patches.
  252. - Change some additional .1 pages to .8.
  253. - Add droproot patch, some --usage and man page fixes.
  254. * Mon Jan 1 2001 Pekka Savola <pekkas@netcore.fi>
  255. - Initial packaging with latest tcpdump.org CVS tcpdump-3.6 and libpcap-0.6.
  256. - add earlier print-domain.c, the latest is segfaulting
  257. - don't unnecesessarily include snprintf.o, it didn't compile with gcc 2.96 anyway
  258. - don't use savestr, require openssl, tweak tweak tweak
  259. - add tcpslice, patch it a bit for egcs detection
  260. * Sun Dec 31 2000 Pekka Savola <pekkas@netcore.fi>
  261. - tcpdump: spice up the manpage about interfaces
  262. - tcpdump: add 'all' and 'any' keywords to -i, saner default behaviour.
  263. - upgrade arpwatch to 2.1a10
  264. * Sun Nov 26 2000 Jeff Johnson <jbj@redhat.com>
  265. - more (potential) overflows in libpcap.
  266. * Sun Nov 12 2000 Jeff Johnson <jbj@redhat.com>
  267. - eliminate still more buffer overflows (from FreeBSD) (#20069).
  268. * Thu Nov 2 2000 Jeff Johnson <jbj@redhat.com>
  269. - eliminate more buffer overflows (from FreeBSD) (#20069).
  270. - 802.1q ether type incorrect (#19850).
  271. - add -u flag to drop arpwatch privs (#19696).
  272. * Sun Oct 15 2000 Jeff Johnson <jbj@redhat.com>
  273. - updated ethercodes.dat
  274. * Thu Oct 12 2000 Jeff Johnson <jbj@redhat.com>
  275. - fix arpwatch tmp race (#18943).
  276. * Fri Aug 11 2000 Bill Nottingham <notting@redhat.com>
  277. - fix condrestart
  278. * Fri Aug 11 2000 Jeff Johnson <jbj@redhat.com>
  279. - correct arpsnmp man pages (#15442).
  280. - don't print harmless ENOPROTOOPT message (#13518).
  281. * Fri Aug 4 2000 Jeff Johnson <jbj@redhat.com>
  282. - rebuild with final kernel headers (#13518).
  283. * Sat Jul 22 2000 Jeff Johnson <jbj@redhat.com>
  284. - add STP patch (#14112).
  285. * Fri Jul 14 2000 Matt Wilson <msw@redhat.com>
  286. - source /etc/init.d/functions
  287. - back out /etc/init.d/arpwatch, place file in /etc/rc.d
  288. - move initscript to /etc/init.d
  289. - changed initscript to use start() and stop() functions
  290. - added condrestart to init script
  291. - added %%post %%preun %%postun scripts to register arpwatch script
  292. - added Prereq: for all things needed in post/preun/postun
  293. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  294. - automatic rebuild
  295. * Tue Jul 11 2000 Jeff Johnson <jbj@redhat.com>
  296. - updated man page and help (pekkas@netcore.fi) (#10739 et al).
  297. * Sun Jun 18 2000 Jeff Johnson <jbj@redhat/com>
  298. - FHS packaging.
  299. * Tue May 9 2000 Bill Nottingham <notting@redhat.com>
  300. - minor tweaks for ia64 (prototypes)
  301. * Thu Feb 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  302. - Compile shared libpcap with -fPIC (Bug #6342)
  303. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  304. - fix descriptions
  305. - man pages are compressed
  306. * Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
  307. - remove sparc64 SIOCGIFNAME hack, not needed with (at least) kernel 2.2.12-40.
  308. - upgrade to ANK ss991030 snapshot with pcap magic fix (#6773).
  309. - add getprotobyname lookup (#6725).
  310. - getservbyname port lookup appears functional (#7569).
  311. - remove uid 2090 backdoor (sorry Dave) (#7116).
  312. * Thu Sep 09 1999 Cristian Gafton <gafton@redhat.com>
  313. - fox the pcap.h header
  314. * Fri Aug 20 1999 Jeff Johnson <jbj@redhat.com>
  315. - prevent segfault on obscure spoofed ip header (#4634).
  316. * Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
  317. - add defattr to arpwatch (#4591).
  318. * Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
  319. - initscript munging
  320. * Sun Aug 8 1999 Jeff Johnson <jbj@redhat.com>
  321. - add -DWORDS_BIGINDIAN to tcpdump compile on sparc sparc61.
  322. * Tue Aug 3 1999 Jeff Johnson <jbj@redhat.com>
  323. - include A. Kuznetsov's patches to libpcap/tcpdump.
  324. - added arpsnmp to package (#3258).
  325. - arp2ethers written for different of awk (#4326).
  326. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  327. - auto rebuild in the new build environment (release 10)
  328. * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
  329. - strip binaries.
  330. * Wed Jan 13 1999 Bill Nottingham <notting@redhat.com>
  331. - autoconf fixes for arm
  332. * Tue Sep 29 1998 Jeff Johnson <jbj@redhat.com>
  333. - libpcap description typo.
  334. * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
  335. - fix arpwatch summary line.
  336. * Mon Aug 17 1998 Jeff Johnson <jbj@redhat.com>
  337. - enable arpwatch
  338. * Mon Aug 3 1998 Jeff Johnson <jbj@redhat.com>
  339. - separate package for libpcap.
  340. - update tcpdump to 3.4, libpcap to 0.4.
  341. - added arpwatch (but disabled for now)
  342. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  343. - translations modified for de, fr, tr
  344. * Sat May 2 1998 Alan Cox <alan@rehat.com>
  345. - Added the SACK printing fix so you can dump Linux 2.1+.
  346. * Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
  347. - updated to release 3.4a5
  348. - uses a buildroot and %attr
  349. * Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
  350. - built against glibc