libproxy-vl.spec 9.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320
  1. %bcond_with mozjs
  2. %define _unpackaged_files_terminate_build 1
  3. Summary: A library handling all the details of proxy configuration
  4. Name: libproxy
  5. Version: 0.4.15
  6. Release: 2%{?_dist_release}
  7. Group: System Environment/Libraries
  8. License: LGPLv2+
  9. URL: http://libproxy.github.io/libproxy
  10. Source0: https://github.com/libproxy/libproxy/releases/download/%{version}/libproxy-%{version}.tar.xz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  12. BuildRequires: python-devel
  13. BuildRequires: python3-devel
  14. #Virtual Provides - We need either mozjs or WebKit
  15. %if %{with mozjs}
  16. Requires: %{name}-pac >= %{version}
  17. %endif
  18. #
  19. Requires: libproxy-python = %{version}-%{release}
  20. Requires: libproxy-bin = %{version}-%{release}
  21. Obsoletes: %{name}-mozjs < 1.4.15
  22. Obsoletes: %{name}-webkitgtk3 < 1.4.15
  23. BuildRequires: cmake
  24. # gnome
  25. BuildRequires: GConf2-devel
  26. %if %{with mozjs}
  27. # mozjs
  28. BuildRequires: mozjs >= 38
  29. %endif
  30. # NetworkManager
  31. BuildRequires: NetworkManager-libnm-devel
  32. BuildRequires: dbus-devel
  33. BuildRequires: glib2
  34. # webkit (gtk)
  35. BuildRequires: webkitgtk4-devel
  36. # kde
  37. BuildRequires: libXmu-devel
  38. BuildRequires: libX11-devel
  39. BuildRequires: python-rpm-macros
  40. BuildRequires: python3-rpm-macros
  41. Provides: %{name}-webkit = %{version}-%{release}
  42. Obsoletes: %{name}-webkit < %{version}-%{release}
  43. Vendor: Project Vine
  44. Distribution: Vine Linux
  45. %description
  46. libproxy offers the following features:
  47. * extremely small core footprint (< 35K)
  48. * no external dependencies within libproxy core
  49. (libproxy plugins may have dependencies)
  50. * only 3 functions in the stable external API
  51. * dynamic adjustment to changing network topology
  52. * a standard way of dealing with proxy settings across all scenarios
  53. * a sublime sense of joy and accomplishment
  54. Non-default rpmbuild options:
  55. --with webkit: Enable WebKit-gtk support
  56. %package bin
  57. Summary: Binary to test %{name}
  58. Group: Applications/System
  59. Requires: %{name} = %{version}-%{release}
  60. %description bin
  61. The %{name}-bin package contains the proxy binary for %{name}
  62. %package python
  63. Summary: Binding for %{name} and python
  64. Group: System Environment/Libraries
  65. Requires: %{name} = %{version}-%{release}
  66. %description python
  67. The %{name}-python package contains the python binding for %{name}
  68. %package python3
  69. Summary: Binding for %{name} and python
  70. Group: System Environment/Libraries
  71. Requires: %{name} = %{version}-%{release}
  72. %description python3
  73. The %{name}-python package contains the python binding for %{name}
  74. %package gnome
  75. Summary: Plugin for %{name} and gnome
  76. Group: System Environment/Libraries
  77. Requires: %{name} = %{version}-%{release}
  78. %description gnome
  79. The %{name}-gnome package contains the %{name} plugin for gnome.
  80. %package kde
  81. Summary: Plugin for %{name} and kde
  82. Group: System Environment/Libraries
  83. Requires: %{name} = %{version}-%{release}
  84. %description kde
  85. The %{name}-kde package contains the %{name} plugin for kde.
  86. %if %{with mozjs}
  87. %package mozjs
  88. Summary: Plugin for %{name} and mozjs
  89. Group: System Environment/Libraries
  90. Requires: %{name} = %{version}
  91. #Tweak this according to the current gecko-libs version
  92. Requires: js
  93. Provides: %{name}-pac = %{version}-%{release}
  94. %description mozjs
  95. The %{name}-mozjs package contains the %{name} plugin for mozjs.
  96. %package webkitgtk4
  97. Summary: Plugin for %{name} and webkitgtk4
  98. Group: System Environment/Libraries
  99. Requires: %{name} = %{version}
  100. Provides: %{name}-pac = %{version}-%{release}
  101. %description webkitgtk4
  102. The %{name}-webkitgtk3 package contains the %{name} plugin for
  103. webkitgtk3.
  104. %endif
  105. %package devel
  106. Summary: Development files for %{name}
  107. Group: Development/Libraries
  108. Requires: %{name} = %{version}-%{release}
  109. Requires: pkgconfig
  110. %description devel
  111. The %{name}-devel package contains libraries and header files for
  112. developing applications that use %{name}.
  113. %prep
  114. %setup -q
  115. #sed -i "s|mozjs185>=1.8.5|mozjs185|" libproxy/cmake/modules/pacrunner_mozjs.cmk
  116. %build
  117. %cmake \
  118. -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
  119. -DMODULE_INSTALL_DIR=%{_libdir}/%{name}/%{version}/modules \
  120. -DWITH_PERL=OFF \
  121. -DWITH_WEBKIT3=ON \
  122. -DWITH_KDE=ON \
  123. .
  124. make VERBOSE=1 %{?_smp_mflags}
  125. %install
  126. rm -rf $RPM_BUILD_ROOT
  127. make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
  128. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  129. %clean
  130. rm -rf $RPM_BUILD_ROOT
  131. %post -p /sbin/ldconfig
  132. %postun -p /sbin/ldconfig
  133. %files
  134. %defattr(-,root,root,-)
  135. %license COPYING
  136. %doc AUTHORS README
  137. %{_libdir}/*.so.*
  138. %dir %{_libdir}/%{name}
  139. %dir %{_libdir}/%{name}/%{version}
  140. %dir %{_libdir}/%{name}/%{version}/modules
  141. %{_libdir}/%{name}/%{version}/modules/network_networkmanager.so
  142. %files bin
  143. %defattr(-,root,root,-)
  144. %{_bindir}/proxy
  145. %files python
  146. %defattr(-,root,root,-)
  147. %{python_sitelib}/libproxy.py
  148. %files python3
  149. %defattr(-,root,root,-)
  150. %{python3_sitelib}/libproxy.py
  151. %files gnome
  152. %defattr(-,root,root,-)
  153. %{_libdir}/%{name}/%{version}/modules/config_gnome3.so
  154. %{_libexecdir}/pxgsettings
  155. %files kde
  156. %defattr(-,root,root,-)
  157. %{_libdir}/%{name}/%{version}/modules/config_kde.so
  158. # Build the pacrunner into libproxy unless we are building for multiple engines
  159. %if %{with mozjs}
  160. %files mozjs
  161. %defattr(-,root,root,-)
  162. %{_libdir}/%{name}/%{version}/modules/pacrunner_mozjs.so
  163. %files webkitgtk4
  164. %defattr(-,root,root,-)
  165. %{_libdir}/%{name}/%{version}/modules/pacrunner_webkit.so
  166. %endif
  167. %files devel
  168. %defattr(-,root,root,-)
  169. %{_includedir}/proxy.h
  170. %{_libdir}/*.so
  171. %{_libdir}/pkgconfig/libproxy-1.0.pc
  172. %{_datadir}/cmake/Modules/Findlibproxy.cmake
  173. %changelog
  174. * Sun Apr 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4.15-2
  175. - rebuilt with current environment.
  176. * Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4.15-1
  177. - updated to 0.4.15.
  178. - enabled python3 support.
  179. - disabled mozjs as default.
  180. - switched to webkitgtk4.
  181. * Thu Jul 07 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.11-2
  182. - rebuild with gcc-5.4.0
  183. * Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.11-1
  184. - update to 0.4.11
  185. - remove Patch0 (libproxy-0.4.7-cmake-modules.patch)
  186. * Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-2
  187. - rebuild with python-2.7.2
  188. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-1
  189. - new upstream release
  190. - change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
  191. - change BuildRequires: js-devel instead of gecko-devel
  192. - replace Patch0 (libproxy-0.4.7-cmake-modules.patch)
  193. - detele -webkit sub package
  194. - create -webkitgtk3 sub package
  195. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.6-1
  196. - new upstream release
  197. - drop Patch0
  198. - add BuildRequires: cmake, kdelibs-devel
  199. - fix %files (from %{_libdir}/%{name}/%{version}/plugins to %{_libdir}/%{name}/%{version}/modules)
  200. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.3-5
  201. - rebuild with rpm-4.8.1 for pkg-config file
  202. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.2.3-4
  203. - rebuild with python-2.6
  204. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-3
  205. - rebuild with gecko-1.9.1
  206. * Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-2
  207. - rebuild with WebKit-gtk-1.0.0-8.svn41944
  208. * Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-1
  209. - initial build for Vine Linux
  210. * Mon Mar 9 2009 kwizart < kwizart at gmail.com > - 0.2.3-10
  211. - Rebuild for webkit
  212. - Raise requirement for xulrunner to 1.9.1
  213. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-9
  214. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  215. * Thu Jan 22 2009 kwizart < kwizart at gmail.com > - 0.2.3-8
  216. - Merge NetworkManager module into the main libproxy package
  217. - Main Requires the -python and -bin subpackage
  218. (splitted for multilibs compliance).
  219. * Fri Oct 24 2008 kwizart < kwizart at gmail.com > - 0.2.3-7
  220. - Disable Gnome/KDE default support via builtin modules.
  221. (it needs to be integrated via Gconf2/neon instead).
  222. * Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-6
  223. - Disable Obsoletes.
  224. - Requires ev instead of evr for optionnals sub-packages.
  225. * Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-5
  226. - Use conditionals build.
  227. * Mon Sep 15 2008 kwizart < kwizart at gmail.com > - 0.2.3-4
  228. - Remove plugin- in the name of the packages
  229. * Mon Aug 4 2008 kwizart < kwizart at gmail.com > - 0.2.3-3
  230. - Move proxy.h to libproxy/proxy.h
  231. This will prevent it to be included in the default include path
  232. - Split main to libs and util and use libproxy to install all
  233. * Mon Aug 4 2008 kwizart < kwizart at gmail.com > - 0.2.3-2
  234. - Rename binding-python to python
  235. - Add Requires: gecko-libs >= %%{gecko_version}
  236. - Fix some descriptions
  237. - Add plugin-webkit package
  238. * Fri Jul 11 2008 kwizart < kwizart at gmail.com > - 0.2.3-1
  239. - Convert to Fedora spec
  240. * Fri Jun 6 2008 - dominique-rpm@leuenberger.net
  241. - Updated to version 0.2.3
  242. * Wed Jun 4 2008 - dominique-rpm@leuenberger.net
  243. - Extended spec file to build all available plugins
  244. * Tue Jun 3 2008 - dominique-rpm@leuenberger.net
  245. - Initial spec file for Version 0.2.2