mdadm-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360
  1. %bcond_with systemd
  2. %define _udevrulesdir /lib/udev/rules.d
  3. Summary: Utilities for Linux md devices (software RAID arrays)
  4. Summary(ja): Linux の MD デバイス(ソフトウエアRAIDアレイ)用のユーティリティ
  5. Name: mdadm
  6. Version: 4.1
  7. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  8. Group: System Environment/Base
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. License: GPL
  13. URL: http://www.kernel.org/pub/linux/utils/raid/mdadm/
  14. Source: https://www.kernel.org/pub/linux/utils/raid/mdadm/mdadm-%{version}.tar.xz
  15. Source1: mdmonitor.init
  16. Source2: raid-check
  17. Source3: mdadm.rules
  18. Source4: mdadm-raid-check-sysconfig
  19. Source5: mdadm-cron
  20. Source103: mdadm.rules.systemd
  21. Source104: mdmonitor.service
  22. Source105: mdadm.conf
  23. Source106: mdadm_event.conf
  24. Source107: raid-check.timer
  25. Source108: raid-check.service
  26. Patch97: mdadm-3.3-udev.patch
  27. Patch98: mdadm-2.5.2-static.patch
  28. Obsoletes: mdctl,raidtools
  29. Requires: postfix
  30. BuildRequires: glibc-static
  31. %if %{with systemd}
  32. Requires(post): systemd coreutils
  33. Requires(preun): systemd
  34. Requires(postun): systemd coreutils
  35. %else
  36. Requires(post): /sbin/chkconfig
  37. Requires(preun): /sbin/chkconfig
  38. Requires(preun): /sbin/service
  39. Requires(postun): /sbin/service
  40. %endif
  41. %description
  42. mdadm is used to create, manage, and monitor Linux MD (software RAID)
  43. devices. As such, it provides similar functionality to the raidtools
  44. package. However, mdadm is a single program, and it can perform
  45. almost all functions without a configuration file, though a configuration
  46. file can be used to help with some common tasks.
  47. %prep
  48. %setup -q
  49. %autopatch -p1
  50. sed -i -e 's/ -Werror / /' Makefile
  51. %build
  52. make %{?_smp_mflags} CXFLAGS="$RPM_OPT_FLAGS" LDFLAGS="$RPM_LD_FLAGS" SYSCONFDIR="%{_sysconfdir}" mdadm mdmon
  53. %install
  54. rm -rf %{buildroot}
  55. %if %{with systemd}
  56. make DESTDIR=%{buildroot} MANDIR=%{_mandir} BINDIR=/sbin SYSTEMD_DIR=%{_unitdir} install install-systemd
  57. %else
  58. make DESTDIR=%{buildroot} MANDIR=%{_mandir} BINDIR=/sbin install
  59. %endif
  60. install -Dp -m 755 %{SOURCE2} %{buildroot}%{_sbindir}/raid-check
  61. install -Dp -m 644 %{SOURCE4} %{buildroot}%{_sysconfdir}/sysconfig/raid-check
  62. %if %{with systemd}
  63. install -Dp -m 644 %{SOURCE103} %{buildroot}%{_udevrulesdir}/65-md-incremental.rules
  64. # systemd
  65. mkdir -p %{buildroot}%{_unitdir}
  66. install -m644 %{SOURCE104} %{buildroot}%{_unitdir}
  67. install -m644 %{SOURCE107} %{buildroot}%{_unitdir}
  68. install -m644 %{SOURCE108} %{buildroot}%{_unitdir}
  69. # tmpfile
  70. mkdir -p %{buildroot}%{_tmpfilesdir}
  71. install -m 0644 %{SOURCE105} %{buildroot}%{_tmpfilesdir}/%{name}.conf
  72. install -d -m 0710 %{buildroot}/run/%{name}/
  73. # abrt
  74. #mkdir -p %{buildroot}/etc/libreport/events.d
  75. #install -m644 %{SOURCE6} %{buildroot}/etc/libreport/events.d
  76. %else
  77. # initscript
  78. mkdir -p %{buildroot}%{_initdir}
  79. install -m755 %{SOURCE1} %{buildroot}%{_initdir}/mdmonitor
  80. install -Dp -m 644 %{SOURCE5} %{buildroot}%{_sysconfdir}/cron.d/raid-check
  81. install -Dp -m 644 %{SOURCE3} %{buildroot}%{_udevrulesdir}/65-md-incremental.rules
  82. mkdir -p %{buildroot}%{_localstatedir}/run/mdadm
  83. %endif
  84. %clean
  85. rm -rf %{buildroot}
  86. %post
  87. %if %{with systemd}
  88. %systemd_post mdmonitor.service raid-check.{service,timer}
  89. %else
  90. /sbin/chkconfig --add mdmonitor
  91. %endif
  92. %preun
  93. %if %{with systemd}
  94. %systemd_preun mdmonitor.service raid-check.timer
  95. %else
  96. if [ "$1" = 0 -o -x /bin/systemctl ]; then
  97. service mdmonitor stop > /dev/null 2>&1 ||:
  98. /sbin/chkconfig --del mdmonitor
  99. fi
  100. if [ -e %{_initrddir}/mdmpd ]; then
  101. service mdmpd stop > /dev/null 2>&1 ||:
  102. /sbin/chkconfig --del mdmpd
  103. fi
  104. %endif
  105. %postun
  106. %if %{with systemd}
  107. %systemd_postun_with_restart mdmonitor.service
  108. %else
  109. if [ "$1" -ge "1" ]; then
  110. service mdmonitor condrestart > /dev/null 2>&1
  111. fi
  112. %endif
  113. %files
  114. %defattr(-,root,root)
  115. %license COPYING
  116. %doc mdadm.conf-example misc/*
  117. /sbin/*
  118. %{_sbindir}/*
  119. %if %{with systemd}
  120. %{_unitdir}/*
  121. /lib/systemd/system-shutdown/*
  122. %config(noreplace) %{_tmpfilesdir}/%{name}.conf
  123. %else
  124. %{_initdir}/*
  125. %config(noreplace) %{_sysconfdir}/cron.d/*
  126. %dir %{_localstatedir}/run/%{name}/
  127. %endif
  128. %{_mandir}/man*/md*
  129. %{_udevrulesdir}/*
  130. %config(noreplace) %{_sysconfdir}/sysconfig/*
  131. %changelog
  132. * Sun Apr 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1-1
  133. - new upstream release.
  134. - added systemd support (disabled as default).
  135. - dropped Patch93-96.
  136. * Sat Feb 24 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0-1
  137. - new upstream release.
  138. * Fri Jan 10 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3-1
  139. - new upstream release.
  140. * Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.9-4
  141. - rebuild with VineSeed environment
  142. * Mon Apr 18 2011 Shu KONNO <owa@bg.wakwak.com> 2.6.9-3
  143. - added BR: glibc-static
  144. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2.6.9-2
  145. - rebuilt with rpm-4.8.1-3
  146. * Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.9-1
  147. - new upstream release
  148. * Sat Oct 04 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.5-1vl5
  149. - applied new versioning policy, spec in utf-8
  150. * Wed Oct 25 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.5-0vl1
  151. - new upstream release
  152. * Wed Aug 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.3-0vl1
  153. - initial build for Vine Linux
  154. * Mon Aug 7 2006 Doug Ledford <dledford@redhat.com> - 2.5.3-1
  155. - Update to 2.5.3 which upstream calls a "bug fix" release
  156. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.5.2-1.1
  157. - rebuild
  158. * Fri Jul 7 2006 Doug Ledford <dledford@redhat.com> - 2.5.2-1
  159. - Update to 2.5.2
  160. - Remove auto default patch as upstream now has a preferred default auto method
  161. * Wed Mar 8 2006 Peter Jones <pjones@redhat.com> - 2.3.1-3
  162. - fix build on ppc64
  163. * Wed Mar 8 2006 Jeremy Katz <katzj@redhat.com> - 2.3.1-2
  164. - fix build on ppc
  165. * Wed Mar 8 2006 Jeremy Katz <katzj@redhat.com> - 2.3.1-1
  166. - update to 2.3.1 to fix raid5 (#184284)
  167. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.2-1.fc5.2.1
  168. - bump again for double-long bug on ppc(64)
  169. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.2-1.fc5.2
  170. - rebuilt for new gcc4.1 snapshot and glibc changes
  171. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  172. - rebuilt
  173. * Mon Dec 05 2005 Warren Togami <wtogami@redhat.com> 2.2-1
  174. - 2.2 upgrade (#167897)
  175. - disable diet because we don't ship it anymore
  176. and we don't actually use mdassemble now
  177. * Mon May 16 2005 Doug Ledford <dledford@redhat.com> 1.11.0-4.fc4
  178. - Make the mdmonitor init script use the pid-file option, major cleanup
  179. of the script now possible (#134459)
  180. * Mon May 16 2005 Doug Ledford <dledford@redhat.com> 1.11.0-3.fc4
  181. - Put back the obsoletes: raidtools that was present in 1.11.0-1.fc4
  182. * Mon May 16 2005 Doug Ledford <dledford@redhat.com> 1.11.0-2.fc4
  183. - Change the default auto= mode so it need not be on the command line to
  184. work with udev, however it is still supported on the command line (#132706)
  185. - Add a man page (from Luca Berra) for mdassemble
  186. * Wed May 11 2005 Doug Ledford <dledford@redhat.com> - 1.11.0-1.fc4
  187. - Upgrade to 1.11.0
  188. * Wed Apr 27 2005 Jeremy Katz <katzj@redhat.com> - 1.9.0-3.fc4
  189. - fix mdmonitor initscript (#144717)
  190. * Mon Mar 21 2005 Doug Ledford <dledford@redhat.com> 1.9.0-2
  191. - Build mdadm.static and mdassemble (static as well) to be used in initrd
  192. images
  193. * Wed Mar 09 2005 Doug Ledford <dledford@redhat.com> 1.9.0-1
  194. - Initial upgrade to 1.9.0 and update of doc files
  195. - Fix an s390 build error
  196. * Mon Oct 04 2004 Doug Ledford <dledford@redhat.com> 1.6.0-2
  197. - Remove /etc/mdadm.conf from the file list. Anaconda will write one out
  198. if it's needed.
  199. * Fri Oct 01 2004 Doug Ledford <dledford@redhat.com> 1.6.0-1
  200. - Update to newer upstream version
  201. - Make mdmpd work on kernels that don't have the event interface patch
  202. * Fri Jul 30 2004 Dan Walsh <dwalsh@redhat.com> 1.5.0-11
  203. - Create a directory /var/run/mdadm to contain mdadm.pid
  204. - This cleans up SELinux problem
  205. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  206. - rebuilt
  207. * Sat May 22 2004 Doug Ledford <dledford@redhat.com> - 1.5.0-9
  208. - Fix Makefile and build method to satisfy bz #123769
  209. - Add mdmpd man page, update mdmpd version to 0.3 - bz #117160
  210. - Make sure mdadm --monitor closes all md device files so that md devices
  211. can be stopped while mdadm is still running - bz #119532
  212. * Thu May 20 2004 Jeremy Katz <katzj@redhat.com> - 1.5.0-8
  213. - remove unneeded patch, can use --run instead
  214. * Wed May 19 2004 Jeremy Katz <katzj@redhat.com> - 1.5.0-7
  215. - add patch with reallyforce mode on creation to be used by anaconda
  216. * Wed May 12 2004 Doug Ledford <dledford@redhat.com> 2.5.0-6
  217. - Fix a bug in the %postun scriptlet related to downgrading to a version
  218. of mdadm that doesn't include the mdmpd daemon.
  219. * Fri May 07 2004 Doug Ledford <dledford@redhat.com> 1.5.0-5
  220. - Disable service mdmpd by default to avoid [Failed] messages on
  221. current 2.6 kernels. Possibly re-enable it by default once the
  222. 2.6 kernels have the md event interface.
  223. * Thu Apr 22 2004 Doug Ledford <dledford@redhat.com> 1.5.0-4
  224. - Update mdmonitor script to start daemon more cleanly
  225. - Repackage mdmpd tarball to include gcc-3.4 changes and to make
  226. mdmpd properly daemonize at startup instead of forking and leaving
  227. the child attached to the terminal.
  228. * Thu Mar 4 2004 Bill Nottingham <notting@redhat.com> 1.5.0-3
  229. - ship /var/run/mpmpd (#117497)
  230. * Thu Feb 26 2004 Doug Ledford <dledford@redhat.com> 1.5.0-2
  231. - Add a default MAILADDR line to the mdadm.conf file installed by default
  232. (Bugzilla #92447)
  233. - Make it build with gcc-3.4
  234. * Mon Feb 23 2004 Doug Ledford <dledford@redhat.com> 1.5.0-1
  235. - Update to 1.5.0 (from Matthew J. Galgoci <mgalgoci@redhat.com>)
  236. * Sun Nov 16 2003 Doug Ledford <dledford@redhat.com> 1.4.0-1
  237. - fix problem with recovery thread sleeping in mdmpd
  238. * Fri Nov 14 2003 Doug Ledford <dledford@redhat.com>
  239. - sync upstream
  240. - add mdmpd package into mdadm package
  241. * Wed Sep 10 2003 Michael K. Johnson <johnsonm@redhat.com> 1.3.0-1
  242. - sync upstream
  243. * Tue Mar 11 2003 Michael K. Johnson <johnsonm@redhat.com> 1.1.0-1
  244. - sync upstream
  245. * Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 1.0.1-1
  246. - update for rebuild
  247. * Wed Dec 25 2002 Tim Powers <timp@redhat.com> 1.0.0-8
  248. - fix references to %%install in the changelog so that it will build
  249. * Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.0.0-7
  250. - Rebuild
  251. * Fri Jul 12 2002 Michael K. Johnson <johnsonm@redhat.com>
  252. - Changed RPM Group to System Environment/Base
  253. * Wed May 15 2002 Michael K. Johnson <johnsonm@redhat.com>
  254. - minor cleanups to the text, conditionalize rm -rf
  255. - added mdmonitor init script
  256. * Fri May 10 2002 <neilb@cse.unsw.edu.au>
  257. - update to 1.0.0
  258. - Set CXFLAGS instead of CFLAGS
  259. * Sat Apr 6 2002 <neilb@cse.unsw.edu.au>
  260. - change %%install to use "make install"
  261. * Fri Mar 15 2002 <gleblanc@localhost.localdomain>
  262. - beautification
  263. - made mdadm.conf non-replaceable config
  264. - renamed Copyright to License in the header
  265. - added missing license file
  266. - used macros for file paths
  267. * Fri Mar 15 2002 Luca Berra <bluca@comedia.it>
  268. - Added Obsoletes: mdctl
  269. - missingok for configfile
  270. * Tue Mar 12 2002 NeilBrown <neilb@cse.unsw.edu.au>
  271. - Add md.4 and mdadm.conf.5 man pages
  272. * Fri Mar 08 2002 Chris Siebenmann <cks@cquest.utoronto.ca>
  273. - builds properly as non-root.
  274. * Fri Mar 08 2002 Derek Vadala <derek@cynicism.com>
  275. - updated for 0.7, fixed /usr/share/doc and added manpage
  276. * Tue Aug 07 2001 Danilo Godec <danci@agenda.si>
  277. - initial RPM build