gpac-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365
  1. #% global svndate 20111217
  2. %define with_static 1
  3. Name: gpac
  4. Summary: MPEG-4 multimedia framework
  5. Version: 0.5.0
  6. Release: 4%{?svndate:.svn%svndate}%{?_dist_release}
  7. License: LGPLv2+
  8. Group: System Environment/Libraries
  9. URL: http://gpac.sourceforge.net/
  10. Source0: http://downloads.sourceforge.net/gpac/gpac-%{version}.tar.gz
  11. #Source0: gpac-%{svndate}.tar.bz2
  12. #Source9: gpac-snapshot-vine.sh
  13. Patch1: gpac-0.5.0-libdir.patch
  14. Patch2: gpac-0.4.6-amr.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  16. Obsoletes: %{name} < %{version}, %{name}-libs < %{version}
  17. Obsoletes: %{name}-devel < %{version}
  18. Obsoletes: %{name}-devel-static < %{version}
  19. Requires: %{name}-libs = %{version}-%{release}
  20. BuildRequires: ImageMagick
  21. BuildRequires: SDL-devel
  22. BuildRequires: librsvg2-devel >= 2.5.0
  23. BuildRequires: libGLU-devel
  24. BuildRequires: freeglut-devel
  25. BuildRequires: freetype2-devel >= 2.1.4
  26. BuildRequires: libjpeg-devel
  27. BuildRequires: libpng-devel >= 1.2.5
  28. BuildRequires: libxml2-devel
  29. BuildRequires: openssl-devel
  30. #BuildRequires: openjpeg-devel
  31. BuildRequires: pulseaudio-libs-devel
  32. BuildRequires: zlib-devel
  33. BuildRequires: libogg-devel libvorbis-devel libtheora-devel
  34. BuildRequires: libXt-devel
  35. BuildRequires: libXpm-devel
  36. BuildRequires: libXv-devel
  37. #BuildRequires: wxGTK-devel
  38. %{?_with_mozilla:BuildRequires: gecko-devel}
  39. #BuildRequires: doxygen
  40. BuildRequires: desktop-file-utils
  41. %{?_with_amr:BuildRequires: amrnb-devel amrwb-devel}
  42. # *-devel packages provided by other self-build-* should only be listed
  43. # in self-build-%{name}.spec as PreReq.
  44. #BuildRequires: a52dec-devel
  45. #BuildRequires: faad2-devel
  46. #BuildRequires: libmad-devel
  47. #BuildRequires: xvidcore-devel >= 1.0.0
  48. ##BuildRequires: ffmpeg-devel
  49. %description
  50. GPAC is a multimedia framework based on the MPEG-4 Systems standard developed
  51. from scratch in ANSI C. The original development goal is to provide a clean,
  52. small and flexible alternative to the MPEG-4 Systems reference software.
  53. GPAC features the integration of recent multimedia standards (SVG/SMIL, VRML,
  54. X3D, SWF, 3GPP(2) tools and more) into a single framework. GPAC also features
  55. MPEG-4 Systems encoders/multiplexers, publishing tools for content distribution
  56. for MP4 and 3GPP(2) files and many tools for scene descriptions
  57. (MPEG4 <-> VRML <-> X3D converters, SWF -> MPEG-4, etc).
  58. %package libs
  59. Summary: Library for %{name}
  60. Group: System Environment/Libraries
  61. %description libs
  62. The %{name}-libs package contains library for %{name}.
  63. %package devel
  64. Summary: Development libraries and files for %{name}
  65. Group: Development/Libraries
  66. Requires: %{name}-libs = %{version}-%{release}
  67. %description devel
  68. Development libraries and files for gpac.
  69. %if %{with_static}
  70. %package devel-static
  71. Summary: Development libraries and files for %{name}
  72. Group: Development/Libraries
  73. Requires: %{name}-devel = %{version}-%{release}
  74. %description devel-static
  75. Static library for gpac.
  76. %endif
  77. %prep
  78. %setup -q -n gpac
  79. ## remove extra_libs directory
  80. %__rm -rf extra_libs
  81. %patch1 -p1 -b .libdir
  82. %patch2 -p1 -b .amr
  83. ## kwizart - enable dynamic mode - hardcoded with patch2
  84. # define SONAME number from the first number of gpac version.
  85. #define soname libgpac.so.0
  86. #sed -i.soname -e 's|EXTRALIBS+=$(GPAC_SH_FLAGS)|EXTRALIBS+=$(GPAC_SH_FLAGS)\nLDFLAGS+="-Wl,-soname,%{soname}"|' src/Makefile
  87. # Fix encoding warnings
  88. %__cp -p Changelog Changelog.origine
  89. iconv -f ISO-8859-1 -t UTF8 Changelog.origine > Changelog
  90. touch -r Changelog.origine Changelog
  91. %__rm -rf Changelog.origine
  92. %__cp -p doc/ipmpx_syntax.bt doc/ipmpx_syntax.bt.origine
  93. iconv -f ISO-8859-1 -t UTF8 doc/ipmpx_syntax.bt.origine > doc/ipmpx_syntax.bt
  94. touch -r doc/ipmpx_syntax.bt.origine doc/ipmpx_syntax.bt
  95. %__rm -rf doc/ipmpx_syntax.bt.origine
  96. # executable ./configure
  97. chmod +x configure
  98. %build
  99. %configure \
  100. --X11-path=%{_prefix} \
  101. --libdir=%{_lib} \
  102. %{?_with_mozilla:--mozdir=%{_libdir}/mozilla/plugins} \
  103. --enable-pic \
  104. --disable-static \
  105. --disable-wx \
  106. --extra-cflags="$RPM_OPT_FLAGS -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1 -D_GNU_SOURCE=1" \
  107. --disable-oss-audio \
  108. %{?_with_amr:--enable-amr} \
  109. --use-js=no \
  110. ;
  111. #Avoid mess with setup.h
  112. cp -p config.h include/gpac
  113. # Parallele build will fail
  114. %__make all OPTFLAGS="$RPM_OPT_FLAGS -fPIC -DPIC"
  115. #{?_smp_mflags}
  116. %__make sggen OPTFLAGS="$RPM_OPT_FLAGS -fPIC -DPIC"
  117. #{?_smp_mflags}
  118. # ## kwizart - build doxygen doc for devel
  119. # pushd doc
  120. # doxygen
  121. # popd
  122. %install
  123. %__rm -rf $RPM_BUILD_ROOT
  124. %__make DESTDIR=$RPM_BUILD_ROOT install install-lib
  125. #Install generated sggen binaries
  126. #MPEG4 SVG X3D
  127. for b in MPEG4 X3D; do
  128. pushd applications/generators/${b}
  129. %__install -pm 0755 ${b}Gen $RPM_BUILD_ROOT%{_bindir} || exit 1
  130. popd
  131. done
  132. # #Fix doxygen timestamp
  133. # touch -r Changelog doc/html/*
  134. #config.h like but not only
  135. #Usual multilib bug https://bugzilla.rpmfusion.org/show_bug.cgi?id=270
  136. %__sed -i -e '/GPAC_CONFIGURATION/d' $RPM_BUILD_ROOT%{_includedir}/gpac/configuration.h || exit 1
  137. touch -r Changelog $RPM_BUILD_ROOT%{_includedir}/gpac/*.h || exit 1
  138. touch -r Changelog $RPM_BUILD_ROOT%{_includedir}/gpac/internal/*.h || exit 1
  139. touch -r Changelog $RPM_BUILD_ROOT%{_includedir}/gpac/modules/*.h || exit 1
  140. %__rm $RPM_BUILD_ROOT%{_includedir}/gpac/config.h || exit 1
  141. %clean
  142. %__rm -rf $RPM_BUILD_ROOT
  143. %post libs -p /sbin/ldconfig
  144. %postun libs -p /sbin/ldconfig
  145. %files
  146. %defattr(-,root,root,-)
  147. %doc AUTHORS BUGS Changelog COPYING README TODO
  148. %{_bindir}/MP4*
  149. %{_bindir}/*Gen
  150. %{_datadir}/gpac/
  151. %{_mandir}/man1/*.1.*
  152. %files libs
  153. %defattr(-,root,root)
  154. %{_libdir}/libgpac.so.*
  155. %{_libdir}/gpac/
  156. %files devel
  157. %doc doc/CODING_STYLE doc/ipmpx_syntax.bt
  158. %defattr(-,root,root)
  159. %{_includedir}/gpac/
  160. %{_libdir}/libgpac.so
  161. %if %{with_static}
  162. %files devel-static
  163. %defattr(-,root,root,-)
  164. %{_libdir}/libgpac_static.a
  165. %else
  166. %exclude %{_libdir}/libgpac_static.a
  167. %endif
  168. %changelog
  169. * Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.0-4
  170. - remove BuildRequires: xmlrpc-epi-devel
  171. * Wed Oct 2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-3
  172. - added Obsoletes: %{name} < %{version} and so on.
  173. * Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-2
  174. - rebuild
  175. * Sat Jan 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-1
  176. - new upstream release
  177. * Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.6-2.svn20111217
  178. - rebuild
  179. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.6-1.svn20111217
  180. - update snapshot svn20111217
  181. - removed upstreamed/obsolated patches
  182. * Mon Apr 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-11
  183. - rebuilt with internal openjpeg
  184. - added --use-openjpeg=local in configure options
  185. - added --enable-pic in configure options
  186. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-10
  187. - rebuild
  188. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-9
  189. - removed doxygen support
  190. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-8
  191. - change release to sync with self-build-gpac
  192. * Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-7
  193. - rebuild
  194. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-6
  195. - added --use-js=no in configure
  196. - added devel-static subpackage
  197. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.7.4-5
  198. - change release to sync with self-build-gpac
  199. * Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-4
  200. - change release to sync with self-build-gpac
  201. * Thu Mar 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-3
  202. - applied gpac-0.4.5-ffmpeg.patch (RPM Fusion #454)
  203. - corrected default %%defattr
  204. * Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-2
  205. - dropped BuildRequires: ffmpeg-devel as self-build-ffmpeg
  206. - rebuilt with ffmpeg-devel by self-build-ffmpeg
  207. * Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-1
  208. - initial build based on RPM Fusion
  209. - without Osmo4 and its plugins for Mozilla browsers
  210. - added --disable-wx in configure options
  211. - included %%{_libdir}/libgpac_static.a in devel subpackage
  212. * Sun Dec 28 2008 kwizart < kwizart at gmail.com > - 0.4.5-3
  213. - Fix -devel doc timestamp which leads to multilib conflict
  214. ( RPM Fusion #270 )
  215. * Thu Dec 18 2008 kwizart < kwizart at gmail.com > - 0.4.5-2
  216. - Fix for ppc64
  217. * Wed Dec 17 2008 kwizart < kwizart at gmail.com > - 0.4.5-1
  218. - Update to 0.4.5 (final)
  219. - Drop upstreamed patches - Rewrite some
  220. - Add More BR.
  221. - Conditionalize --with mozilla amr
  222. * Mon Sep 8 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.5.20080217cvs
  223. - Fix for Large File Support (was livna #2075 )
  224. * Mon Feb 25 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.3.20080217cvs
  225. - Enable devel-static
  226. - Conditionalize Osmo4 (buggy).
  227. - Clean the spec
  228. * Sun Feb 17 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.2.20080217cvs
  229. - Update to 20080217.
  230. - Split libs.
  231. - Use the new amr nosrc scheme (need an end-users rebuilt to add support to it).
  232. - Add openjpeg-devel missing BR
  233. - Static patching instead of dyn patch when possible.
  234. - Disable %%{smp_mflags} (it tries to build the bin before the lib is ready)
  235. - Define soname as libgpac.so.0 (instead of libgpac.so.%%version )
  236. - Exclude static lib
  237. * Mon Feb 11 2008 Stewart Adam < s.adam at diffingo.com > - 0.4.5-0.1.20080211cvs
  238. - Use %%{smp_mflags}
  239. - Oops, we're actually 0.4.5
  240. - Fix gpac so filenames
  241. - Only install nposmozilla when %%{with_firefox} is set
  242. * Mon Feb 11 2008 Stewart Adam < s.adam at diffingo.com > - 0.4.4-3.20080211cvs
  243. - Update to 20080211cvs
  244. - Disable osmozilla, doesn't build with xulrunner
  245. - Fix builds with gcc 4.3
  246. * Sat Dec 15 2007 Stewart Adam < s.adam at diffingo.com > - 0.4.4-2
  247. - Rebuild for rawhide
  248. * Tue Oct 16 2007 Stewart Adam < s.adam at diffingo.com > - 0.4.4-1
  249. - Update to v4.4
  250. * Sat May 26 2007 kwizart < kwizart at gmail.com > - 0.4.3-0.1cvs20070526
  251. - Update to cvs 20070526
  252. - Enable conditional build ( 3gpp firefox )
  253. * Wed Apr 11 2007 kwizart < kwizart at gmail.com > - 0.4.3-0.1cvs20070411
  254. - Update to cvs 20070411
  255. * Thu Dec 08 2006 kwizart < kwizart at gmail.com > - 0.4.3-cvs20061208.1.kwizart.fc6
  256. - Update to 20061208
  257. - Uses firefox-devel (since fc6!)
  258. - Drop tutorial
  259. - Use version-DEV-date with libgpac.so
  260. - Disabled osmozilla
  261. - Fix soname
  262. - Enabled gprof
  263. * Tue Oct 17 2006 kwizart < kwizart at gmail.com > - 0.4.3-cvs20061017.1_FC5
  264. - gpac snapshot.sh
  265. - Revert Patch osmozilla.cpp (v1.17 - build error from gpac/internal/terminal_dev.h)
  266. - TODO: - no-soname make option for libgpac.so
  267. - static lib in devel - needed ?
  268. - osmozilla - xpt link problem.
  269. - Osmo4: segmentation fault on exit.
  270. - MP4Client: segmentation fault on launch.
  271. - The program 'Osmo4' received an X Window System error:
  272. "The error was 'BadMatch (invalid parameter attributes)'.
  273. (Details: serial 37 error_code 8 request_code 42 minor_code 0)"
  274. - MP4Box -version display: GPAC version 0.4.3-DEV (try to display cvs )
  275. * Sat Oct 15 2006 kwizart < kwizart at gmail.com > - 0.4.2-rc2.1_FC5
  276. - Update to 0.4.2cvs20061017
  277. - Use DESTDIR=RPM_BUILD_ROOT in various Makefile.
  278. - Enable mozilla plugin: osmozilla.
  279. - Enable AMR_NB_FLOAT and AMR_WB_FLOAT / bundle AMR_NB_FIXED (but not used by default).
  280. - Provide documentation html in doc .
  281. - Provide tutorial from http://www.wildamerica.com/pages/Marty.html
  282. - Various corrections.
  283. * Fri Sep 01 2006 Anssi Hannula <anssi@zarb.org> 0.4.1-0.20060630.2plf2007.0
  284. - lib64 fixes
  285. * Fri Jan 30 2006 Austin Acton <austin@mandriva.org> 0.4.1-0.20060630.1plf2007.0
  286. - initial package