pcsc-lite-vl.spec 9.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327
  1. Summary: PC/SC Lite smart card framework and applications
  2. Summary(ja): PC/SC Lite スマートカードフレームワークおよびアプリケーション
  3. Name: pcsc-lite
  4. Version: 1.8.3
  5. Release: 2%{?_dist_release}
  6. Group: System Environment/Daemons
  7. License: BSD
  8. URL: http://pcsclite.alioth.debian.org/
  9. Source0: http://alioth.debian.org/download.php/2106/%{name}-%{version}.tar.bz2
  10. Patch0: %{name}-1.4-docinst.patch
  11. Patch1: pcsc-lite-1.8.3-etc.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  13. BuildRequires: eudev-libudev-devel
  14. BuildRequires: doxygen
  15. BuildRequires: flex
  16. Requires(post): initscripts
  17. Requires(post): /sbin/chkconfig
  18. Requires(preun): /sbin/chkconfig
  19. Requires(preun): initscripts
  20. Requires(postun): initscripts
  21. Requires: pcsc-ifd-handler
  22. # 390 does not have libusb or smartCards
  23. ExcludeArch: s390 s390x
  24. %description
  25. The purpose of PC/SC Lite is to provide a Windows(R) SCard interface
  26. in a very small form factor for communicating to smartcards and
  27. readers. PC/SC Lite uses the same winscard API as used under
  28. Windows(R). This package includes the PC/SC Lite daemon, a resource
  29. manager that coordinates communications with smart card readers and
  30. smart cards that are connected to the system, as well as other command
  31. line tools.
  32. %package libs
  33. Summary: PC/SC Lite libraries
  34. Summary(ja): PC/SC Lite libraries
  35. Group: System Environment/Libraries
  36. Provides: libpcsc-lite = %{version}-%{release}
  37. %description libs
  38. PC/SC Lite libraries.
  39. %package devel
  40. Summary: PC/SC Lite development files
  41. Summary(ja): PC/SC Lite development files
  42. Group: Development/Libraries
  43. Requires: %{name}-libs = %{version}-%{release}
  44. Requires: pkgconfig
  45. Provides: libpcsc-lite-devel = %{version}-%{release}
  46. %description devel
  47. PC/SC Lite development files.
  48. %package spy
  49. Summary: PC/SC API spy
  50. Summary(ja): PC/SC API spy
  51. Group: Development/Tools
  52. Requires: %{name}-libs = %{version}-%{release}
  53. %description spy
  54. The purpose of pcsc-spy is to spy all the calls between the PC/SC client
  55. and the PC/SC library.
  56. %package doc
  57. Summary: PC/SC Lite developer documentation
  58. Summary(ja): PC/SC Lite developer documentation
  59. Group: Documentation
  60. %description doc
  61. %{summary}.
  62. %prep
  63. %setup -q
  64. %patch0 -p0 -b .docinst
  65. %patch1 -p1 -b .etc
  66. %build
  67. autoreconf -if
  68. %configure \
  69. --disable-dependency-tracking \
  70. --disable-static \
  71. --enable-runpid=%{_localstatedir}/run/pcscd.pid \
  72. --enable-ipcdir=%{_localstatedir}/run \
  73. --enable-usbdropdir=%{_libdir}/pcsc/drivers
  74. make %{?_smp_mflags}
  75. doxygen doc/doxygen.conf ; rm -f doc/api/*.{map,md5}
  76. %install
  77. rm -rf $RPM_BUILD_ROOT
  78. make install DESTDIR=$RPM_BUILD_ROOT
  79. install -dm 755 $RPM_BUILD_ROOT%{_libdir}/pcsc/drivers
  80. install -Dpm 755 etc/pcscd.init $RPM_BUILD_ROOT%{_initrddir}/pcscd
  81. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/reader.conf.d
  82. rm -f $RPM_BUILD_ROOT{%{_sysconfdir}/reader.conf.d/reader.conf,%{_libdir}/lib*.la}
  83. rm -f $RPM_BUILD_ROOT%{_docdir}/%{name}/README.DAEMON
  84. # formaticc doesn't exist any more, don't include the man page
  85. rm -f $RPM_BUILD_ROOT%{_mandir}/man1/formaticc.1*
  86. %clean
  87. rm -rf $RPM_BUILD_ROOT
  88. %post
  89. /sbin/chkconfig --add pcscd
  90. %preun
  91. if [ $1 = 0 ] ; then
  92. /sbin/service pcscd stop >/dev/null 2>&1 || :
  93. /sbin/chkconfig --del pcscd
  94. fi
  95. %postun
  96. if [ "$1" -ge "1" ]; then
  97. /sbin/service pcscd condrestart >/dev/null 2>&1 || :
  98. fi
  99. %post libs -p /sbin/ldconfig
  100. %postun libs -p /sbin/ldconfig
  101. %files
  102. %defattr(-,root,root,-)
  103. %doc AUTHORS ChangeLog* COPYING DRIVERS HELP README SECURITY TODO
  104. %dir %{_sysconfdir}/reader.conf.d/
  105. %{_initrddir}/pcscd
  106. %{_sbindir}/pcscd
  107. %{_libdir}/pcsc/
  108. %{_mandir}/man5/reader.conf.5*
  109. %{_mandir}/man8/pcscd.8*
  110. %files libs
  111. %defattr(-,root,root,-)
  112. %{_libdir}/libpcsclite.so.*
  113. %{_libdir}/libpcscspy.so.*
  114. %files devel
  115. %defattr(-,root,root,-)
  116. %{_includedir}/PCSC/
  117. %{_libdir}/libpcsclite.so
  118. %{_libdir}/libpcscspy.so
  119. %{_libdir}/pkgconfig/libpcsclite.pc
  120. %files spy
  121. %defattr(-,root,root,-)
  122. %{_bindir}/pcsc-spy
  123. %{_mandir}/man1/pcsc-spy.1.gz
  124. %files doc
  125. %defattr(-,root,root,-)
  126. %doc doc/api/ doc/example/pcsc_demo.c
  127. %changelog
  128. * Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.3-2
  129. - change BuildRequires: eudev-libudev-devel instead of libudev-devel
  130. * Sun Jun 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.3-1
  131. - new upstream release
  132. - add Patch1 (pcsc-lite-1.8.3-etc.patch)
  133. - create -spy sub package
  134. * Sat Jan 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-2
  135. - fix Patch1
  136. * Sat Jan 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
  137. - new upstream release
  138. - remove BuildRequires: hal-devel, libusb-devel
  139. - add BuildRequires: libudev-devel, flex
  140. - add Patch1 (pcsc-lite-1.8.1-etc.patch)
  141. * Fri Oct 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.5.5-2
  142. - rebuilt with rpm-4.8.1 for pkg-config
  143. * Sun Feb 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.5-1
  144. - new upstream release
  145. * Mon Mar 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.102-1
  146. - initial build for Vine Linux
  147. * Mon Aug 18 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.102-3
  148. - bump tag becaue the build system can't deal with mistakes.
  149. * Mon Aug 18 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.102-2
  150. - mock build changes
  151. * Sun Aug 17 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.102-1
  152. - Pick up 1.4.102
  153. * Tue May 6 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.101-1
  154. - Pick up 1.4.101
  155. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.4-3
  156. - Autorebuild for GCC 4.3
  157. * Wed Jan 16 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.4-2
  158. - Silence libpcsc-lite even when the daemon isn't running.
  159. - fix typo in init file which prevents the config file from being read.
  160. * Thu Nov 22 2007 Bob Relyea <rrelyea@redhat.com> - 1.4.4-1
  161. - Pick up 1.4.4
  162. * Tue Feb 06 2007 Bob Relyea <rrelyea@redhat.com> - 1.3.3-1
  163. - Pick up 1.3.3
  164. * Thu Nov 02 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.2-1
  165. - Pick up 1.3.2
  166. * Thu Sep 14 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.1-7
  167. - Incorporate patch from Ludovic to stop the pcsc daemon from
  168. unnecessarily waking up.
  169. * Mon Jul 31 2006 Ray Strode <rstrode@redhat.com> - 1.3.1-6
  170. - follow packaging guidelines for setting up init service
  171. (bug 200778)
  172. * Mon Jul 24 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.1-5
  173. - start pcscd when pcsc-lite is installed
  174. * Sun Jul 16 2006 Florian La Roche <laroche@redhat.com> - 1.3.1-4
  175. - fix excludearch line
  176. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3.1-3.1
  177. - rebuild
  178. * Mon Jul 10 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.1-3
  179. - remove s390 from the build
  180. * Mon Jun 5 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.1-2
  181. - Move to Fedora Core.
  182. - Remove dependency on graphviz.
  183. - Removed %%{_dist}
  184. * Sat Apr 22 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.3.1-1
  185. - 1.3.1.
  186. * Sun Mar 5 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.3.0-1
  187. - 1.3.0, init script and reader.conf updater included upstream.
  188. - Split developer docs into a -doc subpackage, include API docs.
  189. - libmusclecard no longer included, split into separate package upstream.
  190. * Mon Feb 13 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.2.0-14
  191. - Avoid standard rpaths on multilib archs.
  192. - Fine tune dependencies.
  193. * Fri Nov 11 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.2.0-13
  194. - Don't ship static libraries.
  195. - Don't mark the init script as a config file.
  196. - Use rm instead of %%exclude.
  197. - Specfile cleanups.
  198. * Thu May 19 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.2.0-12
  199. - Rebuild.
  200. * Thu Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 1.2.0-11
  201. - rebuilt
  202. * Tue Aug 17 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-10
  203. - Disable dependency tracking to speed up the build.
  204. - Drop reader.conf patch, it's not needed any more.
  205. - Rename update-reader-conf to update-reader.conf for consistency with Debian,
  206. and improve it a bit.
  207. * Sat Jul 31 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.9
  208. - Add update-reader-conf, thanks to Fritz Elfert.
  209. * Thu Jul 1 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.8
  210. - Own the %%{_libdir}/pcsc hierarchy.
  211. * Thu May 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.7
  212. - Make main package require pcsc-ifd-handler (idea from Debian).
  213. * Wed May 12 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.6
  214. - Improve package summary.
  215. - Improvements based on suggestions from Ludovic Rousseau:
  216. - Don't install pcsc_demo but do include its source in -devel.
  217. - Sync reader.conf with current upstream CVS HEAD (better docs, less
  218. intrusive in USB-only setups where it's not needed).
  219. * Fri Apr 16 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.5
  220. - Move PDF API docs to -devel.
  221. - Improve main package and init script descriptions.
  222. * Thu Jan 29 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.4
  223. - Init script fine tuning.
  224. * Fri Jan 9 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.3
  225. - BuildRequires libusb-devel 0.1.6 or newer.
  226. * Thu Oct 30 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.2
  227. - s/pkgconfi/pkgconfig/ in -devel requirements.
  228. * Tue Oct 28 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.1
  229. - Update to 1.2.0.
  230. - Add libpcsc-lite and libmusclecard provides to -libs and -devel.
  231. * Thu Oct 16 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.2.rc3
  232. - Update to 1.2.0-rc3.
  233. - Trivial init script improvements.
  234. - Enable %%{_smp_mflags}.
  235. - Don't bother trying to enable SCF.
  236. * Sun Sep 14 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.2.rc2
  237. - Specfile cleanups.
  238. * Fri Sep 5 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.1.rc2
  239. - Update to 1.2.0-rc2.
  240. * Wed Aug 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.1.rc1
  241. - Update to 1.2.0-rc1.
  242. * Sun Jun 1 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.1.2-0.fdr.0.1.beta5
  243. - Update to 1.1.2beta5.
  244. * Sat May 24 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.1.2-0.fdr.0.1.beta4
  245. - First build, based on PLD's 1.1.1-2.