xorg-x11-drv-intel-vl.spec 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625
  1. %define moduledir %(pkg-config xorg-server --variable=moduledir )
  2. %define driverdir %{moduledir}/drivers
  3. %define gputoolsdate1 20130611
  4. %define gputoolsdate2 20110817
  5. %if "%{?_dist_release}" >= "vl7"
  6. %define accel sna
  7. %define gputoolsdate 20130611
  8. %else
  9. %define accel sna
  10. %define gputoolsdate 20110817
  11. %endif
  12. Summary: Xorg X11 Intel video driver
  13. Summary(ja): Xorg X11 Intel ビデオドライバ
  14. Name: xorg-x11-drv-intel
  15. Epoch: 1
  16. Version: 2.21.15
  17. Release: 3%{?_dist_release}
  18. URL: http://intellinuxgraphics.org/
  19. License: MIT
  20. Group: User Interface/X Hardware Support
  21. Source0: http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
  22. Source2: intel.xinf
  23. Source3: intel-gpu-tools-%{gputoolsdate1}.tar.bz2
  24. Source4: intel-gpu-tools-%{gputoolsdate2}.tar.bz2
  25. # vine patch
  26. ExclusiveArch: %{ix86} x86_64 ia64
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  28. BuildRequires: autoconf, automake, libtool
  29. BuildRequires: xorg-x11-server-sdk >= 1.7.99
  30. BuildRequires: libXvMC-devel
  31. BuildRequires: libGL-devel >= 7.10
  32. BuildRequires: libdrm-devel >= 2.4.25
  33. BuildRequires: kernel-headers >= 2.6.33
  34. BuildRequires: eudev-libudev-devel
  35. BuildRequires: libxcb-devel >= 1.5
  36. BuildRequires: xcb-util-devel
  37. BuildRequires: cairo-devel
  38. Requires: hwdata
  39. Requires: xorg-x11-server-Xorg
  40. Requires: xcb-util
  41. Obsoletes: xorg-x11-drv-i810
  42. Provides: xorg-x11-drv-i810
  43. #Conflicts: kudzu < 1.2.42-1
  44. Vendor: Project Vine
  45. Distribution: Vine Linux
  46. Packager: daisuke
  47. %description
  48. X.Org X11 Intel video driver.
  49. %package devel
  50. Summary: Xorg X11 Intel video driver XvMC development package
  51. Summary(ja): Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
  52. Group: Development/System
  53. Requires: %{name} = %{epoch}:%{version}-%{release}
  54. Provides: xorg-x11-drv-intel-devel = %{version}-%{release}
  55. %description devel
  56. X.Org X11 Intel video driver XvMC development package.
  57. %package -n intel-gpu-tools
  58. Summary: Debugging tools for Intel graphics chips
  59. Group: Development/Tools
  60. %description -n intel-gpu-tools
  61. Debugging tools for Intel graphics chips
  62. %prep
  63. %setup -q -n xf86-video-intel-%{version} -b3 -b4
  64. %build
  65. autoreconf -vi
  66. %if "%{?_dist_release}" < "vl7"
  67. export CFLAGS="-I/usr/include/X11/dri"
  68. %endif
  69. %configure \
  70. --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
  71. --enable-dri --enable-xvmc \
  72. --enable-sna --enable-uxa \
  73. --with-default-accel=%{accel} \
  74. --enable-xaa=no
  75. make
  76. pushd ../intel-gpu-tools-%{gputoolsdate}
  77. autoreconf -v --install
  78. %configure --disable-nouveau --disable-dumper
  79. make
  80. popd
  81. %install
  82. rm -rf $RPM_BUILD_ROOT
  83. make install DESTDIR=$RPM_BUILD_ROOT
  84. mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
  85. install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
  86. pushd ../intel-gpu-tools-%{gputoolsdate}
  87. make install DESTDIR=$RPM_BUILD_ROOT
  88. popd
  89. find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
  90. %clean
  91. rm -rf $RPM_BUILD_ROOT
  92. %triggerpostun -- XOrg < 7.0
  93. if (grep -q i810 /etc/X11/xorg.conf)
  94. then
  95. cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
  96. sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
  97. fi ||:
  98. %files
  99. %defattr(-,root,root,-)
  100. %{driverdir}/intel_drv.so
  101. %{_datadir}/hwdata/videoaliases/intel.xinf
  102. %{_libdir}/libI810XvMC.so.*
  103. %{_libdir}/libIntelXvMC.so.*
  104. %{_mandir}/man4/i*
  105. %files devel
  106. %defattr(-,root,root,-)
  107. %{_libdir}/libI810XvMC.so
  108. %{_libdir}/libIntelXvMC.so
  109. %files -n intel-gpu-tools
  110. %defattr(-,root,root,-)
  111. %{_bindir}/*
  112. %{_mandir}/man1/intel_*.1*
  113. %changelog
  114. * Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.15-3
  115. - change BuildRequires: eudev-libudev-devel instead of libudev-devel
  116. * Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.15-2
  117. - rebuild with VineSeed environment
  118. * Thu Oct 10 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.15-1
  119. - new upstream release
  120. * Sat Jun 01 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.8-1
  121. - new upstream release
  122. - change default accel method to sna.
  123. * Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.6-1
  124. - new upstream release
  125. * Fri Mar 22 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.5-1
  126. - new upstream release
  127. * Mon Feb 11 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.1-1
  128. - new upstream release
  129. * Tue Dec 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.16-1
  130. - new upstream release
  131. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.15-1
  132. - new upstream release
  133. * Tue Oct 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.10-1
  134. - new upstream release
  135. * Sun Sep 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.8-1
  136. - new upstream release
  137. * Tue Sep 04 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.6-2
  138. - new upstream release
  139. * Fri Jul 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
  140. - new upstream release
  141. * Tue Jul 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.1-1
  142. - new upstream release
  143. * Wed Jun 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.19.0-3
  144. - rebuild with xcb-util-0.3.9
  145. * Tue May 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-2
  146. - disable sna, enable uxa
  147. * Wed May 02 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-1
  148. - new upstream release
  149. * Sun Mar 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.0-2
  150. - rebuild with xserver-1.12.0
  151. * Fri Feb 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
  152. - new upstream release
  153. - enable sna
  154. * Sat Nov 26 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-2
  155. - disable sna/vmap
  156. * Fri Nov 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
  157. - new upstram release
  158. - disable copy-fb patch
  159. * Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-3
  160. - rebuild with xserver-1.11.1.902
  161. * Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
  162. - add --enable-sna --enable-vmap
  163. * Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
  164. - new upstream release
  165. * Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
  166. - rebuild with xcb-util-0.3.8
  167. - drop Patch200
  168. * Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
  169. - update to disable copy_fb on sandybridge/ivybridge
  170. * Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
  171. - update intel.xinf
  172. - add patch10 from fedora
  173. - Clamp VGA pixel clock to 250MHz,
  174. anything higher's going to look awful anyway. (#559426)
  175. * Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
  176. - drop patch1-3 and replaced with new patch1 from git master
  177. - add Patch200 to disable DRI on SandyBridge/IvyBridge
  178. - update intel-gpu-tools
  179. * Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
  180. - add Patch1-3 from upstream
  181. * Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
  182. - new upstream release
  183. - drop upstream patches: 107-115
  184. - temporary disabled patch101
  185. - BR: libdrm >= 2.4.25
  186. * Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
  187. - add Patch101-115 from ubuntu/debian package
  188. - Patch101: Plymouth integration patch
  189. - Patch107: Check null return from uxa_acquire_solid()
  190. - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
  191. - Patch109: Fix font corruption (missing glyphs) on rotated screens.
  192. - Patch110,114: Cherry picks to fix a large number of build warnings.
  193. - Patch111: Fix clipped window plane offset
  194. - Patch112: Fix issue where vertical green line and strange colors
  195. shows up when playing gstreamer with certain videos,
  196. when dragged. (LP 460677)
  197. - Patch113: Fixes GPU lockup during login with
  198. "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
  199. error messages listed in the gpu dump text. (LP 710321)
  200. - Patch115: Don't fill up Xorg.0.log with
  201. "get vblank counter failed: Invalid argument" warnings.
  202. * Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
  203. - rebuild with xserver-1.10.0
  204. * Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
  205. - new upstream release
  206. * Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
  207. - new upstream release
  208. * Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
  209. - rebuild with xserver-1.9.2
  210. * Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
  211. - new upstream release
  212. - add Patch40: fix uxa planemask (backported)
  213. - add Patch61: add support for backlight on macbooks
  214. - add Patch62: disable page flipping for stability
  215. * Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
  216. - new upstream release
  217. - drop patch70
  218. * Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
  219. - rebuild again with xserver-1.8rc
  220. * Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
  221. - add intel-gpu-tools as sub-package
  222. - rebuild with libdrm-2.4.18
  223. * Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
  224. - new upstream release
  225. - import Patch1,2,60,70 from fedora
  226. - add BR: kernel-headers >= 2.6.33 (new drm header required)
  227. - add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
  228. - add BR; libudev-devel and autoreconf for Patch60
  229. * Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
  230. - rebuild with libdrm-2.4.17
  231. * Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
  232. - new upstream release
  233. * Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
  234. - new upstream release (hopefully fixes severe issues w/ efifb)
  235. - drop all patches already upstreamed; import Patch20/21 from Fedora
  236. * Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
  237. - import Patch121,122 from ubuntu
  238. - build with libdrm-2.4.12 which fixes vt switch crash
  239. * Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
  240. - apply patch114 to fix Xv with non-GEM kernel
  241. * Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
  242. - update to 2.6.3
  243. - add patch106,107,115,118,119,120 from ubuntu
  244. - add Patch106: remove triple buffering
  245. - add Patch107: remove page flipping
  246. - add Patch115: fix crash Xv overlay
  247. - add Patch118: drop legacy3d
  248. - add Patch119: fix crashes in drm bo
  249. - add Patch120: fix vt switch
  250. - add patch130-134 from upstream git
  251. - add Patch130: fix another vt switch leak
  252. - add Patch131: Create known output configuration at EnterVT time
  253. - add Patch132: fix leak of some 965 render state on VT switch
  254. - add Patch133: fix crash with fake bufmgr and UXA
  255. - add Patch134: fix EnterVT/LeaveVT
  256. - add Patch135: add new chip supoprt
  257. * Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
  258. - revert to 2.6.1, add Epoch
  259. - add Patch103-121 from ubuntu
  260. * Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
  261. - new upstream release
  262. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
  263. - new upstream release
  264. * Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
  265. - new upstream release
  266. * Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
  267. - add Patch5 - Dont die on irq handler failure
  268. * Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
  269. - new upstream release
  270. - add BR: libdrm-devel >= 2.4.0-3
  271. * Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
  272. - import Patch10,11,12 from ubuntu
  273. * Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
  274. - new upstream release
  275. - add triggerpostun script to replace i810 driver to intel driver
  276. * Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
  277. - new upstream release
  278. * Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
  279. - new upstream release
  280. - rename i810.xinf to intel.xinf
  281. - update intel.xinf (add Intel 4 series)
  282. * Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
  283. - rebuild with new xserver
  284. * Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
  285. - new upstream release
  286. * Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
  287. - new upstream release
  288. * Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
  289. - new upstream release
  290. * Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  291. - initial build for Vine Linux
  292. * Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
  293. - Rebuild for new server ABI.
  294. - intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
  295. * Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
  296. - hook up ch7017 (bz#408471)
  297. * Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
  298. - xf86-video-intel 2.2.0
  299. * Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
  300. - xf86-video-intel 2.1.99.
  301. - Drop the i810 driver. Time to move on.
  302. - Require xserver 1.4.99.1
  303. * Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
  304. - intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
  305. * Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
  306. - intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
  307. for textured Xv to use as an offscreen pixmap so xv actually works under
  308. compiz - granted it may be unusably slow but at least stuff shows up.
  309. * Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
  310. - intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
  311. - intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
  312. * Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
  313. - intel-2.1.1-quirk-update.patch - update quirks from master
  314. * Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
  315. - i810.xinf: Flip everything over to -intel by default now. Still install
  316. i810 driver just in case.
  317. * Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
  318. - intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
  319. * Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
  320. - xf86-video-intel 2.1.1.
  321. * Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
  322. - xf86-video-intel 2.1.0.
  323. * Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
  324. - Update Requires and BuildRequires.
  325. * Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
  326. - Update to git master. Many Xv and DVO fixes. Adds support for 945GME,
  327. 965GME, G33, Q33, and Q35 chips.
  328. * Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
  329. - intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
  330. DRI clients are active, for better battery life.
  331. * Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
  332. - Rebuild for final RANDR 1.2 ABI. Fixes segfault at startup. (#238575)
  333. * Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
  334. - xf86-video-intel 2.0.0. Change the version number to match, why not.
  335. - Add a Virtual provides for xorg-x11-drv-intel, since we should probably
  336. rename this at some point.
  337. * Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
  338. - i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
  339. 915GM.
  340. * Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
  341. - i810.xinf: More intel whitelisting (#214011, #234877)
  342. * Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
  343. - xf86-video-intel-1.9.94 (RC4). Adds support for 965GM.
  344. - i810.xinf: Point 965GM support at the intel driver since it's not present
  345. in old i810.
  346. * Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
  347. - xf86-video-intel-1.9.93 (RC3).
  348. * Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
  349. - fix typo with 945GM pci id from my laptop
  350. * Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
  351. - xf86-video-intel 1.9.92 (RC2).
  352. * Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
  353. - Updated modesetting driver to one that will actually work with a 1.3 server.
  354. * Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
  355. - Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
  356. - Remove ivch and ch7017 from the install since they aren't hooked up to the
  357. code anywhere
  358. - Disown the module
  359. * Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
  360. - update modesetting driver to git snapshot from today
  361. * Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
  362. - i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
  363. * Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
  364. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  365. * Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
  366. - Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
  367. actually require kudzu to run.
  368. * Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
  369. - i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
  370. * Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
  371. - i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
  372. - i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
  373. driver match the corresponding terrible heuristic in the server.
  374. * Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
  375. - intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
  376. correctly distinguish between Mac Mini and Macbook Pro.
  377. * Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
  378. - i810.xinf: PCI IDs for i965.
  379. * Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
  380. - i810.xinf: Uppercase PCI IDs.
  381. * Thu Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
  382. - Update i810 to 1.6.5, should fix DRI.
  383. - Add kuzdu requires.
  384. - i810.xinf: Start whitelisting devices over to intel.
  385. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
  386. - intel-driver-rename.patch: Fix the driver name in more places so it'll,
  387. you know, load.
  388. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
  389. - intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
  390. LFP special casing in favor of the blacklist.
  391. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
  392. - Admit defeat, kinda. Package both i810 stable and modesetting drivers.
  393. The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
  394. and is selected with Driver "intel" in xorg.conf. Individual devices will
  395. whitelist over to "intel" until that branch gets merged into head.
  396. - Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
  397. - intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
  398. the BIOS is known to lie.
  399. * Tue Aug 8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
  400. - Today's snapshot: I2C bus creation fix.
  401. * Wed Aug 2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
  402. - intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
  403. clock when computing the modes list.
  404. - intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
  405. in centimeters as the size of the display in pixels.
  406. * Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
  407. - Disable spread-spectrum LVDS, various crash and hang fixes, saner output
  408. probing.
  409. * Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
  410. - Update again for a mode comparison bugfix.
  411. * Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
  412. - Update to today's git; crash fixes, better pre-915 support, slightly better
  413. autoconfigurability.
  414. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
  415. - rebuild
  416. * Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
  417. - Fix Revision number to match naming policy.
  418. * Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
  419. - Add back modesetting changes.
  420. * Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
  421. - Roll back modesetting changes and build for fc5 aiglx repo.
  422. * Fri Jul 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
  423. - Snapshot of the git modesetting branch.
  424. * Fri Jul 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
  425. - Update i810.xinf to include entries for E7221 and 945GM.
  426. * Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
  427. - Add with_dri macro to spec file, and conditionalize build time DRI support
  428. * Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
  429. - Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
  430. to pick up proto-devel as well.
  431. * Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
  432. - Rebuild for 7.1 ABI fix.
  433. * Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
  434. - Bump for fc5-bling build.
  435. * Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
  436. - Update to 1.6.0 from 7.1RC1.
  437. * Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
  438. - Add patch to add missing #include's, specifically assert.h.
  439. * Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
  440. - Update to CVS snapshot of 20060322.
  441. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
  442. - rebuilt for new gcc4.1 snapshot and glibc changes
  443. * Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
  444. - Added 8086:2772 mapping to i810.xinf for bug (#178451)
  445. * Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
  446. - Added 8086:2592 mapping to i810.xinf for bug (#172884)
  447. * Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
  448. - Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
  449. * Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
  450. - Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
  451. - Removed 'x' suffix from manpage dirs to match RC4 upstream.
  452. * Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
  453. - Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
  454. * Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
  455. - Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
  456. - Fix *.la file removal.
  457. - Added 'devel' subpackage for XvMC .so
  458. - Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
  459. * Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
  460. - Update BuildRoot to use Fedora Packaging Guidelines.
  461. - Deglob file manifest.
  462. - Limit "ExclusiveArch" to x86, x86_64, ia64
  463. * Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
  464. - Initial spec file for i810 video driver generated automatically
  465. by my xorg-driverspecgen script.