Judy-vl.spec 4.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134
  1. Name: Judy
  2. Version: 1.0.5
  3. Release: 1%{?_dist_release}
  4. Summary: General purpose dynamic array
  5. Group: System Environment/Libraries
  6. # The source code itself says:
  7. # "GNU Lesser General Public License as published by the
  8. # Free Software Foundation; either version 2 of the License,
  9. # or (at your option) any later version."
  10. # This will probably change to LGPLv2 in a future upstream release,
  11. # but until then, LGPLv2+ is the proper license. Confirmed
  12. # with upstream on 2008/11/28.
  13. License: LGPLv2+
  14. URL: http://sourceforge.net/projects/judy/
  15. Source0: http://downloads.sourceforge.net/judy/Judy-%{version}.tar.gz
  16. Source1: README.Fedora
  17. # Make tests use shared instead of static libJudy.
  18. Patch0: Judy-1.0.4-test-shared.patch
  19. # The J1* man pages were incorrectly being symlinked to Judy, rather
  20. # than Judy1. This patch corrects that. Submitted upstream 2008/11/27.
  21. Patch1: Judy-1.0.4-fix-Judy1-mans.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. #BuildRequires:
  24. #Requires:
  25. %description
  26. Judy is a C library that provides a state-of-the-art core technology
  27. that implements a sparse dynamic array. Judy arrays are declared
  28. simply with a null pointer. A Judy array consumes memory only when it
  29. is populated, yet can grow to take advantage of all available memory
  30. if desired. Judy's key benefits are scalability, high performance, and
  31. memory efficiency. A Judy array is extensible and can scale up to a
  32. very large number of elements, bounded only by machine memory. Since
  33. Judy is designed as an unbounded array, the size of a Judy array is
  34. not pre-allocated but grows and shrinks dynamically with the array
  35. population.
  36. %package devel
  37. Summary: Development libraries and headers for Judy
  38. Group: Development/Libraries
  39. Requires: %{name} = %{version}-%{release}
  40. %description devel
  41. This package contains the development libraries and header files
  42. for developing applications that use the Judy library.
  43. %prep
  44. %setup -q -n judy-%{version}
  45. %patch0 -p1 -b .test-shared
  46. %patch1 -p1 -b .fix-Judy1-mans
  47. cp -p %{SOURCE1} .
  48. %build
  49. %configure --disable-static
  50. make
  51. #%{?_smp_mflags}
  52. # fails to compile properly with parallel make:
  53. # http://sourceforge.net/tracker/index.php?func=detail&aid=2129019&group_id=55753&atid=478138
  54. %install
  55. rm -rf $RPM_BUILD_ROOT
  56. make install DESTDIR=$RPM_BUILD_ROOT
  57. # get rid of static libs and libtool archives
  58. rm -f $RPM_BUILD_ROOT/%{_libdir}/*.{a,la}
  59. # clean out zero length and generated files from doc tree
  60. rm -rf doc/man
  61. rm -f doc/Makefile* doc/ext/README_deliver
  62. [ -s doc/ext/COPYRIGHT ] || rm -f doc/ext/COPYRIGHT
  63. [ -s doc/ext/LICENSE ] || rm -f doc/ext/LICENSE
  64. %check
  65. cd test
  66. ./Checkit
  67. %clean
  68. rm -rf $RPM_BUILD_ROOT
  69. %post -p /sbin/ldconfig
  70. %postun -p /sbin/ldconfig
  71. %files
  72. %defattr(-,root,root,-)
  73. %doc AUTHORS ChangeLog COPYING README README.Fedora
  74. %{_libdir}/*.so.*
  75. %files devel
  76. %defattr(-,root,root,-)
  77. %doc doc
  78. %{_libdir}/*.so
  79. %{_includedir}/*
  80. %{_mandir}/man3/*
  81. %changelog
  82. * Sat Feb 11 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 1.0.5-1
  83. - updated to 1.0.5
  84. * Sun Jun 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.4-7
  85. - Initial build for Vine Linux
  86. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.4-6
  87. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  88. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.4-5
  89. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  90. * Sat Dec 13 2008 Charles R. Anderson <cra@wpi.edu> 1.0.4-4
  91. - for Judy1 man page fix, patch Makefile.{am,in} instead of
  92. relying on autotools to regenerate the latter.
  93. - Add README.Fedora with upstream's license explanation.
  94. * Thu Nov 30 2008 Charles R. Anderson <cra@wpi.edu> 1.0.4-3
  95. - fix Judy1 man page symlinks
  96. - use valid tag License: LGPLv2+ confirmed with upstream
  97. - use version macro in Source0
  98. - remove Makefiles from installed doc tree
  99. * Thu Nov 27 2008 Charles R. Anderson <cra@wpi.edu> 1.0.4-2
  100. - patch tests to run with shared library
  101. - run tests in check section
  102. * Sun Oct 05 2008 Charles R. Anderson <cra@wpi.edu> 1.0.4-1
  103. - Initial package for Fedora