bootparamd-vl.spec 5.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171
  1. %define version 0.17
  2. %define release 15%{?_dist_release}
  3. %define _snapshot -pre20000412
  4. Summary: A server process which provides boot information to diskless clients.
  5. Summary(ja): ディスクレスクライアントに起動情報を提供するサーバプロセス
  6. Name: bootparamd
  7. Version: %{version}
  8. Release: %{release}
  9. License: BSD
  10. Group: System Environment/Daemons
  11. Source: ftp://ftp.uk.linux.org/pub/linux/Networking/netkit-devel/netkit-bootparamd-%{version}%{_snapshot}.tar.gz
  12. Source1: bootparamd.init
  13. Patch: bootparamd-manpage-63567.patch
  14. #Prereq: /sbin/chkconfig /sbin/init.d
  15. Prereq: /sbin/chkconfig
  16. Requires: portmap
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. %description
  19. The bootparamd process provides bootparamd, a server process which
  20. provides the information needed by diskless clients in order for them
  21. to successfully boot. Bootparamd looks first in /etc/bootparams for an
  22. entry for that particular client; if a local bootparams file doesn't
  23. exist, it looks at the appropriate Network Information Service (NIS)
  24. map. Some network boot loaders (notably Sun's) rely on special boot
  25. server code on the server, in addition to the RARP and TFTP servers.
  26. This bootparamd server process is compatible with SunOS bootparam clients
  27. and servers which need that boot server code.
  28. You should install bootparamd if you need to provide boot information to
  29. diskless clients on your network.
  30. %description -l ja
  31. bootparamd はディスクレスクライアントが正しく起動する為の情報を
  32. 提供するサーバプロセスです.bootparamd は最初に /etc/bootparams を
  33. 見て特定のクライアントの情報を探します./etc/bootparams がなければ
  34. NIS (Network Information Service) のマップを探します.
  35. ネットワークブートローダの中には (特に Sun のものが) RARP や TFTP
  36. サーバに加えて特別なブートサーバを必要とします.この bootparamd サーバは
  37. SunOS の bootparam クライアント/サーバと互換性があります.
  38. ネットワーク上のディスクレスクライアントに起動情報を提供する必要が
  39. ある場合は bootparamd パッケージをインストールして下さい.
  40. %prep
  41. %setup -q -n netkit-bootparamd-%{version}%{_snapshot}
  42. %patch -p1
  43. %build
  44. sh configure --with-c-compiler=gcc
  45. perl -pi -e '
  46. s,^CC=.*$,CC=cc,;
  47. s,-O2,\$(RPM_OPT_FLAGS) -D_BSD_SOURCE,;
  48. s,^BINDIR=.*$,BINDIR=%{_bindir},;
  49. s,^MANDIR=.*$,MANDIR=%{_mandir},;
  50. s,^SBINDIR=.*$,SBINDIR=%{_sbindir},;
  51. ' MCONFIG
  52. make
  53. %install
  54. rm -rf %{buildroot}
  55. mkdir -p %{buildroot}%{_bindir}
  56. mkdir -p %{buildroot}%{_mandir}/man{1,8}
  57. mkdir -p %{buildroot}%{_sbindir}
  58. mkdir -p %{buildroot}%{_initdir}
  59. make INSTALLROOT=%{buildroot} install
  60. install -m 755 $RPM_SOURCE_DIR/bootparamd.init %{buildroot}%{_initdir}/bootparamd
  61. %clean
  62. rm -rf %{buildroot}
  63. %post
  64. /sbin/chkconfig --add bootparamd
  65. %preun
  66. if [ $1 = 0 ]; then
  67. /sbin/chkconfig --del bootparamd
  68. fi
  69. %files
  70. %defattr(-,root,root)
  71. %{_sbindir}/rpc.bootparamd
  72. %{_bindir}/callbootd
  73. %{_mandir}/man8/rpc.bootparamd.*
  74. %{_mandir}/man8/bootparamd.*
  75. %config %{_initdir}/bootparamd
  76. %changelog
  77. * Fri Sep 19 2008 Shu KONNO <owa@bg.wakwak.com> 0.17-15vl5
  78. - applied new versioning policy, spec in utf-8
  79. * Thu Jul 3 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-14vl1
  80. - based on Redhat Rawhide 0.17-14
  81. - rebuild with new toolchains
  82. - s/Copyright/License/
  83. * Wed Jan 10 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  84. - 0.17-5vl3
  85. - use better macros (%%{_initdir})
  86. - added Japanese summary and description
  87. - rebuilt with newer %%{_mandir} definition
  88. * Tue Dec 12 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17-5vl2
  89. - remove /etc/init.d from PreReq
  90. * Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 0.17-5vl1
  91. - build on Vine Linux with gcc-2.95.3
  92. * Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
  93. - condrestart fixes
  94. * Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
  95. - move initscript back
  96. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  97. - automatic rebuild
  98. * Mon Jul 10 2000 Preston Brown <pbrown@redhat.com>
  99. - move initscript
  100. * Sun Jun 18 2000 Matt Wilson <msw@redhat.com>
  101. - FHS packaging
  102. - 0.17
  103. * Thu Feb 03 2000 Erik Troan <ewt@redhat.com>
  104. - gzipped man pages
  105. * Tue Dec 21 1999 Jeff Johnson <jbj@redhat.com>
  106. - update to 0.16.
  107. * Fri Sep 25 1999 Bill Nottingham <notting@redhat.com>
  108. - *sigh*.
  109. * Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
  110. - initrscript munging
  111. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  112. - auto rebuild in the new build environment (release 22)
  113. * Mon Mar 15 1999 Jeff Johnson <jbj@redhat.com>
  114. - compile for 6.0
  115. * Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
  116. - removed triggerpostun.
  117. * Fri May 01 1998 Jeff Johnson <jbj@redhat.com>
  118. - added triggerpostun
  119. * Wed Apr 22 1998 Michael K. Johnson <johnsonm@redhat.com>
  120. - enhanced initscript
  121. * Thu Jan 08 1998 Erik Troan <ewt@redhat.com>
  122. - updated initscript to include functions
  123. - fixed 'stop' action of initscript
  124. - added requirement for portmap
  125. * Sun Oct 19 1997 Erik Troan <ewt@redhat.com>
  126. - added an initscript
  127. * Tue Jul 15 1997 Erik Troan <ewt@redhat.com>
  128. - initial build