freetype-vl.spec 7.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A free and portable TrueType font rendering engine.
  3. Name: freetype
  4. Version: 1.3.1
  5. Release: 7%{?_dist_release}
  6. License: BSD-like
  7. Group: System Environment/Libraries
  8. URL: http://www.freetype.org
  9. Source: freetype-%{version}.tar.gz
  10. Source1: ttmkfdir.tar.gz
  11. Patch0: freetype-1.2-fixpath.patch
  12. Patch1: freetype-1.3.1-foundrynames.patch
  13. Patch2: freetype-1.3.1-ftdump-gcc3.patch
  14. Patch3: freetype-1.3.1-config.sub-x86_64.patch
  15. Patch4: freetype-1.3.1-ltconfig-compat32.patch
  16. Buildroot: %{_tmppath}/%{name}-%{version}-root
  17. Obsoletes: freetype-utils
  18. BuildRequires: libX11-devel
  19. BuildRequires: libXt-devel
  20. BuildRequires: imake
  21. %description
  22. The FreeType engine is a free and portable TrueType font rendering
  23. engine, developed to provide TrueType support for a variety of
  24. platforms and environments. FreeType is a library which can open and
  25. manages font files as well as efficiently load, hint and render
  26. individual glyphs. FreeType is not a font server or a complete
  27. text-rendering library.
  28. %package utils
  29. Summary: Several utilities to manipulate and examine TrueType fonts.
  30. Group: Applications/Publishing
  31. %description utils
  32. This package contains several utilities which allow you to view and
  33. manipulate TrueType fonts. They are mainly useful for debugging and
  34. testing purposes, and are not required for using the FreeType
  35. library.
  36. %package devel
  37. Summary: Header files and static library for development with FreeType.
  38. Group: Development/Libraries
  39. Requires: %{name} = %{version}-%{release}
  40. %description devel
  41. The freetype-devel package contains the header files and static
  42. library needed to develop or compile applications which use the
  43. FreeType TrueType font rendering library.
  44. Install freetype-devel if you want to develop FreeType
  45. applications. If you simply want to run existing applications, you
  46. won't need this package.
  47. %if %{build_compat32}
  48. ## to build compat32 for x86_64 architecture support
  49. %package -n compat32-%{name}
  50. Summary: A free and portable TrueType font rendering engine.
  51. Group: System Environment/Libraries
  52. %description -n compat32-%{name}
  53. The FreeType engine is a free and portable TrueType font rendering
  54. engine, developed to provide TrueType support for a variety of
  55. platforms and environments. FreeType is a library which can open and
  56. manages font files as well as efficiently load, hint and render
  57. individual glyphs. FreeType is not a font server or a complete
  58. text-rendering library.
  59. %package -n compat32-%{name}-devel
  60. Summary: Header files and static library for development with FreeType.
  61. Group: Development/Libraries
  62. Requires: compat32-%{name} = %{version}
  63. %description -n compat32-%{name}-devel
  64. The freetype-devel package contains the header files and static
  65. library needed to develop or compile applications which use the
  66. FreeType TrueType font rendering library.
  67. Install freetype-devel if you want to develop FreeType
  68. applications. If you simply want to run existing applications, you
  69. won't need this package.
  70. %endif
  71. %prep
  72. %setup -q
  73. mkdir ttmkfdir
  74. tar xz -C ttmkfdir -f %{SOURCE1}
  75. %patch0 -p1 -b .fixpath
  76. %patch1 -p1 -b .foundrynames
  77. %patch2 -p1 -b .ftdump-gcc3
  78. %patch3 -p1 -b .config.sub-x86_64
  79. %if %{build_compat32}
  80. %patch4 -p1 -b .ltconfig-compat32
  81. %endif
  82. %build
  83. %if %{build_compat32}
  84. export CC='gcc -m32'
  85. %endif
  86. ##libtoolize --copy --force
  87. ./configure --prefix=%{_prefix} \
  88. --with-cflags="$RPM_OPT_FLAGS" \
  89. --disable-debug \
  90. --enable-static --enable-shared \
  91. --with-locale-dir=%{_localedir} \
  92. --libdir=%{_libdir} \
  93. --x-libraries=%{_libdir} \
  94. --target=%{_target_platform}
  95. make
  96. %if 0
  97. make -C ttmkfdir CC="gcc $RPM_OPT_FLAGS"
  98. (cd contrib/ttf2pk
  99. ./configure --prefix=%{_prefix} \
  100. --mandir=%{_mandir} \
  101. --with-cflags="$RPM_OPT_FLAGS"
  102. make
  103. )
  104. %endif
  105. # --libdir=$RPM_BUILD_ROOT%{_libdir} \
  106. %install
  107. rm -rf $RPM_BUILD_ROOT
  108. make prefix=$RPM_BUILD_ROOT%{_prefix} \
  109. libdir=$RPM_BUILD_ROOT%{_libdir} \
  110. install \
  111. gnulocaledir=$RPM_BUILD_ROOT%{_localedir}
  112. %if 0
  113. install -m 755 ttmkfdir/ttmkfdir $RPM_BUILD_ROOT%{_bindir}
  114. %endif
  115. (cd $RPM_BUILD_ROOT%{_includedir}
  116. for i in freetype/*.h
  117. do
  118. ln -sf $i .
  119. done
  120. )
  121. %if 0
  122. (cd contrib/ttf2pk
  123. make prefix=$RPM_BUILD_ROOT%{_prefix} \
  124. mandir=$RPM_BUILD_ROOT%{_mandir} \
  125. install
  126. mkdir -p $RPM_BUILD_ROOT%{_datadir}/ttf2pk
  127. cp data/* $RPM_BUILD_ROOT%{_datadir}/ttf2pk
  128. )
  129. %endif
  130. # remove unpackaged files
  131. rm -rf $RPM_BUILD_ROOT%{_bindir}
  132. %post -p /sbin/ldconfig
  133. %postun -p /sbin/ldconfig
  134. %if %{build_compat32}
  135. %post -n compat32-%{name} -p /sbin/ldconfig
  136. %postun -n compat32-%{name} -p /sbin/ldconfig
  137. %endif
  138. %clean
  139. rm -rf $RPM_BUILD_ROOT
  140. %files
  141. %defattr(-,root,root)
  142. %{_libdir}/libttf.la
  143. %{_libdir}/libttf.so.*
  144. %{_datadir}/locale/*/LC_MESSAGES/*
  145. %doc README announce docs
  146. %if 0
  147. %files utils
  148. %defattr(-,root,root)
  149. %{_bindir}/*
  150. %{_mandir}/man1/*
  151. %{_datadir}/ttf2pk/
  152. %endif
  153. %files devel
  154. %defattr(-,root,root)
  155. %{_includedir}/*
  156. %{_libdir}/libttf.so
  157. %{_libdir}/libttf.a
  158. ## to build compat32 for x86_64 architecture support
  159. %if %{build_compat32}
  160. %files -n compat32-%{name}
  161. %defattr(-,root,root)
  162. %{_libdir}/libttf.la
  163. %{_libdir}/libttf.so.*
  164. %files -n compat32-%{name}-devel
  165. %defattr(-,root,root)
  166. %{_libdir}/libttf.so
  167. %{_libdir}/libttf.a
  168. %endif
  169. %changelog
  170. * Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.1-7
  171. - add Requires: %{name} = %{version}-%{release} (devel package)
  172. - add BuildRequires: libX11-devel, libXt-devel, imake
  173. - change configure option
  174. (from "--x-libraries=%{_prefix}/X11R6/%{_lib}" to "--x-libraries=%{_libdir}")
  175. * Wed Mar 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.1-6
  176. - obsolete freetype-utils
  177. * Thu Feb 23 2006 Shu KONNO <owa@bg.wakwak.com> 1.3.1-5vl5
  178. - fixed libdir to configure and to make install
  179. * Mon Feb 13 2006 Shu KONNO <owa@bg.wakwak.com> 1.3.1-5vl4
  180. - dropt libtoolize
  181. - added freetype-1.3.1-ftdump-gcc3.patch
  182. - added freetype-1.3.1-config.sub-x86_64.patch
  183. - added freetype-1.3.1-ltconfig-compat32.patch
  184. - added options --libdir, --x-libraries, --target to configure
  185. - added URL
  186. - changed Copyright to License
  187. - changed direct path strings to macros
  188. * Sat Mar 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.1-5vl3
  189. - rebuilt with new toolchains
  190. * Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  191. - 1.3.1-5vl2
  192. - rebuilt with new %%{_mandir} for VineSeed
  193. * Wed Aug 2 2000 Jun Nishii <jun@vinelinux.org>
  194. - 1.3.1-5vl1
  195. - follow RHL62
  196. * Sat Jan 22 2000 Jun Nishii <jun@vinelinux.org>
  197. - added %defattr
  198. * Tue Jan 11 2000 Jun Nishii <jun@vinelinux.org>
  199. - added bins from contrib/ttf2pk
  200. * Tue Nov 23 1999 Norihito Ohmori <ohmori@flatout.org>
  201. - modified for Vine Linux
  202. * Wed Nov 10 1999 Norihito Ohmori <nono@kondara.org>
  203. - add /usr/bin/{ftmetric,ftsbit,ftstrtto} to freetype-utils (jitterbug #88)
  204. * Mon Nov 8 1999 Toru Hoshina <t@kondara.org>
  205. - be a NoSrc :-P
  206. * Wed Oct 14 1999 Norihito Ohmori <nono@kondara.org>
  207. - freetype-current dated Oct 12 1999.
  208. * Sat Oct 9 1999 Toru Hoshina <t@kondara.org>
  209. - freetype-current dated Oct 3 1999.
  210. * Thu Aug 19 1999 Preston Brown <pbrown@redhat.com>
  211. - newer ttmkfdir that works better, moved ttmkfdir to /usr/bin from /usr/sbin
  212. - freetype utilities moved to subpkg, X dependency removed from main pkg
  213. - libttf.so symlink moved to devel pkg
  214. * Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
  215. - strip binaries
  216. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  217. - auto rebuild in the new build environment (release 5)
  218. * Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
  219. - fixed the %doc file list
  220. * Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
  221. - Injected new description and group.
  222. * Mon Feb 15 1999 Preston Brown <pbrown@redhat.com>
  223. - added ttmkfdir
  224. * Tue Feb 02 1999 Preston Brown <pbrown@redhat.com>
  225. - update to 1.2
  226. * Thu Jan 07 1999 Cristian Gafton <gafton@redhat.com>
  227. - call libtoolize to sanitize config.sub and get ARM support
  228. - dispoze of the patch (not necessary anymore)
  229. * Wed Oct 21 1998 Preston Brown <pbrown@redhat.com>
  230. - post/postun sections for ldconfig action.
  231. * Tue Oct 20 1998 Preston Brown <pbrown@redhat.com>
  232. - initial RPM, includes normal and development packages.