perl-Tk-vl.spec 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137
  1. # if you wanna test, add " --define '_run_test 1' " option to rpmbuild command
  2. %define run_test %{?_run_test:1}%{!?_run_test:0}
  3. %define pkgname Tk
  4. Summary: A perl module for Tk.
  5. Name: perl-%{pkgname}
  6. Version: 804.028
  7. Release: 5%{_dist_release}
  8. Group: Development/Libraries
  9. License: GPL or Artistic
  10. URL: http://perltk.org/
  11. Source0: %{pkgname}-%{version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: libX11-devel
  14. BuildRequires: libpng-devel
  15. BuildRequires: libjpeg-turbo-devel
  16. ## bug fix
  17. # fixed: http://rt.cpan.org/Public/Bug/Display.html?id=38746
  18. Patch11: perl-Tk-fix38746.patch
  19. ## security fix
  20. Patch100: Tk-804.027-suse-CVE-2006-4484.patch
  21. ## for VineLinux6
  22. Patch200: perl-Tk-804.028.Xlib.patch
  23. Patch201: perl-Tk-804.028.pTkCallback.patch
  24. Patch202: perl-Tk-804.028.encGlue.patch
  25. Patch203: perl-Tk-804.028.tkGlue.patch
  26. Provides: perl(Tk::LabRadio) = 4.004
  27. Provides: perl(Tk::TextReindex) = 4.004
  28. Vendor: Project Vine
  29. Distribution: Vine Linux
  30. %description
  31. Perl bindings to the Tk Graphical User Interface ToolKit.
  32. %prep
  33. %setup -q -n %{pkgname}-%{version}
  34. %{__mkdir} pTk.docs
  35. %{__cp} pTk/Tix.license pTk/license.terms pTk/license.html_lib pTk.docs
  36. ## bug fix
  37. %patch11 -p0 -b .bug38746
  38. ## security fix
  39. %patch100 -p0 -b .CVE-2006-4484
  40. ## for VineLinux6
  41. %patch200 -p1 -b .Xlib
  42. %patch201 -p1 -b .pTkCallback
  43. %patch202 -p1 -b .encGlue
  44. %patch203 -p1 -b .tkGlue
  45. %build
  46. find . -type f -exec %{__perl} -pi -e 's|^#!/.*bin/perl\S*|#!%{__perl}|i;' {} \;
  47. CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL PREFIX=$RPM_BUILD_ROOT%{_prefix} INSTALLDIRS=vendor
  48. #make %{?_smp_mflags}
  49. make
  50. %if %{run_test}
  51. make test
  52. #-------------------------------#
  53. # Sun May 22 2011 ..last tested #
  54. # Result: PASS
  55. #-------------------------------#
  56. %endif
  57. %install
  58. rm -rf $RPM_BUILD_ROOT
  59. make install
  60. [ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
  61. find $RPM_BUILD_ROOT%{_prefix} -type f -print | \
  62. sed "s@^$RPM_BUILD_ROOT@@g" | \
  63. grep -v perllocal.pod | \
  64. grep -v "\.packlist" > %{pkgname}-%{version}-filelist
  65. if [ "$(cat %{pkgname}-%{version}-filelist)X" = "X" ] ; then
  66. echo "ERROR: EMPTY FILE LIST"
  67. exit -1
  68. fi
  69. %clean
  70. rm -rf $RPM_BUILD_ROOT
  71. %files -f %{pkgname}-%{version}-filelist
  72. %defattr(-,root,root)
  73. %doc README MANIFEST COPYING Change.log Changes README.linux pTk.docs
  74. %exclude %{perl_archlib}/perllocal.pod
  75. %exclude %{perl_vendorarch}/auto/Tk/.packlist
  76. %changelog
  77. * Sun May 22 2011 Shu KONNO <owa@bg.wakwak.com> 804.028-5
  78. - added BR: libjpeg-turbo-devel
  79. * Sun May 22 2011 Shu KONNO <owa@bg.wakwak.com> 804.028-4
  80. - added Patch200: perl-Tk-804.028.Xlib.patch
  81. - added Patch201: perl-Tk-804.028.pTkCallback.patch
  82. - added Patch202: perl-Tk-804.028.encGlue.patch
  83. - added Patch203: perl-Tk-804.028.tkGlue.patch
  84. - added _run_test option
  85. * Sat Jan 9 2010 IWAI, Masaharu <iwai@alib.jp> 804.028-3
  86. - add BuildRequires: libX11-devel libpng-devel : <BTS:VineLinux:866>
  87. - drop X11LIBS argument for Makefile.PL on x86_64 architecture
  88. - add documents
  89. * Mon Jan 4 2010 IWAI, Masaharu <iwai@alib.jp> 804.028-2
  90. - add patch11 for fix CPAN bug #38746: <BTS:VineLinux:866>
  91. - see http://rt.cpan.org/Public/Bug/Display.html?id=38746
  92. * Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 804.028-1
  93. - new upstream release
  94. - build with perl-8.10.0
  95. * Fri Mar 28 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 804.027-3
  96. - add patch100 for fix CVE-2006-4484
  97. - with new versioning policy
  98. - add Vendor/Distribution tag
  99. * Mon Dec 31 2007 Shu KONNO <owa@bg.wakwak.com> 804.027-0vl2
  100. - added X11LIB to build (for x86_64)
  101. * Sun Oct 22 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 804.027-0vl1
  102. - updated to 804.027
  103. - build with perl-5.8.6
  104. - no noarch now (arch-dependent files/binaries are actually included)
  105. * Sun Oct 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 804.026-0vl1
  106. - initial build for Vine Linux