gnumeric-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428
  1. %define gnumeric_version %{version}-bonobo
  2. %define goffice_version 0.10.1
  3. Summary: A spreadsheet program for GNOME.
  4. Summary(ja): GNOME スプレッドシート
  5. Name: gnumeric
  6. Version: 1.12.1
  7. Release: 1%{?_dist_release}
  8. License: GPLv2
  9. Group: Applications/Productivity
  10. URL: http://www.gnome.org/projects/gnumeric
  11. Source0: ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.12/%{name}-%{version}.tar.xz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. # default font: VL Gothic
  14. Patch0: gnumeric-1.11.5-vlgothic.patch
  15. Distribution: Vine Linux
  16. Vendor: Project Vine
  17. BuildRequires: bison
  18. BuildRequires: flex
  19. BuildRequires: goffice-devel >= %{goffice_version}
  20. BuildRequires: pygobject3-devel
  21. BuildRequires: perl python-devel
  22. BuildRequires: automake
  23. BuildRequires: gnome-doc-utils
  24. BuildRequires: desktop-file-utils
  25. Requires(postun,posttrans): glib2
  26. Requires(post,postun): desktop-file-utils
  27. Obsoletes: %{name}-devel
  28. %description
  29. GNOME (GNU Network Object Model Environment) is a user-friendly set of
  30. applications and desktop tools to be used in conjunction with a window
  31. manager for the X Window System.
  32. This is the Gnumeric, a spreadsheet for GNOME. It aims to be a drop in
  33. replacement for commercial spreadsheets. It provides import/export from
  34. MS Excel files and many other formats (csv, latex, xbase, applix).
  35. %description -l ja
  36. GNOME (GNU Network Object Model Environment)は
  37. Xウィンドウシステム用の、ウィンドウマネージャと連結した
  38. GUIアプリケーションおよびデスクトップツールのセットです。
  39. これは Gnumeric, GNOMEスプレッドシート・プログラムです。
  40. 商用のスプレッドシート・プログラムを代替できるものを目指しています。
  41. MS Excelファイルや他の多くのフォーマット(csv, latex, xbase, applix)
  42. を読込み、出力できます.
  43. %prep
  44. %setup -q
  45. %patch0 -p1 -b .vlgothic
  46. %build
  47. %ifarch alpha
  48. MYARCH_FLAGS="--host=alpha-redhat-linux"
  49. %endif
  50. %configure \
  51. --without-gda \
  52. --with-perl \
  53. --with-python
  54. make
  55. %install
  56. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  57. make DESTDIR=$RPM_BUILD_ROOT install
  58. ./mkinstalldirs $RPM_BUILD_ROOT%{_datadir}/applications
  59. desktop-file-install --vendor gnome --delete-original \
  60. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  61. --add-category Office \
  62. --add-category Application \
  63. --add-category Spreadsheet \
  64. --remove-mime-type="zz-application/zz-winassoc-xls" \
  65. $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
  66. %find_lang %{name}
  67. %find_lang %{name}-functions
  68. cat %{name}-functions.lang >> %{name}.lang
  69. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  70. rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
  71. rm -rf $RPM_BUILD_ROOT%{_includedir}/libspreadsheet-1.12
  72. rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
  73. %clean
  74. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  75. %post
  76. /sbin/ldconfig
  77. scrollkeeper-update > /dev/null 2>&1 || :
  78. touch --no-create %{_datadir}/icons/hicolor || :
  79. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  80. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  81. fi
  82. update-desktop-database -q &> /dev/null || :
  83. %postun
  84. /sbin/ldconfig
  85. scrollkeeper-update > /dev/null 2>&1 || :
  86. touch --no-create %{_datadir}/icons/hicolor || :
  87. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  88. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  89. fi
  90. update-desktop-database -q &> /dev/null || :
  91. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  92. %posttrans
  93. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  94. %files -f %{name}.lang
  95. %defattr (-, root, root)
  96. %doc AUTHORS BUGS *ChangeLog* COPYING HACKING NEWS README
  97. %{_bindir}/*
  98. %{_libdir}/libspreadsheet*.so
  99. %{_libdir}/%{name}
  100. %{_libdir}/goffice/0.10/plugins/%{name}
  101. %{_datadir}/applications/*.desktop
  102. %{_datadir}/glib-2.0/schemas/*.xml
  103. %{_datadir}/gnome/help/%{name}
  104. %{_datadir}/%{name}
  105. %{_datadir}/pixmaps/*
  106. %{_datadir}/omf/*
  107. %{_datadir}/icons/hicolor/*
  108. %{_mandir}/man*/*
  109. %exclude %{_datadir}/pixmaps/win32-gnumeric.ico
  110. %changelog
  111. * Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.1-1
  112. - new upstream release
  113. * Tue Jan 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
  114. - new upstream release
  115. * Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.11.5-1
  116. - new upstream release
  117. - add Patch0 (gnumeric-1.11.5-vlgothic.patch)
  118. - remove Patch1 (gnumeric-1.10.17-libgsf.patch)
  119. * Fri Dec 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.17-2
  120. - rebuild with libgsf-1.14.22
  121. - add Patch1 (gnumeric-1.10.17-libgsf.patch)
  122. * Wed Aug 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.17-1
  123. - new upstream release
  124. - update Patch0
  125. * Sat Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.14-1
  126. - new upstream release
  127. * Sat Feb 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.13-1
  128. - new upstream release
  129. - add Patch0 (gnumeric-1.10.13-vlgothic.patch)
  130. * Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.12-1
  131. - new upstream release
  132. * Sat Oct 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.11-1
  133. - new upstream release
  134. * Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.10-1
  135. - new upstream release
  136. * Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.9-1
  137. - new upstream release
  138. - add desktop-file-install option: --remove-mime-type="zz-application/zz-winassoc-xls"
  139. (fix error of MIME type)
  140. * Sun Aug 15 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
  141. - new upstream release
  142. * Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.7-1
  143. - new upstream release
  144. * Wed Jun 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
  145. - new upstream release
  146. - fix %post and %postun
  147. * Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
  148. - new upstream release
  149. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
  150. - new upstream release
  151. - add BuildRequires: libSM-devel
  152. - fix BuildRequires: goffice-devel >= 0.8.1
  153. * Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-3
  154. - spec in UTF-8 (fixed)
  155. * Sat May 9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-2
  156. - spec in UTF-8
  157. - added BuildRequires: libffi-devel
  158. - added %%pre, %%preun section
  159. * Mon Jun 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-1
  160. - new upstream release
  161. - built with libgda-3.1.4, libgnomedb-3.1.2
  162. - applied new versioning policy
  163. * Mon Mar 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
  164. - new upstream release
  165. * Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.6.3-0vl2
  166. - rebuild
  167. * Fri May 5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-0vl1
  168. - new upstream release
  169. * Sun Mar 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.2-0vl1
  170. - new upstream release
  171. - updated build dependancies
  172. - rebuilt with libgsf-1.14.0
  173. - built with libgda and libgnomedb again
  174. * Tue Nov 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-0vl1
  175. - new upstream release
  176. - updated build dependancies
  177. - not compile with libgda and libgnomedb in this version
  178. * Mon Mar 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.3-0vl1
  179. - new upstream release
  180. * Fri Feb 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl2
  181. - rebuild with libgda 1.2.0 and libgnome 1.2.0
  182. * Tue Jan 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl1
  183. - new upstream release
  184. * Mon Dec 13 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1-0vl1
  185. - new upstream release
  186. * Thu Dec 2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-0vl1
  187. - new upstream release
  188. * Fri Nov 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl2
  189. - rebuild with gnome-2.8 environment and libgsf-1.10.1
  190. * Tue Jun 29 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl1
  191. - new upstream release
  192. - added BuildRequires: desktop-file-utils
  193. * Thu May 6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-0vl1
  194. - new upstream release
  195. - Requires: libgsf >= 1.9.0, BuildPrereq: libgsf-devel >= 1.9.0
  196. * Wed Apr 21 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
  197. - new upstream release
  198. * Wed Apr 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-0vl1
  199. - new upstream release
  200. * Sun Apr 11 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
  201. - new upstream release
  202. * Thu Mar 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
  203. - new upstream release
  204. * Wed Mar 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.7-0vl1
  205. - new upstream release
  206. - clean up spec file (a little bit!)
  207. * Thu Jan 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
  208. - new upstream release
  209. * Fri Jan 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.4-0vl1
  210. - new upstream release
  211. - to use intltool-0.28
  212. * Sun Dec 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-0vl1
  213. - new upstream release
  214. - rebuild with new toolchains
  215. * Sun Nov 30 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-0vl1
  216. - new upstream release
  217. - build with new libgnomeprint, libgnomeprintui
  218. * Fri Oct 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-0vl1
  219. - new upstream release
  220. * Thu Oct 2 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl2
  221. - rebuild with newer libgda, libgnomedb
  222. * Thu Sep 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
  223. - updated to 1.2.0 (stable release)
  224. - guile support is temporarily off this version.
  225. * Mon Sep 9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl1
  226. - update to 1.1.20 (gtk+-2 port)
  227. - based on Redhat Rawhide 1.1.20-1
  228. * Thu May 1 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.13-0vl1
  229. - update to 1.0.13
  230. - rebuild with gal 0.24
  231. * Sun Mar 9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.12-0vl2
  232. - guile support on
  233. - rebuild with new gal, bonobo, libgda
  234. * Fri Feb 7 2003 Masaki Shinomiya <shino@pos.to> 1.0.12-0vl1
  235. - New upstream release, remove xmliobackward.patch
  236. * Mon Dec 16 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl2
  237. - xml-io back to 1.0.10 because japanese corrups with new xml_parser
  238. * Sun Dec 15 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl1
  239. - New upstream release, fix for xml importing files with non ASCII characters.
  240. - Without guile, changelog.archive, requires, build scripts, description
  241. * Mon Nov 19 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl2
  242. - files: add gnumericConf.sh, which was missing
  243. * Mon Nov 4 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl1
  244. - New upstream release.
  245. - BuildPrereq oaf-devel
  246. * Mon Jul 29 2002 Masaki Shinomiya <shino@pos.to> 1.0.9-0vl1
  247. - New upstream release.
  248. * Mon Jul 1 2002 Masaki Shinomiya <shino@pos.to> 1.0.8-0vl1
  249. - New upstream release.
  250. - Default font and Japanese fonts in excel
  251. - requires
  252. * Sun Jun 30 2002 Masaki Shinomiya <shino@pos.to> 1.0.7-0vl1
  253. - New upstream release.
  254. - fixed plugins, apply patch2, remove patch3
  255. - files - no longer devel package
  256. - function-reference.html in help file
  257. * Thu Jan 24 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.3-0vl1
  258. - New upstream release.
  259. * Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.2-0vl1
  260. - New upstream release.
  261. - Fixed several owner dir.
  262. * Tue Jan 15 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl2
  263. - Build against with new gal
  264. * Mon Jan 7 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl1
  265. - New upstream release.
  266. * Fri Jan 4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.0-0vl1
  267. - New upstream release.
  268. * Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.1-0vl1
  269. - New upstream release.
  270. - Applied XIM over-the-spot patch.
  271. - Fixed directories owner.
  272. * Wed Dec 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.0-0vl1
  273. - New upstream release.
  274. - Enable Bonobo.
  275. - Merged several RH patches.
  276. - Added BuildPreReq tags.
  277. * Tue Jun 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl3
  278. - Fixed packaging mistake.
  279. * Mon May 14 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl2
  280. - Rebuild for GAL 0.7
  281. * Fri Mar 23 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl1
  282. - New upstream release.
  283. - Use rpmmacros.
  284. * Mon Feb 5 2001 Jun Nishii <jun@vinelinux.org>
  285. - 0.56-0vl2
  286. - update ja.po
  287. - avoid core dump when inserting a row
  288. * Mon Jul 10 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  289. - updated to 0.56
  290. - remake spec with the orginal gnumeric spec file.
  291. - added ms_excel_read and edit_item patch from Japanese gnome users mailing list.
  292. * Tue May 16 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  293. - updated to 0.53
  294. - remake SPEC based on gnumeric original.
  295. - added libxml183 patch for libxml 1.8.3
  296. * Thu Mar 29 2000 Kjartan Maraas <kmaraas@online.no>
  297. - Removed gnome-gnumeric-xl.png since it is nowhere to be found.
  298. - Added --without-bonobo and --without-gb.
  299. - Added %define for sysconfdir
  300. * Mon Feb 29 2000 Jody Goldberg <jgolbderg@home.com>
  301. - Updated version requirements for gnome-print, and gnome-libs.
  302. * Sun Jan 30 2000 Gregory McLean <gregm@comstar.net>
  303. - Added in some auto-detect the language files logic (rpm 3.0.xx only)
  304. * Mon Jan 12 2000 Jody Goldberg <jgolbderg@home.com>
  305. - Add depend on gtk+ >= 1.2.2 so that we can get gtk_object_get.
  306. * Mon Jan 03 2000 Gregory McLean <gregm@comstar.net>
  307. - Updated to 0.47
  308. * Mon Dec 20 1999 Jody Goldberg <jgolbderg@home.com>
  309. - Updated the libglade dependancy.
  310. - Remove req for guile. We can build without it.
  311. * Thu Sep 02 1999 Gregory McLean <gregm@comstar.net>
  312. - Added small fix so glade generated dialogs appear.
  313. * Wed Jul 14 1999 Gregory McLean <gregm@comstar.net>
  314. - Added the gnome-print requirement.
  315. - Updated the file list to try and quiet down the updating.
  316. - added the sysconfdir
  317. * Tue Mar 9 1999 Gregory McLean <gregm@comstar.net>
  318. - Updated the spec file.
  319. * Thu Sep 24 1998 Michael Fulbright <msf@redhat.com>
  320. - Version 0.2