llvm-vl.spec 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. # Build options:
  3. # Components skipped by default:
  4. %bcond_with doxygen
  5. %bcond_with ocaml
  6. %bcond_with force_gold
  7. # Documentation install path
  8. %global llvmdocdir() %{_docdir}/%1-%{version}
  9. %define _unpackaged_files_terminate_build 1
  10. Name: llvm
  11. Version: 3.8.1
  12. Release: 1%{?_dist_release}
  13. Summary: The Low Level Virtual Machine
  14. Summary(ja): LLVM - 低レベルバーチャルマシン
  15. Group: Development/Languages
  16. License: NCSA
  17. URL: http://llvm.org/
  18. Source0: http://llvm.org/releases/%{version}/llvm-%{version}.src.tar.xz
  19. Source1: http://llvm.org/releases/%{version}/cfe-%{version}.src.tar.xz
  20. Source2: http://llvm.org/releases/%{version}/compiler-rt-%{version}.src.tar.xz
  21. Source3: http://llvm.org/releases/%{version}/lldb-%{version}.src.tar.xz
  22. # multilib fixes
  23. Source10: llvm-config.h
  24. Source11: clang-config.h
  25. # patches
  26. # added acc5-abi support
  27. Patch1: 0001-GCC-PR23529-Sema-part-of-attrbute-abi_tag-support.patch
  28. Patch2: 0002-GCC-PR23529-Mangler-part-of-attrbute-abi_tag-support.patch
  29. # Vine Patch
  30. Patch1000: clang-3.8.1-driver-ld.gold.patch
  31. Patch1002: clang-3.8.1-driver-vine.patch
  32. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  33. BuildRequires: binutils-devel
  34. BuildRequires: cmake
  35. BuildRequires: bison
  36. BuildRequires: chrpath
  37. BuildRequires: flex
  38. BuildRequires: gcc-c++ >= 3.4
  39. BuildRequires: groff
  40. BuildRequires: libffi-devel
  41. BuildRequires: libstdc++-devel
  42. BuildRequires: libstdc++-static
  43. BuildRequires: libtool-ltdl-devel
  44. BuildRequires: libxml2-devel
  45. BuildRequires: ocaml-findlib
  46. BuildRequires: ocaml-ctypes
  47. BuildRequires: ocaml-ounit
  48. # for DejaGNU test suite
  49. BuildRequires: dejagnu tcl-devel python
  50. %if %{with doxygen}
  51. BuildRequires: doxygen graphviz
  52. %endif
  53. # pod2man
  54. BuildRequires: perl
  55. # lldb
  56. BuildRequires: swig
  57. BuildRequires: libedit-devel
  58. BuildRequires: python-devel >= 2.7
  59. Requires: llvm-libs = %{version}-%{release}
  60. # LLVM is not supported on PPC64
  61. # http://llvm.org/bugs/show_bug.cgi?id=3729
  62. ExcludeArch: ppc64
  63. %description
  64. LLVM is a compiler infrastructure designed for compile-time,
  65. link-time, runtime, and idle-time optimization of programs from
  66. arbitrary programming languages. The compiler infrastructure includes
  67. mirror sets of programming tools as well as libraries with equivalent
  68. functionality.
  69. %package devel
  70. Summary: Libraries and header files for LLVM
  71. Summary(ja): LLVM のライブラリおよびヘッダファイル
  72. Group: Development/Libraries
  73. Requires: %{name} = %{version}-%{release}
  74. Requires: libstdc++-devel
  75. Requires: libffi-devel
  76. Provides: llvm-static = %{version}-%{release}
  77. %description devel
  78. This package contains library and header files needed to develop new
  79. native programs that use the LLVM infrastructure.
  80. %package doc
  81. Summary: Documentation for LLVM
  82. Summary(ja): LLVM のドキュメント
  83. Group: Documentation
  84. BuildArch: noarch
  85. Requires: %{name} = %{version}-%{release}
  86. # might seem redundant, but needed to kill off the old arch-ed -doc subpackage
  87. Obsoletes: %{name}-doc < %{version}-%{release}
  88. %description doc
  89. Documentation for the LLVM compiler infrastructure.
  90. %package libs
  91. Summary: LLVM shared libraries
  92. Summary(ja): LLVM 共有ライブラリ
  93. Group: System Environment/Libraries
  94. %description libs
  95. Shared libraries for the LLVM compiler infrastructure.
  96. %description libs -l ja
  97. LLVM コンパイラ基盤の共有ライブラリです.
  98. %package -n clang
  99. Summary: A C language family front-end for LLVM
  100. Summary(ja): LLVM の C 言語フロントエンド
  101. License: NCSA
  102. Group: Development/Languages
  103. Requires: %{name} = %{version}-%{release}
  104. # clang requires gcc, clang++ requires libstdc++-devel
  105. Requires: libstdc++-devel
  106. # remove clang-doc pacakge
  107. Obsoletes: clang-doc < %{version}-%{release}
  108. %description -n clang
  109. clang: noun
  110. 1. A loud, resonant, metallic sound.
  111. 2. The strident call of a crane or goose.
  112. 3. C-language family front-end toolkit.
  113. The goal of the Clang project is to create a new C, C++, Objective C
  114. and Objective C++ front-end for the LLVM compiler. Its tools are built
  115. as libraries and designed to be loosely-coupled and extensible.
  116. %Package -n clang-libs
  117. Summary: Runtime library for clang
  118. Summary(ja): Clang のランタイムライブラリ
  119. Group: System Environment/Libraries
  120. %description -n clang-libs
  121. Runtime library for clang.
  122. %description -n clang-libs -l ja
  123. Clang のランタイムライブラリです.
  124. %package -n clang-devel
  125. Summary: Header files for clang
  126. Summary(ja): Clang のヘッダファイル
  127. Group: Development/Libraries
  128. Requires: clang = %{version}-%{release}
  129. %description -n clang-devel
  130. This package contains header files for the Clang compiler.
  131. %description -n clang-devel -l ja
  132. Clang コンパイラのヘッダファイル集です.
  133. %package -n clang-analyzer
  134. Summary: A source code analysis framework
  135. Summary(ja): ソースコード分析フレームワーク
  136. License: NCSA
  137. Group: Development/Languages
  138. Requires: clang = %{version}-%{release}
  139. # not picked up automatically since files are currently not instaled
  140. # in standard Python hierarchies yet
  141. Requires: python
  142. %description -n clang-analyzer
  143. The Clang Static Analyzer consists of both a source code analysis
  144. framework and a standalone tool that finds bugs in C and Objective-C
  145. programs. The standalone tool is invoked from the command-line, and is
  146. intended to run in tandem with a build of a project or code base.
  147. #%package -n clang-doc
  148. #Summary: Documentation for Clang
  149. #Summary(ja): Clang のドキュメント
  150. #Group: Documentation
  151. #Requires: %{name} = %{version}-%{release}
  152. #
  153. #%description -n clang-doc
  154. #Documentation for the Clang compiler front-end.
  155. %package -n lldb
  156. Summary: Next generation high-performance debugger
  157. Summary(ja): 高性能デバッガー
  158. License: NCSA
  159. Group: Development/Debuggers
  160. Requires: %{name} = %{version}-%{release}
  161. %description -n lldb
  162. LLDB is a next generation, high-performance debugger. It is built as a set
  163. of reusable components which highly leverage existing libraries in the
  164. larger LLVM Project, such as the Clang expression parser and LLVM
  165. disassembler.
  166. %package -n lldb-devel
  167. Summary: Header files for LLDB
  168. Summary(ja): LLDB のヘッダファイル
  169. Group: Development/Libraries
  170. Requires: lldb = %{version}-%{release}
  171. %description -n lldb-devel
  172. This package contains header files for the LLDB debugger.
  173. %if %{with doxygen}
  174. %package apidoc
  175. Summary: API documentation for LLVM
  176. Summary(ja): LLVM の API ドキュメント
  177. Group: Documentation
  178. BuildArch: noarch
  179. Requires: %{name}-docs = %{version}-%{release}
  180. %description apidoc
  181. API documentation for the LLVM compiler infrastructure.
  182. %package -n clang-apidoc
  183. Summary: API documentation for Clang
  184. Summary(ja): Clang の API ドキュメント
  185. Group: Documentation
  186. BuildArch: noarch
  187. %description -n clang-apidoc
  188. API documentation for the Clang compiler.
  189. %endif
  190. %if %{with ocaml}
  191. %package ocaml
  192. Summary: OCaml binding for LLVM
  193. Summary(ja): LLVM の OCaml バインディング
  194. Group: System Environment/Libraries
  195. Requires: %{name} = %{version}-%{release}
  196. Requires: ocaml
  197. %description ocaml
  198. OCaml binding for LLVM.
  199. %package ocaml-devel
  200. Summary: Development files for %{name}-ocaml
  201. Summary(ja): %{name}-ocaml の開発ファイル
  202. Group: Development/Libraries
  203. Requires: %{name}-devel = %{version}-%{release}
  204. Requires: %{name}-ocaml = %{version}-%{release}
  205. Requires: ocaml
  206. %description ocaml-devel
  207. The %{name}-ocaml-devel package contains libraries and signature files
  208. for developing applications that use %{name}-ocaml.
  209. %package ocaml-doc
  210. Summary: Documentation for %{name}-ocaml
  211. Summary(ja): %{name}-ocaml のドキュメント
  212. Group: Documentation
  213. BuildArch: noarch
  214. Requires: %{name}-ocaml = %{version}-%{release}
  215. # might seem redundant, but needed to kill off the old arch-ed -doc subpackage
  216. Obsoletes: %{name}-ocaml-doc < %{version}-%{release}
  217. %description ocaml-doc
  218. HTML documentation for LLVM's OCaml binding.
  219. %endif
  220. # compat32'
  221. %package -n compat32-%{name}-libs
  222. Summary: LLVM shared libraries
  223. Summary(ja): LLVM 共有ライブラリ
  224. Group: System Environment/Libraries
  225. Requires: %{name}-libs = %{version}-%{release}
  226. %description -n compat32-%{name}-libs
  227. Shared libraries for the LLVM compiler infrastructure.
  228. %prep
  229. %setup -q -a1 -a2 -a3 -n llvm-%{version}.src
  230. rm -rf tools/clang tools/lldb projects/compiler-rt
  231. mv cfe-%{version}.src tools/clang
  232. mv compiler-rt-%{version}.src projects/compiler-rt
  233. mv lldb-%{version}.src tools/lldb
  234. # clang
  235. pushd tools/clang
  236. %patch1 -p1 -b .gcc_abi-1
  237. %patch2 -p1 -b .gcc_abi-2
  238. popd
  239. # Vine Linux
  240. %if %{with force_gold}
  241. pushd tools/clang
  242. %patch1000 -p1 -b .driver-ld.gold
  243. popd
  244. %endif
  245. %patch1002 -p1 -b .driver-vine
  246. sed -i -e 's/"ld"/"ld.gold"/' tools/clang/include/clang/Driver/ToolChain.h
  247. %build
  248. mkdir build
  249. cd build
  250. CFLAGS="%{optflags} -fno-strict-aliasing -Wno-error=format-security -fPIC"
  251. CXXFLAGS="%{optflags} -fno-strict-aliasing -Wno-error=format-security -fPIC -std=c++11"
  252. LDFLAGS="%{?__global_ldflags} -lpthread -ldl"
  253. %cmake .. \
  254. -DBUILD_SHARED_LIBS:BOOL=OFF \
  255. -DCMAKE_BUILD_TYPE=Release \
  256. -DCMAKE_SHARED_LINKER_FLAGS="-Wl,-Bsymbolic -static-libstdc++" \
  257. %if 0%{?__isa_bits} == 64
  258. -DLLVM_LIBDIR_SUFFIX=64 \
  259. %else
  260. -DLLVM_LIBDIR_SUFFIX= \
  261. %endif
  262. -DLLVM_TARGETS_TO_BUILD="X86;AMDGPU;PowerPC;NVPTX;SystemZ;AArch64;ARM;BPF;CppBackend" \
  263. -DLLVM_ENABLE_LIBCXX:BOOL=OFF \
  264. -DLLVM_ENABLE_ZLIB:BOOL=ON \
  265. -DLLVM_ENABLE_FFI:BOOL=ON \
  266. -DLLVM_ENABLE_RTTI:BOOL=ON \
  267. -DLLVM_BINUTILS_INCDIR=%{_includedir} \
  268. -DLLVM_BUILD_RUNTIME:BOOL=ON \
  269. -DLLVM_INCLUDE_TOOLS:BOOL=ON \
  270. -DLLVM_BUILD_TOOLS:BOOL=ON \
  271. -DLLVM_INCLUDE_TESTS:BOOL=ON \
  272. -DLLVM_BUILD_TESTS:BOOL=ON \
  273. -DLLVM_INCLUDE_EXAMPLES:BOOL=ON \
  274. -DLLVM_BUILD_EXAMPLES:BOOL=OFF \
  275. -DLLVM_INCLUDE_UTILS:BOOL=ON \
  276. -DLLVM_INSTALL_UTILS:BOOL=OFF \
  277. -DLLVM_INCLUDE_DOCS:BOOL=ON \
  278. -DLLVM_ENABLE_SPHINX:BOOL=OFF \
  279. %if %{with doxygen}
  280. -DLLVM_ENABLE_DOXYGEN:BOOL=ON \
  281. %else
  282. -DLLVM_ENABLE_DOXYGEN:BOOL=OFF \
  283. %endif
  284. -DLLVM_BUILD_LLVM_DYLIB:BOOL=ON \
  285. -DLLVM_DYLIB_EXPORT_ALL:BOOL=ON \
  286. -DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
  287. -DLLVM_BUILD_EXTERNAL_COMPILER_RT:BOOL=ON \
  288. -DLLVM_INSTALL_TOOLCHAIN_ONLY:BOOL=OFF \
  289. -DLLVM_OPTIMIZED_TABLEGEN:BOOL=ON \
  290. \
  291. -DCLANG_ENABLE_ARCMT:BOOL=ON \
  292. -DCLANG_ENABLE_STATIC_ANALYZER:BOOL=ON \
  293. -DCLANG_INCLUDE_DOCS:BOOL=ON \
  294. -DCLANG_INCLUDE_TESTS:BOOL=ON \
  295. -DCLANG_PLUGIN_SUPPORT:BOOL=ON \
  296. -DCLANG_BUILD_EXAMPLES:BOOL=OFF \
  297. -DLIB_SUFFIX= \
  298. \
  299. -DLLDB_PATH_TO_LLVM_BUILD=%{_prefix} \
  300. -DLLDB_PATH_TO_CLANG_BUILD=%{_prefix} \
  301. \
  302. -DLLDB_DISABLE_CURSES:BOOL=OFF \
  303. -DLLDB_DISABLE_LIBEDIT:BOOL=OFF \
  304. -DLLDB_DISABLE_PYTHON:BOOL=OFF \
  305. \
  306. -DPYTHON_EXECUTABLE:STRING=%{__python} \
  307. -DPYTHON_VERSION_MAJOR:STRING=$(%{__python} -c "import sys; print sys.version_info.major") \
  308. -DPYTHON_VERSION_MINOR:STRING=$(%{__python} -c "import sys; print sys.version_info.minor") \
  309. -DCOMPILER_RT_INCLUDE_TESTS:BOOL=OFF # could be on?
  310. # workaround for all-in-one build
  311. TMP_PWD=$(pwd)
  312. LD_LIBRARY_PATH="$TMP_PWD/%{_lib}" make %{?_smp_mflags}
  313. %install
  314. rm -rf %{buildroot}
  315. cd build
  316. make install DESTDIR=%{buildroot}
  317. # llvm
  318. install -m755 ./bin/lli-child-target %{buildroot}%{_bindir}/lli-child-target
  319. # fix multi-lib
  320. mv -v %{buildroot}%{_bindir}/llvm-config{,-%{__isa_bits}}
  321. mv -v %{buildroot}%{_includedir}/llvm/Config/llvm-config{,-%{__isa_bits}}.h
  322. install -m 0644 %{SOURCE10} %{buildroot}%{_includedir}/llvm/Config/llvm-config.h
  323. # clang
  324. mv -v %{buildroot}%{_includedir}/clang/Config/config{,-%{__isa_bits}}.h
  325. install -m 0644 %{SOURCE11} %{buildroot}%{_includedir}/clang/Config/config.h
  326. # remove git integration
  327. rm -vf %{buildroot}%{_bindir}/git-clang-format
  328. # remove editor integrations (bbedit, sublime, emacs, vim)
  329. rm -vf %{buildroot}%{_datadir}/clang/clang-format-bbedit.applescript
  330. rm -vf %{buildroot}%{_datadir}/clang/clang-format-sublime.py*
  331. rm -vf %{buildroot}%{_datadir}/clang/clang-format.el
  332. rm -vf %{buildroot}%{_datadir}/clang/clang-format.py*
  333. # remove diff reformatter
  334. rm -vf %{buildroot}%{_datadir}/clang/clang-format-diff.py*
  335. # lldb
  336. # remove static libraries
  337. #rm -fv %{buildroot}%{_libdir}/*.a
  338. # python: fix binary libraries location
  339. liblldb=$(basename $(readlink -e %{buildroot}%{_libdir}/liblldb.so))
  340. ln -vsf "../../../${liblldb}" %{buildroot}%{python_sitearch}/lldb/_lldb.so
  341. mv -v %{buildroot}%{python_sitearch}/readline.so %{buildroot}%{python_sitearch}/lldb/readline.so
  342. # remove bundled six.py
  343. rm -f %{buildroot}%{python_sitearch}/six.*
  344. # compiler-rt
  345. # move sanitizer lists to better place
  346. mkdir -p %{buildroot}%{_libdir}/clang/%{version}
  347. for file in asan_blacklist.txt msan_blacklist.txt dfsan_blacklist.txt cfi_blacklist.txt dfsan_abilist.txt; do
  348. mv -v %{buildroot}%{_prefix}/${file} %{buildroot}%{_libdir}/clang/%{version}/ || :
  349. done
  350. # move sanitizer libs to better place
  351. #mkdir -p %{buildroot}%{_libdir}/clang/%{version}/lib
  352. #mv -v %{buildroot}%{_prefix}/lib/linux/libclang_rt* %{buildroot}%{_libdir}/clang/%{version}/lib
  353. #mkdir -p %{buildroot}%{_libdir}/clang/%{version}/lib/linux/
  354. #pushd %{buildroot}%{_libdir}/clang/%{version}/lib
  355. #for i in *.a *.syms *.so; do
  356. # ln -s ../$i linux/$i
  357. #done
  358. rm -rf %{buildroot}%{_libdir}/python*
  359. %check
  360. # the || : is wrong, i know, but the git snaps fail to make check due to
  361. # broken makefiles in the doc dirs.
  362. cd build
  363. make check-all LIT_ARGS="-v -j4" | tee llvm-testlog.txt ||:
  364. make -C tools/clang/test TESTARGS="-v -j4" | tee clang-testlog.txt ||:
  365. %clean
  366. rm -rf %{buildroot}
  367. %post libs -p /sbin/ldconfig
  368. %postun libs -p /sbin/ldconfig
  369. %post -n clang-libs -p /sbin/ldconfig
  370. %postun -n clang-libs -p /sbin/ldconfig
  371. %post -n lldb -p /sbin/ldconfig
  372. %postun -n lldb -p /sbin/ldconfig
  373. %posttrans devel
  374. # link llvm-config to the platform-specific file;
  375. # use ISA bits as priority so that 64-bit is preferred
  376. # over 32-bit if both are installed
  377. alternatives \
  378. --install \
  379. %{_bindir}/llvm-config \
  380. llvm-config \
  381. %{_bindir}/llvm-config-%{__isa_bits} \
  382. %{__isa_bits}
  383. %postun devel
  384. if [ $1 -eq 0 ]; then
  385. alternatives --remove llvm-config \
  386. %{_bindir}/llvm-config-%{__isa_bits}
  387. fi
  388. exit 0
  389. %files
  390. %defattr(-,root,root,-)
  391. %doc CREDITS.TXT README.txt
  392. %{_bindir}/bugpoint
  393. %{_bindir}/llc
  394. %{_bindir}/lli
  395. %{_bindir}/lli-child-target
  396. %{_bindir}/obj2yaml
  397. %{_bindir}/sancov
  398. %{_bindir}/verify-uselistorder
  399. %{_bindir}/yaml2obj
  400. %exclude %{_bindir}/llvm-config-%{__isa_bits}
  401. %{_bindir}/llvm*
  402. %{_bindir}/opt
  403. %dir %{_datadir}/llvm
  404. %exclude %{_mandir}/man1/scan-build.1.*
  405. %doc %{_mandir}/man1/*.1.*
  406. %files devel
  407. %defattr(-,root,root,-)
  408. #doc %{llvmdocdir %{name}-devel}/
  409. %{_bindir}/llvm-config-%{__isa_bits}
  410. %{_includedir}/%{name}
  411. %{_includedir}/%{name}-c
  412. %{_libdir}/*.a
  413. %{_libdir}/libLLVM.so
  414. %{_datadir}/%{name}/cmake
  415. %files libs
  416. %defattr(-,root,root,-)
  417. %doc LICENSE.TXT
  418. #config(noreplace) %{_sysconfdir}/ld.so.conf.d/llvm-%{_arch}.conf
  419. #dir %{_libdir}/%{name}
  420. %{_libdir}/BugpointPasses.so
  421. %{_libdir}/libLLVM-*.so
  422. %{_libdir}/libLTO.so
  423. %{_libdir}/LLVMgold.so
  424. %exclude %{_libdir}/LLVMHello.so
  425. %files -n clang
  426. %defattr(-,root,root,-)
  427. #doc %{llvmdocdir clang}/
  428. %{_bindir}/clang*
  429. %{_bindir}/c-index-test
  430. %{_libdir}/clang
  431. %files -n clang-libs
  432. %defattr(-,root,root,-)
  433. %{_libdir}/libclang.so
  434. %{_libdir}/libclang.so.*
  435. %files -n clang-devel
  436. %defattr(-,root,root,-)
  437. #doc %{llvmdocdir clang-devel}/
  438. %{_includedir}/clang
  439. %{_includedir}/clang-c
  440. %dir %{_datadir}/clang/
  441. %{_datadir}/clang/cmake
  442. %files -n clang-analyzer
  443. %defattr(-,root,root,-)
  444. %{_bindir}/scan-build
  445. %{_bindir}/scan-view
  446. %{_libexecdir}/ccc-analyzer
  447. %{_libexecdir}/c++-analyzer
  448. %{_datadir}/scan-view
  449. %{_datadir}/scan-build
  450. %{_mandir}/man1/scan-build.1.*
  451. %files -n lldb
  452. %defattr(-,root,root,-)
  453. #doc %{llvmdocdir lldb}/
  454. %{_bindir}/lldb
  455. %{_bindir}/lldb-*
  456. %{_libdir}/liblldb.so.*
  457. %files -n lldb-devel
  458. %defattr(-,root,root,-)
  459. %{_includedir}/lldb
  460. %{_libdir}/liblldb.so
  461. #python-lldb
  462. #{python_sitearch}/*
  463. %files doc
  464. %defattr(-,root,root,-)
  465. %doc docs/*
  466. #doc %{llvmdocdir %{name}-doc}/
  467. %if %{with ocaml}
  468. %files ocaml
  469. %defattr(-,root,root,-)
  470. %{_libdir}/ocaml/*.cma
  471. %{_libdir}/ocaml/*.cmi
  472. %{_libdir}/ocaml/*.so
  473. %{_libdir}/ocaml/META.llvm*
  474. %files ocaml-devel
  475. %defattr(-,root,root,-)
  476. %{_libdir}/ocaml/*.a
  477. %{_libdir}/ocaml/*.cmx*
  478. %{_libdir}/ocaml/*.mli
  479. %files ocaml-doc
  480. %defattr(-,root,root,-)
  481. #doc %{llvmdocdir %{name}-ocaml-doc}/
  482. %endif
  483. %if 0%{?_with_doxygen}
  484. %files apidoc
  485. %defattr(-,root,root,-)
  486. %doc %{llvmdocdir %{name}-apidoc}/
  487. %files -n clang-apidoc
  488. %defattr(-,root,root,-)
  489. %doc %{llvmdocdir clang-apidoc}/
  490. %endif
  491. %if %{build_compat32}
  492. %files -n compat32-%{name}-libs
  493. %defattr(-,root,root)
  494. %doc LICENSE.TXT
  495. #config(noreplace) %{_sysconfdir}/ld.so.conf.d/llvm-%{_arch}.conf
  496. %exclude %{_libdir}/libclang.so
  497. %exclude %{_libdir}/liblldb.so
  498. %exclude %{_libdir}/LLVMHello.so
  499. %{_libdir}/*.so
  500. %endif
  501. %changelog
  502. * Fri Aug 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.1-1
  503. - new upstream release.
  504. - switched to cmake.
  505. - disable ocaml binding as default.
  506. - updated Patch1000 and 1002.
  507. - disabled Patch1000 as default.
  508. - cleanup patches.
  509. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-2
  510. - rebuild with gcc-5.4.0
  511. * Sat Sep 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.2-1
  512. - new upstream release
  513. - added BR: ocaml-ctypes
  514. * Thu Jun 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.1-1
  515. - new upstream release
  516. - dropt Patch 1, 201 and 1001
  517. - updated Patch 1000
  518. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.1-1
  519. - updated to 3.5.1
  520. - added Patch1, 2, 100, 101, 200, 201 and 202 from Fedora
  521. - added clang-libs, lldb, lldb-devel and compat32-llvm-libs subpackage
  522. - obsoleted clang-doc
  523. - built with ocaml 4.02.1
  524. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-2
  525. - fix <BTS:2832>
  526. - fix configure option "--with-c-include-dirs"
  527. - update Patch1000: clang-3.5.0-driver-ld.gold.patch
  528. - update Patch1001: clang-3.5.0-driver-lib64.patch
  529. - update Patch1002: clang-3.5.0-driver-vine.patch
  530. * Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-1
  531. - update to 3.5.0
  532. - remove Patch11 (clang-hardfloat-hack.patch)
  533. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3-2
  534. - rebuild with libffi-3.0.13
  535. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3-1
  536. - update to 3.3
  537. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-2
  538. - ld.gold (patch1000,1001)
  539. - add /%{_lib} to ld search path
  540. - add support *-vine-linux gcc (patch1002)
  541. * Fri Nov 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-1
  542. - update to 3.1
  543. * Tue Jan 24 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.0-1
  544. - updated to 3.0 release
  545. * Sun Jan 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 2.9-3
  546. - added patch 2-4 to support -O4 link-time optimization
  547. * Fri Sep 9 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.9-2
  548. - disable -fno-var-tracking-assignments on ppc
  549. (seems like gcc-4.4.5 still doesn't support this)
  550. * Thu Aug 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-1
  551. - new upstream release
  552. - add BR: libffi-devel
  553. - add R: libffi-devel to -devel
  554. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
  555. - initial build for Vine Linux
  556. * Sun May 2 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-1
  557. - Update to final 2.7 release
  558. * Sun Mar 28 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-0.1.pre1
  559. - Update to first 2.7 pre-release
  560. * Fri Sep 18 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.6.pre2
  561. - Update to 2.6 pre-release2
  562. - -devel subpackage now virtually provides -static
  563. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.5.pre1
  564. - Disable var tracking assignments on PPC
  565. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.4.pre1
  566. - Don't adjust clang include dir; files there are noarch (bz#521893)
  567. - Enable clang unit tests
  568. - clang and clang-analyzer renamed; no longer depend on llvm at runtime
  569. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.3.pre1
  570. - Package Clang's static analyzer tools
  571. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.2.pre1
  572. - PIC is now enabled by default; explicitly disable on %%{ix86}
  573. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.1.pre1
  574. - First 2.6 prerelease
  575. - Enable Clang front-end
  576. - Enable debuginfo generation
  577. * Sat Sep 5 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-6
  578. - Disable assertions (needed by OpenGTL, bz#521261)
  579. - Align spec file with upstream build instructions
  580. - Enable unit tests
  581. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-5
  582. - Only disable PIC on %%ix86; ppc actually needs it
  583. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-4
  584. - Disable use of position-independent code on 32-bit platforms
  585. (buggy in LLVM <= 2.5)
  586. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-3
  587. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  588. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-2
  589. - Remove build scripts; they require the build directory to work
  590. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-1
  591. - Update to 2.5
  592. - Package build scripts (bug #457881)
  593. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-2
  594. - Patched build process for the OCaml binding
  595. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-1
  596. - Update to 2.4
  597. - Package Ocaml binding
  598. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-2
  599. - Add dependency on groff
  600. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-1
  601. - LLVM 2.3
  602. * Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2-4
  603. - fix license tags
  604. * Wed Mar 5 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.2-3
  605. - Fix compilation problems with gcc 4.3
  606. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2-2
  607. - Autorebuild for GCC 4.3
  608. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-2
  609. - Fix review comments
  610. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-1
  611. - Initial version