mailutils-vl.spec 5.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218
  1. %ifarch x86_64
  2. %bcond_without doc
  3. %else
  4. %bcond_with doc
  5. %endif
  6. Name: mailutils
  7. Summary: GNU Mailutils: General-Purpose Mail Package
  8. Version: 3.12
  9. Release: 1%{_dist_release}
  10. Group: internet
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. License: GPL3+
  14. URL: https://mailutils.org/
  15. Source0: https://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.xz
  16. BuildRequires: bzip2-devel
  17. BuildRequires: flex
  18. BuildRequires: gdbm-devel
  19. BuildRequires: gnutls-devel
  20. BuildRequires: info
  21. BuildRequires: libgcrypt-devel
  22. BuildRequires: libunistring-devel
  23. BuildRequires: libtool-ltdl-devel
  24. BuildRequires: openldap-devel
  25. BuildRequires: pam-devel
  26. BuildRequires: perl
  27. BuildRequires: readline-devel
  28. BuildRequires: zlib-devel
  29. Requires: mailutils-libs = %{version}-%{release}
  30. %global mailx_version 8.1.2.20180807-2
  31. Conflicts: mailx < %{mailx_version}
  32. Obsoletes: mailx < %{mailx_version}
  33. Provides: mailx = %{mailx_version}
  34. Provides: config(mailx) = %{mailx_version}
  35. Provides: /bin/mail
  36. %description
  37. GNU Mailutils is a rich and powerful protocol-independent mail
  38. framework. It contains a series of useful mail libraries, clients,
  39. and servers. These are the primary mail utilities for the GNU system.
  40. The central library is capable of handling electronic mail in various
  41. mailbox formats and protocols, both local and remote. Specifically,
  42. this project contains a POP3 server, an IMAP4 server, and a Sieve mail
  43. filter. It also provides a POSIX `mailx' client, and a collection of
  44. other handy tools.
  45. %package libs
  46. Summary: GNU Mailutils: mailbox access library.
  47. Group: system
  48. License: LGPL3+
  49. %description libs
  50. The runtime library libmailbox contains various mailbox access
  51. routines and support for a number of mailbox types, such as mbox,
  52. maildir, mh, POP3, and IMAP4. It also supports MIME message
  53. handling, and sending mail via SMTP and /sbin/sendmail.
  54. %package devel
  55. Summary: GNU Mailutils: mailbox access development.
  56. Group: programming
  57. License: LGPL3+
  58. Requires: mailutils-libs = %{version}-%{release}
  59. %description devel
  60. GNU Mailutils: mailbox access development.
  61. %package mh
  62. Summary: GNU Mailutils: The Message Handling System.
  63. Group: internet
  64. License: GPL3+
  65. Requires: mailutils-libs = %{version}-%{release}
  66. %description mh
  67. The GNU MH (Message Handling System).
  68. %if %{with doc}
  69. %package doc
  70. Summary: GNU Mailutils: documentation.
  71. Group: documentation
  72. License: GFDL-1.2
  73. BuildArch: noarch
  74. %description doc
  75. API reference for libmailbox and user documentation for the rest of
  76. the GNU Mailutils.
  77. %endif
  78. %debug_package
  79. %prep
  80. %setup -q
  81. if [ %version = 3.12 ]; then
  82. echo "#endif" >> include/mailutils/sys/streamtrans.h
  83. fi
  84. %build
  85. autoreconf -fiv
  86. %configure \
  87. --disable-static \
  88. --disable-rpath \
  89. --enable-ipv6 \
  90. --with-mail-spool=/var/spool/mail \
  91. --with-mh-bindir=%{_libexecdir}/mu-mh \
  92. --disable-build-pop3d \
  93. --disable-build-imap4d \
  94. --disable-build-comsat \
  95. --disable-build-mda \
  96. --disable-build-lmtpd \
  97. --disable-build-putmail \
  98. --disable-build-sieve \
  99. --without-guile \
  100. --disable-python \
  101. %{nil}
  102. # SMP-incompatible build.
  103. make V=1
  104. %install
  105. %make_install
  106. install -d %{buildroot}/bin
  107. mv -f %{buildroot}%{_bindir}/mail %{buildroot}/bin/
  108. ln -s ./mail %{buildroot}/bin/Mail
  109. ln -s ./mail %{buildroot}/bin/mailx
  110. ln -s ../../bin/mail %{buildroot}%{_bindir}/mail
  111. ln -s ../../bin/mail %{buildroot}%{_bindir}/Mail
  112. ln -s ../../bin/mail %{buildroot}%{_bindir}/mailx
  113. %find_lang %name
  114. # unshipped files
  115. find %{buildroot}%{_libdir} -name "*.la" -delete
  116. rm -f %{buildroot}%{_mandir}/man1/{imap4d,pop3d,popauth}.1*
  117. rm -f %{buildroot}%{_infodir}/dir
  118. # x86_64 only (noarch)
  119. %if !%{with doc}
  120. rm -rf %{buildroot}%{_infodir}
  121. %endif
  122. %check
  123. #make check MH=/dev/null || { cat mh/tests/testsuite.log; exit 1; }
  124. make check
  125. %if %{with doc}
  126. %post doc
  127. /sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir || :
  128. %preun doc
  129. /sbin/install-info --delete %{_infodir}/%{name}.info.gz %{_infodir}/dir || :
  130. %endif
  131. %files -f %name.lang
  132. %license COPYING*
  133. %doc AUTHORS THANKS NEWS README* TODO ChangeLog
  134. /bin/Mail
  135. /bin/mail
  136. /bin/mailx
  137. %{_bindir}/mailutils
  138. %{_bindir}/dotlock
  139. %{_bindir}/frm
  140. %{_bindir}/from
  141. %{_bindir}/Mail
  142. %{_bindir}/mail
  143. %{_bindir}/mailx
  144. %{_bindir}/messages
  145. %{_bindir}/mimeview
  146. %{_bindir}/movemail
  147. %{_bindir}/readmsg
  148. %{_bindir}/decodemail
  149. %{_mandir}/*/mail*
  150. %dir %{_libexecdir}/mailutils
  151. %{_libexecdir}/mailutils/*
  152. %dir %{_datadir}/%{name}
  153. %files libs
  154. %dir %{_libdir}/mailutils
  155. %{_libdir}/mailutils/*.so
  156. %{_libdir}/*.so.*
  157. %files mh
  158. %dir %{_libexecdir}/mu-mh
  159. %{_libexecdir}/mu-mh/*
  160. %dir %{_datadir}/%{name}
  161. %{_datadir}/%{name}/mh
  162. %files devel
  163. %{_bindir}/mailutils-config
  164. %{_includedir}/mailutils
  165. %{_libdir}/*.so
  166. %{_datadir}/aclocal/mailutils.m4
  167. %if %{with doc}
  168. %files doc
  169. %{_infodir}/*
  170. %endif
  171. %changelog
  172. * Thu Mar 18 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.12-1
  173. - initial build for Vine Linux.