nspr-vl.spec 7.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: Netscape Portable Runtime
  3. Summary(ja): Netscape ポータブルランタイム
  4. Name: nspr
  5. Version: 4.8.7
  6. Release: 1%{?_dist_release}
  7. License: MPLv1.1/GPLv2+/LGPLv2+
  8. URL: http://www.mozilla.org/projects/nspr/
  9. Group: System Environment/Libraries
  10. Source0: %{name}-%{version}.tar.bz2
  11. Source1: nspr.pc.in
  12. Source2: nspr-config-vars.in
  13. Patch1: nspr-config-pc.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. Provides: mozilla-nspr
  16. Obsoletes: mozilla-nspr
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. Packager: daisuke
  20. %description
  21. NSPR provides platform independence for non-GUI operating system
  22. facilities. These facilities include threads, thread synchronization,
  23. normal file and network I/O, interval timing and calendar time, basic
  24. memory management (malloc and free) and shared library linking.
  25. %package devel
  26. Summary: Development libraries for the Netscape Portable Runtime
  27. Group: Development/Libraries
  28. Requires: nspr = %{version}-%{release}
  29. Requires: pkgconfig
  30. Provides: mozilla-nspr-devel
  31. Obsoletes: mozilla-nspr-devel
  32. %description devel
  33. Header files for doing development with the Netscape Portable Runtime.
  34. ## to build compat32 for x86_64 architecture support
  35. %package -n compat32-%{name}
  36. Summary: Netscape Portable Runtime
  37. Group: System Environment/Libraries
  38. %description -n compat32-%{name}
  39. NSPR provides platform independence for non-GUI operating system
  40. facilities. These facilities include threads, thread synchronization,
  41. normal file and network I/O, interval timing and calendar time, basic
  42. memory management (malloc and free) and shared library linking.
  43. %prep
  44. %setup -q
  45. # Original nspr-config is not suitable for our distribution,
  46. # because on different platforms it contains different dynamic content.
  47. # Therefore we produce an adjusted copy of nspr-config that will be
  48. # identical on all platforms.
  49. # However, we need to use original nspr-config to produce some variables
  50. # that go into nspr.pc for pkg-config.
  51. cp ./mozilla/nsprpub/config/nspr-config.in ./mozilla/nsprpub/config/nspr-config-pc.in
  52. %patch1 -p0
  53. cp %{SOURCE2} ./mozilla/nsprpub/config/
  54. %build
  55. ./mozilla/nsprpub/configure \
  56. --prefix=%{_prefix} \
  57. --libdir=%{_libdir} \
  58. --includedir=%{_includedir}/nspr4 \
  59. %ifarch x86_64 ppc64 ia64 s390x
  60. --enable-64bit \
  61. %endif
  62. --enable-optimize="$RPM_OPT_FLAGS" \
  63. --disable-debug
  64. make
  65. %install
  66. %{__rm} -Rf $RPM_BUILD_ROOT
  67. DESTDIR=$RPM_BUILD_ROOT \
  68. make install
  69. NSPR_LIBS=`./config/nspr-config --libs`
  70. NSPR_CFLAGS=`./config/nspr-config --cflags`
  71. NSPR_VERSION=`./config/nspr-config --version`
  72. %{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
  73. cat ./config/nspr-config-vars > \
  74. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/nspr.pc
  75. cat %{SOURCE1} | sed -e "s,%%libdir%%,%{_libdir},g" \
  76. -e "s,%%prefix%%,%{_prefix},g" \
  77. -e "s,%%exec_prefix%%,%{_prefix},g" \
  78. -e "s,%%includedir%%,%{_includedir}/nspr4,g" \
  79. -e "s,%%NSPR_VERSION%%,$NSPR_VERSION,g" \
  80. -e "s,%%FULL_NSPR_LIBS%%,$NSPR_LIBS,g" \
  81. -e "s,%%FULL_NSPR_CFLAGS%%,$NSPR_CFLAGS,g" >> \
  82. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/nspr.pc
  83. %{__mkdir_p} $RPM_BUILD_ROOT/%{_bindir}
  84. %{__cp} ./config/nspr-config-pc $RPM_BUILD_ROOT/%{_bindir}/nspr-config
  85. # Get rid of the things we don't want installed (per upstream)
  86. %{__rm} -rf \
  87. $RPM_BUILD_ROOT/%{_bindir}/compile-et.pl \
  88. $RPM_BUILD_ROOT/%{_bindir}/prerr.properties \
  89. $RPM_BUILD_ROOT/%{_libdir}/libnspr4.a \
  90. $RPM_BUILD_ROOT/%{_libdir}/libplc4.a \
  91. $RPM_BUILD_ROOT/%{_libdir}/libplds4.a \
  92. $RPM_BUILD_ROOT/%{_datadir}/aclocal/nspr.m4 \
  93. $RPM_BUILD_ROOT/%{_includedir}/nspr4/md
  94. %clean
  95. %{__rm} -rf $RPM_BUILD_ROOT
  96. %post
  97. /sbin/ldconfig >/dev/null 2>/dev/null
  98. %postun
  99. /sbin/ldconfig >/dev/null 2>/dev/null
  100. %files
  101. %defattr(-,root,root)
  102. %{_libdir}/libnspr4.so
  103. %{_libdir}/libplc4.so
  104. %{_libdir}/libplds4.so
  105. %files devel
  106. %defattr(-, root, root)
  107. %{_includedir}/nspr4
  108. %{_libdir}/pkgconfig/nspr.pc
  109. %{_bindir}/nspr-config
  110. %if %{build_compat32}
  111. %files -n compat32-%{name}
  112. %defattr(-,root,root)
  113. %{_libdir}/*.so
  114. %endif
  115. %changelog
  116. * Mon Mar 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.7-1
  117. - new upstream release
  118. * Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.6-2
  119. - rebuild with rpm-4.8.1 for pkg-config file
  120. * Tue Sep 14 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.6-1
  121. - new upstream release
  122. * Wed Apr 7 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.8.4-1
  123. - new upstream release
  124. * Sat Jan 09 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.2-1
  125. - new upstream release
  126. * Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.8-2
  127. - added compat32 subpackages
  128. * Sun Jun 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8-1
  129. - new upstream release
  130. * Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7.4-1
  131. - new upstream release
  132. * Wed Jul 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7.1-1
  133. - new upstream release
  134. * Fri Oct 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6.7-0vl1
  135. - new upstream release
  136. * Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6.6-0vl1
  137. - initial build for Vine Linux
  138. * Wed Mar 07 2007 Kai Engert <kengert@redhat.com> - 4.6.6-1
  139. - Update to 4.6.6
  140. - Adjust IPv6 patch to latest upstream version
  141. * Sat Feb 24 2007 Kai Engert <kengert@redhat.com> - 4.6.5-2
  142. - Update to latest ipv6 upstream patch
  143. - Add upstream patch to fix a thread cleanup issue
  144. - Now requires pkgconfig
  145. * Mon Jan 22 2007 Wan-Teh Chang <wtchang@redhat.com> - 4.6.5-1
  146. - Update to 4.6.5
  147. * Tue Jan 16 2007 Kai Engert <kengert@redhat.com> - 4.6.4-2
  148. - Include upstream patch to fix ipv6 support (rhbz 222554)
  149. * Tue Nov 21 2006 Kai Engert <kengert@redhat.com> - 4.6.4-1
  150. - Update to 4.6.4
  151. * Thu Sep 14 2006 Kai Engert <kengert@redhat.com> - 4.6.3-1
  152. - Update to 4.6.3
  153. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.6.2-1.1
  154. - rebuild
  155. * Fri May 26 2006 Kai Engert <kengert@redhat.com> - 4.6.2-1
  156. - Update to 4.6.2
  157. - Tweak nspr-config to be identical on all platforms.
  158. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.6.1-2.2
  159. - bump again for double-long bug on ppc(64)
  160. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.6.1-2.1
  161. - rebuilt for new gcc4.1 snapshot and glibc changes
  162. * Thu Jan 5 2006 Kai Engert <kengert@redhat.com> 4.6.1-2
  163. - Do not use -ansi when compiling, because of a compilation
  164. problem with latest glibc and anonymous unions.
  165. See also bugzilla.mozilla.org # 322427.
  166. * Wed Jan 4 2006 Kai Engert <kengert@redhat.com>
  167. - Add an upstream patch to fix gcc visibility issues.
  168. * Tue Jan 3 2006 Christopher Aillon <caillon@redhat.com>
  169. - Stop shipping static libraries; NSS and dependencies no longer
  170. require static libraries to build.
  171. * Thu Dec 15 2005 Christopher Aillon <caillon@redhat.com> 4.6.1-1
  172. - Update to 4.6.1
  173. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  174. - rebuilt
  175. * Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 4.6-4
  176. - Use the NSPR version numbering scheme reported by NSPR,
  177. which unfortunately is not exactly the same as the real
  178. version (4.6 != 4.6.0 according to RPM and pkgconfig).
  179. * Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 4.6-3
  180. - Correct the CFLAGS reported by pkgconfig
  181. * Tue Jul 12 2005 Christopher Aillon <caillon@redhat.com> 4.6-2
  182. - Temporarily include the static libraries allowing nss and
  183. its dependencies to build.
  184. * Tue Jul 12 2005 Christopher Aillon <caillon@redhat.com> 4.6-1
  185. - Update to NSPR 4.6
  186. * Wed Apr 20 2005 Christopher Aillon <caillon@redhat.com> 4.4.1-2
  187. - NSPR doesn't have make install, but it has make real_install. Use it.
  188. * Thu Apr 14 2005 Christopher Aillon <caillon@redhat.com> 4.4.1-1
  189. - Let's make an RPM.