Django-vl.spec 7.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222
  1. %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. %{!?pyver: %define pyver %(%{__python} -c "import sys ; print sys.version[:3]")}
  3. Name: Django
  4. Version: 1.2.1
  5. Release: 1%{?_dist_release}
  6. Summary: A high-level Python Web framework
  7. Group: Development/Languages
  8. License: BSD
  9. URL: http://www.djangoproject.com/
  10. Source0: http://media.djangoproject.com/releases/%{version}/Django-%{version}.tar.gz
  11. # stub simplejson module that imports the system version
  12. Source1: simplejson-init.py
  13. Patch0: Django-hash-compat-13310.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildArch: noarch
  16. # Note: No longer required in development version > 0.95
  17. # BuildRequires: python-setuptools
  18. BuildRequires: python-devel
  19. BuildRequires: python-sphinx
  20. Requires: python-simplejson
  21. Provides: python-Django
  22. %description
  23. Django is a high-level Python Web framework that encourages rapid
  24. development and a clean, pragmatic design. It focuses on automating as
  25. much as possible and adhering to the DRY (Don't Repeat Yourself)
  26. principle.
  27. #'
  28. %prep
  29. %setup -q -n %{name}-%{version}
  30. %patch0 -p3
  31. # remove bundled simplejson
  32. cd django/utils/simplejson/
  33. %__rm -rf *
  34. # and put the replacement stub in place
  35. cp -p %{SOURCE1} __init__.py
  36. %build
  37. %{__python} setup.py build
  38. %install
  39. %__rm -rf $RPM_BUILD_ROOT
  40. %{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
  41. # Handling locale files
  42. # This is adapted from the %%find_lang macro, which cannot be directly
  43. # used since Django locale files are not located in %%{_datadir}
  44. #
  45. # The rest of the packaging guideline still apply -- do not list
  46. # locale files by hand!
  47. (cd $RPM_BUILD_ROOT && find . -name 'django*.mo') | %{__sed} -e 's|^.||' | %{__sed} -e \
  48. 's:\(.*/locale/\)\([^/_]\+\)\(.*\.mo$\):%lang(\2) \1\2\3:' \
  49. >> %{name}.lang
  50. # install man pages
  51. %__mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1/
  52. %__cp -p docs/man/* $RPM_BUILD_ROOT%{_mandir}/man1/
  53. # Fix items in %{_bindir}
  54. %__mv $RPM_BUILD_ROOT%{_bindir}/django-admin.py $RPM_BUILD_ROOT%{_bindir}/django-admin
  55. # remove .po files
  56. find $RPM_BUILD_ROOT -name "*.po" | xargs %__rm -f
  57. %clean
  58. %__rm -rf $RPM_BUILD_ROOT
  59. %files -f %{name}.lang
  60. %defattr(-,root,root,-)
  61. %doc AUTHORS LICENSE README
  62. %{_bindir}/django-admin
  63. %{_mandir}/man1/*
  64. %attr(0755,root,root) %{python_sitelib}/django/conf/project_template/manage.py
  65. %attr(0755,root,root) %{python_sitelib}/django/contrib/admin/media/js/compress.py
  66. %attr(0755,root,root) %{python_sitelib}/django/bin/profiling/gather_profile_stats.py*
  67. %attr(0755,root,root) %{python_sitelib}/django/bin/*-messages.py*
  68. %attr(0755,root,root) %{python_sitelib}/django/bin/daily_cleanup.py*
  69. %attr(0755,root,root) %{python_sitelib}/django/bin/django-admin.py*
  70. %{python_sitelib}/django/bin/profiling/*
  71. %{python_sitelib}/django/bin/__init__.py*
  72. # Include everything but the locale data ...
  73. %{python_sitelib}/django/db/
  74. %{python_sitelib}/django/*.py*
  75. %{python_sitelib}/django/shortcuts/
  76. %{python_sitelib}/django/utils/
  77. %{python_sitelib}/django/dispatch/
  78. %{python_sitelib}/django/template/
  79. %{python_sitelib}/django/views/
  80. %{python_sitelib}/django/contrib/
  81. %{python_sitelib}/django/forms/
  82. %{python_sitelib}/django/templatetags/
  83. %{python_sitelib}/django/core/
  84. %{python_sitelib}/django/http/
  85. %{python_sitelib}/django/middleware/
  86. %{python_sitelib}/django/test/
  87. %{python_sitelib}/django/conf/*.py*
  88. %{python_sitelib}/django/conf/project_template/
  89. %{python_sitelib}/django/conf/app_template/
  90. %{python_sitelib}/django/conf/urls/
  91. %{python_sitelib}/django/conf/locale/*/*.py*
  92. %{python_sitelib}/django/conf/locale/*.py*
  93. %{python_sitelib}/*.egg-info
  94. %changelog
  95. * Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 1.2.1-1
  96. - initial build based on Fedora development
  97. * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1.2.1-6
  98. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  99. * Tue Jun 8 2010 Steve 'Ashcrow' Milner <stevem@gnulinux.net> - 1.2.1-5
  100. - Added http://code.djangoproject.com/changeset/13310?format=diff&new=13310 per BZ#601212
  101. * Thu Jun 3 2010 Steve 'Ashcrow' Milner <stevem@gnulinux.net> - 1.2.1-4
  102. - Include egg in >= rhel6
  103. * Thu Jun 3 2010 Michel Salim <salimma@fedoraproject.org> - 1.2.1-3
  104. - Use generated %%{name}.lang instead of including each locale file by hand
  105. - Temporarily make main package provide -doc on Rawhide, to fix upgrade path
  106. until upstream documentation builds with Sphinx 1.0
  107. * Thu May 27 2010 Steve 'Ashcrow' Milner <stevem@gnulinux.net> - 1.2.1-2
  108. - Allow for building docs in F13 as it's only F14 freaking out
  109. * Tue May 25 2010 Steve 'Ashcrow' Milner <stevem@gnulinux.net> - 1.2.1-1
  110. - Update for new release.
  111. - Added lang files per BZ#584866.
  112. - Changed perms on %%{python_sitelib}/django/contrib/admin/media/js/compress.py
  113. - Lots of explicit files listed in %%files in order to reduce duplicate file listings
  114. - Docs are not built on F-13 for now
  115. * Wed Oct 21 2009 Steve 'Ashcrow' Milner <stevem@gnulinux.net> - 1.1.1-2
  116. - Removed po files per BZ#529188.
  117. * Fri Oct 9 2009 Steve 'Ashcrow' Milner <stevem@gnulinux.net> - 1.1.1-1
  118. - Update to fix http://www.djangoproject.com/weblog/2009/oct/09/security/
  119. - Django-ignore-pyo-bz-495046.patch no longer needed.
  120. * Wed Aug 26 2009 Steve 'Ashcrow' Milner <stevem@gnulinux.net> - 1.1-4
  121. - EL-4 shouldn't get the sphinx docs.
  122. * Wed Aug 26 2009 Steve 'Ashcrow' Milner <stevem@gnulinux.net> - 1.1-3
  123. - ghosting admin py* is now FC9 and under.
  124. * Thu Aug 6 2009 Steve 'Ashcrow' Milner <stevem@gnulinux.net> - 1.1-2
  125. - Applied Daniel Mach's patch from bz#516016.
  126. * Sat Aug 1 2009 Steve 'Ashcrow' Milner <stevem@gnulinux.net> - 1.1-1
  127. - Update for Django 1.1 release.
  128. - Moved /usr/bin/django-admin.py to /usr/bin/django-admin
  129. - sed macro is now being used
  130. - Patch for bz#495046 applied.
  131. * Wed Jul 29 2009 Steve 'Ashcrow' Milner <stevem@gnulinux.net> - 1.0.3-6
  132. - Attempted combined spec for F12/11/10 and EL5
  133. * Wed Jul 29 2009 Steve 'Ashcrow' Milner <stevem@gnulinux.net> - 1.0.3-4
  134. - Older builds must ghost django-admin.py[c,o]
  135. * Wed Jul 29 2009 Steve 'Ashcrow' Milner <stevem@gnulinux.net> - 1.0.3-3
  136. - Bump for tag issue.
  137. * Wed Jul 29 2009 Steve 'Ashcrow' Milner <stevem@gnulinux.net> - 1.0.3-2
  138. - Fix changelog.
  139. * Wed Jul 29 2009 Steve 'Ashcrow' Milner <stevem@gnulinux.net> - 1.0.3-1
  140. - Upgrade for http://www.djangoproject.com/weblog/2009/jul/28/security/
  141. * Thu Mar 12 2009 Michel Salim <salimma@fedoraproject.org> - 1.0.2-3
  142. - Build HTML documentation (bug #484070)
  143. - No longer excluding *.py? in bindir, F11's Python does not optimizes these
  144. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-2
  145. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  146. * Sun Dec 14 2008 Michel Salim <salimma@fedoraproject.org> - 1.0.2-1
  147. - Update to 1.0.2
  148. * Sat Nov 1 2008 Steve 'Ashcrow' Milner <stevem@gnulinux.net> - 1.0.1-0.1.beta1
  149. - Update to 1.0.1_beta_1
  150. * Sat Sep 6 2008 Michel Salim <salimma@fedoraproject.org> - 1.0-1
  151. - Update to final 1.0 release
  152. * Tue Sep 2 2008 Michel Salim <salimma@fedoraproject.org> - 1.0-0.1.rc1%{?dist}
  153. - CSRF security update: bz#460966
  154. * Wed Aug 27 2008 Michel Salim <salimma@fedoraproject.org> - 1.0-0.1.beta2
  155. - Update to 1.0 beta2
  156. * Sat Aug 23 2008 Michel Salim <salimma@fedoraproject.org> - 1.0-0.1.beta1
  157. - Update to 1.0 beta1
  158. * Mon May 19 2008 Michel Salim <salimma@fedoraproject.org> - 0.96.2-1
  159. - XSS security update: CVE-2008-2302 (bz# 442757-60)
  160. * Sat Apr 5 2008 Michel Salim <salimma@fedoraproject.org> - 0.96.1-2
  161. - Package .egg-info file on Fedora >= 9
  162. * Thu Nov 1 2007 Michel Salim <michel.sylvan@gmail.com> 0.96.1-1
  163. - i18n security update: CVE-2007-5712, bz#357051
  164. * Sat Mar 24 2007 Michel Salim <michel.salim@gmail.com> - 0.96-1
  165. - New upstream version
  166. * Sun Jan 21 2007 Michel Salim <michel.salim@gmail.com> - 0.95.1-1
  167. - Upstream security updates:
  168. http://www.djangoproject.com/weblog/2007/jan/21/0951/
  169. * Sun Nov 12 2006 Michel Salim <michel.salim@gmail.com> - 0.95-1
  170. - Initial package