mew-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375
  1. %define _docdir %{_defaultdocdir}
  2. %define _noVersionedDependencies 1
  3. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  4. %define origver 6.3
  5. %define pkgver %{origver}
  6. %define origname mew
  7. %ifarch x86_64
  8. %define _lib lib
  9. %endif
  10. Summary: Mew - Messaging in the Emacs World
  11. Summary(ja): Emacs でメールを読むためのインターフェース
  12. Name: %{origname}
  13. Version: %{origver}
  14. Release: 1%{?_dist_release}
  15. License: distributable
  16. Group: Applications/Editors/Emacs
  17. URL: http://www.mew.org/
  18. Source0: http://www.mew.org/Release/mew-%{pkgver}.tar.gz
  19. Source1: %{origname}-install.sh
  20. Source2: %{origname}-remove.sh
  21. Source3: vine.dot.mew
  22. Source4: %{name}-init.el
  23. Source5: vine-default-%{name}.el
  24. Patch11: mew-2.1-icondir.diff
  25. PreReq: emacsen
  26. Requires: perl >= 5.004_jp-4
  27. Provides: %{origname} = %{origver}
  28. #Conflicts: %{origname}-el
  29. Obsoletes: mew-mule, mew-el
  30. Obsoletes: mew-xemacs, mew-xemacs-extra
  31. Requires: mew-common = %{version}
  32. PreReq: /sbin/install-info
  33. BuildRequires: emacsen
  34. BuildRoot: %{_tmppath}/%{name}-%{origver}-root
  35. Vendor: Project Vine
  36. Distribution: Vine Linux
  37. %description
  38. Messaging in the Emacs World. It provides a very easy user interface
  39. to e-mail, MIME and PGP (Pretty Good Privacy) on Emacsen.
  40. Please install Perl5 to use mew.
  41. Don't forget to copy %{_docdir}/mew-%{version}/vine.dot.mew
  42. to your ~/.mew.el file, and modify the site configurations, e.g.
  43. (setq mew-mail-domain-list '("your mail domain"))
  44. %description -l ja
  45. 電子メールを Emacs / XEmacs 上で簡単に読み書きすることができるインター
  46. フェース mew です。MIME や PGP にも対応しています。mewを使うためには、
  47. perlが必要です。
  48. %{_docdir}/mew-common-%{version}/vine.dot.mew を ~/.mew.el としてコピー
  49. し、適切に設定してください。
  50. (setq mew-mail-domain-list '("your mail domain"))
  51. また、%{_docdir}/mew-common-%{version}/contrib/以下にもいくつかのMewを便利に使う
  52. 為のelispを収録しています。
  53. %package -n mew-common
  54. Summary: Common files/programs for Mew Emacs/XEmacs
  55. Summary(ja): Emacs/XEmacs 用 Mew 両方で利用するファイル/プログラム
  56. Group: Applications/Internet
  57. Obsoletes: mew-xemacs-extra
  58. %description -n mew-common
  59. This package contains common files/programs for Mew Emacs/XEmacs.
  60. %description -n mew-common -l ja
  61. Emacs/XEmacs 用 Mew に共通するファイル/プログラムです.
  62. %prep
  63. %setup -q -n mew-%{pkgver}
  64. %patch11 -p1
  65. cp %{SOURCE3} .
  66. %build
  67. %configure
  68. make PREFIX="/usr" CFLAGS="$RPM_OPT_FLAGS" bin
  69. %install
  70. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  71. mkdir -p %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
  72. mkdir -p %{buildroot}%{_libdir}/emacsen-common/packages/install
  73. mkdir -p %{buildroot}%{_libdir}/emacsen-common/packages/remove
  74. mkdir -p %{buildroot}/usr/info
  75. mkdir -p %{buildroot}/usr/X11R6/include/X11/pixmaps
  76. # install el files
  77. # Add here commands to install the package into debian/mew.
  78. cp *.el %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
  79. cp %{SOURCE4} %{SOURCE5} \
  80. %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
  81. make install-bin prefix=%{buildroot}%{_prefix} \
  82. mandir=%{buildroot}%{_mandir}/man1 \
  83. bindir=%{buildroot}%{_bindir}
  84. # contrib
  85. #install -m 755 contrib/mewinc contrib/incdir contrib/incmbox \
  86. # $RPM_BUILD_ROOT/%{_docdir}/%{origname}/contrib/
  87. ## install icons
  88. cp etc/*.xpm %{buildroot}/usr/X11R6/include/X11/pixmaps
  89. cp etc/*.png %{buildroot}/usr/X11R6/include/X11/pixmaps
  90. cp etc/*.img %{buildroot}/usr/X11R6/include/X11/pixmaps
  91. ## install contrib
  92. #cp -a contrib $(CURDIR)/debian/mew/usr/share/doc/mew
  93. # install {info,jinfo} for mew-emacs
  94. make infodir="%{buildroot}%{_infodir}" \
  95. INSTALLINFO="/sbin/install-info" install-info install-jinfo
  96. rm -f %{buildroot}%{_infodir}/dir
  97. gzip -9nf %{buildroot}%{_infodir}/*
  98. %_installemacsenscript %{origname} %{SOURCE1}
  99. %_removeemacsenscript %{origname} %{SOURCE2}
  100. %post
  101. if [ "$1" = 2 ]; then
  102. %_emacsenPackageRemove %{origname}
  103. fi
  104. %_addemacsenlist %{origname}
  105. %_emacsenPackageInstall %{origname}
  106. /sbin/install-info %{_infodir}/mew.info.gz %{_infodir}/dir \
  107. --section="Message User Agent"
  108. /sbin/install-info %{_infodir}/mew.jis.info.gz %{_infodir}/dir \
  109. --section="Message User Agent"
  110. %preun
  111. if [ "$1" = 0 ]; then
  112. %_emacsenPackageRemove %{origname}
  113. %_removeemacsenlist %{origname}
  114. /sbin/install-info --delete %{_infodir}/mew.info.gz %{_infodir}/dir \
  115. --section="Message User Agent"
  116. /sbin/install-info --delete %{_infodir}/mew.jis.info.gz %{_infodir}/dir \
  117. --section="Message User Agent"
  118. fi
  119. %clean
  120. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  121. %files
  122. %defattr(-,root,root)
  123. %{_infodir}/mew.info*
  124. %{_infodir}/mew.jis.info*
  125. /usr/share/emacs/site-lisp/%{origname}/
  126. /usr/lib/emacsen-common/packages/install/%{origname}
  127. /usr/lib/emacsen-common/packages/remove/%{origname}
  128. /usr/X11R6/include/X11/pixmaps
  129. %files -n mew-common
  130. %defattr(-,root,root)
  131. %doc 00changes 00copyright 00copyright.jis 00diff 00readme
  132. %doc mew.dot.emacs vine.dot.mew
  133. %doc contrib/
  134. %{_bindir}/*
  135. %{_mandir}/man1/*
  136. %changelog
  137. * Mon Dec 21 2009 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.3-1
  138. - new upstream release
  139. * Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 6.2-3
  140. - fixed mew-init.el
  141. * Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 6.2-2
  142. - added mew-init.el, vine-default-mew.el
  143. - updated mew-install.sh, mew-remove.sh for vine-default-mew.el
  144. * Fri Jan 16 2009 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.2-1
  145. - new upstream release
  146. * Sun Jun 15 2008 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.1-1
  147. - applied new versioning policy
  148. * Tue Jun 10 2008 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.1-0vl1
  149. - new upstream release
  150. * Thu Aug 30 2007 Shu KONNO <owa@bg.wakwak.com> 5.2-0vl3
  151. - added %%define _lib lib (for x86_64 support)
  152. * Mon Mar 05 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 5.2-0vl2
  153. - added support X-Spam-Flag header in vine.dot.mew
  154. * Tue Jan 23 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 5.2-0vl1
  155. - new upstream release
  156. * Mon Nov 26 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 5.1-0vl1
  157. - new upstream release
  158. - modified vine.dot.mew for Mew-5.1 feature support
  159. * Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2-0vl3
  160. - changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  161. * Tue Jul 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2-0vl2
  162. - changed Group to Applications/Editors/EmacsLisp
  163. - changed common package's Group to Applications/Internet
  164. * Mon Feb 14 2005 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.2-0vl1
  165. - source update
  166. * Mon Oct 18 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.1-0vl1
  167. - source update
  168. * Mon Jul 28 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.3-0vl1
  169. - source update
  170. * Thu Mar 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.2-0vl1
  171. - source update
  172. - update vine.dot.mew
  173. Obsoleting the following variables:
  174. mew-noreplyto-to-list
  175. mew-noreplyto-cc-list
  176. mew-replyto-to-list
  177. mew-replyto-cc-list
  178. mew-fromme-to-list
  179. mew-fromme-cc-list
  180. And defining the following variables:
  181. mew-reply-all-alist
  182. mew-reply-sender-alist
  183. mew-reply-fromme-alist
  184. * Sat Jan 11 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl3
  185. - added vine.dot.mew(Source3)
  186. * Wed Dec 11 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl2
  187. - source update
  188. * Tue Dec 03 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl1
  189. - update to mew-3.1
  190. * Thu Nov 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl0.2
  191. - test package: update to mew-3.1rc2
  192. * Fri Nov 01 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl0.1
  193. - test package: update to mew-3.1rc1
  194. * Mon Mar 18 2002 Satoshi MACHINO <machino@vinelinux.org> 2.2-0vl4
  195. - changed License to distributable (not GPL2)
  196. * Mon Mar 18 2002 Hironobu MORIGUCHI <moriguti@luna.email.ne.jp> 2.2-0vl3
  197. - incm and man pages are included in common subpackage
  198. * Fri Mar 01 2002 Toru Sagami <sagami@vinelinux.org> 2.2-0vl2
  199. - corrected Group for common subpackage
  200. * Mon Feb 25 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2-0vl1
  201. - update to mew-2.2
  202. * Thu Feb 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.1.99.4-0vl1
  203. - update to mew-2.2rc4
  204. * Sun Jan 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2..99.2-0vl1
  205. - update to mew-2.2rc2
  206. * Sun Dec 30 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1-0vl3
  207. - mew-el -> mew
  208. - added Patch11 to set default icon directory for Vine
  209. * Wed Dec 12 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1-0vl2
  210. - added Obsoletes: mew-xemacs, mew-xemacs-extra
  211. - install-info gzipped info files :)
  212. * Thu Nov 01 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.1-0vl1
  213. - update 2.1
  214. * Sat Oct 6 2001 Kazuhisa TAKEI <takei@vinelinux.org> 2.0-0vl5
  215. - change package name ( mew -> mew-el)
  216. - apply emacsenc-oomon
  217. * Thu Sep 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl4
  218. - Oops, forgot to add %%defattr for mew-common. Fixed.
  219. * Tue Sep 04 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl3
  220. - split mew-common, obsoletes mew-xemacs-extra
  221. * Mon Sep 03 2001 Toru Sagami <sagami@vinelinux.org>
  222. - 2.0-0vl2: eliminate executable bit in %%doc and bin files install 755
  223. - install info files into %%{_infodir}
  224. * Sun Aug 20 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
  225. - 2.0-0vl1
  226. - update
  227. * Tue Oct 24 2000 Tomoya TAKA <tomoya@olive.plala.or.jp>
  228. - 1.94.2-3
  229. - fixed %files section to handle compressed info pages
  230. * Wed Jun 7 2000 Toru Sagami <czs14350@nifty.ne.jp>
  231. - fix description: mess up with mule/emacs/xemacs...
  232. - added BuildRequires and Conflicts
  233. * Wed Apr 26 2000 Toru Sagami <czs14350@nifty.ne.jp>
  234. - updated 1.94.2
  235. * Wed Apr 26 2000 Toru Sagami <czs14350@nifty.ne.jp>
  236. - added PreReq: /sbin/install-info
  237. - attrib +x for /usr/bin/uumerge
  238. - CFLAGS="$RPM_OPT_FLAGS"
  239. * Fri Jan 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  240. - 1.94.1-2
  241. - changed destination to /usr/share/emacs/site-lisp/mew
  242. * Sat Nov 27 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  243. - 1.94.1-1
  244. - updated in sync with 1.94.1 release
  245. - fixed %post and %preun section
  246. - Obsoletes: mew now changed to Obsoletes: mew-mule
  247. * Fri Oct 8 1999 Yasushi Karino <kari-p@mc.kcom.ne.jp>
  248. - fixed info path & install info
  249. - fixed '%description'
  250. * Sat Oct 2 1999 Yasushi Karino <kari-p@mc.kcom.ne.jp>
  251. - removed extra packages
  252. - fixed char-set "euc" of the spec file.
  253. - slight modifications for Vine-1.9
  254. * Wed Sep 29 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  255. - 1.94-3
  256. - package name changed from mew-emacs to mew
  257. - make info, make jinfo now processed even under emacs
  258. * Thu Sep 16 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
  259. - Released as version "1.94-2".
  260. Changed from "mew-emacs 1.94-1".
  261. - Deleted "NoSource: 0", the definition part of data.
  262. - Revised some, the definition part of data.
  263. - Revised some, part of "%post, %postun".
  264. - Changerd "%postun" => "%preun".
  265. * Mon Sep 6 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
  266. - First release.