MAKEDEV-vl.spec 6.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215
  1. Summary: A script for creating the device files in /dev.
  2. Summary(ja): /dev 以下のデバイスファイルを作成するスクリプト
  3. Name: MAKEDEV
  4. Version: 3.24
  5. Release: 3%{?_dist_release}
  6. License: GPLv2
  7. Group: System Environment/Base
  8. URL: http://www.lanana.org/docs/device-list/
  9. Source: MAKEDEV-%{version}-1.tar.gz
  10. Source10: fedora-changelog
  11. Patch10: MAKEDEV-3.24-vine.patch
  12. BuildRoot: %{_tmppath}/%{name}-root
  13. Requires(pre): shadow-utils
  14. Requires(pre): sed, coreutils, mktemp
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. Packager: daisuke
  18. %description
  19. This package contains the MAKEDEV program, which makes it easier to create
  20. and maintain the files in the /dev directory. /dev directory files
  21. correspond to a particular device supported by Linux (serial or printer
  22. ports, scanners, sound cards, tape drives, CD-ROM drives, hard drives,
  23. etc.) and interface with the drivers in the kernel.
  24. You should install the MAKEDEV package because the MAKEDEV utility makes
  25. it easy to manage the /dev directory device files.
  26. %description -l ja
  27. このパッケージには MAKEDEV スクリプトが含まれています。これは /dev ディレ
  28. クトリ以下のファイルを簡単に作成するものです。/dev ディレクトリのファイル
  29. は、それぞれ Linux がサポートしているデバイス (シリアル/プリンタポート、
  30. スキャナ、サウンドカード、テープデバイス、CD-ROM ドライブ、ハードディスク
  31. 等) に対応しており、カーネルのドライバがこれらのファイルを介してデバイス
  32. にアクセスします。
  33. MAKEDEV ユーティリティは /dev ディレクトリ以下のデバイスファイルを簡単に
  34. 作成すことができますので MAKEDEV パッケージをインストールしてください。
  35. %prep
  36. %setup -q
  37. %patch10 -p1 -b .vine
  38. cp %{SOURCE10} .
  39. %build
  40. %__make OPTFLAGS="$RPM_OPT_FLAGS"
  41. %install
  42. %__make install DESTDIR=$RPM_BUILD_ROOT devdir=/dev makedevdir=/sbin
  43. rm -f $RPM_BUILD_ROOT/dev/MAKEDEV
  44. %clean
  45. rm -fr $RPM_BUILD_ROOT
  46. %pre
  47. # Add the floppy group and the vcsa user.
  48. getent group floppy >/dev/null || groupadd -g 19 -r floppy
  49. getent passwd vcsa >/dev/null || \
  50. useradd -r -d /dev -s /sbin/nologin -u 69 \
  51. -c "virtual console memory owner" vcsa
  52. exit 0
  53. %triggerpostun -- dev < 3.22
  54. if [ -x /sbin/MAKEDEV ]; then
  55. /sbin/MAKEDEV null
  56. /sbin/MAKEDEV console
  57. else
  58. /bin/mknod /dev/null c 1 3
  59. /bin/mknod /dev/console c 5 1
  60. fi
  61. if [ "$(/sbin/kernelversion)" == "2.4" ] ||
  62. ( [ "$(/sbin/kernelversion)" == "2.6" ] &&
  63. [ $(($(uname -r |cut -f1 -d-|cut -f3 -d.))) -lt 16 ] )
  64. then
  65. mount --bind /.dev.static /dev ||:
  66. if [ -x /sbin/pam_console_apply ] ; then
  67. /sbin/pam_console_apply
  68. fi
  69. fi
  70. %files
  71. %defattr(-,root,root)
  72. %doc COPYING devices-2.6+.txt fedora-changelog
  73. /sbin/MAKEDEV
  74. %{_mandir}/man8/*
  75. %{_sbindir}/mksock
  76. %config(noreplace) %{_sysconfdir}/makedev.d
  77. %changelog
  78. * Sun Apr 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.24-3
  79. - rebuild for Vine 6
  80. * Tue Mar 02 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.24-2
  81. - rebuilt with new toolchain
  82. * Mon Mar 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.24-1
  83. - new upstream release
  84. - remove dev package.
  85. * Thu Oct 16 2008 Shu KONNO <owa@bg.wakwak.com> 3.22-1vl5
  86. - applied new versioning policy, spec in utf-8
  87. * Thu Apr 05 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.22-0vl5
  88. - explicitly PreReq: coreutils instead of textutils and fileutils
  89. * Sun Aug 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.22-0vl4
  90. - make vcsa/floppy device on MAKEDEV's %%pre script.
  91. * Wed Jul 19 2006 Shu KONNO <owa@bg.wakwak.com> 3.22-0vl3
  92. - rebuild for x86_64
  93. * Sun May 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.22-0vl2
  94. - make null/console device in triggerpostun scripts
  95. * Sat May 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.22-0vl1
  96. - add dev subpackage for static device files.
  97. - initscripts will mount /.dev.static to /dev
  98. if kernel is not support udev.
  99. - import changes from FC
  100. * Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.21-1vl1
  101. - update to 3.21-3 from FC
  102. * Sat May 15 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.3.13-1vl3
  103. - include /dev/mouse (a symlink to /dev/input/mice) in the dev package
  104. please note this change (or revert) only applies to ppc archtecture
  105. * Wed May 12 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3.13-1vl2
  106. - do not make mount a symlink to input/mice on non-ppc architecture.
  107. - add "console" and "ptmx" to "generic" device
  108. - add dv1394 device
  109. - change linux1394 device owner from '$ROOT' to '$CONSOLE'.
  110. * Mon May 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3.13-1vl1
  111. - merged with fedora package
  112. see %{_docdir}/%{name}-%{version}/fedora-changelog for detail.
  113. * Wed Nov 14 2001 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  114. - 2.5.2-1vl4
  115. - fix change log
  116. * Sun Nov 11 2001 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  117. - 2.5.2-1vl3
  118. - support /dev/hdi - hdt
  119. * Tue Jan 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  120. - 2.5.2-1vl2
  121. - rebuild with new %%{_mandir} definition
  122. - added Japanese summary and description
  123. * Sat Nov 18 2000 MACHINO, Satoshi <machino@vinelinux.org> 2.5.2-1vl1
  124. - build with gcc-2.95.3
  125. - partially used rpmmacros
  126. * Wed Mar 01 2000 Nalin Dahyabhai <nalin@redhat.com>
  127. - add audioctl
  128. * Fri Jan 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  129. - make vbi a symlink to vbi0
  130. - make vtx a symlink to vtx0, use vtx from video4linux
  131. * Sat Apr 17 1999 Michael K. Johnson <johnsonm@redhat.com>
  132. - create version 2.5 with a great many devices added from the 2.2 kernel
  133. devices.txt
  134. * Tue Apr 13 1999 Preston Brown <pbrown@redhat.com>
  135. - close bug #2157
  136. * Thu Mar 25 1999 Michael Johnson <johnsonm@redhat.com>
  137. - sg unification
  138. - nb devices
  139. * Thu Mar 25 1999 Jakub Jelinek <jj@ultra.linux.cz>
  140. - create correct /dev/console (c 5 1), support for SCSI
  141. disk devices sdi - sddx
  142. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  143. - auto rebuild in the new build environment (release 9)
  144. * Wed Jan 06 1999 Cristian Gafton <gafton@redhat.com>
  145. - glibc 2.1
  146. * Thu Aug 13 1998 Jeff Johnson <jbj@redhat.com>
  147. - build root
  148. * Fri Apr 24 1998 Prospector System <bugs@redhat.com>
  149. - translations modified for de
  150. * Thu Apr 23 1998 Prospector System <bugs@redhat.com>
  151. - translations modified for fr, tr
  152. * Thu Apr 23 1998 Erik Troan <ewt@redhat.com>
  153. - fixed group add script (had -r instead of -o)
  154. * Fri Apr 17 1998 Erik Troan <ewt@redhat.com>
  155. - put -o option on groupadd after -g -- I hope Christian can tell me why
  156. * Thu Apr 09 1998 Cristian Gafton <gafton@redhat.com>
  157. - redirect groupadd call so that we're more quiet
  158. * Fri Oct 24 1997 Michael K. Johnson <johnsonm@redhat.com>
  159. - 2.3.1: use /usr/sbin/groupadd from new shadow utils
  160. * Mon Sep 29 1997 Michael K. Johnson <johnsonm@redhat.com>
  161. - Updated to 2.3, as Nick agreed to me making an interim release while
  162. he figures out whether he wants to be the maintainer.
  163. * Wed Sep 03 1997 Erik Troan <ewt@redhat.com>
  164. - made a noarch package
  165. * Tue Jul 08 1997 Erik Troan <ewt@redhat.com>
  166. - added dependencies