xmobar-vl.spec 3.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160
  1. %define pkg_name xmobar
  2. %define pkg_version 0.27
  3. %define pkg_release 1%{?_dist_release}
  4. Summary: a minimalistic text based status bar
  5. Summary(ja): テキストを基礎とした最小のステータスバー
  6. Name: %{pkg_name}
  7. Version: %{pkg_version}
  8. Release: %{pkg_release}
  9. License: BSD3
  10. Group: User Interface/Desktops
  11. URL: http://hackage.haskell.org
  12. Source0: packages
  13. # # Patch for building with hinotify-3.10
  14. # Source2: xmobar-0.26_with_hinotify-3.10.patch
  15. Source11: hinotify-0.3.10.tar.gz
  16. Source12: hinotify.cabal
  17. Source13: timezone-series-0.1.9.tar.gz
  18. Source14: timezone-series.cabal
  19. Source15: timezone-olson-0.1.9.tar.gz
  20. Source16: timezone-olson.cabal
  21. Source17: parsec-numbers-0.1.0.tar.gz
  22. Source18: parsec-numbers.cabal
  23. Source19: xmobar-0.27.tar.gz
  24. Source20: xmobar.cabal
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  26. BuildRequires: ghc haskell-platform
  27. BuildRequires: xmonad-contrib
  28. BuildRequires: libffi-devel gmp-devel zlib-devel
  29. BuildRequires: xorg-x11-devel
  30. BuildRequires: libXpm-devel
  31. Requires: haskell-platform-dep
  32. Requires: xmonad-contrib
  33. Requires: libXpm
  34. Vendor: Project Vine
  35. Distribution: Vine Linux
  36. Packager: ara_t
  37. %description
  38. Xmobar is a minimalistic text based status bar.
  39. Inspired by the Ion3 status bar, it supports similar features,
  40. like dynamic color management, output templates, and extensibility
  41. through plugins.
  42. %description -l ja
  43. Xmobarはテキストを基礎とした最小のステータスバーです。
  44. %prep
  45. %{__rm} -rf ${RPM_BUILD_ROOT}
  46. %build
  47. %ghc_pkg_init
  48. cd %{_builddir}
  49. for pkg in `sed '$d' %{SOURCE0}`; do
  50. %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
  51. pushd ${pkg}
  52. %ghc_fix_dependencies ${pkg}
  53. %cabal_configure2 %{name} ${pkg}
  54. %cabal_build
  55. %cabal_haddock
  56. %cabal_copy_resister %{name}_${pkg}
  57. popd
  58. done
  59. cd %{_builddir}
  60. for pkg in `tail -n 1 %{SOURCE0}`; do
  61. %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
  62. pushd ${pkg}
  63. %ghc_fix_dependencies ${pkg}
  64. # # Patch for building with hinotify-3.10
  65. # %{__patch} -p1 < %{SOURCE2}
  66. %cabal_configure2 %{name} ${pkg} \
  67. --flags="with_utf8" --flags="with_xft" \
  68. --flags="with_threaded" --flags="with_inotify" \
  69. --flags="with_datazone" --flags="with_xpm"
  70. %cabal_build
  71. %cabal_haddock
  72. %cabal_copy_resister %{name}_${pkg}
  73. popd
  74. done
  75. %install
  76. # copy documents
  77. pushd %{_builddir}/%{name}-%{version}
  78. %{__cp} readme.md \
  79. ${RPM_BUILD_ROOT}%{_docdir}/%{name}/%{name}-%{version}
  80. popd
  81. %clean
  82. %{__rm} -rf ${RPM_BUILD_ROOT}
  83. %post
  84. %ghc_pkg_recache
  85. %postun
  86. %ghc_pkg_recache
  87. %files
  88. %defattr(-, root, root)
  89. %{_bindir}/
  90. %{_libdir}/ghc-%{ghc_version}/
  91. %{_libdir}/ghc-lib/
  92. %{_docdir}/%{name}/
  93. %changelog
  94. * Fri Jul 20 2018 Toshiaki Ara <ara_t@384.jp> 0.27-1
  95. - update to 0.27
  96. - drop Patch2 (fixed at upstream)
  97. - build using ghc-8.4.3
  98. * Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 0.26-1
  99. - update to 0.26
  100. - rebuild using ghc-8.4.2
  101. - add Patch for building with hinotify-3.10 (Source2)
  102. - rewrite using macro
  103. * Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 0.24.5-2
  104. - update to 0.24.5
  105. - rebuild using ghc-8.2.2
  106. * Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 0.24.3-1
  107. - update to 0.24.3
  108. - build using ghc-8.0.1
  109. * Wed May 04 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-6
  110. - rebuilt
  111. * Tue Apr 12 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-5
  112. - rebuild under xmonad-0.12-3 and xmonad-contrib-0.12-4
  113. - correct SPEC file
  114. * Sun Mar 06 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-4
  115. - correct SPEC file
  116. * Tue Mar 01 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-3
  117. - rebuild under xmonad-0.12-2 and xmonad-contrib-0.12-3
  118. * Sun Feb 28 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-2
  119. - add configure option and required libraries
  120. * Sat Feb 27 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-1
  121. - new package