ffmpeg-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378
  1. #TODO: Build with openjpeg, opencore-amr, vo-amrwbenc
  2. #TODO: add make test to %%check section
  3. #% define svndate 20100625
  4. %define with_faac 1
  5. %define with_vaapi 1
  6. %define with_libvpx 1
  7. #% define enable_avconv 1
  8. %global major_version 1.1
  9. Summary: Digital VCR and streaming server
  10. Name: ffmpeg
  11. Version: %{major_version}.3
  12. Release: 1%{?svndate:.%svndate}%{?_dist_release}
  13. Source: http://ffmpeg.org/releases/%{name}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
  14. %if 0%{?_with_amr:1}
  15. License: GPLv3+
  16. %else
  17. License: GPLv2+
  18. %endif
  19. Group: Applications/Multimedia
  20. URL: http://ffmpeg.org/
  21. BuildRequires: bzip2-devel
  22. BuildRequires: celt-devel
  23. ##BuildRequires: dirac-devel
  24. BuildRequires: freetype2-devel
  25. ##BuildRequires: frei0r-devel
  26. BuildRequires: gnutls-devel
  27. BuildRequires: gsm-devel
  28. BuildRequires: imlib2-devel
  29. BuildRequires: libdc1394-devel
  30. BuildRequires: libogg-devel
  31. BuildRequires: libass-devel
  32. %{!?_without_cdio:BuildRequires: libcdio-devel}
  33. #libcrystalhd is currently broken
  34. %{?_with_crystalhd:BuildRequires: libcrystalhd-devel}
  35. BuildRequires: libraw1394-devel
  36. BuildRequires: librtmp-devel >= 2.3
  37. BuildRequires: libtheora-devel
  38. %{?with_vaapi:BuildRequires:libva-devel >= 0.31.0}
  39. BuildRequires: libvdpau-devel
  40. BuildRequires: libvorbis-devel
  41. %{?with_libvpx:BuildRequires: libvpx-devel >= 0.9.7}
  42. BuildRequires: libXvMC-devel
  43. %{?_with_opencore_amr:BuildRequires: opencore-amr-devel vo-amrwbenc-devel}
  44. %{!?_without_openal:BuildRequires: openal-soft-devel}
  45. %{?_with_opencv:BuildRequires: opencv-devel}
  46. %{?_with_openjpeg:BuildRequires: openjpeg-devel}
  47. ##BuildRequires: schroedinger-devel
  48. BuildRequires: SDL-devel
  49. BuildRequires: speex-devel
  50. ##BuildRequires: texi2html
  51. BuildRequires: zlib-devel
  52. BuildRequires: yasm
  53. # *-devel packages provided by other self-build-* should only be listed
  54. # in self-build-%{name}.spec as PreReq.
  55. #BuildRequires: a52dec-devel
  56. #BuildRequires: faac-devel
  57. #BuildRequires: lame-devel
  58. #BuildRequires: libdca-devel
  59. #BuildRequires: x264-devel >= 0.0.0-18.20111216
  60. #BuildRequires: xvidcore-devel
  61. Requires: %{name}-libs = %{version}-%{release}
  62. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  63. Obsoletes: ffmpeg < %{major_version}, ffmpeg-libs < %{major_version}, ffmpeg-devel < %{major_version}
  64. %description
  65. FFMpeg is a complete and free Internet live audio and video
  66. broadcasting solution for Linux/Unix. It also includes a digital
  67. VCR. It can encode in real time in many formats including MPEG1 audio
  68. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  69. %package libs
  70. Summary: Libraries for %{name}
  71. Group: System Environment/Libraries
  72. %description libs
  73. FFMpeg is a complete and free Internet live audio and video
  74. broadcasting solution for Linux/Unix. It also includes a digital
  75. VCR. It can encode in real time in many formats including MPEG1 audio
  76. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  77. This package contains the libraries for %{name}.
  78. %package devel
  79. Summary: Development package for %{name}
  80. Group: Development/Libraries
  81. Requires: %{name}-libs = %{version}-%{release}
  82. Requires: pkgconfig
  83. %description devel
  84. FFMpeg is a complete and free Internet live audio and video
  85. broadcasting solution for Linux/Unix. It also includes a digital
  86. VCR. It can encode in real time in many formats including MPEG1 audio
  87. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  88. This package contains development files for %{name}.
  89. %prep
  90. %setup -q -n %{name}-%{?svndate:%svndate}%{!?svndate:%version}
  91. %build
  92. %ifarch ppc
  93. # compile with -mlongcall on ppc/ppc64 (rf804)
  94. export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
  95. %endif
  96. ./configure \
  97. --prefix=%{_prefix} \
  98. --incdir=%{_includedir}/%{name} \
  99. --shlibdir=%{_libdir} \
  100. --libdir=%{_libdir} \
  101. --mandir=%{_mandir} \
  102. --arch=%{_target_cpu} \
  103. %ifarch %{ix86}
  104. --cpu=%{_target_cpu} \
  105. %endif
  106. %ifarch ppc
  107. --cpu=g3 \
  108. --enable-pic \
  109. %endif
  110. --enable-runtime-cpudetect \
  111. --extra-cflags="$RPM_OPT_FLAGS" \
  112. %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libvo-amrwbenc --enable-version3} \
  113. --enable-bzlib \
  114. %{!?_with_crystalhd:--disable-crystalhd} \
  115. --enable-zlib \
  116. %{?_with_frei0r:--enable-frei0r} \
  117. --enable-gnutls \
  118. --enable-libass \
  119. %{!?_without_cdio:--enable-libcdio} \
  120. --enable-libcelt \
  121. --enable-libdc1394 \
  122. %{?_with_libdirac:--enable-libdirac} \
  123. %{?with_faac:--enable-libfaac --enable-nonfree} \
  124. --enable-libfreetype \
  125. --enable-libgsm \
  126. --enable-libmp3lame \
  127. %{!?_without_openal:--enable-openal} \
  128. %{?_with_opencv:--enable-libopencv} \
  129. %{?_with_openjpeg:--enable-libopenjpeg} \
  130. --enable-librtmp \
  131. --enable-libspeex \
  132. --enable-libtheora \
  133. --enable-libvorbis \
  134. %{?with_libvpx:--enable-libvpx} \
  135. --enable-libx264 \
  136. --enable-libxvid \
  137. \
  138. --enable-x11grab \
  139. --enable-avfilter \
  140. --enable-postproc \
  141. --enable-pthreads \
  142. --disable-static \
  143. --enable-shared \
  144. --enable-gpl \
  145. --disable-doc \
  146. --disable-debug \
  147. --disable-stripping \
  148. \
  149. %{?enable_avconv:--enable-avconv} \
  150. ;
  151. %__make %{?_smp_mflags}
  152. %__make alltools
  153. %install
  154. %__make install DESTDIR=$RPM_BUILD_ROOT
  155. ## install tool/qt-faststart
  156. %__install -pm755 tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
  157. ## install man
  158. %__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
  159. #%__install -m0644 doc/*.1 $RPM_BUILD_ROOT%{_mandir}/man1/
  160. %clean
  161. %{__rm} -rf $RPM_BUILD_ROOT
  162. %post libs -p /sbin/ldconfig
  163. %postun libs -p /sbin/ldconfig
  164. %files
  165. %defattr(-,root,root,-)
  166. %doc COPYING.* CREDITS Changelog README doc/ffserver.conf
  167. %{?enable_avconv:%{_bindir}/avconv}
  168. %{_bindir}/ffmpeg
  169. %{_bindir}/ffplay
  170. %{_bindir}/ffprobe
  171. %{_bindir}/ffserver
  172. %{_bindir}/qt-faststart
  173. # %{?enable_avconv:%{_mandir}/man1/avconv.1*}
  174. # %{_mandir}/man1/ffmpeg.1*
  175. # %{_mandir}/man1/ffplay.1*
  176. # %{_mandir}/man1/ffprobe.1*
  177. # %{_mandir}/man1/ffserver.1*
  178. %{_datadir}/ffmpeg
  179. %files libs
  180. %defattr(-,root,root,-)
  181. %{_libdir}/lib*.so.*
  182. %files devel
  183. %defattr(-,root,root,-)
  184. %doc MAINTAINERS doc/APIchanges doc/*.txt doc/*.html
  185. %{_includedir}/ffmpeg
  186. %{_libdir}/pkgconfig/lib*.pc
  187. %{_libdir}/lib*.so
  188. %changelog
  189. * Tue Mar 12 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.3-1
  190. - new upstream release
  191. * Sun Feb 3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-2
  192. - libvpx >= 0.9.7
  193. * Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-1
  194. - new upstream release /x264-0.129
  195. * Thu Sep 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.2-1
  196. - new upstream release
  197. * Mon Jun 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.1-1
  198. - new upstream release
  199. * Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11-1
  200. - new upstream release
  201. * Sat Feb 18 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10-1
  202. - new upstream release
  203. * Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
  204. - new upstream release
  205. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
  206. - new upstream release
  207. - enable CELT decoding via libcelt
  208. - enable FreeType support
  209. - drop faad2 support (dropped upstream)
  210. * Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
  211. - change release to sync with self-build-ffmpeg-vl.spec
  212. * Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
  213. - new upstream release
  214. * Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
  215. - new upstream release
  216. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
  217. - required latest x264 build
  218. - added BuildRequires: librtmp-devel >= 2.3
  219. - build PIC objects on PPC
  220. #- add qt-faststart tool
  221. * Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
  222. - new upstream release
  223. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
  224. - change release to sync with self-build-ffmpeg-vl.spec
  225. * Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
  226. - added BuildRequires: libvpx-devel >= 0.9.1
  227. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
  228. - new upstream release
  229. * Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
  230. - bumped version to pre-0.6
  231. * Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-13.20100410
  232. - updated source snapshot 20100410
  233. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
  234. - change release to sync with self-build-ffmpeg-vl.spec
  235. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
  236. - change release to sync with self-build-ffmpeg-vl.spec
  237. * Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
  238. - updated source snapshot 20100401
  239. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-9.20100216
  240. - updated source snapshot 20100326
  241. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
  242. - change release to sync with self-build-ffmpeg
  243. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
  244. - updated source snapshot 20100216
  245. - rebuild with recent x264-devel
  246. - updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
  247. - added BuildRequires: libvdpau-devel
  248. * Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
  249. - change release to sync with self-build-ffmpeg
  250. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
  251. - change release to sync with self-build-ffmpeg
  252. * Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
  253. - applied ffmpeg-0.5-disable-texi2html.patch
  254. - dropped BuildRequires: texi2html
  255. * Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
  256. - change release to sync with self-build-ffmpeg
  257. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
  258. - corrected release number
  259. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
  260. - new upstream release
  261. - added BuildRequires:
  262. - speex-devel
  263. - bzip2-devel
  264. * Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
  265. - 20090227 snapshot
  266. * Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
  267. - added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
  268. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
  269. - changed to PreReq: self-build-faad2 >= 2.0 from faad2-devel
  270. - dropped Requires: a52dec, faad2 in ffmpeg-libs
  271. * Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
  272. - 20090202 snapshot
  273. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
  274. - 20090110 snapshot
  275. - dropped some patches
  276. * Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
  277. - source updated (r15488)
  278. - fixed License: GPLv2+
  279. - added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
  280. - added BuildRequires: yasm (only %%ix86)
  281. - applied ffmpeg-cpu.patch (merged from RPM Fusion)
  282. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
  283. - spec in utf8
  284. * Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
  285. - change release to sync with self-build-ffmpeg
  286. * Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
  287. - drop "Patch100: ffmpeg-vine.patch".
  288. * Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
  289. - build with new versioning policy
  290. - change to use svn export from svn checkout on post install
  291. - fix ffmpeg-vine.patch for libswscale/swscale.c.rej
  292. * Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
  293. - [self-build-ffmpeg.spec]
  294. For all pre-required package that is provied by self-build,
  295. changed to its self-build package
  296. * Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
  297. - initial build for Vine Linux 4.2
  298. - snapshot 2008/01/28 + some Rev.11662 2008/01/29
  299. ### end of file