self-build-ffmpeg-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341
  1. %global gpac_postinstall \
  2. gpac_postinstall_sh=$(mktemp) && \
  3. rpm -q --scripts self-build-gpac | \
  4. /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${gpac_postinstall_sh} && \
  5. /bin/bash ${gpac_postinstall_sh} && /bin/rm -f ${gpac_postinstall_sh}
  6. %global pkgname ffmpeg
  7. %global name self-build-%{pkgname}
  8. %global major_version 1.1
  9. %global version %{major_version}.3
  10. #% define svndate 20110326
  11. %global release 1%{?svndate:.%svndate}%{?_dist_release}
  12. %global sourceurl0 http://ffmpeg.org/releases/%{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
  13. %global with_faac 1
  14. %global with_vaapi 1
  15. %global with_libvpx 1
  16. #% define enable_avconv 1
  17. Summary: Package to automatically build %{pkgname} rpm package
  18. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  19. Name: %{name}
  20. Version: %{version}
  21. Release: %{release}
  22. Source0: %{pkgname}-vl.spec
  23. #Source1: %{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
  24. License: GPLv2+
  25. Group: Restricted Software
  26. Obsoletes: ffmpeg < %{major_version}, ffmpeg-libs < %{major_version}, ffmpeg-devel < %{major_version}
  27. Obsoletes: self-build-ffmpeg < %{major_version}
  28. Requires(post): self-build-setup >= 0.9.9
  29. #Requires(post): subversion
  30. # (build)requies of target package.
  31. Requires(post): bzip2-devel
  32. Requires(post): celt-devel
  33. ##Requires(post): dirac-devel
  34. Requires(post): freetype2-devel
  35. Requires(post): gnutls-devel
  36. Requires(post): gsm-devel
  37. Requires(post): imlib2-devel
  38. Requires(post): libdc1394-devel
  39. Requires(post): libogg-devel
  40. Requires(post): libass-devel
  41. %{!?_without_cdio:Requires(post): libcdio-devel}
  42. #libcrystalhd is currently broken
  43. %{?_with_crystalhd:Requires(post): libcrystalhd-devel}
  44. Requires(post): libraw1394-devel
  45. Requires(post): librtmp-devel >= 2.3
  46. Requires(post): libtheora-devel
  47. %{?with_vaapi:Requires(post): libva-devel >= 0.31.0}
  48. Requires(post): libvdpau-devel
  49. Requires(post): libvorbis-devel
  50. %{?with_libvpx:Requires(post): libvpx-devel >= 0.9.7}
  51. Requires(post): libXvMC-devel
  52. %{?_with_opencore_amr:Requires(post): opencore-amr-devel vo-amrwbenc-devel}
  53. %{!?_without_openal:Requires(post): openal-soft-devel}
  54. %{?_with_opencv:Requires(post): opencv-devel}
  55. %{?_with_openjpeg:Requires(post): openjpeg-devel}
  56. ##Requires(post): schroedinger-devel
  57. Requires(post): SDL-devel
  58. Requires(post): speex-devel
  59. ##Requires(post): texi2html
  60. Requires(post): zlib-devel
  61. Requires(post): libogg-devel
  62. Requires(post): yasm
  63. Requires(post): self-build-a52dec
  64. Requires(post): self-build-faac
  65. Requires(post): self-build-faad2
  66. Requires(post): self-build-lame
  67. Requires(post): self-build-libdca
  68. Requires(post): self-build-x264 >= 0.129
  69. Requires(post): self-build-xvidcore
  70. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  71. BuildArch: noarch
  72. Packager: munepi
  73. %description
  74. FFMpeg is a complete and free Internet live audio and video
  75. broadcasting solution for Linux/Unix. It also includes a
  76. digital VCR. It can encode in real time in many formats
  77. including MPEG1 audio and video, MPEG4, h263, ac3, asf, avi,
  78. real, mjpeg, and flash.
  79. If you install this package, it automaticaly downloads source
  80. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  81. And the created rpm packages are automatically installed
  82. if installation is executed by apt-get command or synaptic
  83. package manager.
  84. [Note]
  85. This package requires many other packages to compile
  86. target software. So it consume more disk space than usual.
  87. Also installation takes longer time because of compilation.
  88. (This will take a few minutes to quarter or half of an hour,
  89. depends on building environment)
  90. [About self-build package]
  91. For some kind of software, distributing of binary package
  92. may viorate the patent or law. Therefore we chose self-build
  93. packge, create binary package on your machine, for such kind
  94. of softwares instead of distributing binary package.
  95. Please obey the national law when you use the created binary
  96. packages. And if you want to use the softwares using patented
  97. thechnology, it may be required to get a permission, make an
  98. agreement or purchas a license. Please consider it with your
  99. purpose or way of use and take appropriate action.
  100. %description -l ja
  101. FFMpeg は Linux/Unix に対する完全にフリーなインターネットライ
  102. ブオーティオ・ビデオブロードキャスティングソリューションです.
  103. またデジタル VCR を含んでいます.MPEG1 オーディオ・ビデオ,
  104. MPEG4, h263, ac3, asf, avi, real, mjpeg, flash を含む
  105. 多様なフォーマットをリアルタイムにエンコードすることができます.
  106. このパッケージをインストールすると、自動的にソースコードを
  107. ダウンロードしてコンパイルし、%{pkgname}-%{version}
  108. の rpm パッケージを作成します。
  109. また apt-get コマンドや synaptic パッケージマネージャから実行
  110. した場合は、作成された rpm パッケージのインストールも自動的に
  111. 行います。
  112. [注意]
  113. コンパイルに必要な多くの関連パッケージを要求するので通常より
  114. ディスクの領域を多く消費します。
  115. またインストール時にコンパイルを行うため、通常より時間がかか
  116. る場合があります。(環境にもよりますが数分から数十分程度)
  117. [self-build パッケージについて]
  118. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  119. 違反する可能性があるものがあります。その為、このような問題が
  120. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  121. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  122. ジという方法を採っています。
  123. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  124. アのライセンス、および利用する国の各種法令に従ってください。
  125. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  126. センスの購入などが必要となる場合がありますので、利用する目的
  127. や形態に応じて各自で判断し適切な対応を取ってください。
  128. %prep
  129. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  130. %install
  131. %{__rm} -rf ${RPM_BUILD_ROOT}
  132. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  133. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  134. %clean
  135. %{__rm} -rf ${RPM_BUILD_ROOT}
  136. %posttrans
  137. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 86000
  138. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  139. %{pkgname}-libs-%{version}-%{release} \
  140. %{pkgname}-devel-%{version}-%{release}
  141. ## Rebuild gpac with ffmpeg-devel
  142. # set locale
  143. case $LANG in
  144. ja*)LOCALE=ja ;;
  145. *) LOCALE=C ;;
  146. esac
  147. Rebuild_gpac_C(){
  148. echo -n " "
  149. echo "Rebuild gpac with ffmpeg-devel"
  150. }
  151. Rebuild_gpac_ja(){
  152. echo -n " "
  153. echo "ffmpeg-devel で gpac をリビルドします。"
  154. }
  155. Rebuild_gpac_$LOCALE
  156. %{gpac_postinstall}
  157. %files
  158. %defattr(-,root,root)
  159. %{_datadir}/%{name}
  160. %changelog
  161. * Tue Mar 12 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.3-1
  162. - new upstream release
  163. * Sun Feb 3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-2
  164. - libvpx >= 0.9.7
  165. * Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-1
  166. - new upstream release /x264-0.129
  167. * Thu Sep 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.2-1
  168. - new upstream release
  169. * Mon Jun 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.1-1
  170. - new upstream release
  171. * Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11-1
  172. - new upstream release
  173. * Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
  174. - new upstream release
  175. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
  176. - new upstream release
  177. - enable CELT decoding via libcelt
  178. - enable FreeType support
  179. - drop faad2 support (dropped upstream)
  180. * Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
  181. - added BuildArch: noarch
  182. * Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
  183. - new upstream release
  184. * Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
  185. - new upstream release
  186. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
  187. - required latest x264 build
  188. - added BuildRequires: librtmp-devel >= 2.3
  189. * Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
  190. - new upstream release
  191. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
  192. - unpacked source archives
  193. * Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
  194. - fixed some dependencies
  195. - Requires(post): libva-devel
  196. - Requires(post): libvpx-devel >= 0.9.1
  197. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
  198. - new upstream release
  199. * Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
  200. - bumped version to pre-0.6
  201. - updated source snapshot 20100410
  202. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
  203. - fixed self-build log size
  204. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
  205. - added ffprobe.1.gz
  206. * Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
  207. - updated source snapshot 20100401
  208. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
  209. - renamed %%{Source0} to ffmpeg-vl.spec
  210. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
  211. - updated source snapshot 20100216
  212. - rebuild with recent x264-devel
  213. - updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
  214. - added BuildRequires: libvdpau-devel
  215. * Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
  216. - dropped BuildArch: noarch
  217. - added ffmpeg.1, ffplay.1, ffserver.1
  218. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
  219. - avoided to execute self-build-rpm.sh on RPM transaction
  220. - moved %%post actions to %%posttrans
  221. * Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
  222. - added BuildArch: noarch
  223. - added ffmpeg-0.5-disable-texi2html.patch
  224. - dropped PreReq: texi2html
  225. * Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
  226. - added %%{gpac_postinstall} in %%post
  227. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
  228. - corrected release number
  229. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
  230. - new upstream release
  231. - added PreReq:
  232. - speex-devel
  233. - bzip2-devel
  234. * Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
  235. - change release to sync with ffmpeg
  236. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
  237. - changed to PreReq: self-build-faad2 >= 2.0 from faad2-devel
  238. * Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
  239. - 20090202 snapshot
  240. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
  241. - 20090110 snapshot
  242. - dropped some patches
  243. * Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
  244. - source updated (r15488)
  245. - fixed License: GPLv2+
  246. - added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
  247. - added BuildRequires: yasm (only %%ix86)
  248. - applied ffmpeg-cpu.patch (merged from RPM Fusion)
  249. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
  250. - spec in utf8
  251. * Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
  252. - run pre-allocate-rpm.sh in %%post
  253. - set PreReq: self-build-setup >= 0.8
  254. - change release number
  255. * Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
  256. - add "Source1: %{pkgname}-%{version}.r%{svnrev}.tar.gz",
  257. include Source1 in the binary package.
  258. - drop "Source100: ffmpeg-vine.patch".
  259. - drop "PreReq: subversion".
  260. * Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
  261. - build with new versioning policy
  262. - change to use svn export from svn checkout on post install
  263. - fix ffmpeg-vine.patch for libswscale/swscale.c.rej
  264. * Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
  265. - For all pre-required package that is provied by self-build,
  266. changed to its self-build package
  267. * Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
  268. - initial build for Vine Linux 4.2
  269. - snapshot 2008/01/28 + some Rev.11662 2008/01/29
  270. ### end of file