kdevelop-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507
  1. Name: kdevelop
  2. Summary: Integrated Development Environment for C++/C
  3. Summary(ja): C++/C 向け統合開発環境
  4. Version: 4.4.0
  5. Release: 1%{?_dist_release}
  6. License: GPLv2
  7. URL: http://www.kdevelop.org/
  8. Group: Applications/Development
  9. Source0: ftp://ftp.kde.org/pub/kde/stable/kdevelop/%{version}/src/kdevelop-%{version}.tar.bz2
  10. # fixing https://bugs.kde.org/show_bug.cgi?id=236315
  11. Patch100: kdevelop-4.0.0-qmake_qt4.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: desktop-file-utils
  14. BuildRequires: gettext
  15. BuildRequires: kdebase-workspace-devel
  16. BuildRequires: kdevplatform-devel >= 1.4.0
  17. BuildRequires: kdelibs-devel
  18. BuildRequires: kdesdk-devel
  19. BuildRequires: soprano-devel
  20. BuildRequires: valgrind
  21. Requires: %{name}-libs = %{version}-%{release}
  22. Requires: kdevplatform >= 1.4.0
  23. #Conflicts: kdevelop
  24. %description
  25. The KDevelop Integrated Development Environment provides many features
  26. that developers need as well as providing a unified interface to programs
  27. like gdb, the C/C++ compiler, and make. KDevelop manages or provides:
  28. All development tools needed for C++ programming like Compiler,
  29. Linker, automake and autoconf; KAppWizard, which generates complete,
  30. ready-to-go sample applications; Classgenerator, for creating new
  31. classes and integrating them into the current project; File management
  32. for sources, headers, documentation etc. to be included in the
  33. project; The creation of User-Handbooks written with SGML and the
  34. automatic generation of HTML-output with the KDE look and feel;
  35. Automatic HTML-based API-documentation for your project's classes with
  36. cross-references to the used libraries; Internationalization support
  37. for your application, allowing translators to easily add their target
  38. language to a project;
  39. KDevelop also includes WYSIWYG (What you see is what you get)-creation
  40. of user interfaces with a built-in dialog editor; Debugging your
  41. application by integrating KDbg; Editing of project-specific pixmaps
  42. with KIconEdit; The inclusion of any other program you need for
  43. development by adding it to the "Tools"-menu according to your
  44. individual needs.
  45. %package libs
  46. Summary: %{name} runtime libraries
  47. Summary(ja): %{name} のランタイムライブラリ
  48. Group: System Environment/Libraries
  49. #Requires: %{name} = %{version}-%{release}
  50. Requires: kdelibs4
  51. %description libs
  52. %{summary}.
  53. %package devel
  54. Summary: Development files for %{name}
  55. Summary(ja): %{name} の開発用ファイル
  56. Group: Development/Libraries
  57. Requires: %{name}-libs = %{version}-%{release}
  58. %description devel
  59. %{summary}.
  60. %prep
  61. %setup -q -n kdevelop-%{version}
  62. #patch100 -p1 -b .qmake_qt4
  63. %build
  64. mkdir -p %{_target_platform}
  65. pushd %{_target_platform}
  66. %cmake \
  67. -DCMAKE_BUILD_TYPE=release \
  68. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  69. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  70. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  71. -DLIB_INSTALL_DIR:PATH=%{_libdir} \
  72. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  73. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  74. ..
  75. popd
  76. make %{?_smp_mflags} -C %{_target_platform}
  77. %install
  78. rm -rf $RPM_BUILD_ROOT
  79. make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  80. %find_lang %{name} --all-name --with-kde
  81. %clean
  82. rm -rf $RPM_BUILD_ROOT
  83. %post
  84. touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
  85. %postun
  86. if [ $1 -eq 0 ] ; then
  87. touch --no-create %{_datadir}/icons/hicolor &> /dev/null
  88. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  89. update-desktop-database -q &> /dev/null
  90. update-mime-database %{_datadir}/mime &> /dev/null
  91. fi
  92. %posttrans
  93. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  94. update-desktop-database -q &> /dev/null
  95. update-mime-database %{_datadir}/mime &> /dev/null
  96. %post libs -p /sbin/ldconfig
  97. %postun libs -p /sbin/ldconfig
  98. %files -f %{name}.lang
  99. %defattr(-,root,root)
  100. %{_bindir}/*
  101. %config %{_datadir}/config/kdeveloprc
  102. %{_datadir}/applications/kde4/*.desktop
  103. %{_datadir}/config/kdevelop-qthelp.knsrc
  104. %{_datadir}/kde4/apps/kdev*/
  105. %{_datadir}/kde4/apps/plasma/plasmoids/kdevelopsessions/contents/ui/kdevelopsessions.qml
  106. %{_datadir}/kde4/apps/plasma/plasmoids/kdevelopsessions/metadata.desktop
  107. %{_datadir}/kde4/apps/plasma/services/org.kde.plasma.dataengine.kdevelopsessions.operations
  108. %{_datadir}/kde4/services/*.desktop
  109. %{_datadir}/icons/hicolor/*/*/*
  110. %{_datadir}/mime/packages/kdevelop.xml
  111. #{_datadir}/servicetypes/*
  112. #doc %{_datadir}/doc/HTML/en/*
  113. %files libs
  114. %defattr(-,root,root,-)
  115. %{_libdir}/lib*.so
  116. %{_libdir}/kde4/*.so
  117. %files devel
  118. %defattr(-,root,root,-)
  119. %{_datadir}/kde4/apps/cmake/modules/FindKDevelop.cmake
  120. %{_includedir}/kde4/kdevelop/
  121. %changelog
  122. * Sat Oct 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.4.0-1
  123. - new upstream release
  124. * Sat Sep 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.3.1-1
  125. - new upstream release
  126. * Sat Jun 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.3-1
  127. - new upstream release
  128. * Sat May 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.0-2
  129. - add BuildRequires: kdesdk-devel, soprano-devel
  130. * Sat Feb 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.0-1
  131. - new upstream release
  132. * Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.2-1
  133. - new upstream release
  134. * Sat May 8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.0-1
  135. - new upstream release
  136. - split shared libraries and header files
  137. * Sun May 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.4-1
  138. - new upstream release
  139. - applied new versioning policy, spec in UTF-8
  140. - changed Group to Applications/Development
  141. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl2
  142. - rebuild for VineSeed
  143. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl1
  144. - new upstream release
  145. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl2
  146. - rebuild for VineSeed
  147. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl1
  148. - new upstream release
  149. * Fri Jun 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl2
  150. - rebuild for VineSeed
  151. * Fri Jun 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl1
  152. - new upstream release
  153. - use ap?-config for Vine3.x and use ap?-1-config for VineSeed
  154. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
  155. - rebuild for VineSeed
  156. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
  157. - new upstream release
  158. * Mon Feb 6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
  159. - rebuild for VineSeed
  160. * Mon Feb 6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
  161. - new upstream release
  162. * Thu Dec 8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl2
  163. - rebuild for VineSeed
  164. * Thu Dec 8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl1
  165. - new upstream release
  166. - add BuildPrereq: apache2-devel subversion-devel
  167. * Tue Nov 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl0.rc1
  168. - new upstream release
  169. * Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.92-0vl1
  170. - new upstream release
  171. - delete Patch0
  172. * Thu Sep 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.91-0vl1
  173. - new upstream release
  174. - add Patch0
  175. - update %%files
  176. * Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl2
  177. - rebuild for VineSeed
  178. * Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
  179. - new upstream release
  180. * Tue Jul 5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
  181. - rebuild for VineSeed
  182. * Tue Jul 5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
  183. - new upstream release
  184. - add --disable-rpath to configure option
  185. - remove BuildPrereq: qt-static
  186. * Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl2
  187. - rebuild for VineSeed
  188. * Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl1
  189. - new upstream release
  190. - update %%files
  191. - add +w to %%{_prefix}/kdevbdb/*
  192. * Sun Jan 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl2
  193. - rebuild for VineSeed
  194. * Sun Jan 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
  195. - new upstream release
  196. - update %%files
  197. * Thu Oct 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
  198. - source upgrade
  199. - add BuildPrereq: qt-static
  200. * Wed Aug 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
  201. - rebuild with qt32
  202. * Wed Jun 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
  203. - source upgrade
  204. - remove lines about vine26
  205. * Sat May 1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
  206. - source upgrade
  207. - add Requires: ctags
  208. * Tue Mar 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.2-0vl1
  209. - source upgrade
  210. - remove all patches
  211. - remove c references
  212. - add Requires: htdig
  213. * Fri Feb 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl0
  214. - change spec to build both VineSeed and Vine2.5/2.6
  215. - change configure options
  216. - add %%clean section
  217. - add Requires: kdbg kdoc kdegraphics kdeutils kdesdk
  218. * Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl1
  219. - source upgrade
  220. - change spec to build both VineSeed and Vine2.5/2.6
  221. - change configure option (add -enable--final, remove -enable--debug)
  222. - update %%files section
  223. * Thu Oct 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.3-0vl1
  224. - source upgrade
  225. - remove patch1 (rejected)
  226. * Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl2
  227. - BuildPrereq: autoconf253 objprelink2 instead of autoconf252 objprelink
  228. * Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.2-0vl1
  229. - source upgrade
  230. - revised Source1
  231. - remove Patch1 and Patch4
  232. * Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.1-3vl1
  233. - merged with rawhide 2.1.1-3
  234. - clean up spec
  235. - add BuildPrereq: objprelink (i386 only)
  236. - remove Obsoletes: kdevelop-c_c++_ref
  237. - add BuildPrereq: autoconf252 automake15
  238. - There is Vine's previous changes, hacked for Vine
  239. -- Sat Mar 23 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.0.2-2vl1
  240. - build for VineSeed
  241. - delete Epoch
  242. - update Patch1 and delete Patch2
  243. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  244. - automated rebuild
  245. * Wed Jun 19 2002 Than Ngo <than@redhat.com> 2.1.1-2
  246. - don't forcibly strip binaries
  247. * Sun Jun 2 2002 Than Ngo <than@redhat.com> 2.1.1-1
  248. - 2.1.1
  249. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  250. - automated rebuild
  251. * Thu May 23 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-3
  252. - Use automake15
  253. * Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-2
  254. - Change sonames
  255. * Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-1
  256. - final
  257. * Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-0.cvs20020326.1
  258. - update
  259. * Wed Mar 20 2002 Than Ngo <than@redhat.com> 2.1rc3-1
  260. - update to 2.1rc3
  261. * Sun Mar 17 2002 Than Ngo <than@redhat.com> 2.1rc2-1
  262. - update to 2.1rc2
  263. * Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-3
  264. - rebuild against new kdelibs
  265. * Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-2
  266. - fixed Strange characters appear in the output window (bug #59217)
  267. - fixed return-line feed sign in Kdevelop setup tool (bug #55032)
  268. * Wed Mar 8 2002 Than Ngo <than@redhat.com> 2.1beta2-1
  269. - update to 2.1beta2
  270. * Wed Jan 16 2002 Than Ngo <than@redhat.com> 2.1beta1-2
  271. - rebuild against new kdelibs
  272. * Wed Jan 9 2002 Than Ngo <than@redhat.com> 2.1beta1-1
  273. - update to 2.1 beta1
  274. - fix build against gcc 3
  275. - fix some typo bugs
  276. - get rid of libkfile
  277. - update c_cpp_reference to 2.0.1
  278. * Mon Oct 22 2001 Than Ngo <than@redhat.com> 2.0-1
  279. - add patch to show non lattin1 font in build-in editor correct (bug #54457)
  280. * Sat Sep 22 2001 Than Ngo <than@redhat.com> 2.0-2
  281. - fix a bug in creating documentation index when running KDevelop Setup (bug #52760)
  282. - backport some major bugfixes from 2.0.1
  283. * Mon Jul 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010730.1
  284. - Don't crash on startup
  285. * Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010724.1
  286. - Fix file list
  287. * Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010723.1
  288. - Update
  289. * Mon Feb 26 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  290. - Yet another respin - printing was broken.
  291. * Sat Feb 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  292. - Update the C/C++ reference guide docs. The older version had a
  293. couple of examples that won't work with gcc 2.96-*
  294. * Thu Feb 22 2001 Than Ngo <than@redhat.com>
  295. - fix version number
  296. * Wed Feb 21 2001 Than Ngo <than@redhat.com>
  297. - 1.4-respin
  298. * Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  299. - 1.4
  300. * Wed Feb 14 2001 Than Ngo <than@redhat.com>
  301. - update (only bugfixes)
  302. - fix up kdelibs documentation path
  303. - fix a dependency problem with kde-i18n package (Bug #27675)
  304. - add qt-designer into requires
  305. * Sun Feb 11 2001 Than Ngo <than@redhat.com>
  306. - fixed to build on s390
  307. * Tue Feb 06 2001 Than Ngo <than@redhat.com>
  308. - update, only bugfixes
  309. * Wed Jan 24 2001 Than Ngo <than@redhat.com>
  310. - hacked for building of KDE references
  311. * Tue Jan 23 2001 Than Ngo <than@redhat.com>
  312. - work-around to build on alpha
  313. * Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  314. - Update
  315. * Wed Jan 10 2001 Than Ngo <than@redhat.com>
  316. - update new snapshot, only require KDE2/Qt2
  317. * Fri Dec 22 2000 Than Ngo <than@redhat.com>
  318. - fixed dependency problem with kde-i18n
  319. * Thu Dec 21 2000 Than Ngo <than@redhat.com>
  320. - updated to 1.4beta1 with KDE2 support
  321. - fixed to build on s390
  322. - fixed some broken codes
  323. * Fri Dec 8 2000 Than Ngo <than@redhat.com>
  324. - fixed for building on ia64
  325. * Wed Nov 15 2000 Than Ngo <than@redhat.com>
  326. - build snapshot 20001112, it works now with KDE2 and kde1-compat
  327. - fix libtool to build on sparc and alpha
  328. - don't use make -j
  329. * Sun Aug 13 2000 Than Ngo <than@redhat.com>
  330. - fix kdelibsdoc-dir to show kdelibs-1.1.2 html docu correct
  331. * Tue Aug 01 2000 Than Ngo <than@redhat.de>
  332. - add missing ldconfig in %post and %postun section (Bug #14924)
  333. - add missing C references stuff to kdevelop
  334. * Sun Jul 30 2000 Than Ngo <than@redhat.de>
  335. - rebuilt against compat-egcs-c++, put KDE1 under /usr
  336. - cleanup specfile
  337. * Tue Jul 25 2000 Than Ngo <than@redhat.de>
  338. - fix dependency problem
  339. * Wed Jul 19 2000 Than Ngo <than@redhat.de>
  340. - rebuilt against compat-libstdc++
  341. * Mon Jul 17 2000 Than Ngo <than@redhat.de>
  342. - install under /usr/share instead /usr/lib/kde1-compat/share,
  343. fix dependency problem
  344. * Sat Jul 15 2000 Than Ngo <than@redhat.de>
  345. - rebuilt with egcs-c++-1.1.2
  346. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  347. - automatic rebuild
  348. * Mon Jul 03 2000 Than Ngo <than@redhat.de>
  349. - fix docdir
  350. - add requires kdebase
  351. * Sun Jul 02 2000 Than Ngo <than@redhat.de>
  352. - rebuilt with kde1-compat
  353. * Sun Jun 18 2000 Than Ngo <than@redhat.de>
  354. - rebuilt in the new build environment, fix docdir
  355. - FHS packaging
  356. * Thu Jun 08 2000 Than Ngo <than@redhat.de>
  357. - update to 1.2
  358. - move from powertools to main CD
  359. - use %%configure
  360. * Mon Apr 3 2000 Ngo Than <than@redhat.de>
  361. - fix up reference (Bug #10368)
  362. * Tue Feb 15 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  363. - Fix up documentation path (Bug #7291)
  364. - Update to current stable branch - this should fix up the debugger problem
  365. - clean up spec file
  366. * Fri Jan 6 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  367. - Update to current stable branch
  368. - Adapt to 6.2 Qt libraries
  369. - Use BuildPrereq
  370. * Wed Jan 05 2000 Ngo Than <than@redhat.de>
  371. - added patch for alpha
  372. * Tue Dec 21 1999 Ngo Than <than@redhat.de>
  373. - updated kdevelop-1.0 release
  374. * Tue Nov 16 1999 Preston Brown <pbrown@redhat.com>
  375. - kdevelop 1.0beta4.1, docdir added, using DESTDIR env. variable.
  376. * Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
  377. - initial packaging for 6.1.