python-bsddb3-vl.spec 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667
  1. %define pyver %(python -c 'import sys;print(sys.version[0:3])')
  2. Summary: Python bindings for Berkeley DB
  3. Summary(ja): Berkeley DB 用 python バインディング
  4. Name: python-bsddb3
  5. Version: 5.3.0
  6. Release: 1%{?_dist_release}
  7. Source0: http://pypi.python.org/packages/source/b/bsddb3/bsddb3-%{version}.tar.gz
  8. License: MIT
  9. Group: Development/Languages
  10. URL: http://www.jcea.es/programacion/pybsddb.htm
  11. Requires: python
  12. BuildRequires: python-devel
  13. BuildRequires: db4-devel
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. %description
  16. python-bsddb3 are the Python "bindings" for the excellent Oracle Berkeley DB.
  17. %description -l ja
  18. python-bsddb3 は Oracle Berkeley DB 用の python バインディングです。
  19. %package devel
  20. Summary: Development files for %{name}
  21. Group: Development/Libraries
  22. Requires: %{name} = %{version}-%{release}
  23. %description devel
  24. %{summary}
  25. %prep
  26. %setup -q -n bsddb3-%{version}
  27. %build
  28. %{__python} setup.py build
  29. %install
  30. %{__rm} -rf ${RPM_BUILD_ROOT}
  31. %{__python} setup.py install --root ${RPM_BUILD_ROOT}
  32. %clean
  33. %{__rm} -rf ${RPM_BUILD_ROOT}
  34. %files
  35. %defattr(-,root,root,-)
  36. %doc ChangeLog README.txt
  37. %{python_sitearch}/bsddb3/
  38. %{python_sitearch}/bsddb3-%{version}-py%{pyver}.egg-info
  39. %files devel
  40. %defattr(-,root,root,-)
  41. %{_includedir}/python%{pyver}/bsddb3/bsddb.h
  42. %changelog
  43. * Sun Oct 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.3.0-1
  44. - initial build