python-twisted-vl.spec 3.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. %define pyver %(python -c 'import sys;print(sys.version[0:3])')
  3. Summary: Event-driven networking engine in Python
  4. Summary(ja): Pythonで書かれたイベントドリブンなネットワークエンジン
  5. Name: python-twisted
  6. Version: 12.2.0
  7. Release: 1%{?_dist_release}
  8. Source0: http://pypi.python.org/packages/source/T/Twisted/Twisted-%{version}.tar.bz2
  9. License: MIT
  10. Group: Development/Languages
  11. URL: http://twistedmatrix.com/trac/
  12. Requires: python
  13. Requires: python-zope-interface
  14. Requires: pyOpenSSL
  15. BuildRequires: python, python-devel
  16. BuildRequires: python-zope-interface
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. %description
  19. Twisted is a networking engine written in Python, supporting
  20. numerous protocols. It contains a web server, numerous chat
  21. clients, chat servers, mail servers, and more.
  22. Twisted is a platform for developing internet applications.
  23. %description -l ja
  24. Twisted は Python で書かれた、多くのプロトコルをサポートする
  25. ネットワーク・エンジンです。このパッケージにはウェブサーバや
  26. 多種多様なチャット用クライアント、チャットサーバ、メールサーバ
  27. 等が含まれています。
  28. Twisted はウェブアプリケーション開発用のプラットフォームです。
  29. %package docs
  30. Summary: Documentation for Twisted
  31. Summary(ja): Twisted のドキュメント
  32. Group: Applications/Documentation
  33. # workaround to prevent find-requires error
  34. AutoReq: No
  35. %description docs
  36. This package contains various documents and examples for
  37. Twisted.
  38. %description docs -l ja
  39. このパッケージには Twisted の各種ドキュメントやサンプルが
  40. 含まれています。
  41. %prep
  42. %setup -q -n Twisted-%{version}
  43. %build
  44. %{__python} setup.py build
  45. # create plugins cache
  46. python -c "from twisted.plugin import IPlugin, getPlugins;list(getPlugins(IPlugin))" >/dev/null 2>&1
  47. %install
  48. %{__rm} -rf ${RPM_BUILD_ROOT}
  49. %{__python} setup.py install --root ${RPM_BUILD_ROOT}
  50. # install man pages
  51. %{__install} -d -m 755 "$RPM_BUILD_ROOT"/%{_mandir}/man1/
  52. %{__install} -m 644 doc/core/man/*.1 ${RPM_BUILD_ROOT}/%{_mandir}/man1/
  53. %clean
  54. %{__rm} -rf ${RPM_BUILD_ROOT}
  55. %files
  56. %defattr(-,root,root)
  57. %doc INSTALL LICENSE NEWS README
  58. #%{_bindir}/bookify
  59. %{_bindir}/cftp
  60. %{_bindir}/ckeygen
  61. %{_bindir}/conch
  62. #%{_bindir}/im
  63. %{_bindir}/lore
  64. %{_bindir}/mailmail
  65. %{_bindir}/manhole
  66. %{_bindir}/pyhtmlizer
  67. #%{_bindir}/t-im
  68. %{_bindir}/tap2deb
  69. %{_bindir}/tap2rpm
  70. %{_bindir}/tapconvert
  71. %{_bindir}/tkconch
  72. %{_bindir}/trial
  73. %{_bindir}/twistd
  74. %{python_sitearch}/twisted
  75. %{python_sitearch}/Twisted-%{version}-py%{pyver}.egg-info
  76. %{_mandir}/man1/*
  77. %files docs
  78. %defattr(-,root,root)
  79. %doc doc/*
  80. %changelog
  81. * Sat Oct 27 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 12.2.0-1
  82. - new upstream release
  83. * Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.2.0-2
  84. - rebuild with python-2.7.2
  85. * Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 10.2.0-1
  86. - updated twisted to 10.2.0
  87. * Thu Feb 04 2010 Shu KONNO <owa@bg.wakwak.com> 8.1.0-2
  88. - rebuilt with python-2.6.4-3
  89. * Tue Dec 23 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 8.1.0-1
  90. - initial build for Vine Linux