sbcl-vl.spec 3.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162
  1. %define pkg_name sbcl
  2. %define pkg_version 1.4.1
  3. %define pkg_release 1%{?_dist_release}
  4. %define sbcl 1
  5. Summary: Steel Bank Common Lisp
  6. Name: %{pkg_name}
  7. Version: %{pkg_version}
  8. Release: %{pkg_release}
  9. License: A mixture of BSD-style and public domain
  10. Group: Development/Languages
  11. URL: http://www.sbcl.org/
  12. SOURCE: %{name}-%{version}-source.tar.bz2
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. %if !%{sbcl}
  15. BuildRequires: clisp
  16. %else
  17. BuildRequires: sbcl
  18. %endif
  19. BuildRequires: texinfo
  20. BuildRequires: texlive-common
  21. %if %{?_dist_release} == "vl6"
  22. BuildRequires: texlive-collection-texinfo
  23. %else
  24. BuildRequires: texlive-collection-plaingeneric
  25. BuildRequires: texlive-collection-fontsrecommended
  26. %endif
  27. Vendor: Project Vine
  28. Distribution: Vine Linux
  29. Packager: ara_t
  30. %description
  31. Steel Bank Common Lisp (SBCL) is a high performance Common Lisp compiler.
  32. It is open source / free software, with a permissive license.
  33. In addition to the compiler and runtime system for ANSI Common Lisp,
  34. it provides an interactive environment including a debugger,
  35. a statistical profiler, a code coverage tool, and many other extensions.
  36. %prep
  37. %{__rm} -rf ${RPM_BUILD_ROOT}
  38. %setup -q
  39. %build
  40. %if !%{sbcl}
  41. sh make.sh "clisp" --prefix=%{_usr}
  42. %else
  43. sh make.sh --prefix=%{_usr}
  44. %endif
  45. cd doc/manual
  46. %{__make} pdf html info
  47. %install
  48. export INSTALL_ROOT=${RPM_BUILD_ROOT}%{_prefix}
  49. sh install.sh
  50. %{__rm} ${RPM_BUILD_ROOT}%{_infodir}/dir
  51. %{__mv} ${RPM_BUILD_ROOT}%{_docdir}/sbcl/*.html \
  52. ${RPM_BUILD_ROOT}%{_docdir}/sbcl/html
  53. %{__mv} ${RPM_BUILD_ROOT}%{_docdir}/sbcl \
  54. ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
  55. %post
  56. for doc in asdf sbcl; do
  57. file=%{_infodir}/${doc}.info.gz
  58. if [ -e ${file} ]; then
  59. %{_syssbindir}/install-info ${file} %{_infodir}/dir 2>/dev/null
  60. fi
  61. done
  62. %preun
  63. if [ $1 = 0 ]; then
  64. for doc in asdf sbcl; do
  65. file=%{_infodir}/${doc}.info.gz
  66. if [ -e ${file} ]; then
  67. %{_syssbindir}/install-info --delete ${file} %{_infodir}/dir \
  68. 2>/dev/null
  69. fi
  70. done
  71. fi
  72. %clean
  73. %{__rm} -rf ${RPM_BUILD_ROOT}
  74. %files
  75. %defattr(-, root, root)
  76. %{_bindir}/
  77. /usr/lib/sbcl/
  78. %{_docdir}/sbcl-%{version}
  79. %{_infodir}/
  80. %{_mandir}/man1/
  81. %changelog
  82. * Wed Nov 01 2017 Toshiaki Ara <ara_t@384.jp> 1.4.1-1
  83. - new upstream release
  84. * Sun Oct 01 2017 Toshiaki Ara <ara_t@384.jp> 1.4.0-1
  85. - new upstream release
  86. * Sat Sep 02 2017 Toshiaki Ara <ara_t@384.jp> 1.3.21-1
  87. - new upstream release
  88. * Fri Aug 01 2017 Toshiaki Ara <ara_t@384.jp> 1.3.20-1
  89. - new upstream release
  90. * Sat Jul 01 2017 Toshiaki Ara <ara_t@384.jp> 1.3.19-1
  91. - new upstream release
  92. - change to BuildRequires: texlive-collection-plaingeneric
  93. * Sat Jun 03 2017 Toshiaki Ara <ara_t@384.jp> 1.3.18-1
  94. - new upstream release
  95. * Wed May 03 2017 Toshiaki Ara <ara_t@384.jp> 1.3.17-1
  96. - new upstream release
  97. * Tue Apr 11 2017 Toshiaki Ara <ara_t@384.jp> 1.3.16-1
  98. - new upstream release
  99. * Sat Jan 28 2017 Toshiaki Ara <ara_t@384.jp> 1.3.14-1
  100. - new upstream release
  101. * Sat Dec 31 2016 Toshiaki Ara <ara_t@384.jp> 1.3.13-1
  102. - new upstream release
  103. * Wed Nov 30 2016 Toshiaki Ara <ara_t@384.jp> 1.3.12-1
  104. - new upstream release
  105. * Sun Nov 06 2016 Toshiaki Ara <ara_t@384.jp> 1.3.11-2
  106. - change Group to Development/Languages
  107. * Wed Nov 02 2016 Toshiaki Ara <ara_t@384.jp> 1.3.11-1
  108. - update to 1.3.11
  109. * Sun Oct 02 2016 Toshiaki Ara <ara_t@384.jp> 1.3.10-1
  110. - update to 1.3.10
  111. * Wed Aug 31 2016 Toshiaki Ara <ara_t@384.jp> 1.3.9-1
  112. - update to 1.3.9
  113. * Tue Aug 02 2016 Toshiaki Ara <ara_t@384.jp> 1.3.8-1
  114. - update to 1.3.8
  115. * Mon Jul 18 2016 Toshiaki Ara <ara_t@384.jp> 1.3.7-1
  116. - update to 1.3.7
  117. * Sun Jun 19 2016 Toshiaki Ara <ara_t@384.jp> 1.3.6-1
  118. - update to 1.3.6
  119. - make PDF files for VineSeed
  120. * Sun Apr 17 2016 Toshiaki Ara <ara_t@384.jp> 1.3.4-1
  121. - new package