gnumeric-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436
  1. %define gnumeric_version %{version}-bonobo
  2. %define goffice_version 0.8.7
  3. Summary: A spreadsheet program for GNOME.
  4. Summary(ja): GNOME スプレッドシート
  5. Name: gnumeric
  6. Version: 1.10.7
  7. Release: 1%{?_dist_release}
  8. License: GPLv2
  9. Group: Applications/Productivity
  10. URL: http://www.gnome.org/projects/gnumeric
  11. Source: ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.8/%{name}-%{version}.tar.bz2
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. Distribution: Vine Linux
  14. Vendor: Project Vine
  15. BuildRequires: gtk2-devel >= 2.10.0
  16. BuildRequires: libglade2-devel >= 2.3.6
  17. BuildRequires: libgnomeprint-devel >= 2.8.2
  18. BuildRequires: libgnomeprintui-devel >= 2.8.2
  19. BuildRequires: libart_lgpl-devel >= 2.3.11
  20. BuildRequires: libxml2-devel >= 2.4.12
  21. BuildRequires: libgsf-devel >= 1.13.2
  22. BuildRequires: goffice-devel >= %{goffice_version}
  23. BuildRequires: libbonobo-devel libgnomeui-devel
  24. BuildRequires: libffi-devel
  25. #BuildPreReq: libgda-devel >= 1.9.100
  26. #BuildPreReq: libgnomedb-devel >= 1.9.100
  27. BuildRequires: perl python-devel
  28. BuildRequires: automake autoconf libtool docbook-utils
  29. BuildRequires: intltool >= 0.28 desktop-file-utils
  30. BuildRequires: libSM-devel
  31. Requires: gtk2 >= 2.10.0
  32. Requires: libglade2 >= 2.3.6
  33. Requires: libgnomeprint >= 2.8.2
  34. Requires: libgnomeprintui >= 2.8.2
  35. Requires: libgsf >= 1.14.6
  36. Requires: perl python
  37. Requires: GConf2 scrollkeeper
  38. # no longer devel package
  39. #Provides: %{name}-devel
  40. Obsoletes: %{name}-devel
  41. %description
  42. GNOME (GNU Network Object Model Environment) is a user-friendly set of
  43. applications and desktop tools to be used in conjunction with a window
  44. manager for the X Window System.
  45. This is the Gnumeric, a spreadsheet for GNOME. It aims to be a drop in
  46. replacement for commercial spreadsheets. It provides import/export from
  47. MS Excel files and many other formats (csv, latex, xbase, applix).
  48. %description -l ja
  49. GNOME (GNU Network Object Model Environment)は
  50. Xウィンドウシステム用の、ウィンドウマネージャと連結した
  51. GUIアプリケーションおよびデスクトップツールのセットです。
  52. これは Gnumeric, GNOMEスプレッドシート・プログラムです。
  53. 商用のスプレッドシート・プログラムを代替できるものを目指しています。
  54. MS Excelファイルや他の多くのフォーマット(csv, latex, xbase, applix)
  55. を読込み、出力できます.
  56. # %package devel
  57. #Summary: Files necessary to develop gnumeric-based applications.
  58. #Group: Development/Libraries
  59. #Requires: %{name} = %{PACKAGE_VERSION}
  60. #%#description devel
  61. #The gnumeric-devel package includes files necessary to develop gnumeric-based
  62. #applications.
  63. #Install gnumeric-devel if you want to develop programs which will use gnumeric.
  64. %prep
  65. %setup -q
  66. %build
  67. %ifarch alpha
  68. MYARCH_FLAGS="--host=alpha-redhat-linux"
  69. %endif
  70. export mllibname=%{_lib}
  71. %configure --with-gnome \
  72. --with-gda --without-gb --with-perl --with-python \
  73. --disable-schemas-install
  74. make
  75. %install
  76. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  77. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  78. make DESTDIR=$RPM_BUILD_ROOT install
  79. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  80. ./mkinstalldirs $RPM_BUILD_ROOT%{_datadir}/applications
  81. desktop-file-install --vendor gnome --delete-original \
  82. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  83. --add-category X-Red-Hat-Extra \
  84. --add-category Office \
  85. --add-category Application \
  86. --add-category Spreadsheet \
  87. $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
  88. %find_lang %{name}
  89. %find_lang %{name}-functions
  90. cat %{name}-functions.lang >> %{name}.lang
  91. rm -rf $RPM_BUILD_ROOT%{_libdir}/libspreadsheet.la
  92. rm -rf $RPM_BUILD_ROOT%{_libdir}/goffice/%{goffice_version}/plugins/gnumeric/*.la
  93. rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
  94. rm -rf $RPM_BUILD_ROOT%{_includedir}/libspreadsheet-1.10
  95. rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
  96. %clean
  97. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  98. %post
  99. /sbin/ldconfig
  100. scrollkeeper-update > /dev/null 2>&1 || :
  101. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  102. gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gnumeric*.schemas > /dev/null
  103. touch --no-create %{_datadir}/icons/hicolor || :
  104. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  105. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  106. fi
  107. %pre
  108. if [ "$1" -gt 1 ]; then
  109. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  110. gconftool-2 --makefile-uninstall-rule \
  111. %{_sysconfdir}/gconf/schemas/gnumeric*.schemas >& /dev/null ||:
  112. fi
  113. %preun
  114. if [ "$1" -eq 0 ]; then
  115. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  116. gconftool-2 --makefile-uninstall-rule \
  117. %{_sysconfdir}/gconf/schemas/gnumeric*.schemas >& /dev/null ||:
  118. fi
  119. %postun
  120. /sbin/ldconfig
  121. scrollkeeper-update > /dev/null 2>&1 || :
  122. touch --no-create %{_datadir}/icons/hicolor || :
  123. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  124. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  125. fi
  126. %files -f %{name}.lang
  127. %defattr (-, root, root)
  128. %doc AUTHORS BUGS *ChangeLog* COPYING HACKING NEWS README
  129. %config %{_sysconfdir}/gconf/schemas/*
  130. %{_bindir}/*
  131. %{_libdir}/lib*.so*
  132. %{_libdir}/gnumeric
  133. %{_libdir}/goffice/%{goffice_version}/plugins/gnumeric/*
  134. #{_libdir}/bonobo/servers/*
  135. %{_datadir}/applications/*.desktop
  136. %{_datadir}/gnome/help/gnumeric
  137. %{_datadir}/gnumeric
  138. %{_datadir}/pixmaps/*
  139. #{_datadir}/mime-info/*
  140. #{_datadir}/mc/templates/*
  141. %{_datadir}/omf/*
  142. %{_datadir}/icons/hicolor/*
  143. %{_mandir}/man*/*
  144. %exclude %{_datadir}/pixmaps/win32-gnumeric.ico
  145. #%{_libexecdir}/gnumeric-component
  146. #%#dir %{_libdir}/gnumeric
  147. #%#dir %{_libdir}/gnumeric/%{bonobover}
  148. #%#dir %{_libdir}/gnumeric/%{bonobover}/plugins
  149. #%#dir %{_libdir}/gnumeric/%{bonobover}/plugins/*
  150. # This is really silly. The .la files are useless for plugins.
  151. #%#{_libdir}/gnumeric/%{bonobover}/plugins/*/*.la
  152. #%#{_libdir}/gnumericConf.sh
  153. #%#if %{bonobo}
  154. #%#dir %{_datadir}/gnumeric
  155. #%#dir %{_datadir}/gnumeric/%{bonobover}
  156. #%#{_datadir}/gnumeric/%{bonobover}/idl
  157. #%#endif
  158. %changelog
  159. * Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.7-1
  160. - new upstream release
  161. * Wed Jun 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
  162. - new upstream release
  163. - fix %post and %postun
  164. * Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
  165. - new upstream release
  166. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
  167. - new upstream release
  168. - add BuildRequires: libSM-devel
  169. - fix BuildRequires: goffice-devel >= 0.8.1
  170. * Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-3
  171. - spec in UTF-8 (fixed)
  172. * Sat May 9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-2
  173. - spec in UTF-8
  174. - added BuildRequires: libffi-devel
  175. - added %%pre, %%preun section
  176. * Mon Jun 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-1
  177. - new upstream release
  178. - built with libgda-3.1.4, libgnomedb-3.1.2
  179. - applied new versioning policy
  180. * Mon Mar 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
  181. - new upstream release
  182. * Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.6.3-0vl2
  183. - rebuild
  184. * Fri May 5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-0vl1
  185. - new upstream release
  186. * Sun Mar 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.2-0vl1
  187. - new upstream release
  188. - updated build dependancies
  189. - rebuilt with libgsf-1.14.0
  190. - built with libgda and libgnomedb again
  191. * Tue Nov 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-0vl1
  192. - new upstream release
  193. - updated build dependancies
  194. - not compile with libgda and libgnomedb in this version
  195. * Mon Mar 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.3-0vl1
  196. - new upstream release
  197. * Fri Feb 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl2
  198. - rebuild with libgda 1.2.0 and libgnome 1.2.0
  199. * Tue Jan 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl1
  200. - new upstream release
  201. * Mon Dec 13 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1-0vl1
  202. - new upstream release
  203. * Thu Dec 2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-0vl1
  204. - new upstream release
  205. * Fri Nov 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl2
  206. - rebuild with gnome-2.8 environment and libgsf-1.10.1
  207. * Tue Jun 29 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl1
  208. - new upstream release
  209. - added BuildRequires: desktop-file-utils
  210. * Thu May 6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-0vl1
  211. - new upstream release
  212. - Requires: libgsf >= 1.9.0, BuildPrereq: libgsf-devel >= 1.9.0
  213. * Wed Apr 21 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
  214. - new upstream release
  215. * Wed Apr 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-0vl1
  216. - new upstream release
  217. * Sun Apr 11 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
  218. - new upstream release
  219. * Thu Mar 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
  220. - new upstream release
  221. * Wed Mar 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.7-0vl1
  222. - new upstream release
  223. - clean up spec file (a little bit!)
  224. * Thu Jan 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
  225. - new upstream release
  226. * Fri Jan 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.4-0vl1
  227. - new upstream release
  228. - to use intltool-0.28
  229. * Sun Dec 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-0vl1
  230. - new upstream release
  231. - rebuild with new toolchains
  232. * Sun Nov 30 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-0vl1
  233. - new upstream release
  234. - build with new libgnomeprint, libgnomeprintui
  235. * Fri Oct 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-0vl1
  236. - new upstream release
  237. * Thu Oct 2 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl2
  238. - rebuild with newer libgda, libgnomedb
  239. * Thu Sep 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
  240. - updated to 1.2.0 (stable release)
  241. - guile support is temporarily off this version.
  242. * Mon Sep 9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl1
  243. - update to 1.1.20 (gtk+-2 port)
  244. - based on Redhat Rawhide 1.1.20-1
  245. * Thu May 1 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.13-0vl1
  246. - update to 1.0.13
  247. - rebuild with gal 0.24
  248. * Sun Mar 9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.12-0vl2
  249. - guile support on
  250. - rebuild with new gal, bonobo, libgda
  251. * Fri Feb 7 2003 Masaki Shinomiya <shino@pos.to> 1.0.12-0vl1
  252. - New upstream release, remove xmliobackward.patch
  253. * Mon Dec 16 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl2
  254. - xml-io back to 1.0.10 because japanese corrups with new xml_parser
  255. * Sun Dec 15 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl1
  256. - New upstream release, fix for xml importing files with non ASCII characters.
  257. - Without guile, changelog.archive, requires, build scripts, description
  258. * Mon Nov 19 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl2
  259. - files: add gnumericConf.sh, which was missing
  260. * Mon Nov 4 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl1
  261. - New upstream release.
  262. - BuildPrereq oaf-devel
  263. * Mon Jul 29 2002 Masaki Shinomiya <shino@pos.to> 1.0.9-0vl1
  264. - New upstream release.
  265. * Mon Jul 1 2002 Masaki Shinomiya <shino@pos.to> 1.0.8-0vl1
  266. - New upstream release.
  267. - Default font and Japanese fonts in excel
  268. - requires
  269. * Sun Jun 30 2002 Masaki Shinomiya <shino@pos.to> 1.0.7-0vl1
  270. - New upstream release.
  271. - fixed plugins, apply patch2, remove patch3
  272. - files - no longer devel package
  273. - function-reference.html in help file
  274. * Thu Jan 24 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.3-0vl1
  275. - New upstream release.
  276. * Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.2-0vl1
  277. - New upstream release.
  278. - Fixed several owner dir.
  279. * Tue Jan 15 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl2
  280. - Build against with new gal
  281. * Mon Jan 7 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl1
  282. - New upstream release.
  283. * Fri Jan 4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.0-0vl1
  284. - New upstream release.
  285. * Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.1-0vl1
  286. - New upstream release.
  287. - Applied XIM over-the-spot patch.
  288. - Fixed directories owner.
  289. * Wed Dec 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.0-0vl1
  290. - New upstream release.
  291. - Enable Bonobo.
  292. - Merged several RH patches.
  293. - Added BuildPreReq tags.
  294. * Tue Jun 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl3
  295. - Fixed packaging mistake.
  296. * Mon May 14 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl2
  297. - Rebuild for GAL 0.7
  298. * Fri Mar 23 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl1
  299. - New upstream release.
  300. - Use rpmmacros.
  301. * Mon Feb 5 2001 Jun Nishii <jun@vinelinux.org>
  302. - 0.56-0vl2
  303. - update ja.po
  304. - avoid core dump when inserting a row
  305. * Mon Jul 10 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  306. - updated to 0.56
  307. - remake spec with the orginal gnumeric spec file.
  308. - added ms_excel_read and edit_item patch from Japanese gnome users mailing list.
  309. * Tue May 16 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  310. - updated to 0.53
  311. - remake SPEC based on gnumeric original.
  312. - added libxml183 patch for libxml 1.8.3
  313. * Thu Mar 29 2000 Kjartan Maraas <kmaraas@online.no>
  314. - Removed gnome-gnumeric-xl.png since it is nowhere to be found.
  315. - Added --without-bonobo and --without-gb.
  316. - Added %define for sysconfdir
  317. * Mon Feb 29 2000 Jody Goldberg <jgolbderg@home.com>
  318. - Updated version requirements for gnome-print, and gnome-libs.
  319. * Sun Jan 30 2000 Gregory McLean <gregm@comstar.net>
  320. - Added in some auto-detect the language files logic (rpm 3.0.xx only)
  321. * Mon Jan 12 2000 Jody Goldberg <jgolbderg@home.com>
  322. - Add depend on gtk+ >= 1.2.2 so that we can get gtk_object_get.
  323. * Mon Jan 03 2000 Gregory McLean <gregm@comstar.net>
  324. - Updated to 0.47
  325. * Mon Dec 20 1999 Jody Goldberg <jgolbderg@home.com>
  326. - Updated the libglade dependancy.
  327. - Remove req for guile. We can build without it.
  328. * Thu Sep 02 1999 Gregory McLean <gregm@comstar.net>
  329. - Added small fix so glade generated dialogs appear.
  330. * Wed Jul 14 1999 Gregory McLean <gregm@comstar.net>
  331. - Added the gnome-print requirement.
  332. - Updated the file list to try and quiet down the updating.
  333. - added the sysconfdir
  334. * Tue Mar 9 1999 Gregory McLean <gregm@comstar.net>
  335. - Updated the spec file.
  336. * Thu Sep 24 1998 Michael Fulbright <msf@redhat.com>
  337. - Version 0.2