thunderbird-vl.spec 28 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842
  1. # do not include minor version number in MOZILLA_FIVE_HOME
  2. %define tbmajor 10.0
  3. #%define tbversion %{tbmajor}.10
  4. %define tbversion %{tbmajor}
  5. %define tbrelease 1%{?_dist_release}
  6. # The tarball is pretty inconsistent with directory structure.
  7. # Sometimes there is a top level directory. That goes here.
  8. #
  9. # IMPORTANT: If there is no top level directory, this should be
  10. # set to the cwd, ie: '.'
  11. #%define tarballdir .
  12. %define tarballdir comm-release
  13. %define mozappdir %{_libdir}/%{name}-%{version_internal}
  14. %define moz_objdir objdir-tb
  15. %define version_internal 9.0.1
  16. %define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
  17. %define desktop_file_utils_version 0.6
  18. %define nspr_version 4.8
  19. %define nss_version 3.13.1
  20. %define cairo_version 1.6.0
  21. %define freetype_version 2.1.9
  22. %define sqlite_version 3.6.14
  23. %define libnotify_version 0.4
  24. %define build_vine7 0
  25. %define build_vine6 0
  26. %define build_vine5 0
  27. %if "%{?_dist_release}" >= "vl7"
  28. %define build_vine7 1
  29. %endif
  30. %if "%{?_dist_release}" == "vl6"
  31. %define build_vine6 1
  32. %endif
  33. %if "%{?_dist_release}" == "vl5"
  34. %define build_vine5 1
  35. %endif
  36. Summary: Thunderbird Community Edition, Mail/newsgroup client
  37. Summary(ja): Thunderbirdコミュニティエディション, メール・ニュースクライアント
  38. Name: thunderbird
  39. Version: %{tbversion}
  40. Release: %{tbrelease}
  41. URL: http://www.mozilla.org/projects/thunderbird/
  42. License: MPL
  43. Group: Applications/Internet
  44. Source0: ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
  45. Source1: ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/linux-x86_64/xpi/ja.xpi
  46. Source1010: mozconfig-thunderbird-vine5
  47. Source1020: mozconfig-thunderbird-vine6
  48. Source1030: mozconfig-thunderbird-vine7
  49. Source12: thunderbird-vine-default-prefs.js
  50. Source20: thunderbird.desktop
  51. Source21: thunderbird.vine.sh.in
  52. Source30: thunderbird-open-browser.sh
  53. Source40: thunderbird-unofficial-brandig-tb-brand.properties
  54. Source41: thunderbird-unofficial-brandig-tb-brand.dtd
  55. Source42: thunderbird-unofficial-brandig-tb-ja-brand.properties
  56. Source43: thunderbird-unofficial-brandig-tb-ja-brand.dtd
  57. Source100: find-external-requires
  58. # locale sources
  59. #%define MOZ_BUILD_LOCALES "ja"
  60. # get from mercurial repository with command,
  61. # mkdir l10n
  62. # hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
  63. #Source1000: thunderbird-%{tbversion}-ja.tar.bz2
  64. # upstream patch
  65. # Fix for version issues
  66. Patch0: thunderbird-version.patch
  67. # customization patches
  68. Patch1: firefox-1.5-default-a4-paper.patch
  69. # Linux specific
  70. Patch100: thunderbird-9.0-enable-addons.patch
  71. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  72. BuildRequires: pango-devel
  73. BuildRequires: cairo-devel >= %{cairo_version}
  74. %if %{build_vine7}
  75. BuildRequires: nspr-devel >= %{nspr_version}
  76. BuildRequires: nss-devel >= %{nss_version}
  77. BuildRequires: hunspell-devel
  78. %endif
  79. %if %{build_vine6}
  80. BuildRequires: nspr-devel >= %{nspr_version}
  81. BuildRequires: hunspell-devel
  82. %endif
  83. BuildRequires: pixman-devel
  84. BuildRequires: libpng-devel
  85. %if %{build_vine5}
  86. BuildRequires: libjpeg-devel
  87. %else
  88. BuildRequires: libjpeg-turbo-devel
  89. %endif
  90. BuildRequires: gtk2-devel
  91. BuildRequires: zlib-devel, gzip, zip, unzip
  92. BuildRequires: libIDL-devel
  93. BuildRequires: freetype2-devel >= %{freetype_version}
  94. ## disabled libnotify support
  95. ## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
  96. BuildRequires: libnotify-devel >= %{libnotify_version}
  97. BuildRequires: bzip2-devel
  98. BuildRequires: gnome-vfs2-devel
  99. BuildRequires: libgnome-devel
  100. BuildRequires: libgnomeui-devel
  101. BuildRequires: krb5-devel
  102. BuildRequires: pango-devel
  103. BuildRequires: libXt-devel
  104. BuildRequires: libXrender-devel
  105. # hunspell is in plus category for vine
  106. #BuildRequires: hunspell-devel
  107. BuildRequires: sqlite3-devel >= %{sqlite_version}
  108. BuildRequires: startup-notification-devel
  109. BuildRequires: desktop-file-utils
  110. BuildRequires: alsa-lib-devel
  111. BuildRequires: yasm
  112. Requires: sqlite3 >= %{sqlite_version}
  113. Requires(post): desktop-file-utils >= %{desktop_file_utils_version}
  114. Requires(postun): desktop-file-utils >= %{desktop_file_utils_version}
  115. Obsoletes: MozillaThunderbird
  116. Provides: MozillaThunderbird = %{version}
  117. Vendor: Project Vine
  118. Distribution: Vine Linux
  119. Packager: daisuke, ryoichi, kazutaka
  120. AutoProv: 0
  121. %define _use_internal_dependency_generator 0
  122. %define __find_requires %{SOURCE100}
  123. %description
  124. Thunderbird is a standalone mail and newsgroup client.
  125. %description -l ja
  126. Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
  127. #===============================================================================
  128. %prep
  129. %setup -q %{name}-%{version} -c
  130. cd %{tarballdir}
  131. # Fix for version issue
  132. sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
  133. > version.patch
  134. %{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
  135. cd mozilla
  136. %patch1 -p1 -b .default-a4
  137. cd -
  138. %{__rm} -f .mozconfig
  139. %if %{build_vine5}
  140. %{__cp} %{SOURCE1010} .mozconfig
  141. %endif
  142. %if %{build_vine6}
  143. %{__cp} %{SOURCE1020} .mozconfig
  144. %endif
  145. %if %{build_vine7}
  146. %{__cp} %{SOURCE1030} .mozconfig
  147. %endif
  148. # setup unofficial branding name
  149. %{__cp} %{SOURCE40} mail/branding/aurora/locales/en-US/brand.properties
  150. %{__cp} %{SOURCE41} mail/branding/aurora/locales/en-US/brand.dtd
  151. %patch100 -p1 -b .addons
  152. #===============================================================================
  153. %build
  154. cd %{tarballdir}
  155. INTERNAL_GECKO=%{version_internal}
  156. MOZ_APP_DIR=%{mozappdir}
  157. #MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
  158. MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
  159. export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
  160. export CFLAGS="$RPM_OPT_FLAGS"
  161. export CXXFLAGS="$CFLAGS"
  162. export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
  163. %ifarch ppc ppc64 s390 s390x
  164. %define moz_make_flags -j1
  165. %else
  166. %define moz_make_flags %{?_smp_mflags}
  167. %endif
  168. export PREFIX='%{_prefix}'
  169. export LIBDIR='%{_libdir}'
  170. export LDFLAGS="-Wl,-rpath,%{mozappdir}"
  171. export MAKE="gmake %{moz_make_flags}"
  172. %{__make} -f client.mk build
  173. ## build locales
  174. #LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
  175. # sed -e 's|\./\(.*\)/locales/.*|\1|g'`
  176. #for dir in $LOCALEDIRS
  177. #do
  178. # for lang in %{MOZ_BUILD_LOCALES} ; do
  179. # make -C $dir/locales AB_CD=$lang
  180. # done
  181. #done
  182. #===============================================================================
  183. %install
  184. %{__rm} -rf $RPM_BUILD_ROOT
  185. cd %{tarballdir}
  186. INTERNAL_GECKO=%{version_internal}
  187. INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
  188. MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
  189. cd %{moz_objdir}
  190. DESTDIR=$RPM_BUILD_ROOT make install
  191. # install unofficial icons
  192. cd -
  193. %{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/icons
  194. %{__cp} mail/branding/aurora/mailicon16.png \
  195. $RPM_BUILD_ROOT/%{mozappdir}/icons/
  196. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
  197. %{__cp} mail/branding/aurora/mailicon16.png \
  198. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
  199. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
  200. %{__cp} mail/branding/aurora/mailicon22.png \
  201. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
  202. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
  203. %{__cp} mail/branding/aurora/mailicon24.png \
  204. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
  205. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
  206. %{__cp} mail/branding/aurora/mailicon32.png \
  207. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
  208. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
  209. %{__cp} mail/branding/aurora/mailicon48.png \
  210. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
  211. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
  212. %{__cp} mail/branding/aurora/mailicon256.png \
  213. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
  214. desktop-file-install --vendor vine \
  215. --dir $RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE20}
  216. # set up the thunderbird start script
  217. rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
  218. %{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
  219. $RPM_BUILD_ROOT%{_bindir}/thunderbird
  220. %{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
  221. install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
  222. %{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
  223. %{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
  224. -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
  225. $RPM_BUILD_ROOT/vine-default-prefs
  226. %{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
  227. %{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
  228. %{__rm} $RPM_BUILD_ROOT/vine-default-prefs
  229. %{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
  230. # own mozilla plugin dir (#135050)
  231. %{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
  232. # own extension directories
  233. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
  234. %{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
  235. # install locales
  236. #for lang in %{MOZ_BUILD_LOCALES} ; do
  237. # %{__install} -p -D -m 664 %{moz_objdir}/objdir-tb/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
  238. #done
  239. # install ja.xpi to langpacks directory
  240. #%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
  241. #unzip %{SOURCE1} -d $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
  242. # also setup unofficial branding name
  243. #%{__cp} %{SOURCE42} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.properties
  244. #%{__cp} %{SOURCE43} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.dtd
  245. # install ja.xpi to langpack file
  246. %{__mkdir_p} lang_tmp
  247. unzip %{SOURCE1} -d lang_tmp
  248. # also setup unofficial branding name
  249. %{__cp} %{SOURCE42} lang_tmp/chrome/ja/locale/ja/branding/brand.properties
  250. %{__cp} %{SOURCE43} lang_tmp/chrome/ja/locale/ja/branding/brand.dtd
  251. %{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks
  252. cd lang_tmp; \
  253. zip -r $RPM_BUILD_ROOT%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org.xpi chrome chrome.manifest install.rdf
  254. %clean
  255. %{__rm} -rf $RPM_BUILD_ROOT
  256. #===============================================================================
  257. %post
  258. update-desktop-database &> /dev/null || :
  259. touch --no-create %{_datadir}/icons/hicolor
  260. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  261. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  262. fi
  263. %postun
  264. update-desktop-database &> /dev/null || :
  265. touch --no-create %{_datadir}/icons/hicolor
  266. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  267. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  268. fi
  269. %files
  270. %defattr(-,root,root,-)
  271. %attr(755,root,root) %{_bindir}/thunderbird
  272. %attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
  273. %{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
  274. %{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
  275. %{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
  276. %{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
  277. %{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
  278. %{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
  279. %{mozappdir}
  280. #%{_libdir}/mozilla
  281. %exclude %{_libdir}/%{name}-%{version_internal}/removed-files
  282. %exclude %{_datadir}/idl/%{name}-%{version_internal}
  283. %exclude %{_includedir}/%{name}-%{version_internal}
  284. %exclude %{_libdir}/%{name}-devel-%{version_internal}
  285. #===============================================================================
  286. %changelog
  287. * Wed Feb 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0-1
  288. - new upstream release
  289. * Sat Dec 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0.1-1
  290. - new upstream release
  291. - update Source1
  292. * Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0-1
  293. - new upstream release
  294. - update Source1
  295. - add Source1030 (mozconfig-thunderbird-vine7)
  296. - add Patch100 (thunderbird-9.0-enable-addons.patch)
  297. * Thu Nov 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-2
  298. - fix %%version_internal
  299. * Wed Nov 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-1
  300. - new upstream release
  301. - update Source1
  302. * Sat Oct 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.0.1-1
  303. - new upstream release
  304. - update Source1,21,1010,1020
  305. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.0-3
  306. - rebuild with libnotify-0.7
  307. * Wed Jul 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0-2
  308. - enable-install-strip
  309. * Wed Jul 06 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 5.0-1
  310. - new upstream release
  311. - drop obsolete patch and renumber patch26 to patch1
  312. - add BuildRequires: yasm
  313. - enable libnotify support
  314. - add --disable-updater and --disable-installer to mozconfig
  315. - use ja.xpi instead of l10n source
  316. - update Source21: add step to setup langpack plugin
  317. - update Source20: add japanese translation
  318. - add Source42 & Source43 for localized branding
  319. - add --disable-system-cairo and ac_add_options --disable-libjpeg-turbo
  320. for mozconfig-thunderbird-vine5
  321. * Mon May 16 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.10-1
  322. - new upstream release with security fix
  323. * Wed Dec 22 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.7-1
  324. - new upstream release with security fix
  325. * Fri Oct 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.6-1
  326. - new upstream release with security fix
  327. * Thu Oct 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.5-1
  328. - new upstream release with security fix
  329. - add patch5 to fix build failure
  330. * Sun Sep 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.4-1
  331. - new upstream release
  332. * Thu Sep 09 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.3-1
  333. - new upstream release with security fix
  334. - add Patch1030 to fix compilation error
  335. * Sat Aug 07 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-2
  336. - change mozconfig (Source1030 & 1040): add --enable-jsd
  337. * Fri Aug 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-1
  338. - new upstream release
  339. * Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
  340. - new upstream release with security fix
  341. - add Patch0 from fedora development: fix version issue
  342. - remove BuildRequires: hunspell-devel
  343. - update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
  344. * Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
  345. - add BuildRequires: alsa-lib-devel
  346. - remove BuildRequires: libnotify-devel
  347. (workaround for known bug)
  348. - update mozconfig to add --disable-libnotify option
  349. * Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
  350. - new upstream release
  351. - update spec entirely
  352. - import patches from fedora (Patch1, 2 & 4)
  353. - drop outdated patches (Patch22, 24)
  354. - update Sources:
  355. - mozconfig (Source1030 & Source1040)
  356. - default prefs.js (Source12)
  357. - unofficial branding (Source40 & Source41)
  358. - japanese translation (Source1000)
  359. - update Patch1000 (sjis-alias)
  360. * Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
  361. - new upstream release
  362. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
  363. - new upstream release
  364. * Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
  365. - don't install official branding logos
  366. * Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
  367. - add necessary icons in %%{tbdir}/chrome/icons/default
  368. - add Packager tag
  369. * Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
  370. - new upstream release
  371. * Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
  372. - new upstream release
  373. * Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
  374. - new upstream release
  375. * Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
  376. - new upstream release
  377. * Sun Aug 5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
  378. - rebuilt for VineSeed
  379. * Sun Aug 5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
  380. - new upstream release
  381. * Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
  382. - new upstream release
  383. - built for Vine Linux 4.x
  384. - dropped Patch1020 (merged into upstream)
  385. * Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
  386. - added Patch1020 for workaround gcc visibility hidden bugs
  387. * Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
  388. - build with new environment/toolchain
  389. - add build options to build with external nss/nspr libraries
  390. ac_add_options --with-system-nspr
  391. ac_add_options --with-system-nss
  392. * Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
  393. - new upstream release
  394. * Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
  395. - new upstream release
  396. * Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
  397. - new upstream release
  398. * Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
  399. - new upstream release
  400. * Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
  401. - new upstream release
  402. - merge changes from firefox
  403. - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
  404. * Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
  405. - new upstream release
  406. - build en-US locale
  407. - merge changes from firefox
  408. - add upstream patches
  409. - disable pango rendering by default
  410. (workaround fix slow rendering in some page)
  411. * Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
  412. - initial build for Vine Linux based on FC package
  413. - update to 1.5RC2
  414. * Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
  415. - Fix issue with popup dialogs and other actions causing lockups
  416. * Sat Nov 5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
  417. - Update to 1.5 rc1
  418. * Sat Oct 8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
  419. - Update to 1.5 beta2
  420. * Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
  421. - Update to 1.5 beta1
  422. - Bring the install phase of the spec file up to speed
  423. * Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
  424. - Rebuild
  425. * Sat Aug 6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
  426. - Add patch to make file chooser dialog modal
  427. * Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
  428. - Update to 1.0.6
  429. * Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
  430. - 1.0.6 Release Candidate
  431. * Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
  432. - Use system NSPR
  433. - Fix crash on 64bit platforms (#160330)
  434. * Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com> 1.0.2-7
  435. - Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
  436. references, fixing the "no fonts" problem.
  437. * Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
  438. - Change the Exec line in the desktop file to `thunderbird`
  439. * Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
  440. - Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
  441. * Mon May 9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
  442. - Add temporary workaround to not create files in the user's $HOME (#149664)
  443. * Wed May 4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
  444. - Don't have downloads "disappear" when downloading to desktop (#139015)
  445. - Fix for some more cursor issues in textareas (149991, 150002, 152089)
  446. - Add upstream patch to fix bidi justification of pango
  447. - Add patch to fix launching of helper applications
  448. - Add patch to properly link against libgfxshared_s.a
  449. - Fix multilib conflicts
  450. * Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
  451. - correct confusing PANGO vars in startup script
  452. * Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
  453. - Thunderbird 1.0.2
  454. * Tue Mar 8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
  455. - Add patch to compile against new fortified glibc macros
  456. * Sat Mar 5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
  457. - Rebuild against GCC 4.0
  458. - Add execshield patches
  459. - Minor specfile cleanup
  460. * Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
  461. - Rebuild
  462. * Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
  463. - Add RPM version to useragent
  464. * Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
  465. - Port over pango patches from firefox
  466. * Wed Dec 8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
  467. - Thunderbird 1.0
  468. * Mon Dec 6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
  469. - Fix advanced prefs
  470. * Fri Dec 3 2004 Christopher Aillon <caillon@redhat.com>
  471. - Make this run on s390(x) now for real
  472. * Wed Dec 1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
  473. - Update to 1.0 rc1
  474. * Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
  475. - Add patches to build and run on s390(x)
  476. * Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
  477. - Rebuild to fix file chooser
  478. * Fri Nov 5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
  479. - Update to 0.9
  480. * Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
  481. - Prevent inlining of stack direction detection (#135255)
  482. * Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
  483. - More file chooser fixes (same as in firefox)
  484. - Fix for upstream 28327.
  485. * Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
  486. - Update the pango patch
  487. * Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
  488. - Pull over patches from firefox build:
  489. - disable default application dialog
  490. - don't include software update since it doesn't work
  491. - make external app support work
  492. * Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
  493. - Use pango for rendering
  494. * Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
  495. - Fix for 64 bit crash at startup (b.m.o #256603)
  496. * Sat Oct 9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
  497. - Add patches to fix xremote (#135036)
  498. * Fri Oct 8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
  499. - Add patch to fix button focus issues (#133507)
  500. - Add patch for fix IMAP race issues (bmo #246439)
  501. * Fri Oct 1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
  502. - filter out library Provides: and internal Requires:
  503. * Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
  504. - Backport the GTK+ File Chooser.
  505. - Add fix for JS math on x86_64 systems
  506. - Add pkgconfig patch
  507. * Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
  508. - Update to 0.8.0
  509. - Remove enigmail
  510. - Update BuildRequires
  511. - Remove gcc34 and extension manager patches -- they are upstreamed.
  512. - Fix for gnome-vfs2 error at component registration
  513. * Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
  514. - Build with --disable-xprint
  515. * Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
  516. - remove all Xvfb-related hacks
  517. * Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
  518. - actually apply psfonts
  519. - add mozilla gnome-uriloader patch to prevent build failure
  520. * Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
  521. - rawhide import
  522. - apply NetBSD's freetype 2.1.8 patch
  523. - apply psfonts patch
  524. - remove BR on /usr/bin/ex, breaks beehive
  525. * Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
  526. - oops, fix %%install
  527. * Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
  528. - update to Thunderbird 0.7.3 and Enigmail 0.85.0
  529. - remove XUL.mfasl on startup, add Debian enigmail patches
  530. - add Xvfb hack for -install-global-extension
  531. * Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
  532. - update to 0.7.2, just because it's there
  533. - update gcc-3.4 patch (Kaj Niemi)
  534. - add EM registration patch and remove instdir hack
  535. * Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
  536. - re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
  537. * Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
  538. - update to 0.7.1
  539. - remove Enigmail
  540. * Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
  541. - re-enable Enigmail 0.84.1
  542. - add gcc-3.4 patch (Kaj Niemi)
  543. - use official branding (with permission)
  544. * Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
  545. - update to 0.7
  546. - temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
  547. - specify libdir, change BR for apt (V. Skytt辰, #1617)
  548. * Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
  549. - temporary workaround for enigmail skin "modern" bug
  550. * Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
  551. - update to Enigmail 0.84.0
  552. - update launch script
  553. * Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
  554. - installation directory now versioned
  555. - allow root to run the program (for installing extensions)
  556. - remove unnecessary %%pre and %%post
  557. - remove separators, update mozconfig and launch script (M. Schwendt, #1460)
  558. * Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
  559. - include Enigmail, re-add release notes
  560. - delete %{_libdir}/thunderbird in %%pre
  561. * Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
  562. - update to Thunderbird 0.6
  563. * Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
  564. - update to Thunderbird 0.6 RC1
  565. - add new icon, remove release notes
  566. * Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
  567. - update to latest CVS, update mozconfig and %%build accordingly
  568. - update to Enigmail 0.83.6
  569. - remove x-remote and x86_64 patches
  570. - build with -Os
  571. * Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
  572. - update x-remote patch
  573. - more startup script fixes
  574. * Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
  575. - startup script fixes, and a minor cleanup
  576. * Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
  577. - Minor cleanups
  578. * Sun Apr 04 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.8
  579. - minor improvements to open-browser.sh and startup script
  580. - update to latest version of Blizzard's x-remote patch
  581. * Thu Mar 25 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.7
  582. - update open-browser.sh, startup script, and BuildRequires
  583. * Sun Mar 14 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.6
  584. - update open-browser script, modify BuildRequires (Warren)
  585. - add Blizzard's x-remote patch
  586. - initial attempt at x-remote-enabled startup script
  587. * Sun Mar 07 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.5
  588. - refuse to run with excessive privileges
  589. * Fri Feb 27 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.4
  590. - add Mozilla x86_64 patch (Oliver Sontag)
  591. - Enigmail source filenames now include the version
  592. - modify BuildRoot
  593. * Thu Feb 26 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.3
  594. - use the updated official tarball
  595. * Wed Feb 18 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.2
  596. - fix %%prep script
  597. * Mon Feb 16 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.1
  598. - update Enigmail to 0.83.3
  599. - use official source tarball (after removing the CRLFs)
  600. - package renamed to thunderbird
  601. * Mon Feb 09 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.0
  602. - update to 0.5
  603. - check for lockfile before launching
  604. * Fri Feb 06 2004 David Hill <djh[at]ii.net>
  605. - update to latest cvs
  606. - update to Enigmail 0.83.2
  607. * Thu Jan 29 2004 David Hill <djh[at]ii.net> 0:0.4-0.fdr.5
  608. - update to Enigmail 0.83.1
  609. - removed Mozilla/Firebird script patching
  610. * Sat Jan 03 2004 David Hill <djh[at]ii.net> 0:0.4-0.fdr.4
  611. - add startup notification to .desktop file
  612. * Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
  613. - open-browser.sh release 3
  614. - patch broken /usr/bin/mozilla script during install
  615. - dir ownership
  616. - XXX: Source fails build on x86_64... fix later
  617. * Tue Dec 23 2003 David Hill <djh[at]ii.net> 0:0.4-0.fdr.2
  618. - update to Enigmail 0.82.5
  619. - add Warren's open-browser.sh (#1113)
  620. * Tue Dec 09 2003 David Hill <djh[at]ii.net> 0:0.4-0.fdr.1
  621. - use Thunderbird's mozilla-xremote-client to launch browser
  622. * Sun Dec 07 2003 David Hill <djh[at]ii.net> 0:0.4-0.fdr.0
  623. - update to 0.4
  624. - make hyperlinks work (with recent versions of Firebird/Mozilla)
  625. * Thu Dec 04 2003 David Hill <djh[at]ii.net>
  626. - update to 0.4rc2
  627. * Wed Dec 03 2003 David Hill <djh[at]ii.net>
  628. - update to 0.4rc1 and Enigmail 0.82.4
  629. * Thu Nov 27 2003 David Hill <djh[at]ii.net>
  630. - update to latest CVS and Enigmail 0.82.3
  631. * Sun Nov 16 2003 David Hill <djh[at]ii.net>
  632. - update to latest CVS (0.4a)
  633. - update Enigmail to 0.82.2
  634. - alter mozconfig for new build requirements
  635. - add missing BuildReq (#987)
  636. * Thu Oct 16 2003 David Hill <djh[at]ii.net> 0:0.3-0.fdr.0
  637. - update to 0.3
  638. * Sun Oct 12 2003 David Hill <djh[at]ii.net> 0:0.3rc3-0.fdr.0
  639. - update to 0.3rc3
  640. - update Enigmail to 0.81.7
  641. * Thu Oct 02 2003 David Hill <djh[at]ii.net> 0:0.3rc2-0.fdr.0
  642. - update to 0.3rc2
  643. * Wed Sep 17 2003 David Hill <djh[at]ii.net> 0:0.2-0.fdr.2
  644. - simplify startup script
  645. * Wed Sep 10 2003 David Hill <djh[at]ii.net> 0:0.2-0.fdr.1
  646. - add GPG support (Enigmail 0.81.6)
  647. - specfile fixes (#679)
  648. * Thu Sep 04 2003 David Hill <djh[at]ii.net> 0:0.2-0.fdr.0
  649. - update to 0.2
  650. * Mon Sep 01 2003 David Hill <djh[at]ii.net>
  651. - initial RPM
  652. (based on the fedora MozillaFirebird-0.6.1 specfile)