empathy-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466
  1. %define major_ver 3.4
  2. %define minor_ver 2
  3. %define rel 1
  4. %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  5. ## Minimum required versions of GLib, GTK+, libtelepathy, and Mission-Control,
  6. ## respectively.
  7. %global gtk3_min_version 3.4.0
  8. %global glib2_min_version 2.32.0
  9. %global tp_mc_min_version 5.12.0
  10. %global tp_glib_min_version 0.18.0
  11. %global tp_logger_min_version 0.2.10
  12. %global aspell_version 0.50
  13. %global libcanberra_version 0.25
  14. %global gnome_keyring_version 3.4
  15. %global libnotify_version 0.7.4
  16. %global folks_version 0.6.8
  17. Summary: GNOME Instant Messaging Client
  18. Summary(ja): GNOME インスタントメッセージクラアイント
  19. Name: empathy
  20. Version: %{major_ver}.%{minor_ver}
  21. Release: %{rel}%{?_dist_release}
  22. Group: Applications/Communications
  23. License: GPLv2+
  24. URL: http://live.gnome.org/Empathy
  25. Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{majorver}/%{name}-%{version}.tar.xz
  26. Source1: %{name}-README.ConnectionManagers
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  28. #BuildRequires: enchant-devel >= %{enchant_version}
  29. BuildRequires: aspell-devel >= %{aspell_version}
  30. BuildRequires: iso-codes
  31. BuildRequires: desktop-file-utils
  32. BuildRequires: evolution-data-server-devel
  33. BuildRequires: gettext
  34. BuildRequires: glib2-devel >= %{glib2_min_version}
  35. BuildRequires: gnome-doc-utils >= 0.17.3
  36. BuildRequires: gnome-panel
  37. BuildRequires: gtk3-devel >= %{gtk3_min_version}
  38. BuildRequires: intltool
  39. BuildRequires: libxml2-devel
  40. BuildRequires: perl(XML::Parser)
  41. BuildRequires: telepathy-glib-devel >= %{tp_glib_min_version}
  42. BuildRequires: telepathy-logger-devel >= %{tp_logger_min_version}
  43. BuildRequires: telepathy-mission-control-devel >= %{tp_mc_min_version}
  44. BuildRequires: farstream-devel
  45. BuildRequires: telepathy-farstream-devel
  46. BuildRequires: libcanberra-gtk3-devel >= %{libcanberra_version}
  47. BuildRequires: libgnome-keyring-devel >= %{gnome_keyring_version}
  48. BuildRequires: unique3-devel
  49. BuildRequires: libnotify-devel >= %{libnotify_version}
  50. BuildRequires: folks-devel >= %{folks_version}
  51. BuildRequires: gcr-devel >= %{gnome_keyring_version}
  52. BuildRequires: openssl-devel
  53. BuildRequires: NetworkManager-glib-devel
  54. BuildRequires: WebKit3-gtk-devel
  55. BuildRequires: geoclue-devel
  56. BuildRequires: enchant-devel
  57. BuildRequires: libICE-devel
  58. BuildRequires: cheese-devel
  59. BuildRequires: pulseaudio-libs-devel
  60. BuildRequires: gnome-online-accounts-devel
  61. BuildRequires: libgudev1-devel
  62. BuildRequires: libchamplain-gtk-devel
  63. BuildRequires: gsettings-desktop-schemas-devel
  64. BuildRequires: itstool
  65. Requires: telepathy-filesystem
  66. Requires: telepathy-gabble
  67. Requires: telepathy-salut
  68. Requires: telepathy-idle
  69. ## Also hardcode Haze dependency since Empathy is the default IM client in F10+
  70. ## and I'd hate for people to simply disregard it for lack of the "out of the
  71. ## box" protocol support that Pidgin has. (RHBZ: 458935)
  72. BuildRequires: telepathy-haze
  73. # Require this for VOIP support
  74. Requires: telepathy-mission-control >= %{tp_mc_min_version}
  75. Requires(post): GConf2
  76. Requires(post): scrollkeeper
  77. Requires(postun): scrollkeeper
  78. ## We're using Empathy's upstreamed profiles for Haze-provided stuff now.
  79. Obsoletes: telepathy-haze-mission-control < 0.2.0-3
  80. Provides: telepathy-haze-mission-control = 0.2.0-3
  81. ## upstream 2.29.1 removed shared libraries: #599086
  82. Obsoletes: empathy-libs < 2.29.1, empathy-devel < 2.29.1
  83. ## upstream 2.29.1 removed python bindings' #599039
  84. Obsoletes: empathy-python < 2.29.1
  85. Vendor: Project Vine
  86. Distribution: Vine Linux
  87. %description
  88. Empathy provides a powerful multiple protocol instant messaging
  89. client using the Telepathy framework.
  90. %package -n nautilus-sendto-empathy
  91. License: GPLv2+
  92. Summary: Nautilus-sendto plugin for empathy
  93. Summary(ja): empathy 用 nautilus-sendto プラグイン
  94. Group: User Interface/Desktop
  95. Requires: %{name} = %{version}-%{release}
  96. Requires: nautilus-sendto
  97. BuildRequires: nautilus-sendto-devel
  98. %description -n nautilus-sendto-empathy
  99. This package contains nautilus-sendto plugin for the Empathy IM application.
  100. %prep
  101. %setup -q
  102. %build
  103. ## GCC complains about some unused functions, so we forcibly show those as
  104. ## simple warnings instead of build-halting errors.
  105. %configure --disable-static
  106. ## RPATHs are yucky.
  107. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  108. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  109. ##make %{?_smp_mflags}
  110. ## don't use _smp_mflags at empathy-2.18.1
  111. make
  112. install -m 0644 %{SOURCE1} ./README.ConnectionManagers
  113. %install
  114. rm -rf $RPM_BUILD_ROOT
  115. make install DESTDIR=$RPM_BUILD_ROOT
  116. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  117. %find_lang %{name}
  118. desktop-file-install --vendor "" --delete-original \
  119. --dir %{buildroot}%{_datadir}/applications \
  120. %{buildroot}%{_datadir}/applications/%{name}.desktop
  121. %clean
  122. rm -rf %{buildroot}
  123. %post
  124. scrollkeeper-update -q -o %{_datadir}/omf/%{name} ||:
  125. touch --no-create %{_datadir}/icons/hicolor ||:
  126. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  127. %postun
  128. scrollkeeper-update -q || :
  129. touch --no-create %{_datadir}/icons/hicolor || :
  130. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  131. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  132. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  133. fi
  134. %posttrans
  135. gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null ||:
  136. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  137. %files -f %{name}.lang
  138. %defattr(-,root,root,-)
  139. %doc AUTHORS COPYING README README.ConnectionManagers NEWS
  140. %{_bindir}/empathy
  141. %{_bindir}/empathy-accounts
  142. %{_bindir}/empathy-debugger
  143. %{_libdir}/mission-control-plugins.0/mcp-account-manager-goa.so
  144. %{_libexecdir}/empathy-auth-client
  145. %{_libexecdir}/empathy-call
  146. %{_libexecdir}/empathy-chat
  147. %{_datadir}/dbus-1/services/*
  148. %{_datadir}/empathy
  149. %{_datadir}/glib-2.0/schemas/*.xml
  150. %{_datadir}/GConf/gsettings/*
  151. %{_datadir}/applications/*.desktop
  152. %{_datadir}/help/*/%{name}
  153. #{_datadir}/omf/%{name}/
  154. %{_datadir}/icons/hicolor/*/apps/%{name}*
  155. #{_datadir}/mission-control/profiles/*.profile
  156. %{_datadir}/telepathy/clients/*.client
  157. %{_mandir}/man1/empathy*.1*
  158. %files -n nautilus-sendto-empathy
  159. %defattr(-,root,root,-)
  160. %{_libdir}/nautilus-sendto/plugins/libnstempathy.so
  161. %changelog
  162. * Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  163. - new upstream release
  164. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  165. - new upstream release
  166. - change BuildRequires: gcr-devel instead of gnome-keyring-devel
  167. - change BuildRequires: farstream-devel instead of farsight2-devel
  168. - change BuildRequires: telepathy-farstream-devel instead of telepathy-farsight-devel
  169. - add BuildRequires: itstool
  170. - remove Requires: telepathy-stream-engine
  171. - add Requires: telepathy-idle
  172. * Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
  173. - new upstream release
  174. * Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1.1-1
  175. - new upstream release
  176. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  177. - new upstream release
  178. - add BuildRequires: libgudev1-devel, gnome-online-accounts-devel
  179. * Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0.1-1
  180. - new upstream release
  181. * Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  182. - new upstream release
  183. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  184. - new upstream release
  185. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
  186. - new upstream release
  187. * Sun Aug 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5.1-1
  188. - new upstream release
  189. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
  190. - new upstream release
  191. - add BuildRequires: pulseaudio-libs-devel
  192. * Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  193. - new upstream release
  194. - change BuildRequires: gtk3-devel instead of gtk2-devel
  195. - change BuildRequires: unique3-devel instead of unique-devel
  196. - change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
  197. - change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
  198. - add BuildRequires: gsettings-desktop-schemas, libICE-devel, cheese-devel, libchamplain-gtk-devel
  199. * Sun Jan 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
  200. - new upstream release
  201. - add BuildRequires: openssl-devel, NetworkManager-glib-devel, WebKit-devel
  202. geoclue-devel, enchant-devel
  203. - add Requires: telepathy-mission-control
  204. - add configure option: --with-ca-file=/usr/share/ssl/certs/ca-bundle.crt
  205. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.1-1
  206. - new upstream release
  207. - add BuildRequires: folks-devel, telepathy-logger-devel, gnome-keyring-devel
  208. - fix %files
  209. - fix %post, %postun
  210. - drop %pre, %preun
  211. * Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0.1-3
  212. - rebuild with evolution-data-server-2.30.2
  213. - add nautilus-sendto-empathy package
  214. - add configure option (--enable-nautilus-sendto=yes)
  215. - add BuildRequires: nautilus-sendto-devel
  216. * Sat Jun 12 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-2
  217. - add Obsoletes: empathy-python < 2.29.1
  218. * Tue Apr 13 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-1
  219. - new upstream release
  220. - add new files: %%{_bindir}/empathy-{accounts,debugger}
  221. - drop -libs, -devel, -python sub packages: upstream removed
  222. - Obsoletes: empathy-{libs,devel} < 2.29.1
  223. - drop BuildRequires: python-devel
  224. - drop %%{_bindir}/empathy-logs in %%files: upstream don not install
  225. - drop applet files in %%files: upstream removed the panel applets
  226. - update %%post, %pre and %%preun
  227. - update BuildRequires version for glib2 and tp_glib
  228. - defined major_ver, minor_ver and rel
  229. - fix BuildRequires for gnome-keyring
  230. * Sat Mar 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
  231. - new upstream release
  232. - add BuildRequires: libtelepathy-devel, libgnomecanvas-devel, libbonoboui-devel, python-devel
  233. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-4
  234. - rebuilt with python-2.6.4
  235. * Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> - 2.28.1-3
  236. - unuse %%{?_smp_mflags} option to make
  237. * Wed Nov 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
  238. - add {gnome-keyring,libcanberra,libnotify,unique}-devel to BuildRequires
  239. * Sat Nov 7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
  240. - new upstream release
  241. * Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
  242. - new upstream release
  243. * Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  244. - initial build for Vine Linux
  245. * Tue Sep 9 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
  246. - Update to 2.23.92
  247. * Thu Sep 4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
  248. - Update to 2.23.91
  249. * Sun Aug 24 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-2
  250. - Now that Empathy will be the default IM client in F10+, hardcode a dependency
  251. on telepathy-haze to keep the same protocol functionality across upgrades,
  252. for a much improved "out of the box" experience.
  253. - Reference: bug 458935.
  254. * Fri Aug 22 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-1
  255. - Update to new upstream release (2.23.90)
  256. * Fri Aug 15 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-3
  257. - Apply patch from Colin Walters to automagically update profile namings for
  258. the switch to using Empathy's provided profiles.
  259. - Drop the upgrade script (no longer needed since it's automatically done).
  260. - upgrade-haze-profiles.sh
  261. * Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-2
  262. - Use upstream's AIM, ICQ, MSN-Haze, and Yahoo profiles instead of recommending
  263. the telepathy-haze-mission-control package. (The Haze-provided ones have grown
  264. horribly stale...). This makes for better automagic functionality (if Haze is
  265. installed, Empathy/MC will autodetect it) and tracks upstream more closely.
  266. + upgrade-haze-profiles.sh
  267. * Mon Aug 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-1
  268. - Update to new upstream release (2.23.6)
  269. - Use the in-tarball libtool scripts instead of the system copy to workaround
  270. 'make install' errors.
  271. * Wed Jul 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.4-1
  272. - Update to 0.23.4.
  273. - Update source url.
  274. * Mon Jun 2 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.3-1
  275. - Update to 0.23.3.
  276. - Remove reference to stream-engine in connections managers readme.
  277. * Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.2-1
  278. - Update to 0.23.2.
  279. - Add man pages.
  280. - Use enchant-devel, instead of aspell-devel.
  281. * Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-3
  282. - Rebuild for new e-d-s.
  283. * Sun May 4 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-2
  284. - Drop multiple copies of COPYING file.
  285. - Drop BR on gnome-vfs2-devel.
  286. - Require telepathy-stream-engine for VOIP support.
  287. - Add BR on iso-codes-devel, so spell-checking is enabled.
  288. * Wed Apr 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.23.1-1
  289. - Update to new upstream release (0.23.1)
  290. - Drop libtelepathy dependencies; upstream switched fully to telepathy-glib.
  291. * Fri Apr 11 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.1-1
  292. - Update to new upstream release (0.22.1)
  293. * Mon Mar 10 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.0-1
  294. - Update to new upstream release (0.22.0)
  295. * Sun Mar 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.91-1
  296. - Update to new upstream release (0.21.91)
  297. * Fri Feb 22 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.90-1
  298. - Update to new upstream release (0.21.90)
  299. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.21.4-2
  300. - Autorebuild for GCC 4.3
  301. * Mon Dec 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.4-1
  302. - Update to new upstream release (0.21.4)
  303. * Tue Nov 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.2-1
  304. - Update to new upstream release (0.21.2)
  305. - Drop backported drag-and-drop patch (fixed upstream):
  306. - svn380-fix-contact-DnD.patch
  307. - Update README.ConnectionManagers: Include Haze package note, remove Galago
  308. note (a feed-only connection manager isn't useful for instant messaging),
  309. and fix some wording.
  310. * Fri Oct 19 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-5
  311. - Backport upstream patch to fixes crashes when using drag-and-drop of a
  312. contact from the buddy list to the current conversation window to initiate a
  313. conversation:
  314. + svn380-fix-contact-DnD.patch
  315. - Resolves: GNOME bug 483168 (crash in Empathy Instant Messenger: I had
  316. dragged a contact ...)
  317. * Tue Oct 16 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-4
  318. - Depend on Salut and Gabble to enable XMPP by default. Otherwise, Empathy
  319. is essentially useless due to the need to install an external connection
  320. manager. Also, add a README.ConnectionManagers to the installed
  321. documentation which lists other possibilities.
  322. - Resolves: bug 308871 (Make empathy dependent at least on telepathy-gabble)
  323. and bug 334221 (Default empathy install is useless).
  324. * Wed Oct 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-3
  325. - Enable VoIP support for those brave enough to test/break/debug it (F9+
  326. only). Though it is functional, it is still deemed rather unstable by
  327. upstream. Use it at your own risk. :)
  328. * Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-2
  329. - Disable VoIP support at this time, since it is deemed unstable by upstream
  330. for now. (Thanks to Brian Pepple for the notice.)
  331. * Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-1
  332. - Update to new upstream release (0.14).
  333. * Sun Sep 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.13-1
  334. - Update to new upstream release (0.13), which adds a panel applet (Megaphone)
  335. and python bindings.
  336. - Split shared libraries into a libs subpackage for easier handling
  337. in multi-lib environments.
  338. * Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
  339. - Add ldconfig invocations to %%post and %%postun scriptlets.
  340. * Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
  341. - Update to new upstream release (0.12).
  342. - Build against new mission-control stack.
  343. - Update License tag (GPLv2+).
  344. - Alphabetize BuildRequires list (aesthetic-only change).
  345. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.8-2
  346. - Rebuild for selinux ppc32 issue.
  347. * Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
  348. - Update to new upstream release (0.11)
  349. * Fri Jun 22 2007 David Nielsen <david@lovesunix.net> - 0.8-1
  350. - bump to 0.8
  351. - Now with aspell support (deat to teh speeling mistaks)
  352. * Sat Jun 9 2007 David Nielsen <david@lovesunix.net> - 0.7-1
  353. - bump to 0.7
  354. * Mon Jun 4 2007 David Nielsen <david@lovesunix.net> - 0.6-3
  355. - Add telepathy-filesystem to Requires
  356. - Move .desktop from autostart to applications
  357. - Nasty hackery to make empathy launch from the menu
  358. * Mon Jun 4 2007 David Nielsen <david@lovesunix.net> - 0.6-2
  359. - Add gettext to BuildRequires
  360. * Fri Jun 1 2007 David Nielsen <david@lovesunix.net> - 0.6-1
  361. - Bump to 0.6
  362. * Fri Jun 1 2007 David Nielsen <david@lovesunix.net> - 0.5-2
  363. - Let Empathy own the directory and not just the files in it
  364. * Tue May 30 2007 David Nielsen <david@lovesunix.net> - 0.5-1
  365. - Initial package